Jump to content
funtoo forums
devs

One or more pkgs have been skipped

Recommended Posts

My customer bought HP Blade isp-ass AS 32 GB RAMS

 

Now - he asked me to install Funtoo & configure it as WebServer
 

emerge -av apache php
(...)
WARNING: One or more updates/rebuilds have been skipped due to a dependency conflict:

www-servers/apache:2

  (www-servers/apache-2.4.27-r1:2/2::gentoo, ebuild scheduled for merge) conflicts with
    >=www-servers/apache-2.4[apache2_modules_unixd,threads] required by (dev-lang/php-7.0.23:7.0/7.0::gentoo, installed)
                                                   ^^^^^^^ 


Nothing to merge; quitting.

How can be Apache cause this on fresh, clean OS?

????????????????????????????????????????????????????????????????????????

Share this post


Link to post
Share on other sites

Yes, this is more an issue of a bad error message that is confusing rather than anything else. Adding "www-servers/apache threads" to /etc/portage/package.use or /etc/portage/package.use/apache should fix this as then all the deps should be happy.

@Oleg Vinichenko, I do think that this is probably not the greatest default -- it seems like we should enable 'threads' by default to prevent this from even bothering users. Do you see any potential downside for this?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×