Jump to content

Recommended Posts

im going to compile some notes here before i post a bug & or wiki....  maybe we need a bug dumpster forum?  my pings are back to being bad from the ping insanity thread.  i tested against wpa_supplicant and its dropping high pinging etc also....
 
mkultra@spaceball-1 ~ $ smokeping
ERROR: /etc/smokeping/config, line 13: Directory '/run/smokeping' does not exist
 
sudo mkdir /run/smokeping
 
mkultra@spaceball-1 ~ $ smokeping
WARNING: Hostname 'james.address' does currently not resolve to an IPv6 or IPv4 address
ERROR: mkdir /var/lib/smokeping/Test: Permission denied

 

root@spaceball-1 /home/mkultra # smokeping

WARNING: Hostname 'james.address' does currently not resolve to an IPv6 or IPv4 address
Note: logging to syslog as local0/info.
ERROR: I Quit! Another copy of /usr/bin/smokeping (29677) seems to be running.
 
 
 
 
(clearly its going to take me a second to wiki this one)
 
this renders via cgi & perl apparently....
 
some files
 
init:
/etc/init.d/smokeping
 
configuration:
/etc/smokeping/config
/etc/smokeping
 
bins:
/usr/bin/smokeping
/usr/bin/smokeping_cgi
 
web end:
 
/var/www/localhost/cgi-bin/smokeping.fcgi
or
^^ is probably not right ^^
^^ probably should be an apache/nginx/lighttpd config section instead and aliased url^^
^^ link above && default configs && init.d script running results in these errors^^
 
Software error:ERROR: creating /var/lib/smokeping/.simg/Test: No such file or directory
 
some official documentation:
Link to post
Share on other sites

What were you trying to do?, looking at the Arch wiki smokeping is a webapp, and what you seemed to have done there, is nothing like configuring a webapp, apparently you should normally launch it as a service through /etc/init.d/. Also that Arch guide looks messed up and old, it still mentions /etc/rc.d and thats long gone from Arch, I would recommend you to go to the official ducumentation at the project site, it seemed OK, the ebuild in the tree is only a few days old, so its actively maintained on the Gentoo land. Anyway smokeping looks like an interesting tool, I might try it these days and give some feedback how it went.

Link to post
Share on other sites

j-g- i realize what you're saying....  im going to wiki it from scratch, if its maintained it might as well have excellent documentation especially since its an auditing tool.  im just trying to smooth over the initial deployment for the time being.  the config it ships with is bad....  doesnt make that dir

 

god this is such a shitty mess im probably going to need help on this one.....

Link to post
Share on other sites

the config it ships with is bad....  doesnt make that dir

 

That's because it's created at startup by the service script, look at ${PORTDIR}/net-analyzer/smokeping/files/smokeping.init.3 :

 

 


 19 start() {                                                                     
 20     checkconfig || return 1                                                    
 21                                                                                
 22     if [ ! -d /run/smokeping/ ]; then                                          
 23         mkdir /run/smokeping/         
            ^^^^^^^^^^^^^^^^^^^^                            
 24     fi                                                                         
 25     chown smokeping:smokeping /run/smokeping/                                  
 26                                                                                
 27     ebegin "Starting smokeping"                                                
 28     LC_ALL=C \                                                                 
 29     start-stop-daemon --start --name smokeping \                               
 30         --pidfile /run/smokeping/smokeping.pid \                               
 31         --exec /usr/bin/smokeping \                                            
 32         --user smokeping:smokeping                                             
 33     eend $?                                                                    
 34 }

 

 

You shouldn't be creating anything under /run/ manually, for starting any service, if you find yourself needing to do so, I'd call that a bug.

Link to post
Share on other sites

lol ive gathered that much...  at first i just merge, then i start to glance around at things....  fcgi scripts generally dont need init scripts.  the part that im going to need help with is the aliasing and proper loading into web servers.  :unsure:   i have 1 example of loading cgi on gentoos wiki and thats the bugzilla install wiki, and that took me months to figure out.

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...