Jump to content
funtoo forums

Search the Community

Showing results for tags 'radeon'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 4 results

  1. Hello, I'm encountering a most annying problem, my system boots up with my custom kernel and initramfs (both created by genkernel, though I did the configuring), but I can't see anything. The system changes that state of the numlock key, reponds to ctrl-alt-del, cleans tmp, but I can't see a thing. I have merged that ati-drives. The default debian kernel does output messages. My card is an amd 7770. My kernel version is pf-sources 3.19_r1, grub 2.02_beta2-r3, boot-update 1.7.3, and genkernel 3.4.40.7-r6. I did read the ati install guide and follow the directions. Thanks.
  2. I get the following message in my /var/log/Xorg.0.log and was wondering if anyone else was getting it: [ 1312.812] (II) RADEON(0): Use GLAMOR acceleration. [ 1312.812] (II) RADEON(0): Acceleration enabled [ 1312.812] (==) RADEON(0): DPMS enabled [ 1312.812] (==) RADEON(0): Silken mouse enabled [ 1312.812] (EE) RADEON(0): Failed to set up textured video (glamor) Does anyone know what implications this has / how I can resolve it?
  3. Hello, now that I want to swith my desktop from Opensuse to Funtoo I remmember that some of the AMD cards requier a seperate binary only proprietary driver. The Linux kernel has been upgraded several times since 3.0 and so they might have a driver out or I might need to do some magic to get my card working properly, I'm not certain. Mine is the R7770. Here's the output of lspci: 01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Cape Verde [Radeon HD 7700 Series] (prog-if 00 [VGA controller]) Subsystem: Micro-Star International Co., Ltd. Device 2710 Flags: bus master, fast devsel, latency 0, IRQ 74 Memory at c0000000 (64-bit, prefetchable) Memory at fea00000 (64-bit, non-prefetchable) I/O ports at e000 Expansion ROM at fea40000 [disabled] Capabilities: [48] Vendor Specific Information: Len=08 <?> Capabilities: [50] Power Management version 3 Capabilities: [58] Express Legacy Endpoint, MSI 00 Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+ Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?> Capabilities: [150] Advanced Error Reporting Capabilities: [270] #19 Kernel driver in use: radeon I would research this myself, however, I'm not sure where to start since if I did a web search I'll undoubtably get a bunch of outdated info.
  4. I recently made the switch from fglrx to the radeon drivers for my video cards. The installation and modifications to the kernel went well and my system booted correctly. However, when I ran my compositor, compton, with backend glx things slowed down -- specifically, window dragging was very slow and laggy -- almost like a vsync issue. This led me to check my X.org log, where I found the following: [ 22.676] (II) RADEON(0): EDID for output DVI-0 [ 22.690] (II) RADEON(0): EDID for output DVI-1 [ 22.690] (II) RADEON(0): Output DisplayPort-0 disconnected [ 22.690] (II) RADEON(0): Output HDMI-0 connected [ 22.690] (II) RADEON(0): Output DVI-0 disconnected [ 22.690] (II) RADEON(0): Output DVI-1 disconnected [ 22.690] (II) RADEON(0): Using exact sizes for initial modes [ 22.690] (II) RADEON(0): Output HDMI-0 using initial mode 1920x1080 [ 22.690] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated. [ 22.690] (II) RADEON(0): mem size init: gart size :3fbce000 vram size: s:80000000 visible:7f39e000 [ 22.690] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM [ 22.690] (==) RADEON(0): DPI set to (96, 96) [ 22.690] (II) Loading sub module "fb" [ 22.690] (II) LoadModule: "fb" [ 22.690] (II) Loading /usr/lib64/xorg/modules/libfb.so [ 22.692] (II) Module fb: vendor="X.Org Foundation" [ 22.692] compiled for 1.16.1, module version = 1.0.0 [ 22.692] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.692] (II) Loading sub module "ramdac" [ 22.692] (II) LoadModule: "ramdac" [ 22.692] (II) Module "ramdac" already built-in [ 22.692] (==) RADEON(G0): Depth 24, (--) framebuffer bpp 32 [ 22.692] (II) RADEON(G0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps) [ 22.692] (==) RADEON(G0): Default visual is TrueColor [ 22.692] (==) RADEON(G0): RGB weight 888 [ 22.692] (II) RADEON(G0): Using 8 bits per RGB (8 bit DAC) [ 22.692] (--) RADEON(G0): Chipset: "PITCAIRN" (ChipID = 0x6819) [ 22.692] (II) Loading sub module "dri2" [ 22.692] (II) LoadModule: "dri2" [ 22.692] (II) Module "dri2" already built-in [ 22.692] (II) Loading sub module "glamoregl" [ 22.692] (II) LoadModule: "glamoregl" [ 22.692] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so [ 22.692] (II) Module glamoregl: vendor="X.Org Foundation" [ 22.692] compiled for 1.16.1, module version = 0.6.0 [ 22.692] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.692] (II) glamor: OpenGL accelerated X.org driver based. [ 22.693] (II) glamor: EGL version 1.4 (DRI2): [ 22.693] EGL_MESA_drm_image required. [ 22.693] (EE) RADEON(G0): glamor detected, failed to initialize EGL. [ 22.693] (II) Loading sub module "shadow" [ 22.693] (II) LoadModule: "shadow" [ 22.693] (II) Loading /usr/lib64/xorg/modules/libshadow.so [ 22.693] (II) Module shadow: vendor="X.Org Foundation" [ 22.693] compiled for 1.16.1, module version = 1.1.0 [ 22.693] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.693] (II) RADEON(G0): KMS Color Tiling: disabled [ 22.693] (II) RADEON(G0): KMS Color Tiling 2D: disabled [ 22.693] (II) RADEON(G0): KMS Pageflipping: enabled [ 22.693] (II) RADEON(G0): SwapBuffers wait for vsync: enabled [ 22.699] (II) RADEON(G0): Output DisplayPort-1-1 has no monitor section [ 22.705] (II) RADEON(G0): Output DisplayPort-1-2 has no monitor section [ 22.707] (II) RADEON(G0): Output HDMI-1-1 has no monitor section [ 22.722] (II) RADEON(G0): Output DVI-1-1 has no monitor section [ 22.728] (II) RADEON(G0): EDID for output DisplayPort-1-1 [ 22.734] (II) RADEON(G0): EDID for output DisplayPort-1-2 [ 22.736] (II) RADEON(G0): EDID for output HDMI-1-1 [ 22.750] (II) RADEON(G0): EDID for output DVI-1-1 [ 22.750] (II) RADEON(G0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated. [ 22.750] (II) RADEON(G0): mem size init: gart size :3fbce000 vram size: s:80000000 visible:7f887000 [ 22.750] (II) RADEON(G0): EXA: Driver will allow EXA pixmaps in VRAM [ 22.750] (==) RADEON(G0): DPI set to (96, 96) [ 22.750] (II) Loading sub module "fb" [ 22.750] (II) LoadModule: "fb" [ 22.750] (II) Loading /usr/lib64/xorg/modules/libfb.so [ 22.750] (II) Module fb: vendor="X.Org Foundation" [ 22.750] compiled for 1.16.1, module version = 1.0.0 [ 22.750] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.750] (II) Loading sub module "ramdac" [ 22.750] (II) LoadModule: "ramdac" [ 22.750] (II) Module "ramdac" already built-in [ 22.750] (--) Depth 24 pixmap format is 32 bpp [ 22.751] (II) RADEON(G0): Front buffer size: 3072K [ 22.751] (II) RADEON(G0): VRAM usage limit set to 1877698K [ 22.752] (==) RADEON(G0): Backing store enabled [ 22.752] (WW) RADEON(G0): Direct rendering disabled [ 22.752] (II) RADEON(G0): Acceleration disabled [ 22.752] (==) RADEON(G0): DPMS enabled [ 22.752] (==) RADEON(G0): Silken mouse enabled [ 22.753] (II) RADEON(G0): RandR 1.2 enabled, ignore the following RandR disabled message. [ 22.753] (II) RADEON(0): Front buffer size: 8100K [ 22.753] (II) RADEON(0): VRAM usage limit set to 1868648K [ 22.753] (==) RADEON(0): Backing store enabled [ 22.753] (WW) RADEON(0): Direct rendering disabled [ 22.753] (II) RADEON(0): Acceleration disabled [ 22.754] (==) RADEON(0): DPMS enabled [ 22.754] (==) RADEON(0): Silken mouse enabled [ 22.754] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message. [ 22.771] (--) RandR disabled [ 22.778] (II) AIGLX: Screen 0 is not DRI2 capable [ 22.778] (EE) AIGLX: reverting to software rendering [ 22.779] (II) AIGLX: Loaded and initialized swrast [ 22.779] (II) GLX: Initialized DRISWRAST GL provider for screen 0 [ 22.789] (II) RADEON(0): Setting screen physical size to 508 x 285 [ 22.830] (II) config/udev: Adding input device Power Button (/dev/input/event1) [ 22.830] (**) Power Button: Applying InputClass "evdev keyboard catchall" [ 22.830] (II) LoadModule: "evdev" [ 22.830] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so [ 22.833] (II) Module evdev: vendor="X.Org Foundation" [ 22.833] compiled for 1.16.1, module version = 2.9.1 [ 22.833] Module class: X.Org XInput Driver [ 22.833] ABI class: X.Org XInput driver, version 21.0 [ 22.833] (II) Using input driver 'evdev' for 'Power Button' [ 22.833] (**) Power Button: always reports core events [ 22.833] (**) evdev: Power Button: Device: "/dev/input/event1" [ 22.833] (--) evdev: Power Button: Vendor 0 Product 0x1 [ 22.833] (--) evdev: Power Button: Found keys [ 22.833] (II) evdev: Power Button: Configuring as keyboard [ 22.833] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1" [ 22.833] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6) [ 22.833] (**) Option "xkb_rules" "evdev" [ 22.833] (**) Option "xkb_model" "pc104" [ 22.833] (**) Option "xkb_layout" "us" [ 22.852] (II) config/udev: Adding input device Power Button (/dev/input/event0) [ 22.852] (**) Power Button: Applying InputClass "evdev keyboard catchall" [ 22.852] (II) Using input driver 'evdev' for 'Power Button' [ 22.852] (**) Power Button: always reports core events [ 22.852] (**) evdev: Power Button: Device: "/dev/input/event0" [ 22.852] (--) evdev: Power Button: Vendor 0 Product 0x1 [ 22.852] (--) evdev: Power Button: Found keys [ 22.852] (II) evdev: Power Button: Configuring as keyboard [ 22.852] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0" [ 22.852] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7) [ 22.852] (**) Option "xkb_rules" "evdev" [ 22.852] (**) Option "xkb_model" "pc104" [ 22.852] (**) Option "xkb_layout" "us" [ 22.852] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2) [ 22.852] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall" [ 22.852] (II) Using input driver 'evdev' for 'Logitech USB Receiver' [ 22.852] (**) Logitech USB Receiver: always reports core events [ 22.852] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2" [ 22.852] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b [ 22.852] (--) evdev: Logitech USB Receiver: Found keys [ 22.852] (II) evdev: Logitech USB Receiver: Configuring as keyboard [ 22.852] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:05.0/0000:03:00.0/usb1/1-1/1-1:1.0/0003:046D:C52B.0001/input/input5/event2" [ 22.852] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 8) [ 22.852] (**) Option "xkb_rules" "evdev" [ 22.852] (**) Option "xkb_model" "pc104" [ 22.852] (**) Option "xkb_layout" "us" [ 22.853] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3) [ 22.853] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall" [ 22.853] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall" [ 22.853] (II) Using input driver 'evdev' for 'Logitech USB Receiver' [ 22.853] (**) Logitech USB Receiver: always reports core events [ 22.853] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event3" [ 22.853] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b [ 22.853] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons [ 22.853] (--) evdev: Logitech USB Receiver: Found scroll wheel(s) [ 22.853] (--) evdev: Logitech USB Receiver: Found relative axes [ 22.853] (--) evdev: Logitech USB Receiver: Found x and y relative axes [ 22.853] (--) evdev: Logitech USB Receiver: Found absolute axes [ 22.853] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist. [ 22.853] (--) evdev: Logitech USB Receiver: Found keys [ 22.853] (II) evdev: Logitech USB Receiver: Configuring as mouse [ 22.853] (II) evdev: Logitech USB Receiver: Configuring as keyboard [ 22.853] (II) evdev: Logitech USB Receiver: Adding scrollwheel support [ 22.853] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5 [ 22.853] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200 [ 22.853] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:05.0/0000:03:00.0/usb1/1-1/1-1:1.1/0003:046D:C52B.0002/input/input6/event3" [ 22.853] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9) [ 22.853] (**) Option "xkb_rules" "evdev" [ 22.853] (**) Option "xkb_model" "pc104" [ 22.853] (**) Option "xkb_layout" "us" [ 22.853] (II) evdev: Logitech USB Receiver: initialized for relative axes. [ 22.853] (WW) evdev: Logitech USB Receiver: ignoring absolute axes. [ 22.853] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration profile 0 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration threshold: 4 [ 22.853] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0) [ 22.853] (II) No input driver specified, ignoring this device. [ 22.853] (II) This device may have been added with another device file. [ 22.854] (II) config/udev: Adding input device Logitech Logitech Illuminated Keyboard (/dev/input/event4) [ 22.854] (**) Logitech Logitech Illuminated Keyboard: Applying InputClass "evdev keyboard catchall" [ 22.854] (II) Using input driver 'evdev' for 'Logitech Logitech Illuminated Keyboard' [ 22.854] (**) Logitech Logitech Illuminated Keyboard: always reports core events [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: Device: "/dev/input/event4" [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Vendor 0x46d Product 0xc318 [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found keys [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as keyboard [ 22.854] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:07.0/0000:04:00.0/usb3/3-2/3-2:1.0/0003:046D:C318.0004/input/input7/event4" [ 22.854] (II) XINPUT: Adding extended input device "Logitech Logitech Illuminated Keyboard" (type: KEYBOARD, id 10) [ 22.854] (**) Option "xkb_rules" "evdev" [ 22.854] (**) Option "xkb_model" "pc104" [ 22.854] (**) Option "xkb_layout" "us" [ 22.854] (II) config/udev: Adding input device Logitech Logitech Illuminated Keyboard (/dev/input/event5) [ 22.854] (**) Logitech Logitech Illuminated Keyboard: Applying InputClass "evdev keyboard catchall" [ 22.854] (II) Using input driver 'evdev' for 'Logitech Logitech Illuminated Keyboard' [ 22.854] (**) Logitech Logitech Illuminated Keyboard: always reports core events [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: Device: "/dev/input/event5" [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Vendor 0x46d Product 0xc318 [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found 1 mouse buttons [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found scroll wheel(s) [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found relative axes [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Forcing relative x/y axes to exist. [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found absolute axes [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Forcing absolute x/y axes to exist. [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found keys [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as mouse [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as keyboard [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Adding scrollwheel support [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: YAxisMapping: buttons 4 and 5 [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200 [ 22.854] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:07.0/0000:04:00.0/usb3/3-2/3-2:1.1/0003:046D:C318.0005/input/input8/event5" [ 22.854] (II) XINPUT: Adding extended input device "Logitech Logitech Illuminated Keyboard" (type: KEYBOARD, id 11) [ 22.854] (**) Option "xkb_rules" "evdev" [ 22.854] (**) Option "xkb_model" "pc104" [ 22.854] (**) Option "xkb_layout" "us" [ 22.855] (II) evdev: Logitech Logitech Illuminated Keyboard: initialized for relative axes. [ 22.855] (WW) evdev: Logitech Logitech Illuminated Keyboard: ignoring absolute axes. [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) keeping acceleration scheme 1 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration profile 0 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration factor: 2.000 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration threshold: 4 [ 23.128] (II) RADEON(0): EDID vendor "DEL", prod id 41072 [ 23.128] (II) RADEON(0): Using EDID range info for horizontal sync [ 23.128] (II) RADEON(0): Using EDID range info for vertical refresh [ 23.128] (II) RADEON(0): Printing DDC gathered Modelines: Of particular interest to me were the lines: [ 22.693] (II) glamor: EGL version 1.4 (DRI2): [ 22.693] EGL_MESA_drm_image required. [ 22.693] (EE) RADEON(G0): glamor detected, failed to initialize EGL. and [ 22.753] (WW) RADEON(0): Direct rendering disabled [ 22.753] (II) RADEON(0): Acceleration disabled EDIT: I am also getting the following error: [ 996.530] (II) AIGLX: Screen 0 is not DRI2 capable [ 996.530] (EE) AIGLX: reverting to software rendering [ 996.531] (II) AIGLX: Loaded and initialized swrast My specs, if they will be useful: xorg-server-1.16.1-r4 xf86-video-ati-7.5.0 mesa-10.3.5 llvm-3.5.1 Radeon HD 7850 Any ideas as to how I can re-enable direct rendering and acceleration / resolve the problem with GLamor?
×
×
  • Create New...