Jump to content
funtoo forums

Search the Community

Showing results for tags 'qt'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 2 results

  1. Well, a time ago I knew about Gentoo and Funtoo and I liked the philosophy and how it works, then I decided to install Funtoo on my notebook (that I'm using right now). Someday I tried to install VLC and in the middle of the installation, when compiling QtGui, my notebook stopped being hot and noisy (what is normal when it's compiling packages). So I checked the processor cores with htop and it seemed like the compilation process just was dead. I waited some more minutes and nothing... I decided to cancel the installation. Later I tried to install Aseprite and the Allegro package has needed as well, so I started emerging the packages but when my notebook was compiling Allegro just occurred an Emake error with no much details about what happened. Then I decided to install Aseprite by compiling manually (as shown on its github page) and it worked fine. Finally some days ago I tried to install nextcloud-client package that required some Qt packages and once again the installation failed but this time with an error saying that my notebook processor has not support for aes. I also tried to install G'MIC on my GIMP but I could not be able to do that; I suspect that because I don't have any Qt package and because that G'MIC (that uses Qt) does not work. What can I do to solve this situation? I tried to use Entropy package manager but occurred some conflicts and I had to reinstall Funtoo. I also tried to install some packages with Flatpak, but it does not have some packages (qutebrowser for example). Is there a another way to install binary packages or to solve the compilation errors?
  2. HI. i have problems with AES FLAG. i installed funtoo on a samsung laptop with Core i3 Westmere. i used intel64-westmere stage3. but when i installed KDE desktop refuses to init because: # nano /var/lib/sddm/.local/share/sddm/xorg-session.log Incompatible processor. This Qt build requires the following features: aes Aborted. Incompatible processor: missing feature 0x2000000 - aes. my processor is westmere but do not support aes. # gcc -march=native -E -v - </dev/null 2>&1 | grep cc1 /usr/libexec/gcc/x86_64-pc-linux-gnu/7.3.1/cc1 -E -quiet -v - -march=westmere -mmmx -mno-3dnow -msse -msse2 -msse3 -mssse3 -mno-sse4a -mcx16 -msahf -mno-movbe -mno-aes -mno-sha -mno-pclmul -mpopcnt -mno-abm -mno-lwp -mno-fma -mno-fma4 -mno-xop -mno-bmi -mno-sgx -mno-bmi2 -mno-tbm -mno-avx -mno-avx2 -msse4.2 -msse4.1 -mno-lzcnt -mno-rtm -mno-hle -mno-rdrnd -mno-f16c -mno-fsgsbase -mno-rdseed -mno-prfchw -mno-adx -mfxsr -mno-xsave -mno-xsaveopt -mno-avx512f -mno-avx512er -mno-avx512cd -mno-avx512pf -mno-prefetchwt1 -mno-clflushopt -mno-xsavec -mno-xsaves -mno-avx512dq -mno-avx512bw -mno-avx512vl -mno-avx512ifma -mno-avx512vbmi -mno-avx5124fmaps -mno-avx5124vnniw -mno-clwb -mno-mwaitx -mno-clzero -mno-pku -mno-rdpid --param l1-cache-size=32 --param l1-cache-line-size=64 --param l2-cache-size=3072 -mtune=westmere so i changed in /etc/portage/make.conf CFLAGS="-march=native -mno-aes -O2 -pipe" CXXFLAGS="${CFLAGS}" FFLAGS="${CFLAGS}" FCFLAGS="${CFLAGS}" USE="-aes" then emerge -ave @system Now works, i hope this help someone. related topics
×
×
  • Create New...