Jump to content
funtoo forums

Search the Community

Showing results for tags 'mysql'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 2 results

  1. I am trying to activate my mariadb database. After installting mariadb: [ebuild R ] dev-db/mariadb-10.4.6:0/18::core-server-kit USE="server -backup -bindist -client-libs -cracklib -debug -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jdbc -jemalloc -kerberos -latin1 -libressl -mroonga -numa -odbc -oqgraph -pam -perl -profiling -rocksdb (-selinux) -sphinx -sst-mariabackup -sst-rsync -static -systemd -systemtap -tcmalloc -test -tokudb -xml -yassl" 0 KiB [ebuild R ] virtual/mysql-5.6-r12:0/18::core-server-kit USE="server -embedded -static" 0 KiB After the installtion I wrote: emerge --config =dev-db/mariadb-10.4.6 and i got: Configuring pkg... * Trying to get password for mysql 'root' user from 'mysql' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Trying to get password for mysql 'root' user from 'client' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Please provide a password for the mysql 'root'@'localhost' user now * or through the /root/.my.cnf file. * Avoid ["'\_%] characters in the password * Not entering a password defaults to UNIX authentication > * Retype the password > * Creating the mysql database and setting proper permissions on it ... * Command: usr/bin/mysql_install_db --basedir=/usr --loose-skip-grant-tables --loose-skip-host-cache --loose-skip-name-resolve --loose-skip-networking --loose-skip-slave-start --loose-skip-ssl --loose-skip-log-bin --loose-skip-relay-log --loose-skip-slow-query-log --loose-skip-external-locking --loose-skip-log-slave-updates --datadir=//var/lib/mysql --tmpdir=/ * ERROR: dev-db/mariadb-10.4.6::core-server-kit failed (config phase): * Failed to initialize mysqld. Please review /var/log/mysql/mysqld.err AND /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log * * Call stack: * ebuild.sh, line 93: Called pkg_config * environment, line 4492: Called die * The specific snippet of code: * die "Failed to initialize mysqld. Please review ${EPREFIX}/var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"; * * If you need support, post the output of `emerge --info '=dev-db/mariadb-10.4.6::core-server-kit'`, * the complete build log and the output of `emerge -pqv '=dev-db/mariadb-10.4.6::core-server-kit'`. !!! When you file a bug report, please include the following information: GENTOO_VM= CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm" JAVACFLAGS="" COMPILER="" and of course, the output of emerge --info =mariadb-10.4.6 * The complete build log is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment'. * Working directory: '/var/tmp/portage/dev-db/mariadb-10.4.6/temp' * S: '/var/tmp/portage/dev-db/mariadb-10.4.6/work/mariadb-10.4.6' The output of file /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log: sh: usr/bin/mysql_install_db: No such file or directory On my computer I have the file mysql_install_db at a different directory: /usr/share/mariadb/scripts/mysql_install_db Any idea how to solve this problem?
  2. Hi, Currently I am using the layman mysql, its 5.7.12 atm. But it not upped in months. I tried to fiddle with the ebuilds - copied the latest one as mysql-5.7.15.ebuild, - ebuild mysql-5.7.15.ebuild manifest all went just fine, but at the end I receive : -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/mysql/magic -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/aclocal/mysql.m4 -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/mysql/mysql.server * Making Convenience links for mysqlcheck multi-call binary * Building default my.cnf (5.6) * Adjusting to prefix / * my.cnf.ok ... [ ok ] * Creating initial directories * Including support files and sample configurations * Header files have changed between ABIs. * --- /var/tmp/portage/dev-db/mysql-5.7.15/temp/.multilib_header_cksum 2016-10-18 19:31:00.892131266 +0300 * +++ /var/tmp/portage/dev-db/mysql-5.7.15/temp/.multilib_header_cksum.new 2016-10-18 19:31:06.632131397 +0300 * @@ -10,6 +10,7 @@ * 931919434 13470 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_command.h * 2987720505 1384 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/thread_type.h * 39760184 13897 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/plugin_audit.h.pp * +2782043840 1443 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysqlx_version.h * 4220503078 1489 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_thd_engine_lock.h * 1955776921 14902 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/sql_state.h * 1175938711 1506 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/my_list.h * @@ -43,6 +44,7 @@ * 3200460594 26101 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/plugin.h * 819488767 2682 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_thread_scheduler.h * 3234572590 2760 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_mysql_alloc.h * +947087210 2791 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysqlx_error.h * 4221559651 2821 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/my_xml.h * 3848574317 2837 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/psi/mysql_sp.h * 1075151809 2878 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/sslopt-longopts.h * ERROR: dev-db/mysql-5.7.15::x-portage failed (install phase): * Header checksum mismatch, aborting. * My USE flags atm are: [root@tangra][/usr/local/portage/dev-db/mysql]# emerge -pv mysql These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-db/mysql-5.7.15:0/20::x-portage [5.7.11:0/20::mysql] USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" ABI_X86="32 (64) (-x32)" 0 KiB Total: 1 package (1 upgrade), Size of downloads: 0 KiB * IMPORTANT: 9 news items need reading for repository 'gentoo'. * Use eselect news read to view new items. [root@tangra][/usr/local/portage/dev-db/mysql emerge --info -> http://pastebin.com/d5Z0vJA8 I guess I am doing smth wrong /obviously/. How can I proceed from there? Thanks.
×
×
  • Create New...