Jump to content
funtoo forums

Search the Community

Showing results for tags 'mariadb'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 2 results

  1. I am trying to activate my mariadb database. After installting mariadb: [ebuild R ] dev-db/mariadb-10.4.6:0/18::core-server-kit USE="server -backup -bindist -client-libs -cracklib -debug -extraengine -galera -innodb-lz4 -innodb-lzo -innodb-snappy -jdbc -jemalloc -kerberos -latin1 -libressl -mroonga -numa -odbc -oqgraph -pam -perl -profiling -rocksdb (-selinux) -sphinx -sst-mariabackup -sst-rsync -static -systemd -systemtap -tcmalloc -test -tokudb -xml -yassl" 0 KiB [ebuild R ] virtual/mysql-5.6-r12:0/18::core-server-kit USE="server -embedded -static" 0 KiB After the installtion I wrote: emerge --config =dev-db/mariadb-10.4.6 and i got: Configuring pkg... * Trying to get password for mysql 'root' user from 'mysql' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Trying to get password for mysql 'root' user from 'client' section ... /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory /var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment: line 4365: usr/libexec/mariadb/my_print_defaults: No such file or directory * Please provide a password for the mysql 'root'@'localhost' user now * or through the /root/.my.cnf file. * Avoid ["'\_%] characters in the password * Not entering a password defaults to UNIX authentication > * Retype the password > * Creating the mysql database and setting proper permissions on it ... * Command: usr/bin/mysql_install_db --basedir=/usr --loose-skip-grant-tables --loose-skip-host-cache --loose-skip-name-resolve --loose-skip-networking --loose-skip-slave-start --loose-skip-ssl --loose-skip-log-bin --loose-skip-relay-log --loose-skip-slow-query-log --loose-skip-external-locking --loose-skip-log-slave-updates --datadir=//var/lib/mysql --tmpdir=/ * ERROR: dev-db/mariadb-10.4.6::core-server-kit failed (config phase): * Failed to initialize mysqld. Please review /var/log/mysql/mysqld.err AND /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log * * Call stack: * ebuild.sh, line 93: Called pkg_config * environment, line 4492: Called die * The specific snippet of code: * die "Failed to initialize mysqld. Please review ${EPREFIX}/var/log/mysql/mysqld.err AND ${TMPDIR}/mysql_install_db.log"; * * If you need support, post the output of `emerge --info '=dev-db/mariadb-10.4.6::core-server-kit'`, * the complete build log and the output of `emerge -pqv '=dev-db/mariadb-10.4.6::core-server-kit'`. !!! When you file a bug report, please include the following information: GENTOO_VM= CLASSPATH="" JAVA_HOME="/etc/java-config-2/current-system-vm" JAVACFLAGS="" COMPILER="" and of course, the output of emerge --info =mariadb-10.4.6 * The complete build log is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/dev-db/mariadb-10.4.6/temp/environment'. * Working directory: '/var/tmp/portage/dev-db/mariadb-10.4.6/temp' * S: '/var/tmp/portage/dev-db/mariadb-10.4.6/work/mariadb-10.4.6' The output of file /var/tmp/portage/dev-db/mariadb-10.4.6/temp/mysql_install_db.log: sh: usr/bin/mysql_install_db: No such file or directory On my computer I have the file mysql_install_db at a different directory: /usr/share/mariadb/scripts/mysql_install_db Any idea how to solve this problem?
  2. Help! I am trying to get mariadb up and running. It installs and I can run mysql, but the emerge ---config dev-db/mariadb exits with the following error: "Failed to initialize mysqld" Even though I can start the database with "/etc/init.d/mysql start", I can't access it because the config failed and it doesn't have my password. Can someone give me a hint about what is going wrong here? Thanks, Don James
×
×
  • Create New...