Jump to content

Search the Community

Showing results for tags 'luks'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

  • drobbins' Blog
  • It's a Bear's life
  • haxmeister's Blog
  • psychopatch's Blog
  • 666threesixes666's Blog
  • decision theory
  • Chris Kurlinski's Blog
  • Sandro's Blog
  • danielv's Blog
  • Not So Stupid Admin Tricks
  • maldoror's Blog
  • andreawilson's Blog
  • Simple Step-by-Step Server Setup
  • saraedward's Blog
  • eusanpe
  • Linux Container Club - LXD/LXC's Blog
  • Funtoo Perl Hackers's Perl on Funtoo

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 5 results

  1. hello first like to thank you for the forum to have the participation of the creator of the Best Linux distro created and an honor. good i use linux just over two years, but there a few months decides to abandon the simplest distros such as Ubuntu, Debian .... and decides to migrate pro Arch Linux, but found it very easy then went pro Gentoo and Funtoo Finally a few days, I plan on not leaving until he creates own. Finally, I would like to use PURE-UEFI + Luks + ZFS, and I wonder if this is possible or do I have to install Grub?
  2. Hi, On one of my laptops I have gone encrypted along with syslinux. To get there I had to hack the initrd scripts a bit but well, I got it working. In some documentation I have come across (funtoo, gentoo, and arch linux) there are quite some references to /etc/crypttab that seems to be used along with systemd but are there any scripts making use of crypttab in if open RC is used? // Erik
  3. Hello, I have an encrypted LUKS root filesystem on one harddisk that I "open" with a passphrase at startup. The initrd.script of genkernel package provide the methods for decrypting. But if I understand the script(s) correct this will work only for encrypted root and swap devices. Normally I have my home directory on an additional raid10 setup which should be encrypted too. There is a comment at the top of the script which says that I need cryptsetup-luks for decrypting additional encrypted devices but this package does not exist anymore. Does someone is using a similar setup? Where would
  4. This is my first installation with funtoo. I have used a combination of luks and lvm that is I encrypted the partition /dev/sda2. After I've created three volume root, home and portage and formatted with btrfs. The mount point are respectively: /mnt/funtoo, /mnt/funtoo/home,/mnt/funtoo/usr/portage. The sda1 is vfat efi partition where I installed the grub2 . The kernel is debian-sources. The boot.conf is the following "Funtoo Linux General" { kernel kernel[-v] initrd initramfs[-v] params += crypt_root=/dev/sda2 dolvm real_root=/dev/mapper/vg-root rootfstype=btrfs } The boot-boot-update
  5. I'm fairly certain I've botched my LUKS on LVM setup. The main problem is that the root partition is getting mapped to the wrong place; I would like it to be in /dev/mapper/root, but instead it gets mapped to /dev/mapper/luks-<gibberish, I think the PARTUUID?>. Once I enter the decryption password on boot, it hangs for a bit, starts "Scanning for btrfs devices" before crashing to an emergency shell. From there, I close /dev/mapper/luks... and reopen it, mapping it to /dev/mapper/root. Any ideas? Here's my dracut config and the initramfs log: /etc/dracut.conf # PUT YOUR CONFIG HER
×
×
  • Create New...