Jump to content

Search the Community

Showing results for tags 'lprng foomatic cups'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.

Marker Groups

  • Members

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 1 result

  1. Hi, I am running lprng with this use flags at the moment: net-print/lprng-3.8.35-r2 USE="nls ssl -foomaticdb -kerberos" Now I need to add the foomaticdb use flag so that I can run my printer with lprng - but then I get a block: Calculating dependencies... done! [ebuild N ] app-text/qpdf-5.1.2:0/13 USE="-doc -examples -static-libs {-test}" 7,485 kB [ebuild N ] app-text/enscript-1.6.6 USE="nls -ruby" 1,300 kB [ebuild N ] net-print/foomatic-filters-4.0.17-r1 USE="dbus -cups" 261 kB [ebuild N ] net-print/cups-1.7.3 USE="X acl dbus pam python ssl threads -debug -gnutls -java -kerberos -lprng-compat (-selinux) -static-libs -sy stemd -usb -xinetd -zeroconf" LINGUAS="-ca -es -fr -it -ja -pt_BR -ru" PYTHON_SINGLE_TARGET="python2_7 (-python2_6)" PYTHON_TARGETS="python2_7 (-pytho n2_6)" 8,587 kB [ebuild R ] app-text/ghostscript-gpl-9.14 USE="X cups* dbus djvu idn -bindist -gtk -static-libs" LINGUAS="de -ja -ko -zh_CN -zh_TW" 0 kB [ebuild N ] net-print/cups-filters-1.0.54 USE="dbus foomatic jpeg png tiff -perl -static-libs -zeroconf" 1,284 kB [ebuild N ] net-print/foomatic-db-engine-4.0.11 352 kB [ebuild N ] net-print/foomatic-db-4.0.20140105 37,935 kB [ebuild R ] net-print/lprng-3.8.35-r2 USE="foomaticdb* nls ssl -kerberos" 0 kB [blocks B ] >=net-print/cups-1.6.2-r4[-lprng-compat] (">=net-print/cups-1.6.2-r4[-lprng-compat]" is blocking net-print/lprng-3.8.35-r2) [blocks B ] >=net-print/cups-filters-1.0.43-r1[foomatic] (">=net-print/cups-filters-1.0.43-r1[foomatic]" is blocking net-print/foomatic-filters-4 .0.17-r1) [blocks B ] net-print/lprng ("net-print/lprng" is blocking net-print/cups-1.7.3) [blocks B ] net-print/foomatic-filters ("net-print/foomatic-filters" is blocking net-print/cups-filters-1.0.54) Total: 9 packages (7 new, 2 reinstalls), Size of downloads: 57,201 kB Conflict: 4 blocks (4 unsatisfied) !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: app-text/ghostscript-gpl:0 (app-text/ghostscript-gpl-9.14::gentoo, ebuild scheduled for merge) pulled in by app-text/ghostscript-gpl[cups] required by (net-print/cups-1.7.3::gentoo, ebuild scheduled for merge) (app-text/ghostscript-gpl-9.14::gentoo, installed) pulled in by (no parents that aren't satisfied by other packages in this slot) As soon I enable the foomaticdb use flag of lprng, the ebuild foomatic-db-engine pulls cups in by: .. DEPEND="net-print/cups" .. That makes no sense to me as the foomatic drivers are especially made the way that they can be used by any printing system (see also http://www.linuxfoundation.org/collaborate/workgroups/openprinting/databasefoomatic#Using_Foomatic_with_a_particular_printer_and_spooler ). Can this be fixed or is here a bug reported needed? Thanks
×
×
  • Create New...