Search the Community
Showing results for tags 'libquvi'.
Found 1 result
Hey folks, I've recently run into a dependency conflict that forced me to remove lua 5.2 from my box. This is the situation: mplayer, ffmpeg and other packages with the libquvi USE and podofo (needed by the pdf USE of krenamer) asked for lua >=5.2. vlc and other programs (I can't recall now) asked for lua <5.2 I ended removing the libquvi USE and the pdf USE of krenamer, but I don't like that as a solution; I tried to slot the new version of lua (and I succeeded) but after doing that somehow the blockage persists as if I never had slotted lua in first place. I saw that this issue appeared in Gentoo forums as well, but in my case, I have programs that rely on both versions. I'm not a lua fanboy (in fact, I didn't knew that so many programs relied on lua) but yes, I'm a fanboy of satisfying every needed dependency on my system in order to provide the best funcionality and user experience available, so I would like to regain the libquvi flag (although it is not a priority) without breaking the system. This is the status of my box right now: sakura pega # equery d dev-lang/lua * These packages depend on dev-lang/lua: app-arch/rpm-4.11.2 (lua ? >=dev-lang/lua-5.1.0[deprecated]) app-editors/vim-7.4.326 (!luajit ? dev-lang/lua[deprecated]) app-editors/vim-qt-20131004 (!luajit ? dev-lang/lua) app-text/podofo-0.9.2 (dev-lang/lua) dev-util/geany-plugins-1.24-r1 (lua ? dev-lang/lua) media-libs/libquvi-0.4.1-r1 (>=dev-lang/lua-5.1[deprecated]) media-video/vlc-2.1.4 (lua ? >=dev-lang/lua-5.1:0) net-analyzer/nmap-6.25 (lua ? >=dev-lang/lua-5.1.4-r1[deprecated]) www-client/elinks-0.12_pre6 (lua ? >=dev-lang/lua-5) I'd really appreciate a hint regarding how to deal with lua and achieve the coexistence between the two versions of lua (5.1 and 5.2). Thanks in advance!