Jump to content

Search the Community

Showing results for tags 'grub2'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services


  • drobbins' Blog
  • It's a Bear's life
  • haxmeister's Blog
  • psychopatch's Blog
  • 666threesixes666's Blog
  • decision theory
  • Chris Kurlinski's Blog
  • Sandro's Blog
  • danielv's Blog
  • Not So Stupid Admin Tricks
  • maldoror's Blog
  • andreawilson's Blog
  • Simple Step-by-Step Server Setup
  • saraedward's Blog
  • eusanpe
  • Funtoo Perl Hackers's Perl on Funtoo

Find results in...

Find results that contain...

Date Created

  • Start


Last Updated

  • Start


Filter by number of...


  • Start






First Name

Last Name



Found 3 results

  1. Hello, I have a crypted /home (/dev/mapper/lvm-home) inside lvm, and a keyfile on /boot (/dev/sda1): /boot/keyfile Why: On normal days, it boot automatically, but on vacations/trips I delet the /boot/keyfile and people can't access. On ArchLinux it worked with: [ /etc/default/grub ] GRUB_CMDLINE_LINUX="cryptdevice=/dev/mapper/lvm-home:home cryptkey=/dev/sda1:ext4:/.boot root=/dev/mapper/lvm-funtoo dolvm rootfstype=ext4" and before: grub-mkconfig -o /boot/grub/grub.cfg On Funtoo I tried the same and: [ /etc/crypttab ] home UUID=44ae1749-28d7-4f35-9948-e02b747213cf /dev/disk/by-uuid/013e1dc7-cb3f-4a90-8b4e-251179adcbe5:/keyfile luks,initramfs [ /etc/conf.d/dmcrypt ] target=home source=UUID=44ae1749-28d7-4f35-9948-e02b747213cf key=/dev/disk/by-uuid/013e1dc7-cb3f-4a90-8b4e-251179adcbe5:/keyfile With "genkernel --lvm --luks initramfs" after all. [ /boot/grub/grub.cfg ] linux /kernel-debian-sources-x86_64-5.10.40_p1 root=/dev/mapper/lvm-funtoo ro cryptdevice=/dev/mapper/lvm-home:home cryptkey=/dev/sda1:ext4:/keyfile root=/dev/mapper/lvm-funtoo dolvm rootfstype=ext4 loglevel=7 echo 'Loading initial ramdisk ...' initrd /early_ucode.cpio /initramfs-genkernel-x86_64-5.10.40_p1-debian-sources [ /etc/fstab ] /dev/mapper/lvm-funtoo / ext4 defaults 0 1 /dev/sda1 /boot ext4 defaults 0 0 /dev/mapper/home /home ext4 defaults 0 0 /home/.swap none swap sw 0 0
  2. Hello, everyone! I have an issue that I haven't been able to resolve yet. Funtoo is running on my system, but I would like to modify the parameters at boot so the boot screen was running in 1920x1080 mode. I believe it is in 1024x768 mode currently, as shown by the "videoinfo" command that I run at the Grub command-line stage. I've modified the /etc/boot file to have a "params += GRUB_GFXMODE=1920x1080-24,auto GRUB_GFXPAYLOAD_LINUX=keep" (along with the root info, of course), but this does not seem to work after I 'ego boot update'. I also modified the file at '/etc/default/grub' to reflect these values (with the (x)x(y)-(b) format which a GTX 970 apparently needs), to no avail. Does 'ego boot update' also process 'grub-mkconfig -o /boot/grub/grub.cfg' when it runs? This seems like a simple matter to resolve, but I've tried many suggestions over the past week, and nothing seems to be working. Thank you for any suggestions!
  3. So i was feeling a bit adventurous. I have been away from linux for a while and i decided to jump back into the swing of things. My Laptop Is an Asus R554L Intel Core i-3 6GB intel integrated graphics single hard drive this is the partition scheme Device Start End Sectors Size Type /dev/sda1 2048 534527 532480 260M EFI System /dev/sda2 534528 567295 32768 16M Microsoft reserved /dev/sda3 567296 389689343 389122048 185.6G Microsoft basic data /dev/sda4 389689344 390711295 1021952 499M Windows recovery environment /dev/sda5 390711296 669573119 278861824 133G Microsoft basic data /dev/sda6 669573120 964376575 294803456 140.6G Linux filesystem /dev/sda7 964376576 976771071 12394496 5.9G Linux swap so the Funtoo Bootloader is installed at ./sda1 the windows partition is the ./sda3 and i would like to add that to the grub boot menu. I can still find the efi file from windows. But not sure how to get the boot loader to understand the efi file. I tried to use grub-mkconfig and all it seemed to do was add a boot option inside my uefi bios for windows which does not properly load the Operating System. I have turned off secure boot in the bios and turned off fast boot, however it is still booting uefi mode. I tried adding an entry to /etc/boot.cfg and reinstalling the boot loader by mounting the /boot partition but that did not seem to work. below is the attempted entry on /etc/boot.cfg boot { generate grub default "Funtoo Linux genkernel" timeout 3 } "Funtoo Linux" { kernel bzImage[-v] } "Funtoo Linux genkernel" { kernel kernel[-v] initrd initramfs[-v] params += real_root=auto rootfstype=auto } "Funtoo Linux better-initramfs" { kernel vmlinuz[-v] initrd /initramfs.cpio.gz } "Windows 10" --class windows --class os { insmod ntfs search --no-floppy --set=root --fs-uuid c132cb80-fdd7-4c84-84f4-46e164fa65dd ntldr /bootmgr } any help would be appreciated. I was able to install kde so im starting to really enjoy this Distro. always been a fan of gentoo but the documentation seemed cryptic to say the least. I found my experience with Funtoo to be pretty easy considering ive been away from linux for about 4 years. If there is anymore information needed please let me know I do have a couple other issues im experiencing with USE flags but honestly, they are not as important as booting into my windows.
  • Create New...