Jump to content

Search the Community

Showing results for tags 'consolekit'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 1 result

  1. I desperately tried to find a solution myself, but not succeeded. When I am logged in Gnome session via GDM no local user privileges (such as reboot/shutdown, passwordless usb media mount, user session switching) are available to me. No power management options while in GDM login window either. Obviously, the reason is inactive state of consolekit sessions run through GDM: Session6: unix-user = '115' realname = 'added by portage for gdm' seat = 'Seat5' session-type = 'LoginWindow' active = FALSE x11-display = ':0' x11-display-device = '' display-device = '' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:56:13.786129Z' login-session-id = '4' idle-since-hint = '2015-03-30T00:56:15.796297Z' Session7: unix-user = '1000' realname = 'Nexie' seat = 'Seat6' session-type = '' active = FALSE x11-display = ':0' x11-display-device = '' display-device = '' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:56:47.125458Z' login-session-id = '5' When I start Gnome session manually with startx, everything works as expected and consolekit session is active: Session5: unix-user = '1000' realname = 'Nexie' seat = 'Seat1' session-type = '' active = TRUE x11-display = ':0' x11-display-device = '/dev/tty7' display-device = '/dev/tty1' remote-host-name = '' is-local = TRUE on-since = '2015-03-30T00:54:22.822545Z' login-session-id = '4' .xinitrc ? as recommended in wiki: exec ck-launch-session gnome-session Here are the installed packages which may be relevant: [ebuild R ] sys-apps/dbus-1.8.16 USE="X -debug -doc (-selinux) -static-libs -systemd {-test}" ABI_X86="32 (64) (-x32)" 0 kB [ebuild R ] sys-fs/eudev-1.5.3-r2 USE="gudev hwdb introspection keymap kmod modutils openrc rule-generator static-libs -doc (-selinux) {-test}" ABI_X86="32 (64) (-x32)" 0 kB [ebuild R ] x11-base/xorg-server-1.17.1-r1:0/1.17.1 USE="ipv6 kdrive nptl suid udev xorg -dmx -doc -glamor -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xephyr -xnest -xvfb" 0 kB [ebuild R ] sys-auth/polkit-0.112-r2 USE="gtk introspection nls pam -examples -jit -kde (-selinux) -systemd" 0 kB [ebuild R ] sys-auth/consolekit-0.4.6 USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}" 0 kB [ebuild R ] gnome-base/gdm-3.14.1 USE="introspection ipv6 tcpd -accessibility -audit -branding -debug -fprint -plymouth (-selinux) -smartcard -systemd {-test} -wayland -xinerama" 0 kB rc-status shows that consolekit, dbus and openrc-settingsd are running as dependencies. Tried to add them explicitly to default runlevel, nothing changed. Could you give me any suggestion how to solve this or where else to look?
×
×
  • Create New...