Jump to content
funtoo forums

Search the Community

Showing results for tags 'cflags'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


Location


Interests

Found 3 results

  1. Hello! I tried to recompile all my world with a new CFLAGS: -O3 in /etc/portage/make.conf file (I had -O2 before). I saw the errors while 3 days my laptop Lenovo compiled command `emerge -e world`. F.e. one package (mutagen) was not compiled due to error 404 not found. I typed `emerge --resume` but I think it did not compile that package. Another package compilation was failed due to Internet break. `emerge --resume` did not compiled that broken package. Another emerge stop was with laptop turn off (do not know why). The forth was qt-webkit compilation that was not compiled because of memory limit (could not allocate memory). Now my laptop boots in command line and shows: ERROR: Your XDM value is invalid. No xdm executable could be found on your system. Please set your display manager variable in /etc/conf.d/xdm, or install x11-apps/xdm package . I will do it. But I do no know what else I need to compile. So please say me where can I look which packages need to compile with xdm, qt-webkt??? Where is error log from last emerge? PS: sorry, my English is not enough.
  2. I use Funtoo for browsing the web. I compiled all my world with CFLAGS -O2. I changed it to -O3 to try how it will work. I typed world update # cat /etc/portage/make.conf MAKEOPTS="-j5" LINGUAS="en_US ru_RU" L10N="en-US ru-RU" CFLAGS="-march=native -O3 -pipe" CXXFLAGS="${CFLAGS}" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" VIDEO_CARDS="intel" USE="alsa bmp dbus djvu core-kit flv gif introspection jpeg mp3 networkamagern png udev policykit rar tiff X zlib -gnome -gtk -gtk2 -gtk3 -kde -minimal -qt3 -qt4 -qt5 -wicd" # emerge -e world It started to compile 1038 packages and it had finished 600 of them when I reboot. Now I want it continues to compile the rest. How to do it? How to compile packages that were compiled with -O2 flag instead of current -O3 as file /etc/portage/make.conf is containing now?
  3. There are no CHOST and CFLAGS variables in /etc/portage/make.conf as delivered by stage3 dowloaded from build.funtoo.org. File is http://build.funtoo.org/funtoo-current/x86-64bit/corei7/2015-04-16/stage3-corei7-funtoo-current-2015-04-16.tar.xz.
×