Jump to content
funtoo forums

Search the Community

Showing results for tags 'ati'.



More search options

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

There are no results to display.

There are no results to display.


Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

Found 3 results

  1. I recently made the switch from fglrx to the radeon drivers for my video cards. The installation and modifications to the kernel went well and my system booted correctly. However, when I ran my compositor, compton, with backend glx things slowed down -- specifically, window dragging was very slow and laggy -- almost like a vsync issue. This led me to check my X.org log, where I found the following: [ 22.676] (II) RADEON(0): EDID for output DVI-0 [ 22.690] (II) RADEON(0): EDID for output DVI-1 [ 22.690] (II) RADEON(0): Output DisplayPort-0 disconnected [ 22.690] (II) RADEON(0): Output HDMI-0 connected [ 22.690] (II) RADEON(0): Output DVI-0 disconnected [ 22.690] (II) RADEON(0): Output DVI-1 disconnected [ 22.690] (II) RADEON(0): Using exact sizes for initial modes [ 22.690] (II) RADEON(0): Output HDMI-0 using initial mode 1920x1080 [ 22.690] (II) RADEON(0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated. [ 22.690] (II) RADEON(0): mem size init: gart size :3fbce000 vram size: s:80000000 visible:7f39e000 [ 22.690] (II) RADEON(0): EXA: Driver will allow EXA pixmaps in VRAM [ 22.690] (==) RADEON(0): DPI set to (96, 96) [ 22.690] (II) Loading sub module "fb" [ 22.690] (II) LoadModule: "fb" [ 22.690] (II) Loading /usr/lib64/xorg/modules/libfb.so [ 22.692] (II) Module fb: vendor="X.Org Foundation" [ 22.692] compiled for 1.16.1, module version = 1.0.0 [ 22.692] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.692] (II) Loading sub module "ramdac" [ 22.692] (II) LoadModule: "ramdac" [ 22.692] (II) Module "ramdac" already built-in [ 22.692] (==) RADEON(G0): Depth 24, (--) framebuffer bpp 32 [ 22.692] (II) RADEON(G0): Pixel depth = 24 bits stored in 4 bytes (32 bpp pixmaps) [ 22.692] (==) RADEON(G0): Default visual is TrueColor [ 22.692] (==) RADEON(G0): RGB weight 888 [ 22.692] (II) RADEON(G0): Using 8 bits per RGB (8 bit DAC) [ 22.692] (--) RADEON(G0): Chipset: "PITCAIRN" (ChipID = 0x6819) [ 22.692] (II) Loading sub module "dri2" [ 22.692] (II) LoadModule: "dri2" [ 22.692] (II) Module "dri2" already built-in [ 22.692] (II) Loading sub module "glamoregl" [ 22.692] (II) LoadModule: "glamoregl" [ 22.692] (II) Loading /usr/lib64/xorg/modules/libglamoregl.so [ 22.692] (II) Module glamoregl: vendor="X.Org Foundation" [ 22.692] compiled for 1.16.1, module version = 0.6.0 [ 22.692] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.692] (II) glamor: OpenGL accelerated X.org driver based. [ 22.693] (II) glamor: EGL version 1.4 (DRI2): [ 22.693] EGL_MESA_drm_image required. [ 22.693] (EE) RADEON(G0): glamor detected, failed to initialize EGL. [ 22.693] (II) Loading sub module "shadow" [ 22.693] (II) LoadModule: "shadow" [ 22.693] (II) Loading /usr/lib64/xorg/modules/libshadow.so [ 22.693] (II) Module shadow: vendor="X.Org Foundation" [ 22.693] compiled for 1.16.1, module version = 1.1.0 [ 22.693] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.693] (II) RADEON(G0): KMS Color Tiling: disabled [ 22.693] (II) RADEON(G0): KMS Color Tiling 2D: disabled [ 22.693] (II) RADEON(G0): KMS Pageflipping: enabled [ 22.693] (II) RADEON(G0): SwapBuffers wait for vsync: enabled [ 22.699] (II) RADEON(G0): Output DisplayPort-1-1 has no monitor section [ 22.705] (II) RADEON(G0): Output DisplayPort-1-2 has no monitor section [ 22.707] (II) RADEON(G0): Output HDMI-1-1 has no monitor section [ 22.722] (II) RADEON(G0): Output DVI-1-1 has no monitor section [ 22.728] (II) RADEON(G0): EDID for output DisplayPort-1-1 [ 22.734] (II) RADEON(G0): EDID for output DisplayPort-1-2 [ 22.736] (II) RADEON(G0): EDID for output HDMI-1-1 [ 22.750] (II) RADEON(G0): EDID for output DVI-1-1 [ 22.750] (II) RADEON(G0): Using default gamma of (1.0, 1.0, 1.0) unless otherwise stated. [ 22.750] (II) RADEON(G0): mem size init: gart size :3fbce000 vram size: s:80000000 visible:7f887000 [ 22.750] (II) RADEON(G0): EXA: Driver will allow EXA pixmaps in VRAM [ 22.750] (==) RADEON(G0): DPI set to (96, 96) [ 22.750] (II) Loading sub module "fb" [ 22.750] (II) LoadModule: "fb" [ 22.750] (II) Loading /usr/lib64/xorg/modules/libfb.so [ 22.750] (II) Module fb: vendor="X.Org Foundation" [ 22.750] compiled for 1.16.1, module version = 1.0.0 [ 22.750] ABI class: X.Org ANSI C Emulation, version 0.4 [ 22.750] (II) Loading sub module "ramdac" [ 22.750] (II) LoadModule: "ramdac" [ 22.750] (II) Module "ramdac" already built-in [ 22.750] (--) Depth 24 pixmap format is 32 bpp [ 22.751] (II) RADEON(G0): Front buffer size: 3072K [ 22.751] (II) RADEON(G0): VRAM usage limit set to 1877698K [ 22.752] (==) RADEON(G0): Backing store enabled [ 22.752] (WW) RADEON(G0): Direct rendering disabled [ 22.752] (II) RADEON(G0): Acceleration disabled [ 22.752] (==) RADEON(G0): DPMS enabled [ 22.752] (==) RADEON(G0): Silken mouse enabled [ 22.753] (II) RADEON(G0): RandR 1.2 enabled, ignore the following RandR disabled message. [ 22.753] (II) RADEON(0): Front buffer size: 8100K [ 22.753] (II) RADEON(0): VRAM usage limit set to 1868648K [ 22.753] (==) RADEON(0): Backing store enabled [ 22.753] (WW) RADEON(0): Direct rendering disabled [ 22.753] (II) RADEON(0): Acceleration disabled [ 22.754] (==) RADEON(0): DPMS enabled [ 22.754] (==) RADEON(0): Silken mouse enabled [ 22.754] (II) RADEON(0): RandR 1.2 enabled, ignore the following RandR disabled message. [ 22.771] (--) RandR disabled [ 22.778] (II) AIGLX: Screen 0 is not DRI2 capable [ 22.778] (EE) AIGLX: reverting to software rendering [ 22.779] (II) AIGLX: Loaded and initialized swrast [ 22.779] (II) GLX: Initialized DRISWRAST GL provider for screen 0 [ 22.789] (II) RADEON(0): Setting screen physical size to 508 x 285 [ 22.830] (II) config/udev: Adding input device Power Button (/dev/input/event1) [ 22.830] (**) Power Button: Applying InputClass "evdev keyboard catchall" [ 22.830] (II) LoadModule: "evdev" [ 22.830] (II) Loading /usr/lib64/xorg/modules/input/evdev_drv.so [ 22.833] (II) Module evdev: vendor="X.Org Foundation" [ 22.833] compiled for 1.16.1, module version = 2.9.1 [ 22.833] Module class: X.Org XInput Driver [ 22.833] ABI class: X.Org XInput driver, version 21.0 [ 22.833] (II) Using input driver 'evdev' for 'Power Button' [ 22.833] (**) Power Button: always reports core events [ 22.833] (**) evdev: Power Button: Device: "/dev/input/event1" [ 22.833] (--) evdev: Power Button: Vendor 0 Product 0x1 [ 22.833] (--) evdev: Power Button: Found keys [ 22.833] (II) evdev: Power Button: Configuring as keyboard [ 22.833] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1/event1" [ 22.833] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6) [ 22.833] (**) Option "xkb_rules" "evdev" [ 22.833] (**) Option "xkb_model" "pc104" [ 22.833] (**) Option "xkb_layout" "us" [ 22.852] (II) config/udev: Adding input device Power Button (/dev/input/event0) [ 22.852] (**) Power Button: Applying InputClass "evdev keyboard catchall" [ 22.852] (II) Using input driver 'evdev' for 'Power Button' [ 22.852] (**) Power Button: always reports core events [ 22.852] (**) evdev: Power Button: Device: "/dev/input/event0" [ 22.852] (--) evdev: Power Button: Vendor 0 Product 0x1 [ 22.852] (--) evdev: Power Button: Found keys [ 22.852] (II) evdev: Power Button: Configuring as keyboard [ 22.852] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0/event0" [ 22.852] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7) [ 22.852] (**) Option "xkb_rules" "evdev" [ 22.852] (**) Option "xkb_model" "pc104" [ 22.852] (**) Option "xkb_layout" "us" [ 22.852] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event2) [ 22.852] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall" [ 22.852] (II) Using input driver 'evdev' for 'Logitech USB Receiver' [ 22.852] (**) Logitech USB Receiver: always reports core events [ 22.852] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event2" [ 22.852] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b [ 22.852] (--) evdev: Logitech USB Receiver: Found keys [ 22.852] (II) evdev: Logitech USB Receiver: Configuring as keyboard [ 22.852] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:05.0/0000:03:00.0/usb1/1-1/1-1:1.0/0003:046D:C52B.0001/input/input5/event2" [ 22.852] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 8) [ 22.852] (**) Option "xkb_rules" "evdev" [ 22.852] (**) Option "xkb_model" "pc104" [ 22.852] (**) Option "xkb_layout" "us" [ 22.853] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/event3) [ 22.853] (**) Logitech USB Receiver: Applying InputClass "evdev pointer catchall" [ 22.853] (**) Logitech USB Receiver: Applying InputClass "evdev keyboard catchall" [ 22.853] (II) Using input driver 'evdev' for 'Logitech USB Receiver' [ 22.853] (**) Logitech USB Receiver: always reports core events [ 22.853] (**) evdev: Logitech USB Receiver: Device: "/dev/input/event3" [ 22.853] (--) evdev: Logitech USB Receiver: Vendor 0x46d Product 0xc52b [ 22.853] (--) evdev: Logitech USB Receiver: Found 20 mouse buttons [ 22.853] (--) evdev: Logitech USB Receiver: Found scroll wheel(s) [ 22.853] (--) evdev: Logitech USB Receiver: Found relative axes [ 22.853] (--) evdev: Logitech USB Receiver: Found x and y relative axes [ 22.853] (--) evdev: Logitech USB Receiver: Found absolute axes [ 22.853] (II) evdev: Logitech USB Receiver: Forcing absolute x/y axes to exist. [ 22.853] (--) evdev: Logitech USB Receiver: Found keys [ 22.853] (II) evdev: Logitech USB Receiver: Configuring as mouse [ 22.853] (II) evdev: Logitech USB Receiver: Configuring as keyboard [ 22.853] (II) evdev: Logitech USB Receiver: Adding scrollwheel support [ 22.853] (**) evdev: Logitech USB Receiver: YAxisMapping: buttons 4 and 5 [ 22.853] (**) evdev: Logitech USB Receiver: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200 [ 22.853] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:05.0/0000:03:00.0/usb1/1-1/1-1:1.1/0003:046D:C52B.0002/input/input6/event3" [ 22.853] (II) XINPUT: Adding extended input device "Logitech USB Receiver" (type: KEYBOARD, id 9) [ 22.853] (**) Option "xkb_rules" "evdev" [ 22.853] (**) Option "xkb_model" "pc104" [ 22.853] (**) Option "xkb_layout" "us" [ 22.853] (II) evdev: Logitech USB Receiver: initialized for relative axes. [ 22.853] (WW) evdev: Logitech USB Receiver: ignoring absolute axes. [ 22.853] (**) Logitech USB Receiver: (accel) keeping acceleration scheme 1 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration profile 0 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration factor: 2.000 [ 22.853] (**) Logitech USB Receiver: (accel) acceleration threshold: 4 [ 22.853] (II) config/udev: Adding input device Logitech USB Receiver (/dev/input/mouse0) [ 22.853] (II) No input driver specified, ignoring this device. [ 22.853] (II) This device may have been added with another device file. [ 22.854] (II) config/udev: Adding input device Logitech Logitech Illuminated Keyboard (/dev/input/event4) [ 22.854] (**) Logitech Logitech Illuminated Keyboard: Applying InputClass "evdev keyboard catchall" [ 22.854] (II) Using input driver 'evdev' for 'Logitech Logitech Illuminated Keyboard' [ 22.854] (**) Logitech Logitech Illuminated Keyboard: always reports core events [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: Device: "/dev/input/event4" [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Vendor 0x46d Product 0xc318 [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found keys [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as keyboard [ 22.854] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:07.0/0000:04:00.0/usb3/3-2/3-2:1.0/0003:046D:C318.0004/input/input7/event4" [ 22.854] (II) XINPUT: Adding extended input device "Logitech Logitech Illuminated Keyboard" (type: KEYBOARD, id 10) [ 22.854] (**) Option "xkb_rules" "evdev" [ 22.854] (**) Option "xkb_model" "pc104" [ 22.854] (**) Option "xkb_layout" "us" [ 22.854] (II) config/udev: Adding input device Logitech Logitech Illuminated Keyboard (/dev/input/event5) [ 22.854] (**) Logitech Logitech Illuminated Keyboard: Applying InputClass "evdev keyboard catchall" [ 22.854] (II) Using input driver 'evdev' for 'Logitech Logitech Illuminated Keyboard' [ 22.854] (**) Logitech Logitech Illuminated Keyboard: always reports core events [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: Device: "/dev/input/event5" [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Vendor 0x46d Product 0xc318 [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found 1 mouse buttons [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found scroll wheel(s) [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found relative axes [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Forcing relative x/y axes to exist. [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found absolute axes [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Forcing absolute x/y axes to exist. [ 22.854] (--) evdev: Logitech Logitech Illuminated Keyboard: Found keys [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as mouse [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Configuring as keyboard [ 22.854] (II) evdev: Logitech Logitech Illuminated Keyboard: Adding scrollwheel support [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: YAxisMapping: buttons 4 and 5 [ 22.854] (**) evdev: Logitech Logitech Illuminated Keyboard: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200 [ 22.854] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:07.0/0000:04:00.0/usb3/3-2/3-2:1.1/0003:046D:C318.0005/input/input8/event5" [ 22.854] (II) XINPUT: Adding extended input device "Logitech Logitech Illuminated Keyboard" (type: KEYBOARD, id 11) [ 22.854] (**) Option "xkb_rules" "evdev" [ 22.854] (**) Option "xkb_model" "pc104" [ 22.854] (**) Option "xkb_layout" "us" [ 22.855] (II) evdev: Logitech Logitech Illuminated Keyboard: initialized for relative axes. [ 22.855] (WW) evdev: Logitech Logitech Illuminated Keyboard: ignoring absolute axes. [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) keeping acceleration scheme 1 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration profile 0 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration factor: 2.000 [ 22.855] (**) Logitech Logitech Illuminated Keyboard: (accel) acceleration threshold: 4 [ 23.128] (II) RADEON(0): EDID vendor "DEL", prod id 41072 [ 23.128] (II) RADEON(0): Using EDID range info for horizontal sync [ 23.128] (II) RADEON(0): Using EDID range info for vertical refresh [ 23.128] (II) RADEON(0): Printing DDC gathered Modelines: Of particular interest to me were the lines: [ 22.693] (II) glamor: EGL version 1.4 (DRI2): [ 22.693] EGL_MESA_drm_image required. [ 22.693] (EE) RADEON(G0): glamor detected, failed to initialize EGL. and [ 22.753] (WW) RADEON(0): Direct rendering disabled [ 22.753] (II) RADEON(0): Acceleration disabled EDIT: I am also getting the following error: [ 996.530] (II) AIGLX: Screen 0 is not DRI2 capable [ 996.530] (EE) AIGLX: reverting to software rendering [ 996.531] (II) AIGLX: Loaded and initialized swrast My specs, if they will be useful: xorg-server-1.16.1-r4 xf86-video-ati-7.5.0 mesa-10.3.5 llvm-3.5.1 Radeon HD 7850 Any ideas as to how I can re-enable direct rendering and acceleration / resolve the problem with GLamor?
  2. OK - here is the only line in my logs that might explain: Taro ~ # grep '(EE)' /var/log/Xorg.0.log (WW) warning, (EE) error, (NI) not implemented, (??) unknown. [ 478.015] (EE) AIGLX error: failed to open /usr/X11R6/lib64/modules/dri/fglrx_dri.so, error[/usr/X11R6/lib64/modules/dri/fglrx_dri.so: cannot open shared object file: No such file or directory] This is odd because the file is in /usr/lib64/modules/dri. Why is it looking in the wrong place and how do I tell it to look in the right place? but later, it says .. [ 478.266] ukiOpenByBusid: ukiGetBusid reports PCI:0:1:0 [ 478.904] (II) AIGLX: Loaded and initialized OpenGL driver(II) GLX: Initialized DRI GL provider for screen 0 So .. did it initialize or not? Did it finally look in the right place and find it? Am I chasing shadows? The X server starts up, initializes the monitors (no picture though), and then shuts down. It never says WHY it shuts down. I can pastebin the full log if anyone wants to read it. However, it leaves my screen in an unusable state. Likely, because of: [ 481.169] (II) fglrx(0): Restoring Recent Mode via PCS is not supported in RANDR 1.2 capable environments So ... once I try starting it, I have to reboot! That makes debugging this myself time consuming. Anyone have any suggestions, or seen this before?
  3. Portage displays an error when trying to install ati-drivers, but I am a newbie to *too Linux and my English is not well and I do not understand what is going on :( Output of emerge ati-drivers is: Calculating dependencies... done! [ebuild N ] sys-power/acpid-2.0.22-r1 USE="(-selinux)" [ebuild N ] x11-libs/libvdpau-0.8 USE="dri -doc {-test}" [ebuild N ] x11-proto/xf86miscproto-0.9.3 [ebuild N ] virtual/linux-sources-2.6 USE="-hardened" [ebuild N ] app-admin/eselect-opencl-1.1.0-r3 [ebuild UD ] x11-base/xorg-server-1.15.1 [1.16.0] [ebuild N ] x11-libs/libva-1.3.1 USE="X drm opengl -egl -vdpau -wayland" VIDEO_CARDS="-dummy -fglrx -intel -nvidia" [ebuild N ] x11-drivers/ati-drivers-14.4_p1 USE="modules (multilib) vaapi -debug -pax_kernel -qt4 -static-libs" [ebuild N ] x11-libs/xvba-video-0.8.0-r6 USE="opengl -debug" !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: x11-base/xorg-server:0 (x11-base/xorg-server-1.15.1::gentoo, ebuild scheduled for merge) pulled in by <=x11-base/xorg-server-1.15.49[-minimal] required by (x11-drivers/ati-drivers-14.4_p1::gentoo, ebuild scheduled for merge) (x11-base/xorg-server-1.16.0::gentoo, installed) pulled in by x11-base/xorg-server:0/1.16.0= required by (x11-drivers/xf86-video-ati-7.4.0::gentoo, installed) x11-base/xorg-server:0/1.16.0= required by (x11-libs/glamor-0.6.0-r1::gentoo, installed) x11-base/xorg-server:0/1.16.0= required by (x11-drivers/xf86-input-evdev-2.8.4::gentoo, installed)
×
×
  • Create New...