Jump to content

Search the Community

Showing results for tags 'portage'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Funtoo Discussion Forums
    • News and Announcements
    • General Discussion
    • Dev Central
    • Funtoo Hosting
    • Funtoo Infrastructure
  • Help Central
    • General Help
    • Installation Help
    • Portage Help
    • Desktop Help
    • Server Help
  • Funtoo Services

Blogs

  • drobbins' Blog
  • It's a Bear's life
  • haxmeister's Blog
  • psychopatch's Blog
  • 666threesixes666's Blog
  • decision theory
  • Chris Kurlinski's Blog
  • Sandro's Blog
  • danielv's Blog
  • Not So Stupid Admin Tricks
  • maldoror's Blog
  • andreawilson's Blog
  • Simple Step-by-Step Server Setup
  • saraedward's Blog
  • eusanpe
  • Linux Container Club - LXD/LXC's Blog
  • Funtoo Perl Hackers's Perl on Funtoo

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


freenode


github


web


First Name


Last Name


Location


Interests

  1. hello again, i've the following set into my ego.conf: xorg-kit = 1.19-prime media-kit = 1.1-prime kde-kit = master however on today sync i've got this message: "Kit kde-kit branch master specified in ego.conf is not currently active; using default kit instead." so why can i not choose kde-kit's master branch anymore in ego.conf? i've forced the master branch checkout by adding: @git -C /home/meta-repo/kits/kde-kit checkout origin/master || true into eix-sync.conf, however i wonder why these kind of hacks are necessary... thank you
  2. Hi, When using funtoo, regularly doing update/upgrade, sometimes I have messages about modifying /etc/portage/package.use. At this time my package.use contain (too) many changes like this The question is: How to know when it is the time to remove the lines (the forced change)?
  3. skunk

    kits logic

    hello devs (oleg) :) i wonder what are the rules behind this new kit organization... do packages from the master branch eventually make into a prime branch or are prime branches virtually immutable? if the former, after lying into the the master branch for some time (like gentoo's stable/unstable)? how long? any other criterion instead? if the latter, are "stable users" supposed to jump from prime-n to prime-n+1 branches at their discretion? for example i'm on the default 5.10-prime kde-kit's branch and i see that kde-plasma-5.11.0, kde-frameworks-5.39 and kde-apps-17.08.2 were added t
  4. Is it possible to use apt-get along with portage? My reason for doing this is that i require a ppa for the system76 driver. That would be the only reason for wanting to use apt-get. Also, has the system76 repo been forked so it is compatible with Funtoo?
  5. With the on-going change, it's expected that we, users, have several and different, difficulties. And while it is impossible to deal with all at once, I feel that one sticky thread should be there to guide. Or use only github's issues feature. Myself, have posted in various threads during the last weeks. And contribute, this way, in more noise. Apologies for that. Can we have one sticky thread for the Switch? Thank you
  6. Good night,since today ,have trouble with sync new-host-20 ~ # emerge --sync >>> Syncing repository 'gentoo' into '/usr/portage'... /usr/bin/git pull fatal: ambiguous argument 'HEAD': unknown revision or path not in the working tree. Use '--' to separate paths from revisions, like this: 'git <command> [<revision>...] -- [<file>...]' Traceback (most recent call last): File "/usr/lib64/python2.7/site-packages/portage/util/_async/AsyncFunction.py", line 39, in _run result = self.target(*(self.args or []), **(self.kwargs or {})) File "/usr/lib64/python2.7/site
  7. hello, what's the reason for kde stuff lagging that far behind when compared to gentoo's tree? gentoo | funtoo ------------------------------------------------------ kde-frameworks/*-5.35.0 | kde-frameworks/*-5.31.0 kde-plasma/*-5.10.2 | kde-plasma/*-5.9.2 kde-base/*-17.04.2 | kde-base/*-16.12.2 thank you!
  8. When I do "eix-sync", I have: [0] "local" /usr/local/portage/ (cache: metadata-md5-or-flat) Reading category 170|170 (100) EMPTY! But I have ebuilds in local overlay and "OVERLAY_CACHE_METHOD="assign"" in file "/etc/eixrc/01-cache". My file "/etc/eix-sync.conf" have: * @emerge --regen || true @emerge --metadata || true Other error: if I do "eix gnome-subtitles" I have: * media-video/gnome-subtitles [1] Available versions: 1.3-r1 Homepage: http://gnome-subtitles.sourceforge.net/ Description: Video subtitling for the Gnome desktop [1]
  9. Hi, I'm trying a feel days install the firefox, but that error keep showing to me. >>> Source compiled. >>> Test phase [not enabled]: www-client/firefox-50.0.2 >>> Install firefox-50.0.2 into /tmp/portage/www-client/firefox-50.0.2/image/ category www-client [32;01m*[0m PT_PAX marking -m /tmp/portage/www-client/firefox-50.0.2/work/firefox-50.0.2/ff/dist/bin/xpcshell with paxctl [32;01m*[0m PT_PAX marking -m /tmp/portage/www-client/firefox-50.0.2/work/firefox-50.0.2/ff/dist/bin/xpcshell with scanelf [32;01m*[0m XATTR_PAX marking -me /tmp/portage/www-client/f
  10. I am attempting a world update but netpbm won't rebuild. Output of "emerge --info '=media-libs/netpbm-10.70.00::gentoo'": Portage 2.3.2 (python 2.7.12-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.3, glibc-2.22, 4.7.8-1~bpo8+1 x86_64) ================================================================= System Settings ================================================================= System uname: Linux-4.7.8-1~bpo8+1-x86_64-AMD_A10-7860K_Radeon_R7,_12_Compute_Cores_4C+8G-with-gentoo-2.2.1 KiB Mem: 7090824 total, 5416188 free KiB Swap: 8388604 to
  11. ahoy all, long time Gentoo user getting a little tired of long and loud compile times on my used hardware, was looking for other options and stumbled upon Funtoo. i am very interested in the philosophy and lots of the features. nice work! however, just wondering if there is a public source for binary builds of packages beyond the common XXXX-bin packages (e.g. firefox-bin, libreoffice-bin, etc), i.e. a public BINHOST server in Gentoo parlance? there are not really any options for Gentoo so i realize this is a long shot. i am also aware that getting binary packages with all the
  12. Hi, I'm using the latest version of Plasma Dekstop but the latest version has some issue with the touchpad and other stuff, well I'm use a Asus ROG G750jx is a amazing laptop but has some troubles, but almost all works fantastic so, I wanna mask the "kde-plasma/plasma-meta-5.5.5" but not it, I want all kde-plasma/* packages from this category. someone how a way to do it without put each package on "package.accept_keywords" file ?
  13. Hi to all, I am trying to mask the package dev-scheme/guile-2.0.11* since gnucash demand dev-scheme/guile-1.8.8. Unfortently Gnucash does not support dev-scheme/guile-2.0.11* (I adapted the ebuild to check). After masking the package dev-scheme/guile-2.0.11* cat /etc/portage/package.mask =dev-scheme/guile-2.0.11-r1 Despite the mask of ev-scheme/guile-2.0.11-r, funtoo still try to merge it: emerge -au @world These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB WARNING: One or more updates/reb
  14. uxcn

    GCC 5

    I was wondering if there are plans to merge gcc-5.1 and gcc-5.2 into Funtoo Portage. As a C/C++ developer, having the latest compilers is helpful for me. I know the ebuilds are a bit less monolithic than the Gentoo ebuilds. What would be involved if someone wanted to try to maintain them?
  15. Hello All, I have a question regarding the use flags with the intel64-haswell subarch. Since I don't plan to compile code on any other machine but the computer I'm installing on, why would the use flag -march=core-avx2 be superior to -march=native? Perhaps I'm incorrect, but wouldn't -march=native be best for me? If not, why? I'm really confused by core-avx2. I could be wrong, but I think using -march=native is equivalent to -march=haswell in this case. If so, is -march=haswell different from -march=core-avx2? I did notice that the CPU_FLAGS mentioned on the subarch page misse
  16. I have a problem with updating my system. I wasn't using my computer quite a long time. Now when I am performing system update I get a lot of errors. I have no idea how should I solved them. $ sudo emerge --update --newuse --deep --with-bdeps=y @world Calculating dependencies... done! !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.22.0:0/5.22::gentoo, ebuild scheduled for merge) pulled in by =dev-lang/perl-5.22* required by (virtual/perl-File-Spec-3.560.0:0/0::
  17. I'm curious if there is any current effort to track packages not building under Clang/LLVM. FreeBSD switched as a default, and I've heard that Debian was considering a switch at one point. Gentoo seemed to have an effort to track packages, but it seems like it may have fallen off the radar. There are some major blockers, like glibc, but the list already seems fairly small. Are there any formal plans for support Clang/LLVM as a system compiler going forward?
  18. Hi - Is anyone having issues with these two ebuilds in the last two or three days? After recent update of @world, I am left with only two these packages which fail to build. Thought I would quick post here to see it anyone else had noticed issues with these two packages recently. Checking at bugs.funtoo.org, a search shows no recent trouble with these. Best Regards
  19. Hi, sorry ask things like that again, so I want to know if possible install local packages with emerge ? I know install manually, but will not show on emerge that package are installed, I was wondering about that.
  20. I have been struggling to install gnome for a while now. There was a recent bugfix that was fixed a problem with the spidermonkey installation, but now I'm running into problems with pulseaudio. Whenever I try to emerge it, I get the following errors just after compilation starts: Here is the output of the emerge --info '=blah blah blah':
  21. I recently installed funtoo, and I'm having trouble emerging gnome-shell. It brings dev-lang/spidermonkey-24.2.0, and polkit requires version 1.8.5. When I try to install version 24, everything compiles successfully, but it tries to overwrite the config files for the old version. If I unmerge version 1.8, it will let me install version 24, but it complains about polkit missing it's dependency after any portage command is run. When I try to emerge gnome-shell with spidermonkey-24, everything works untill dev-libs/gjs is pulled in, which fails to compile (probably because I'm missing polkit). Is
  22. Hello, I decided that instead of just manually solving the circular deps I get I'd rather point them out and maybe you guys could eventually fix them so others would not have to do this. This is just me trying to make funtoo better, I don't claim that cirular dependencies can be fully removed or that you MUST do something about it. You may feel free to add any that you find, I will as I go along so check for updates! media-libs/giflib-4.1.6-r3 media-libs/urt-3.1b-r1
  23. Hello, I am installing funtoo and I copied my make.conf, package.use, etc. files over since I liked that use flags I'm using and I got a messsage while updating world that there are no ebuilds for dev-python/python-docs needed by dev-lang/python-3.3.6-r1000 with the doc use flag enabled. I'm not sure if this is a bug in the ebuild or what.
  24. Hello Funtoo Community, this is my first post here, but I am working with Linux generel for many years now. A long time with Gentoo Linux. I want to setup a completly new system as my workstation. Everything for now works fine and I got a very fast and responsible base system. As my desktop environment I want to have the newest version of Xfce 4.12, but no ebuild exists in default Funtoo portage tree. So I search a little bit and found a suitable ebuild in Gentoo's portage tree. I added the tree as overlay using layman. Everything seems to be fine, but when I'm doing emerge -av
  25. Hi folks, I have no idea why I was advised to enable 'abi_x86_32' flag when I was trying to do a system update. I blindly followed those instructions printed out in my termianl and made a big trouble on my running machine. The first error I got looks like * Error: circular dependencies: (app-admin/eselect-opengl-1.3.1-r3::gentoo, ebuild scheduled for merge) depends on (x11-base/xorg-server-1.17.1-r1::gentoo, ebuild scheduled for merge) (runtime) (app-admin/eselect-opengl-1.3.1-r3::gentoo, ebuild scheduled for merge) (buildtime) After I fixed it up by removing eselect-opengl
×
×
  • Create New...