Jump to content
funtoo forums

djbrennan

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. This issue is solved. The problem was related to an incorrect GENTOO_MIRRORS entry in make.conf. Once the entry was removed, gcc complied without issue.
  2. Thanks jhan, This is also addressed in https://bugs.funtoo.org/browse/FL-6766.
  3. Hello, I am attempting to update from 1.2 to 1.3. I have a server running 1.2 without X. ego version is 2.7.4-r2. When attempting to update gcc, "emerge -u1 gcc" I get a fetch failure with the following message: rsync: link_stat "/distfiles/gcc-7.4.0-to-svn-266882.patch" (in gentoo) failed: No such file or directory (2) Any idea how to correct or work around! Many thanks.
  4. Hello all, I discovered my problem. I had a separate lvm for distfiles mounted under /usr/portage/distfiles. After a more careful read of the above error message I unmounted the distfiles lvm and deleted the distfiles directory under /usr/portage. With an empty /usr/portage directory, as it should be per the stage3 tar ball, I re-ran "emerge --sync" and everything proceeded correctly. So this problem is solved. Thanks, Dan
  5. I am working through a new funtoo install and am running into trouble installing a portage snapshot. I have untarred the stage3-latest into the chrooted environment. However when I attempt "emerge-sync" I get the following error: (chroot) sysresccd / # emerge --sync >>> Syncing repository 'gentoo' into '/usr/portage'... /usr/bin/git clone --depth 1 git://github.com/funtoo/ports-2012.git . fatal: destination path '.' already exists and is not an empty directory. !!! git clone error in /usr/portage q: Updating ebuild cache in /usr/portage ... q: Finished 0 entries in 0.000017 seconds !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' I discovered that in several recent stages (x86_64) there is nothing in /usr/portage, no profile information and no .git directory. I get git errors if I attempt "git checkout funtoo.org" from /usr/portage. Finally, I have been unable to get to any portage shapshots, all the links are broken (403 errors). Any help is greatly appreciated.
×
×
  • Create New...