Jump to content
funtoo forums

elkhunter

Members
  • Content Count

    0
  • Joined

  • Last visited

  1. I finally got it working by removing the mac_replace lines from net.tap* I'd still like to know if there's an easy way to revert back to using standard gentoo networking scripts though.
  2. Thanks. I did have interface="bridge" in net.br0 but somehow didn't paste that line into my question above. I changed eth0 from interface to inteterface-noip and rebooted but I still have the same error. Any other ideas? I did find that some scripts under /etc/netif.d/ have hard-coded paths to /sbin/sysctl but it's under /usr/sbin/. I created a symlink so the scripts would find it but it still didn't help.
  3. Hi all, I'm a longtime gentoo user who recently switched to funtoo (for the no-systemd subprofile). I have most things working but cannot get networking to work correctly in KVM guests running under funtoo (neither windows nor linux guests work and it looks like no packets are ever received). Since the networking scripts differ from gentoo I assume I have something misconfigured. Here's my /etc/conf.d/net from gentoo: bridge_br0="eth0 tap0 tap1 tap2 tap3" brctl_br0="setfd 0 sethello 0 stp off" rc_net_br0_need="net.tap0 net.tap1 net.tap2 net.tap3" config_br0="192.168.2.110/24" routes_br0="default via 192.168.2.1" dns_domain_br0="homenetwork" dns_servers_br0="192.168.2.1" dns_search_br0="homenetwork" config_tap0="null" tuntap_tap0="tap" tunctl_tap0="-u lance" carrier_timeout_tap0="0" config_tap1="null" tuntap_tap1="tap" tunctl_tap1="-u lance" carrier_timeout_tap1="0" config_tap2="null" tuntap_tap2="tap" tunctl_tap2="-u lance" carrier_timeout_tap2="0" config_tap3="null" tuntap_tap3="tap" tunctl_tap3="-u lance" carrier_timeout_tap3="0" config_eth0="null" modules_eth0="!plug" mtu_eth0="7000" mtu_br0="7000" mtu_tap0="7000" mtu_tap1="7000" mtu_tap2="7000" mtu_tap3="7000" and here are the corresponding files under funtoo: /etc/conf.d/net.br0: ipaddr="192.168.2.110/24" gateway="192.168.2.1" nameservers="192.168.2.1" domain="lshome" mtu="7000" slaves="net.eth0 net.tap0 net.tap1 net.tap2 net.tap3" stp="off" forwarding=1 /etc/conf.d/net.eth0: template="interface" /etc/conf.d/net.tap0: template="tap" group="kvm" mac_replace="4c:61:6e:63:65:00" mtu="7000" (note: net.tap1 to net.tap3 are the same except for the mac address) Here's the output of brtl show on funtoo : # brctl show bridge name bridge id STP enabled interfaces br0 8000.002522b0f029 no eth0 tap0 tap1 tap2 tap3 And here are the network-related options passed to qemu when launching a VM: -net nic,vlan=0,macaddr=4c:61:6e:63:65:03 \ -net tap,vlan=0,ifname=tap2,script=no \ Any suggestions? Is there any (relatively easy) way to revert the funtoo network scripts back to use the ones from gentoo? Thanks in advance.
×
×
  • Create New...