Jump to content
funtoo forums

cptnemo

Members
  • Content Count

    10
  • Joined

  • Last visited

  1. Okay, I did what you said. However I am still having the same problem. I still get this when I try and emerge anything: emerge kate !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. I also removed /usr/portage and did another --sync but still no luck. What else can I do? Do I just need to reinstall funtoo?
  2. Okay, I did that and it did not work. This is what shows up at the end of the --sync: Number of files: 208,344 (reg: 180,865, dir: 27,479) Number of created files: 208,343 (reg: 180,865, dir: 27,478) Number of deleted files: 0 Number of regular files transferred: 180,865 Total file size: 416.47M bytes Total transferred file size: 416.47M bytes Literal data: 416.47M bytes Matched data: 0 bytes File list size: 5.31M File list generation time: 0.001 seconds File list transfer time: 0.000 seconds Total bytes sent: 3.68M Total bytes received: 429.58M sent 3.68M bytes received 429.58M bytes 803.08K bytes/sec total size is 416.47M speedup is 0.96 === Sync completed for gentoo q: Updating ebuild cache in /usr/portage ... q: Finished 39712 entries in 0.922385 seconds !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' * IMPORTANT: 1 news items need reading for repository 'gentoo'. * Use eselect news read to view new items. If I try and emerge a program like kate, I get this: # emerge kate !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. I went ahead and created all the folders in the /usr/portage/profiles/funtoo directory and then tried to install kate. This is what I got: emerge kate * IMPORTANT: 1 news items need reading for repository 'gentoo'. * Use eselect news read to view new items. Calculating dependencies /================================================================================================ ======== Traceback for invalid call to portage.package.ebuild.config.config.__getitem__ ======== File "/usr/lib/python-exec/python2.7/emerge", line 50, in <module> retval = emerge_main() File "/usr/lib64/python2.7/site-packages/_emerge/main.py", line 1224, in emerge_main return run_action(emerge_config) File "/usr/lib64/python2.7/site-packages/_emerge/actions.py", line 3261, in run_action retval = action_build(emerge_config, spinner=spinner) File "/usr/lib64/python2.7/site-packages/_emerge/actions.py", line 338, in action_build settings, trees, myopts, myparams, myaction, myfiles, spinner) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9247, in backtrack_depgraph myaction, myfiles, spinner) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9284, in _backtrack_depgraph success, favorites = mydepgraph.select_files(myfiles) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 3606, in select_files return self._select_files(args) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 3949, in _select_files return self._resolve(myfavorites) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 4013, in _resolve myroot, atom, onlydeps=onlydeps) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5364, in _select_pkg_highest_available ret = self._select_pkg_highest_available_imp(root, atom, onlydeps=onlydeps, parent=parent) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5598, in _select_pkg_highest_available_imp autounmask_level=autounmask_level, parent=parent) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5939, in _wrapped_select_pkg_highest_available_imp if not self._pkg_visibility_check(pkg, autounmask_level): File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5636, in _pkg_visibility_check mreasons = _get_masking_status(pkg, pkgsettings, root_config, use=self._pkg_use_enabled(pkg)) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9530, in _get_masking_status portdb=root_config.trees["porttree"].dbapi, myrepo=myrepo) File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/getmaskingstatus.py", line 100, in _getmaskingstatus myarch = settings["ARCH"] File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/config.py", line 2585, in __getitem__ return self._getitem(key) File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/config.py", line 2638, in _getitem raise KeyError(mykey) KeyError: u'ARCH' ================================================================================================ !!! Problem in 'kde-apps/kate' dependencies. !!! u'ARCH' None ... done! Traceback (most recent call last): File "/usr/lib/python-exec/python2.7/emerge", line 50, in <module> retval = emerge_main() File "/usr/lib64/python2.7/site-packages/_emerge/main.py", line 1224, in emerge_main return run_action(emerge_config) File "/usr/lib64/python2.7/site-packages/_emerge/actions.py", line 3261, in run_action retval = action_build(emerge_config, spinner=spinner) File "/usr/lib64/python2.7/site-packages/_emerge/actions.py", line 338, in action_build settings, trees, myopts, myparams, myaction, myfiles, spinner) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9247, in backtrack_depgraph myaction, myfiles, spinner) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9284, in _backtrack_depgraph success, favorites = mydepgraph.select_files(myfiles) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 3606, in select_files return self._select_files(args) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 3949, in _select_files return self._resolve(myfavorites) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 4013, in _resolve myroot, atom, onlydeps=onlydeps) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5364, in _select_pkg_highest_available ret = self._select_pkg_highest_available_imp(root, atom, onlydeps=onlydeps, parent=parent) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5598, in _select_pkg_highest_available_imp autounmask_level=autounmask_level, parent=parent) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5939, in _wrapped_select_pkg_highest_available_imp if not self._pkg_visibility_check(pkg, autounmask_level): File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 5636, in _pkg_visibility_check mreasons = _get_masking_status(pkg, pkgsettings, root_config, use=self._pkg_use_enabled(pkg)) File "/usr/lib64/python2.7/site-packages/_emerge/depgraph.py", line 9530, in _get_masking_status portdb=root_config.trees["porttree"].dbapi, myrepo=myrepo) File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/getmaskingstatus.py", line 100, in _getmaskingstatus myarch = settings["ARCH"] File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/config.py", line 2585, in __getitem__ return self._getitem(key) File "/usr/lib64/python2.7/site-packages/portage/package/ebuild/config.py", line 2638, in _getitem raise KeyError(mykey) KeyError: u'ARCH' It seems like all the packages that I try and install are all masked. Also, when I restart my computer the /usr/portage/profiles/funtoo directory is gone. So, any idea what is going on?
  3. Okay, I just realized that I misunderstood your post. I did what you said and I have the parent file under /etc/portage/make.profile. Here is the contents of that file. cat /etc/portage/make.profile/parent gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit gentoo:funtoo/1.0/linux-gnu/build/current gentoo:funtoo/1.0/linux-gnu/subarch/core2_64 gentoo:funtoo/1.0/linux-gnu/flavor/desktop gentoo:funtoo/1.0/linux-gnu/mix-ins/kde gentoo:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5 This is what I get when I run epro show: epro show !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' === Enabled Profiles: === arch: x86-64bit build: current subarch: core2_64 flavor: desktop mix-ins: kde mix-ins: kde-plasma-5 However, something is still wrong. When I try and add a mix-in like dvd I get this: epro mix-ins dvd !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' WARNING: Error: dvd is not a valid mix-in. Also, if I try and install a program I get this: emerge -av kate !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. Why does this error keep coming up and why does it say that "/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit" is not found?
  4. Here is the result from that command: epro show !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' === Enabled Profiles: === arch: x86-64bit build: current subarch: core2_64 flavor: desktop mix-ins: kde mix-ins: kde-plasma-5
  5. I should probably mark this thread as solved because I know that I just need more memory. Not sure how to do that. Thanks to everyone who helped figure out this problem. However, since this is an old laptop and I got it cheap, not sure that I want to put any more money in it. May just get a newer one instead.
  6. Well, I don't know how this happened but my /etc/make.profile is now missing. When I try and use emerge I get this warning: !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. Any idea how to fix this? Thanks
  7. I already have google-chrome installed, but there are other programs that I was hoping to install, like the text editor Atom. Also, I am trying to get Aptana Studio working but it keeps asking for Chromium for the embedded browser and I have not been able to get it to use Firefox instead. So, is my only option to get more RAM, or is there something that I might have done wrong when trying to make Portage use my hard drive instead of my RAM?
  8. Here is the info you asked for: df -h Filesystem Size Used Avail Use% Mounted on udev 10M 0 10M 0% /dev /dev/sda3 108G 12G 92G 12% / tmpfs 200M 1012K 199M 1% /run shm 998M 0 998M 0% /dev/shm cgroup_root 10M 0 10M 0% /sys/fs/cgroup tmpfs 3.0G 0 3.0G 0% /var/tmp/portage free -m total used free shared buff/cache available Mem: 1994 526 771 106 696 1331 Swap: 2047 0 2047 Hope this is all you needed. I am not sure what you mean about the "destination of use" for each partition.
  9. I did that and it still does not work. I get this error: >>> Verifying ebuild manifests >>> Running pre-merge checks for www-client/chromium-54.0.2840.34 * Checking for at least 3 GiB RAM ... [ !! ] * There is NOT at least 3 GiB RAM * Checking for at least 5 GiB disk space at "/var/tmp/portage/www-client/chromium-54.0.2840.34/temp" ... [ !! ] * There is NOT at least 5 GiB disk space at "/var/tmp/portage/www-client/chromium-54.0.2840.34/temp" * * Space constraints set in the ebuild were not met! * The build will most probably fail, you should enhance the space * as per failed tests. * * ERROR: www-client/chromium-54.0.2840.34::gentoo failed (pretend phase): * Build requirements not met! * * Call stack: * ebuild.sh, line 115: Called pkg_pretend * chromium-54.0.2840.34.ebuild, line 185: Called check-reqs_pkg_pretend * check-reqs.eclass, line 109: Called check-reqs_pkg_setup * check-reqs.eclass, line 100: Called check-reqs_output * check-reqs.eclass, line 256: Called die * The specific snippet of code: * [[ ${EBUILD_PHASE} == "pretend" && -z ${I_KNOW_WHAT_I_AM_DOING} ]] && \ * die "Build requirements not met!" * * If you need support, post the output of `emerge --info '=www-client/chromium-54.0.2840.34::gentoo'`, * the complete build log and the output of `emerge -pqv '=www-client/chromium-54.0.2840.34::gentoo'`. * The complete build log is located at '/var/tmp/portage/www-client/chromium-54.0.2840.34/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/www-client/chromium-54.0.2840.34/temp/die.env'. * Working directory: '/usr/lib64/python2.7/site-packages' * S: '/var/tmp/portage/www-client/chromium-54.0.2840.34/work/chromium-54.0.2840.34' * Messages for package www-client/chromium-54.0.2840.34: * There is NOT at least 3 GiB RAM * There is NOT at least 5 GiB disk space at "/var/tmp/portage/www-client/chromium-54.0.2840.34/temp" * * Space constraints set in the ebuild were not met! * The build will most probably fail, you should enhance the space * as per failed tests. * * ERROR: www-client/chromium-54.0.2840.34::gentoo failed (pretend phase): * Build requirements not met! * * Call stack: * ebuild.sh, line 115: Called pkg_pretend * chromium-54.0.2840.34.ebuild, line 185: Called check-reqs_pkg_pretend * check-reqs.eclass, line 109: Called check-reqs_pkg_setup * check-reqs.eclass, line 100: Called check-reqs_output * check-reqs.eclass, line 256: Called die * The specific snippet of code: * [[ ${EBUILD_PHASE} == "pretend" && -z ${I_KNOW_WHAT_I_AM_DOING} ]] && \ * die "Build requirements not met!" * * If you need support, post the output of `emerge --info '=www-client/chromium-54.0.2840.34::gentoo'`, * the complete build log and the output of `emerge -pqv '=www-client/chromium-54.0.2840.34::gentoo'`. * The complete build log is located at '/var/tmp/portage/www-client/chromium-54.0.2840.34/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/www-client/chromium-54.0.2840.34/temp/die.env'. * Working directory: '/usr/lib64/python2.7/site-packages' * S: '/var/tmp/portage/www-client/chromium-54.0.2840.34/work/chromium-54.0.2840.34' Here is the output it asks me to post: Portage 2.3.1 (python 2.7.12-final-0, funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.9.3, glibc-2.22, 4.5.2-1 x86_64) ================================================================= System Settings ================================================================= System uname: Linux-4.5.2-1-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5250_@_1.50GHz-with-gentoo-2.2.1 KiB Mem: 2041876 total, 694644 free KiB Swap: 2097148 total, 1864868 free sh bash 4.3_p42 ld GNU ld (Funtoo 2.25) 2.25.0 app-shells/bash: 4.3_p42::gentoo dev-java/java-config: 2.2.0-r3::gentoo dev-lang/perl: 5.22.2::gentoo dev-lang/python: 2.7.12::gentoo, 3.4.5::gentoo dev-util/cmake: 3.6.2::gentoo sys-apps/baselayout: 2.2.1::gentoo sys-apps/openrc: 0.18.3-r2::gentoo sys-apps/sandbox: 2.10-r2::gentoo sys-devel/autoconf: 2.13::gentoo, 2.69-r2::gentoo sys-devel/automake: 1.11.6-r2::gentoo, 1.13.4-r1::gentoo, 1.14.1-r1::gentoo, 1.15-r2::gentoo sys-devel/binutils: 2.25-r2::gentoo sys-devel/gcc: 4.9.3-r3::gentoo sys-devel/gcc-config: 1.8-r1::gentoo sys-devel/libtool: 2.4.6-r2::gentoo sys-devel/make: 4.1-r1::gentoo sys-kernel/linux-headers: 4.3::gentoo (virtual/os-headers) sys-libs/glibc: 2.22::gentoo Repositories: gentoo location: /usr/portage sync-type: rsync sync-uri: rsync://rsync.gentoo.org/gentoo-portage priority: -1000 ACCEPT_KEYWORDS="amd64 ~amd64" ACCEPT_LICENSE="* -@EULA" CBUILD="x86_64-pc-linux-gnu" CFLAGS="-march=core2 -O2 -pipe" CHOST="x86_64-pc-linux-gnu" CONFIG_PROTECT="/etc /usr/lib64/libreoffice/program/sofficerc /usr/share/config /usr/share/gnupg/qualified.txt" CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo" CXXFLAGS="-march=core2 -O2 -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync xattr" FFLAGS="-march=core2 -O2 -pipe" GENTOO_MIRRORS="http://distfiles.gentoo.org" LANG="en_US.UTF-8" LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed" MAKEOPTS="-j3" PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/" PORTAGE_TMPDIR="/var/tmp" USE="X a52 aac acl alsa amd64 apng berkdb bluray bzip2 cdda cddb cdio cdr consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr dvdread encode exif faac faad ffmpeg flac gdbm gif gpm gtk ico iconv icu ieee1394 introspection ios ipod ipv6 jpeg jpeg2k kde kipi lame libass libguess libmpeg2 mad matroska minimal mjpeg mmx modules mp3 mpeg mtp mudflap multilib ncurses nls nptl nsplugin ogg opengl openmp pam pcre pdf phonon plasma png policykit postproc pppd python python? qml qt3support qt4 qt5 quicktime readline resolvconf semantic-desktop sndfile sse sse2 ssl svg taglib tcpd theora tiff truetype twolame udev unicode v4l vorbis vpx wav wavpack webp widgets win32codecs wmf x264 x265 xattr xcomposite xinerama xml xscreensaver xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" CPU_FLAGS_X86="mmx mmxext sse sse2 sse3 ssse3" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" GRUB_PLATFORMS="efi-64 pc" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-6" PYTHON_SINGLE_TARGET="python3_4" PYTHON_TARGETS="python2_7 python3_4" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby20 ruby21 ruby22" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
  10. I have tried to emerge Chromium and Atom but they have failed because of space constraints. I have followed this Gentoo wiki and it did not work: https://wiki.gentoo.org/wiki/Portage_TMPDIR_on_tmpfs . Any idea what I can do to fix this? Thanks!
×
×
  • Create New...