Jump to content

cptnemo

Members
  • Content Count

    10
  • Joined

  • Last visited

  1. Okay, I did what you said. However I am still having the same problem. I still get this when I try and emerge anything: emerge kate !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. I also removed /usr/portage and did
  2. Okay, I did that and it did not work. This is what shows up at the end of the --sync: Number of files: 208,344 (reg: 180,865, dir: 27,479) Number of created files: 208,343 (reg: 180,865, dir: 27,478) Number of deleted files: 0 Number of regular files transferred: 180,865 Total file size: 416.47M bytes Total transferred file size: 416.47M bytes Literal data: 416.47M bytes Matched data: 0 bytes File list size: 5.31M File list generation time: 0.001 seconds File list transfer time: 0.000 seconds Total bytes sent: 3.68M Total bytes received: 429.58M sent 3.68M bytes received 429.58M bytes 803
  3. Okay, I just realized that I misunderstood your post. I did what you said and I have the parent file under /etc/portage/make.profile. Here is the contents of that file. cat /etc/portage/make.profile/parent gentoo:funtoo/1.0/linux-gnu/arch/x86-64bit gentoo:funtoo/1.0/linux-gnu/build/current gentoo:funtoo/1.0/linux-gnu/subarch/core2_64 gentoo:funtoo/1.0/linux-gnu/flavor/desktop gentoo:funtoo/1.0/linux-gnu/mix-ins/kde gentoo:funtoo/1.0/linux-gnu/mix-ins/kde-plasma-5 This is what I get when I run epro show: epro show !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Par
  4. Here is the result from that command: epro show !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' === Enabled Profiles: === arch: x86-64bit build: current subarch: core2_64 flavor: desktop mix-ins: kde mix-ins: kde-plasma-5
  5. I should probably mark this thread as solved because I know that I just need more memory. Not sure how to do that. Thanks to everyone who helped figure out this problem. However, since this is an old laptop and I got it cheap, not sure that I want to put any more money in it. May just get a newer one instead.
  6. Well, I don't know how this happened but my /etc/make.profile is now missing. When I try and use emerge I get this warning: !!! Unable to parse profile: '/etc/portage/make.profile' !!! ParseError: Parent '/usr/portage/profiles/funtoo/1.0/linux-gnu/arch/x86-64bit' not found: '/etc/portage/make.profile/parent' !!! Your current profile is invalid. If you have just changed your profile !!! configuration, you should revert back to the previous configuration. !!! Allowed actions are limited to --help, --info, --search, --sync, and !!! --version. Any idea how to fix this? Thanks
  7. I already have google-chrome installed, but there are other programs that I was hoping to install, like the text editor Atom. Also, I am trying to get Aptana Studio working but it keeps asking for Chromium for the embedded browser and I have not been able to get it to use Firefox instead. So, is my only option to get more RAM, or is there something that I might have done wrong when trying to make Portage use my hard drive instead of my RAM?
  8. Here is the info you asked for: df -h Filesystem Size Used Avail Use% Mounted on udev 10M 0 10M 0% /dev /dev/sda3 108G 12G 92G 12% / tmpfs 200M 1012K 199M 1% /run shm 998M 0 998M 0% /dev/shm cgroup_root 10M 0 10M 0% /sys/fs/cgroup tmpfs 3.0G 0 3.0G 0% /var/tmp/portage free -m total used free shared buff/cache available Mem: 1994 526 771 106 696 1331 Swap: 2047 0 2047 Hope
  9. I did that and it still does not work. I get this error: >>> Verifying ebuild manifests >>> Running pre-merge checks for www-client/chromium-54.0.2840.34 * Checking for at least 3 GiB RAM ... [ !! ] * There is NOT at least 3 GiB RAM * Checking for at least 5 GiB disk space at "/var/tmp/portage/www-client/chromium-54.0.2840.34/temp" ... [ !! ] * There is NOT at least 5 GiB disk space at "/var/tmp/portage/www-client/chromium-54.0.2840.34/temp" * * Space constrai
  10. I have tried to emerge Chromium and Atom but they have failed because of space constraints. I have followed this Gentoo wiki and it did not work: https://wiki.gentoo.org/wiki/Portage_TMPDIR_on_tmpfs . Any idea what I can do to fix this? Thanks!
×
×
  • Create New...