Jump to content

nblind

Members
  • Posts

    8
  • Joined

  • Last visited

Recent Profile Visitors

576 profile views

nblind's Achievements

Newbie

Newbie (1/14)

0

Reputation

  1. Thank you for pointing me in the right direction. I got it fixed now ?
  2. Thank you for your reply. But a rebuild does not seem to help. I already earlier did a complete @world rebuild with --emptytree, -e. I have distcc set up, so it "only" takes about one day ? emerge -ep @world | genlop -p Estimated update time: 1 day, 15 hours, 42 minutes.
  3. Hi, I am stuck with 18 packages that constantly wants to be rebuilt. emerge -vp @preserved-rebuild https://dpaste.com/7YPPPM5QU No mater how many times i run @preserved-rebuild or revdep-rebuild.sh I can not get portage to be satisfied. I have also rebuilt my whole machine with emerge -e @world but portage still wants to rebuild the same 18 packages. Here is the output from emerge --info https://dpaste.com/BC3D57MSB Does anyone know how I should troubleshot this?
  4. Hi, Have you masked the unsupported nvidia-driver versions in /etc/portage/package.mask according to the instructions in https://www.funtoo.org/Package:NVIDIA_Linux_Display_Drivers ? BR, Niklas
  5. nblind

    Distcc makeopts

    I started to think about another thing. When using distcc under gentoo, one has to explicitly set CFLAGS & CXXFLAGS, and not use -march=native. How is this handled on funtoo with subarch profiles? Should i set CFLAGS & CXXFLAGS in make.conf? I guess I do not have to. Because distcc is working just fine.
  6. nblind

    Distcc makeopts

    Okay. Thanks for the clarification.
  7. I recently noticed this post by Oleg He mentions that setting makeopts is not really necessary. Is that true even when using distcc? I currently have this in my make.conf MAKEOPTS="-j65 -l8" FEATURES="distcc distcc-pump" Is my makeopts line unnecessary?
  8. 1) I have not had this problem 2) I dont have xfce4-places-plugin installed 3) This however is something I am also having trouble with. And I have still not found any solution. I am also having trouble since xfce-extra/xfce4-mixer started to fail during build. (gentoo bug #628424) [niklas@wst5500:~] 2s 1 % sudo emerge -uDNav --tree @world These are the packages that would be merged, in reverse order: Calculating dependencies... done! [nomerge ] xfce-base/xfce4-meta-4.12::gentoo USE="mixer ristretto svg terminal thunar thunar-volman tumbler xfburn -minimal" [ebuild N #] xfce-extra/xfce4-mixer-4.11.0::desktop-kit USE="alsa keybinder -debug -oss" 0 KiB Total: 1 package (1 new), Size of downloads: 0 KiB The following mask changes are necessary to proceed: (see "package.unmask" in the portage(5) man page for more details) # required by xfce-base/xfce4-meta-4.12::gentoo # required by @selected # required by @world (argument) # /var/git/meta-repo/kits/core-kit/profiles/package.mask/00-gentoo: # Micha? G?rny <mgorny@gentoo.org> (21 Aug 2017) # xfce4-mixer is discontinued upstream and no longer considered part # of the DE since 4.12. It requires vulnerable gstreamer:0.10, and no # longer builds with the development versions of core Xfce4 components. # The suggested replacement is xfce-extra/xfce4-pulseaudio-plugin. # Removal in 30 days. Bug #628424. =xfce-extra/xfce4-mixer-4.11.0 NOTE: The --autounmask-keep-masks option will prevent emerge from creating package.unmask or ** keyword changes. Would you like to add these changes to your config files? [Yes/No] n [niklas@wst5500:~] 53s 1 % sudo USE="-mixer" emerge -1av xfce4-meta These are the packages that would be merged, in order: Calculating dependencies... done! !!! All ebuilds that could satisfy "xfce4-meta" have been masked. !!! One of the following masked packages is required to complete your request: - xfce-base/xfce4-meta-4.12::desktop-kit (masked by: invalid: RDEPEND: Invalid atom (xfce4-pulseaudio-plugin), token 31) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. [niklas@wst5500:~] 10s 1 % equery l -p -o xfce4-pulseaudio-plugin * Searching for xfce4-pulseaudio-plugin ... [--O] [ ] xfce-extra/xfce4-pulseaudio-plugin-0.2.4:0 [I-O] [ ] xfce-extra/xfce4-pulseaudio-plugin-0.2.5:0 [niklas@wst5500:~] 3s % Is this something that's happening to you as well?
×
×
  • Create New...