Jump to content
funtoo forums

Chris Kurlinski

Members
  • Content Count

    34
  • Joined

  • Last visited

  • Days Won

    4

Chris Kurlinski last won the day on January 15 2016

Chris Kurlinski had the most liked content!

1 Follower

About Chris Kurlinski

  • Rank
    Advanced Member

Personal

  • Location
    Nassau, The Bahamas
  1. I am an idiot... I just realised that the last time I did an install, I used netif.${whatever} as the name of my symbolic links in my network configs.... Please ignore my failing. It was an ID10T error #101 - PEBCAK....
  2. Here's a diff *** lxc 2015-12-22 06:55:00.886700278 -0500 --- lxc.mod 2015-12-22 06:55:23.323701398 -0500 *************** *** 71,78 **** # the net_admin capability), but we might also not set it up # at all on the host and leave the net_admin capable service # to take care of it. ! phys) use net.${_if} ;; ! *) need net.${_if} ;; esac done } --- 71,78 ---- # the net_admin capability), but we might also not set it up # at all on the host and leave the net_admin capable service # to take care of it. ! phys) use netif.${_if} ;; ! *) need netif.${_if} ;; esac done }
  3. Just found an error in the init.d lxc script The ebuild depend section is: depend() { # be quiet, since we have to run depend() also for the # non-muxed init script, unfortunately. checkconfig 2>/dev/null || return 0 config ${CONFIGFILE} need localmount local _x _if for _x in $(lxc_get_net_link_type); do _if=${_x%:*} case "${_x##*:}" in # when the network type is set to phys, we can make use of a # network service (for instance to set it up before we disable # the net_admin capability), but we might also not set it up # at all on the host and leave the net_admin capable service # to take care of it. phys) use net.${_if} ;; *) need net.${_if} ;; esac done } But the net.{$_if} is wrong. Should be netif.${_if} Changed it in my lxc init.d script, and my container start right up. Don't know what to do with the info. Just sharing.
  4. VirtualBox only needs the modules loaded, modprobe vboxdrv vboxnetadp vboxnetflt vboxpci. The userland side ( virtualbox, VBoxManage, VBoxHeadless ) uses the modules, openrc doesn't need to do anything. I did a clean install a month ago, whenever I switch hypervisors, and I don't see vboxdrv in my /etc/init.d or /etc/conf.d. Running app-emulation/virtualbox-5.0.8 Is this a left over from a previous series 4 box install.
  5. Here's mine fubar ~ # cat /etc/make.conf MAKEOPTS="-j25" VIDEO_CARDS="ast fbdev vesa" fubar ~ # epro === Enabled Profiles: === arch: x86-64bit build: current subarch: intel64-sandybridge flavor: server mix-ins: X mix-ins: console-extras mix-ins: no-systemd === All inherited flavors from server flavor: === core (from server flavor) minimal (from core flavor)
  6. I found the fix. Needed to patch the sb_edac. Link to the patch https://lkml.org/lkml/2015/8/5/695 [ 5.713554] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 5.713567] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 5.713575] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 5.713578] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 5.713587] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 5.713592] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 5.713594] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 5.713600] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 5.713605] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 5.713607] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 5.713612] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 5.713619] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 5.713620] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 5.713626] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 5.713631] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 5.713633] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 5.713638] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 5.713644] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 5.713645] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 5.713651] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 5.713657] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 5.713658] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 5.713664] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 5.713670] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 5.713671] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 5.713676] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 5.713682] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 5.713684] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 5.713689] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 5.713695] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 5.713697] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 5.713702] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 5.713715] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 5.713963] EDAC MC0: Giving out device to module sbridge_edac.c controller Sandy Bridge Socket#0: DEV 0000:7f:0e.0 (POLLED) [ 5.714467] EDAC MC1: Giving out device to module sbridge_edac.c controller Sandy Bridge Socket#1: DEV 0000:ff:0e.0 (POLLED) [ 5.714467] EDAC sbridge: Ver: 1.1.1
  7. Ok I get it. Never really played with X before. So just a Xlib. I'll try it. As far as the phone, I keep going back to the OnePlus One. I was looking at the Asus Intel phone, but just looked like a pain wth weird button placement. Plus you can Install Sailfish OS on the OnePlus One. Thanks
  8. Anyone have a e5 sandy bridge. I keep getting an EDAC sdbridge error. EDAC sbridge: Some needed devices are missing EDAC sbridge: Couldn't find mic handler EDAC sbridge: Couldn't find mci handler Not sure that my registered ram is initilized. dmesg | grep -i edac [ 5.899737] EDAC MC: Ver: 3.0.0 [ 6.070393] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 6.070409] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 6.070421] EDAC sbridge: Seeking for: PCI ID 8086:3ca0 [ 6.070425] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 6.070434] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 6.070440] EDAC sbridge: Seeking for: PCI ID 8086:3ca8 [ 6.070443] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 6.070452] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 6.070458] EDAC sbridge: Seeking for: PCI ID 8086:3c71 [ 6.070461] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 6.070467] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 6.070473] EDAC sbridge: Seeking for: PCI ID 8086:3caa [ 6.070475] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 6.070481] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 6.070487] EDAC sbridge: Seeking for: PCI ID 8086:3cab [ 6.070490] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 6.070496] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 6.070502] EDAC sbridge: Seeking for: PCI ID 8086:3cac [ 6.070504] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 6.070510] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 6.070517] EDAC sbridge: Seeking for: PCI ID 8086:3cad [ 6.070519] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 6.070526] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 6.070532] EDAC sbridge: Seeking for: PCI ID 8086:3cb8 [ 6.070534] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 6.070540] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 6.070553] EDAC sbridge: Seeking for: PCI ID 8086:3cf4 [ 6.070562] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 6.070568] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 6.070574] EDAC sbridge: Seeking for: PCI ID 8086:3cf6 [ 6.070577] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 6.070582] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 6.070588] EDAC sbridge: Seeking for: PCI ID 8086:3cf5 [ 6.070641] EDAC sbridge: Some needed devices are missing [ 6.070645] EDAC sbridge: Couldn't find mci handler [ 6.070645] EDAC sbridge: Couldn't find mic handler And the output from lspci lspci -n | grep 8086:3ca0 7f:0e.0 0880: 8086:3ca0 (rev 07) ff:0e.0 0880: 8086:3ca0 (rev 07) lspci -k -s 7f:0e.0 7f:0e.0 System peripheral: Intel Corporation Xeon E5/Core i7 Processor Home Agent (rev 07) Subsystem: Super Micro Computer Inc Xeon E5/Core i7 Processor Home Agent Kernel modules: sb_edac And lsmod lsmod | grep sb_edac sb_edac 24576 0 edac_core 49152 1 sb_edac Any one seen this?
  9. Yeah I am getting sick of i3 and tigervnc. They are headaches for me right now, after my recent rebuild. I think i will try it your way. Running on a mac and android, so should not be a big deal. Just broke my work phone, so looking for a new primary, thinking about something that I could run Paranoid Android on. I want to do openvpn and ssh back to server. Just don't trust android to put my rsa certs on it yet. Is there a good tutorial for headless X?
  10. Update : Just created a git repo. https://github.com/ckurlinski/vm.d Also realised that I can do other VM formats, kvm xen qemu.
  11. I've been working out a json template / bash script to setup my system. With the end game being to hook it into metro to create my own stage3, exactly the way I want it. Including all the basics, netif, hostname, samba configs, et all. Basically I'm copying the modified configs from my current system, setup exactly the way I like, removing the comments and whatnot, and reformatting the config to a json entry, then catting the entries into a master file, resulting into a system config. Then I added the epro profiles. I can generate the system.json, but haven't got any further. Not sure how to apply it in a consistent manner. Borked a lot of VM's to get to this stage. Thank god for zfs snapshots. Just need to work out the metro interface. Building out the stage3 in metro seems to be the way to go to me as it gives you a clean system, with all deps worked out. Is there a way to get metro to read a json file?
  12. Well, I wanted to play with VirtualBox on Funtoo again. Setup metro to create a custom stage3, added my stuff I use. All went well, chrooted into the new install, did all the normal setup stuff. Rebooted into the new install. all was fine in the world. Adjusted my VM's to use VirtualBox, and even finally got OS X to work right virtualised. Then the bullshit. How the fuck do you autostart vm's on boot. Went down the google rabbit hole, all the info was based on other Distros or outdated info. Fuck!!!! So I did what any self respecting person would do. I built a rc startup script. Well (4) actually. So here they are. 1) vbox.example - this is the /etc/conf.d file - set options there. rename file to the name of the service - vbox.myvm 2) vbox.tmpl - this is the rc script that goes in to /etc/init.d, then create symbolic link to the vm name, use like netif.tmpl # ln -s /etc/init.d/vbox.tmpl /etc/init.d/vbox.myvm 3) vboxd.start - goes into the /etc/vboxd dir - starts the vm. The correct vm config is passed to the script by init script 4) vboxd.stop - goes into the /etc/vboxd dir - stops the vm. The correct vm config is passed to the script by init script And that's it. I can run as any user, VirtualBox segments the available vm's according to user, so a VM under ckurlinski will not show up under root. Nice for some things, suck for writing a init script. All VM's will run under created user, and can be set to start / stop with different parameters: headless , saved state. Sends info to dmesg also. The last thing I would like to do is create a portage package.... Not even sure where to start on that ..... Thanks for sharing.
  13. Anyone else having issues with building in zfs / spl into kernel 4.1 and higher? ref - https://github.com/zfsonlinux/zfs/issues/3546 Anyone know of a work around? kernel patch? Tried using the latest git zfs sources and git kernel sources. Works with 4.0 kernels and lower. Currently on 4.0.9.
  14. Not sure how many people out there are like me, but here is a project I just about to complete for a client. I'm not in the IT industry, I'm in construction, a master plumber by trade, but do a lot of building management system integrations, and a lot of really specialty projects, like custom fire pits with iPad controls, high end pools ( we're talking 100K gal completely automated, heat pump / solar water heater for potable water, large solar systems ( looking forward to trying out the Tesla Power Wall ). Generally, anything that requires a computer interface, I'll do. Basic anything is boring, and not for me. Well, this leads my to my latest project that's wrapping up. (3) Years ago, I did a pool system for a client, but they didn't have time to build a structure over the equipment, and over the last (3) years the equipment is starting to fail, the Bahamian sun and sea is brutal on this kind of stuff. So I proposed to he client to build a structure over the equipment to protect it. He said great idea, what will it cost, and I went huh? After some thought and a lot of design work, I draw some plans up and priced it to the client, and he said great, when can you start. So here is the original design. And here is the final structure without paint. The only modification from the original design was the doors, which I custom built from Number 1 grade fir, and used some left over epi wood for the siding. Sanding and painting is all that is left.
  15. not sure if this counts, but I have gone to i3 wm running from tigervnc as my main server access, works great with my os x screenshare. i3 is completely stripped down, but I can still start virt-manager or whatnot. I can just close my laptop when the kids start screaming, or phone rings, open it back up, and everything is still there.......
×
×
  • Create New...