Jump to content

overkill

Members
  • Content Count

    129
  • Joined

  • Last visited

  • Days Won

    11

Everything posted by overkill

  1. ...to the end of WHAT emerge command? A new one?, the same one with the backtrack switch. I think I need a literal example. As I said above, I only have one left to go - dev-libs/glib. The --ignore-world option isn't solving it. Do I need to add gdbus-codegen --nodeps the dev-libs/glib --nodeps or would that be a bad idea?
  2. Can't get past the last one # emerge dev-libs/glib -av --ignore-world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-util/gdbus-codegen-2.58.1::gnome-kit [2.48.2::gnome-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,792 KiB [ebuild U ] dev-libs/glib-2.58.1:2::gnome-kit [2.48.2:2::gentoo] USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap {-test} -utils (-debug%)" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB Total: 2 packages (2 upgrades), S
  3. That worked. Now each time I run `emerge system -uDNav --ignore world` I no longer get the list of packages to be installed, just the conflicts. Each time I run it is different. I guess I just continue to emerge the package in "My candidates are" with --ignore-world until `emerge system -uDNav` returns no conflicts?
  4. OK, tried `emerge perl --ignore-world -av` and made progress. Looks like it would work. emerge perl --ignore-world -av These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild r U ] dev-lang/perl-5.26.2-r1:0/5.26::perl-kit [5.24.0-r3:0/5.24::perl-kit] USE="berkdb gdbm -debug -doc -ithreads" 11,770 KiB [ebuild r U ] virtual/perl-File-Spec-3.670.0::perl-kit [3.630.0-r2::gentoo] 0 KiB [ebuild r U ] virtual/perl-Data-Dumper-2.167.0::perl-kit [2.160.0-r1::gentoo] 0 KiB [ebuild r U ] virtual/perl-Test-Harness-3.380.0::perl-kit [3.360.0-r1::g
  5. Which installed packages? Ones under "My candidates are" ? Can you give me an example? Would it be correct to go ahead and install the higher of the two candidates with --oneshot --nodeps?, perl for example.
  6. Just tried. No worky. See the output below. Looks like it wants to unmask perl-5.28.0. Are you using Funtoo 1.3? If so, what version of perl do you have installed? # perl-cleaner --reallyall -p * Would try to remove the following perl-core packages from world file * emerge --deselect perl-core/File-Temp perl-core/Math-BigInt perl-core/Scalar-List-Utils * Would try to update installed Perl virtuals * emerge -u1 virtual/perl-AutoLoader virtual/perl-CPAN-Meta virtual/perl-CPAN-Meta-YAML virtual/perl-Carp virtual/perl-Compress-Raw-Bzip2 virtual/perl-Compress-Raw-Zlib v
  7. Anyone know for sure? How would one check?
  8. @jhan - 'perl-cleaner --all -p` shows nothing to be done. Only perl-5.24.0 is currently installed. I can't even manually install it unless I use the --nodeps switch. I don't know if that is the proper way to resolve this conflict or any other conflict. @mantas - Nope. Another conflict. See below. I can with the --nodeps switch. Again, I don't know if that would be the correct solution or not. # emerge portage -1av These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] sys-apps/portage-2.3.47::core-kit [2.3.41::core-kit] USE="
  9. Using the 1.3 upgrade instructions, I'm stuck at `emerge -auDN @system --ignore-world`. I get mulitple conflicts I am unable to solve. See the attached file emerge-output.txt Adding the suggested lines to my unmask file doesn't help either. As far as I remember, adding anything with python_targets_pythonX_X is wrong and depreated. It doesn't help either. I'ved tried it. Anyone know how I can solve these slot conflicts? If you need any additional info, just let me know and I'll supply as requested. emerge-output.txt # emerge -auDN @system --ignore-world These are the p
  10. OK, will do. Isn't it still beta? Looks like I need to -- I have the boot-update & ego conflict -- and I already did 'ego sync'. I guess I need to remove xorg-server too according to the directions. Fun stuff! ?
  11. Thanks guys. So I will just update as usually and deal with issues if/as they pop up, then follow the upgrade guide to 1.2? Reinstallation shouldn't be necessary IMO. BTW, my forum profile has "Notify me of replies" and I didn't get any. Check my mail logs -- looks like email is coming from 192.150.253.91, and the sender is forums@www.funtoo.org, but postifx doesn't find a hostname with the reverse lookup check: Dec 9 07:58:27 newton postfix/smtpd[2728]: NOQUEUE: reject: RCPT from unknown[192.150.253.91]: 450 4.7.25 Client host rejected: cannot find your hostname, [192.150.253.91]
  12. I've been a bad boy and haven't updated my system since Aug 05, 2018. I think I hit a gnome version update and was waiting for it to settle. I had already moved to 1.2-prime early back in May 2018. I've looked over the latest announcements and it looks like many things have changed. Can anyone supply me with sound advise on how to proceed? Below is my system info. I've deleted all the unused options from `ego profile list `since highlighting didn't work with cut & paste. If I need to post more, just ask and I will provide. Thanks in Advance # ego profile list === ar
  13. OK, I finished upgrading GCC to 7.3.1. I had already completed the upgrade to Funtoo 1.2 with gcc-6.4.0. I follow the same instructions except I changed `emerge -u1 glibc libnsl libtirpc rpcsvc-proto` to `emerge -1av glibc libnsl libtirpc rpcsvc-proto` otherwise nothing would be compiled in that step. Now after rebooting, amavisd-new fails to start with this error # /etc/init.d/amavisd start * Starting amavisd-new ... Problem in Amavis::DB or Amavis::DB::SNMP code: BerkeleyDB needs compatible versions of libdb & db.h you have db.h version 6.0.30 and libdb version 6.0.35 Co
  14. Since it's a new major version, what else needs to be compiled? Is there a particular order? Can you post the steps?
  15. 7.3.1 is masked, and 6.4.0 is removed from the tree on my system. Is that how it's supposed to be? Is there an upgrade guide like there was to move to Funtoo 1.2?
  16. Thanks. I already had moved distfiles and packages directories when I migrated to meta-repo. IIRC, the instructions mentioned moving those directories to /var/cache/portage/
  17. Can /usr/portage be deleted now that /var/git/meta-repo stores all the ebuild info?
  18. Thanks cardinal. I thought I would have to do it manually. Just checking if anyone had some emerge kung fu to do it in one step with an emerge command combo that I wasn't aware of. Let the compiling begin....
  19. I've switched my second box from ports-2012 to meta-repo. The initial `emerge world -auDN kicks back conflicts preventing all the updates and downgrades. Here's the output of `emerge world -uDNav --verbose-conflicts --backtrack=30`. What is the best way to resolve the conflicts? # emerge world -uDNav --verbose-conflicts --backtrack=30 These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] sys-apps/debianutils-4.8.1.1::core-kit [4.8.1::gentoo] USE="-static" 153 KiB [ebuild U ] dev-util/pkgconf-1.2.2::core-kit [0.9.11::gentoo] USE
  20. 1x i5-4690 and 1x i7-4770K. If you are refering to my post, I meant I would be willing to donate to Funtoo so they could have a Ryzen system. Maybe we should start a gofundme drive to get Oleg and Daniel Ryzen systems.
  21. Thanks for the info, Oleg. Guess I'll wait a little longer. I hate being an early adopter. BIOS from AMD/motherboard makers still need work as well.
  22. Is Funtoo ready for AMD Ryzen CPUs? Does it need GCC 6.X and a 4.11 kernel for full support? I'd like to know before I get a new system.
  23. To accomplish what? I've been using gentoo sources with the same cpufreq kernel config for years. Are you trying to get pstates working or update your microcode? I'm not the one who knows how to do either :( # uname -a Linux kpd 4.4.15-gentoo #1 SMP Mon Jul 18 10:18:41 CDT 2016 x86_64 Intel(R) Core(TM) i5-4690 CPU @ 3.50GHz GenuineIntel GNU/Linux This is my i5 box, but it's the same config as my i7
×
×
  • Create New...