Jump to content

overkill

Members
  • Content Count

    129
  • Joined

  • Last visited

  • Days Won

    11

Posts posted by overkill

  1. I'm not sure about exim, but it think it's common for <> to be used for forwarding.  Because of this, some servers will not accept forwarded mail because of the null sender address.  Is that what you are running into?  One should be able to check the logs to see what indeed is being used as the sender address on forwarded messages.

  2. I've just upgraded to Funtoo 1.3.  My overlay seems to be broken.  It's still in the old /usr/local/portage directory.

    Before the upgrade, it did work.  But equery always shows the O even if there isn't an overlay ebuild for that package.

    [--O] [  ] www-client/chromium-70.0.3538.67:0
    [--O] [  ] www-client/chromium-70.0.3538.67-r1:0
    [--O] [  ] www-client/chromium-71.0.3578.10:0
    [I-O] [  ] www-client/chromium-71.0.3578.30:0
    [--O] [M ] www-client/chromium-72.0.3595.2:0

     

    I've followed the new overlay guide (https://www.funtoo.org/Local_Overlay) and made a new overlay in /var/git/overlay.  Now portage seems to think I have 3 overlays.

     

    # emerge chromium -1av
    WARNING: One or more repositories have been ignored due to duplicate
      profiles/repo_name entries:
    
      /, overkill, /usr/local/portage overrides
        /var/git/overlay/overkill
    
      All profiles/repo_name entries must be unique in order to avoid having
      duplicates ignored. Set PORTAGE_REPO_DUPLICATE_WARN="0" in
      /etc/portage/make.conf if you would like to disable this warning.
    
    
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] www-client/chromium-71.0.3578.30::net-kit  USE="cups gnome-keyring hangouts (pic) proprietary-codecs pulseaudio suid -component-build -custom-cflags -jumbo-build -kerberos (-neon) (-selinux) (-system-ffmpeg) (-system-icu) (-system-libvpx) (-tcmalloc) -widevine" L10N="-am -ar -bg -bn -ca -cs -da -de -el -en-GB -es -es-419 -et -fa -fi -fil -fr -gu -he -hi -hr -hu -id -it -ja -kn -ko -lt -lv -ml -mr -ms -nb -nl -pl -pt-BR -pt-PT -ro -ru -sk -sl -sr -sv -sw -ta -te -th -tr -uk -vi -zh-CN -zh-TW" 0 KiB
    
    Total: 1 package (1 reinstall), Size of downloads: 0 KiB
    
    Would you like to merge these packages? [Yes/No]

     

    What is the best way to fix this so I only use the new Overlay location and hopefully fix the equery output.

  3. Just upgraded to Gnome 3.30.  The time/date display in the middle of the top bar is always UTC.  My system clock is using local time America/Chicago for Central Standard Time.  Using the settings utility in gnome, it shows the correct time zone, but it says UTC America/Chicago.  No matter what I change it to, it will still show UTC time.

    If I manually change the time with the gnome settings date / time control, it will change the system time to UTC, but the time/date will be correct.

    How do I force gnome to NOT BE STUCK in UTC?

    Screenshot from 2018-12-15 18-28-10.png

    Screenshot from 2018-12-15 22-54-59.png

    Screenshot from 2018-12-15 22-55-06.png

  4. 2 hours ago, drobbins said:

    OK, you should definitely set a subarch, but that is an unrelated issue.

    I was planning on migrating to a different CPU in the short term.

    2 hours ago, drobbins said:

    And you currently have release = 1.3 in /etc/ego.conf and no hard-coded kits settings in /etc/ego.conf? And you've done an ego sync?

    Yes, here it is

    # cat /etc/ego.conf 
    # This is the ego.conf file
    
    [global]
    
    release = 1.3

     

    2 hours ago, drobbins said:

    All righty, and what's the output of "emerge -av enchant" ? (you don't need to actually merge it, just want to see what's installed and if it wants to install an update)

    Here it is, but I'm having a problem with empathy, not enchant.  Are they related?

    # emerge enchant -av
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] app-text/enchant-2.2.1-r1:0/2::text-kit  USE="hunspell -aspell -static-libs -test" 0 KiB
    
    Total: 1 package (1 reinstall), Size of downloads: 0 KiB
    
    Would you like to merge these packages? [Yes/No] 

     

  5. I do use gnome, so the mix in is enabled.

     

    # epro show
    
    === Enabled Profiles: ===
    
            arch: x86-64bit
           build: current
         subarch: (not set)
          flavor: desktop
         mix-ins: gnome
    
    
    === Python kit: ===
    
          branch: 3.7-release
    
    === All inherited flavor from desktop flavor: ===
    
                         workstation (from desktop flavor)
                                core (from workstation flavor)
                             minimal (from core flavor)
    
    === All inherited mix-ins from desktop flavor: ===
    
                                   X (from workstation flavor)
                               audio (from workstation flavor)
                                 dvd (from workstation flavor)
                               media (from workstation flavor)
          mediadevice-audio-consumer (from media mix-in)
                    mediadevice-base (from mediadevice-audio-consumer mix-in)
          mediadevice-video-consumer (from media mix-in)
                    mediadevice-base (from mediadevice-video-consumer mix-in)
            mediaformat-audio-common (from media mix-in)
              mediaformat-gfx-common (from media mix-in)
            mediaformat-video-common (from media mix-in)
                      console-extras (from workstation flavor)
                               print (from desktop flavor)
    
    === All inherited flavor from gnome mix-ins: ===
    
                             desktop (from gnome-kit:gnome mix-in)
                         workstation (from desktop flavor)
                                core (from workstation flavor)
                             minimal (from core flavor)
    
    === All inherited mix-ins from gnome mix-ins: ===
    
                     gnome-kit:gnome (from gnome mix-in)
                                   X (from workstation flavor)
                               audio (from workstation flavor)
                                 dvd (from workstation flavor)
                               media (from workstation flavor)
          mediadevice-audio-consumer (from media mix-in)
                    mediadevice-base (from mediadevice-audio-consumer mix-in)
          mediadevice-video-consumer (from media mix-in)
                    mediadevice-base (from mediadevice-video-consumer mix-in)
            mediaformat-audio-common (from media mix-in)
              mediaformat-gfx-common (from media mix-in)
            mediaformat-video-common (from media mix-in)
                      console-extras (from workstation flavor)
                               print (from desktop flavor)

     

  6. Can't finish `emerge @preserved-rebuild`.  Empathy fails everytime.  go keeps being included in the list, just like it says in the guide.  I did uninstall it and reinstall it.

    # emerge @preserved-rebuild -av
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] dev-lang/go-1.11.2:0/1.11.2::lang-kit  USE="-gccgo" 0 KiB
    [ebuild     U  ] net-im/empathy-3.12.14::gnome-kit [3.12.12::gentoo] USE="geolocation gnome gnome-online-accounts map spell v4l -debug -test" 0 KiB
    
    Total: 2 packages (1 upgrade, 1 reinstall), Size of downloads: 0 KiB
    
    Would you like to merge these packages? [Yes/No]

    So close.

    libtool: link: x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe -Wl,-O1 -Wl,--sort-common -o .libs/empathy-debugger empathy-debug-window.o empathy-debugger.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ../libempathy-gtk/.libs/libempathy-gtk.so -lenchant-2 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy/.libs/libempathy.so ../libempathy/.libs/libempathy.so -lgeocode-glib -lmission-control-plugins -lgoa-1.0 -lm ../extensions/.libs/libemp-extensions.a -ldbus-glib-1 -ldbus-1 -lfolks-telepathy -lfolks -ltelepathy-logger -lcanberra-gtk3 -lcanberra -lnotify -lgcr-ui-3 -lgcr-base-3 -lgck-1 -lp11-kit -lpulse-mainloop-glib -lpulse -lwebkit2gtk-4.0 -ljavascriptcoregtk-4.0 -lsoup-2.4 -lgee-0.8 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/telepathy-account-widgets/tp-account-widgets/.libs/libtp-account-widgets.a -ltelepathy-glib -lxml2 -lsecret-1 -lcheese-gtk -lgudev-1.0 -lchamplain-gtk-0.12 -lclutter-gtk-1.0 -lgtk-3 -lchamplain-0.12 -lclutter-1.0 -lcogl-path -latk-1.0 -lcogl-pango -lcogl -lgmodule-2.0 -lgbm -ldrm -lEGL -lXrandr -ljson-glib-1.0 -lgio-2.0 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lXdamage -lXfixes -lXcomposite -lXi -pthread -Wl,-rpath -Wl,/usr/lib64/empathy
    libtool: link: x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe -Wl,-O1 -Wl,--sort-common -o .libs/empathy-auth-client empathy-sanity-cleaning.o empathy-auth-client.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ../libempathy-gtk/.libs/libempathy-gtk.so -lenchant-2 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy/.libs/libempathy.so ../libempathy/.libs/libempathy.so -lgeocode-glib -lmission-control-plugins -lgoa-1.0 -lm ../extensions/.libs/libemp-extensions.a -ldbus-glib-1 -ldbus-1 -lfolks-telepathy -lfolks -ltelepathy-logger -lcanberra-gtk3 -lcanberra -lnotify -lgcr-ui-3 -lgcr-base-3 -lgck-1 -lp11-kit -lpulse-mainloop-glib -lpulse -lwebkit2gtk-4.0 -ljavascriptcoregtk-4.0 -lsoup-2.4 -lgee-0.8 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/telepathy-account-widgets/tp-account-widgets/.libs/libtp-account-widgets.a -ltelepathy-glib -lxml2 -lsecret-1 -lcheese-gtk -lgudev-1.0 -lchamplain-gtk-0.12 -lclutter-gtk-1.0 -lgtk-3 -lchamplain-0.12 -lclutter-1.0 -lcogl-path -latk-1.0 -lcogl-pango -lcogl -lgmodule-2.0 -lgbm -ldrm -lEGL -lXrandr -ljson-glib-1.0 -lgio-2.0 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lXdamage -lXfixes -lXcomposite -lXi -pthread -Wl,-rpath -Wl,/usr/lib64/empathy
    ../libempathy-gtk/.libs/libempathy-gtk.so: undefined reference to `enchant_dict_add_to_pwl'
    collect2: error: ld returned 1 exit status
    libtool: link: x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe -Wl,-O1 -Wl,--sort-common -o .libs/empathy-chat chat-manager-interface.o empathy-about-dialog.o empathy-chat-manager.o empathy-chat-window.o empathy-invite-participant-dialog.o empathy-chat.o empathy-chat-resources.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ../libempathy-gtk/.libs/libempathy-gtk.so -lenchant-2 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy/.libs/libempathy.so ../libempathy/.libs/libempathy.so -lgeocode-glib -lmission-control-plugins -lgoa-1.0 -lm ../extensions/.libs/libemp-extensions.a -ldbus-glib-1 -ldbus-1 -lfolks-telepathy -lfolks -ltelepathy-logger -lcanberra-gtk3 -lcanberra -lnotify -lgcr-ui-3 -lgcr-base-3 -lgck-1 -lp11-kit -lpulse-mainloop-glib -lpulse -lwebkit2gtk-4.0 -ljavascriptcoregtk-4.0 -lsoup-2.4 -lgee-0.8 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/telepathy-account-widgets/tp-account-widgets/.libs/libtp-account-widgets.a -ltelepathy-glib -lxml2 -lsecret-1 -lcheese-gtk -lgudev-1.0 -lchamplain-gtk-0.12 -lclutter-gtk-1.0 -lgtk-3 -lchamplain-0.12 -lclutter-1.0 -lcogl-path -latk-1.0 -lcogl-pango -lcogl -lgmodule-2.0 -lgbm -ldrm -lEGL -lXrandr -ljson-glib-1.0 -lgio-2.0 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lXdamage -lXfixes -lXcomposite -lXi -pthread -Wl,-rpath -Wl,/usr/lib64/empathy
    make[3]: *** [Makefile:892: empathy-debugger] Error 1
    make[3]: *** Waiting for unfinished jobs....
    ../libempathy-gtk/.libs/libempathy-gtk.so: undefined reference to `enchant_dict_add_to_pwl'
    collect2: error: ld returned 1 exit status
    make[3]: *** [Makefile:880: empathy-auth-client] Error 1
    libtool: link: x86_64-pc-linux-gnu-gcc -march=corei7 -O2 -pipe -Wl,-O1 -Wl,--sort-common -o .libs/empathy empathy-about-dialog.o empathy-chat-window.o empathy-chatrooms-window.o empathy-event-manager.o empathy-ft-manager.o empathy-invite-participant-dialog.o empathy-roster-window.o empathy-new-chatroom-dialog.o empathy-notifications-approver.o empathy-call-observer.o empathy-preferences.o empathy-status-icon.o empathy-chat-manager.o empathy.o chat-manager-interface.o -Wl,--export-dynamic -pthread -pthread  -Wl,--as-needed ./.libs/libempathy-accounts-common.a /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy-gtk/.libs/libempathy-gtk.so ../libempathy-gtk/.libs/libempathy-gtk.so -lenchant-2 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy/.libs/libempathy.so ../libempathy/.libs/libempathy.so -lcheese-gtk -lgeocode-glib -lgudev-1.0 -lmission-control-plugins -lgoa-1.0 -lm ../extensions/.libs/libemp-extensions.a -ldbus-glib-1 -ldbus-1 -lfolks-telepathy -lfolks -lsecret-1 -ltelepathy-logger -ltelepathy-glib -lxml2 -lcanberra-gtk3 -lcanberra -lnotify -lgcr-ui-3 -lgcr-base-3 -lgck-1 -lp11-kit -lpulse-mainloop-glib -lpulse -lwebkit2gtk-4.0 -ljavascriptcoregtk-4.0 -lsoup-2.4 -lgee-0.8 -lchamplain-gtk-0.12 -lclutter-gtk-1.0 -lgtk-3 -lchamplain-0.12 -lclutter-1.0 -lcogl-path -latk-1.0 -lcogl-pango -lcogl -lgmodule-2.0 -lgbm -ldrm -lEGL -lXrandr -ljson-glib-1.0 -lgio-2.0 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lXdamage -lXfixes -lXcomposite -lXi -pthread -Wl,-rpath -Wl,/usr/lib64/empathy
    libtool: link: x86_64-pc-linux-gnu-gcc -I/usr/include/farstream-0.2 -I/usr/include/gstreamer-1.0 -I/usr/include/glib-2.0 -I/usr/lib64/glib-2.0/include -I/usr/lib64/libffi-3.3_rc0/include -I/usr/include/telepathy-1.0 -I/usr/include/dbus-1.0 -I/usr/lib64/dbus-1.0/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/uuid -I/usr/include/clutter-1.0 -I/usr/include/cogl -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/libdrm -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/atk-1.0 -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/harfbuzz -I/usr/include/json-glib-1.0 -I/usr/include/gtk-3.0 -I/usr/include/gio-unix-2.0 -I/usr/include/clutter-gtk-1.0 -I/usr/include/at-spi2-atk/2.0 -I/usr/include/at-spi-2.0 -I/usr/include/clutter-gst-3.0 -I/usr/include/orc-0.4 -pthread -DGST_USE_UNSTABLE_API -march=corei7 -O2 -pipe -pthread -Wl,-O1 -Wl,--sort-common -o .libs/empathy-call empathy_call-empathy-call.o empathy_call-empathy-call-factory.o empathy_call-empathy-call-handler.o empathy_call-empathy-call-window.o empathy_call-empathy-call-window-fullscreen.o empathy_call-empathy-about-dialog.o empathy_call-empathy-audio-sink.o empathy_call-empathy-audio-src.o empathy_call-empathy-audio-utils.o empathy_call-empathy-video-src.o empathy_call-empathy-preferences.o empathy_call-empathy-camera-menu.o empathy_call-empathy-mic-menu.o empathy_call-empathy-rounded-actor.o empathy_call-empathy-rounded-rectangle.o empathy_call-empathy-rounded-texture.o empathy_call-empathy-mic-monitor.o -Wl,--export-dynamic -pthread -pthread  -lfarstream-0.2 -ltelepathy-farstream -lclutter-gst-3.0 -lgstaudio-1.0 -lgstvideo-1.0 -lgstbase-1.0 -lgstreamer-1.0 -Wl,--as-needed ../libempathy-gtk/.libs/libempathy-gtk.so -lenchant-2 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy/.libs/libempathy.so ../libempathy/.libs/libempathy.so -lgeocode-glib -lmission-control-plugins -lgoa-1.0 -lm ../extensions/.libs/libemp-extensions.a -ldbus-glib-1 -ldbus-1 -lfolks-telepathy -lfolks -ltelepathy-logger -lcanberra-gtk3 -lcanberra -lnotify -lgcr-ui-3 -lgcr-base-3 -lgck-1 -lp11-kit -lpulse-mainloop-glib -lpulse -lwebkit2gtk-4.0 -ljavascriptcoregtk-4.0 -lsoup-2.4 -lgee-0.8 /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/telepathy-account-widgets/tp-account-widgets/.libs/libtp-account-widgets.a -ltelepathy-glib -lxml2 -lsecret-1 -lcheese-gtk -lgudev-1.0 -lchamplain-gtk-0.12 -lclutter-gtk-1.0 -lgtk-3 -lchamplain-0.12 -lclutter-1.0 -lcogl-path -latk-1.0 -lcogl-pango -lcogl -lgmodule-2.0 -lgbm -ldrm -lEGL -lXrandr -ljson-glib-1.0 -lgio-2.0 -lgdk-3 -lpangocairo-1.0 -lpango-1.0 -lgdk_pixbuf-2.0 -lcairo-gobject -lcairo -lgobject-2.0 -lglib-2.0 -lX11 -lXext -lXdamage -lXfixes -lXcomposite -lXi -pthread -Wl,-rpath -Wl,/usr/lib64/empathy
    ../libempathy-gtk/.libs/libempathy-gtk.so: undefined reference to `enchant_dict_add_to_pwl'
    collect2: error: ld returned 1 exit status
    make[3]: *** [Makefile:888: empathy-chat] Error 1
    /var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/libempathy-gtk/.libs/libempathy-gtk.so: undefined reference to `enchant_dict_add_to_pwl'
    ../libempathy-gtk/.libs/libempathy-gtk.so: undefined reference to `enchant_dict_add_to_pwl'
    collect2: error: ld returned 1 exit status
    collect2: error: ld returned 1 exit status
    make[3]: *** [Makefile:872: empathy] Error 1
    make[3]: *** [Makefile:884: empathy-call] Error 1
    make[3]: Leaving directory '/var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/src'
    make[2]: *** [Makefile:723: all] Error 2
    make[2]: Leaving directory '/var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14/src'
    make[1]: *** [Makefile:509: all-recursive] Error 1
    make[1]: Leaving directory '/var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14'
    make: *** [Makefile:441: all] Error 2
     * ERROR: net-im/empathy-3.12.14::gnome-kit failed (compile phase):
     *   emake failed
     * 
     * If you need support, post the output of `emerge --info '=net-im/empathy-3.12.14::gnome-kit'`,
     * the complete build log and the output of `emerge -pqv '=net-im/empathy-3.12.14::gnome-kit'`.
     * The complete build log is located at '/var/tmp/portage/net-im/empathy-3.12.14/temp/build.log'.
     * The ebuild environment file is located at '/var/tmp/portage/net-im/empathy-3.12.14/temp/environment'.
     * Working directory: '/var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14'
     * S: '/var/tmp/portage/net-im/empathy-3.12.14/work/empathy-3.12.14'
    

     

  7. Couldn't wait.  Had to uninstall 3 packages to proceed.

    # emerge -C =compiler-rt-sanitizers-6.0.0 -a
    # emerge -C =webkit-gtk-2.4.11-r2 -a
    # emerge -C =grilo-plugins-0.2.17

    Now `emege @preserved-rebuild works!

    # emerge @preserved-rebuild -av
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] dev-lang/go-1.11.2:0/1.11.2::lang-kit  USE="-gccgo" 0 KiB
    [ebuild   R    ] dev-scheme/guile-2.0.11-r1:0/2.0.11::core-kit  USE="deprecated nls regex threads -debug -debug-malloc -emacs -networking -static" 0 KiB
    [ebuild     UD ] dev-libs/protobuf-3.5.1.1:0/15::dev-kit [3.6.1:0/17::dev-kit] USE="zlib -emacs -examples -static-libs -test" 0 KiB
    [ebuild   R    ] dev-libs/protobuf-c-1.3.0-r1:0/1.0.0::dev-kit  USE="-static-libs -test" 0 KiB
    [ebuild     UD ] dev-lang/spidermonkey-24.2.0-r4:24::net-kit [24.2.0-r5:24::lang-kit] USE="icu system-icu -debug -jit -minimal -static-libs -test" 0 KiB
    [ebuild     U  ] sys-devel/llvm-5.0.2:5::llvm-kit [5.0.1:5::llvm-kit] USE="libffi ncurses -debug -doc -gold -libedit -test" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 22,994 KiB
    [ebuild     U  ] sys-devel/llvm-6.0.1-r2:6::llvm-kit [6.0.0:6::llvm-kit] USE="libffi ncurses xml -debug -doc -gold -libedit -test -xar" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 24,814 KiB
    [ebuild   R    ] dev-libs/cyrus-sasl-2.1.26-r11:2::net-kit [2.1.26-r11:2::dev-kit] USE="gdbm pam ssl urandom -authdaemond -berkdb -java -kerberos -ldapdb -libressl -mysql -openldap -postgres -sample (-selinux) -sqlite -srp -static-libs" 0 KiB
    [ebuild   R    ] dev-python/namespace-google-1::python-modules-kit [1::python-kit] PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5 -python3_7%" 0 KiB
    [ebuild   R    ] dev-python/protobuf-python-3.5.1.1:0/15::dev-kit [3.5.1.1:0/15::python-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
    [ebuild     U #] dev-lang/php-7.3.0_rc5:7.3::core-server-kit [7.3.0_alpha3:7.3::php-kit] USE="acl berkdb bzip2 cli ctype curl exif fileinfo filter fpm gd gdbm hash iconv intl ipv6 json nls opcache phar posix readline session simplexml soap ssl tokenizer truetype unicode webp xml zlib -apache2 -argon2 -bcmath -calendar -cdb -cgi -cjk -coverage -debug -embed -enchant -firebird -flatfile -ftp -gmp -imap -inifile -iodbc -kerberos -ldap -ldap-sasl -libedit -libressl -lmdb -mhash -mssql -mysql -mysqli -oci8-instant-client -odbc -pcntl -pdo -phpdbg -postgres -qdbm -recode (-selinux) -session-mm -sharedmem -snmp -sockets -sodium -spell -sqlite -systemd -sysvipc -test -threads -tidy -tokyocabinet -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xslt -zip -zip-encryption" 11,637 KiB
    [ebuild   R    ] net-analyzer/gnome-nettool-3.8.1::gnome-kit [3.8.1::gentoo] USE="-debug" 0 KiB
    [ebuild     U  ] www-client/epiphany-3.30.2::gnome-kit [3.20.7::gnome-kit] USE="-test" 4,422 KiB
    [ebuild     U  ] media-libs/gegl-0.3.34:0.3::gnome-kit [0.3.26:0.3::media-kit] USE="cairo ffmpeg introspection jpeg2k raw svg tiff v4l webp -debug -lcms -lensfun -openexr -sdl -test -umfpack -vala" CPU_FLAGS_X86="mmx sse" 6,551 KiB
    [ebuild     U  ] net-im/empathy-3.12.14::gnome-kit [3.12.12::gentoo] USE="geolocation gnome gnome-online-accounts map spell v4l -debug -test" 4,901 KiB
    
    Total: 15 packages (6 upgrades, 2 downgrades, 7 reinstalls), Size of downloads: 75,318 KiB
    
    Would you like to merge these packages? [Yes/No] no

    I'll follow instructions and perform emerge -C dev-lang/go; emerge dev-lang/go before doing the @preserved-rebuild.

    EDIT:  The guide should show `emerge dev-lang/go --oneshot` or -1av

  8. Good news, bad news.

    I was able to complete `emerge world -uDNav`, but cannot do a `emerge @preserved-rebuild -a`.

    # emerge @preserved-rebuild -av
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    emerge: there are no ebuilds to satisfy "sys-libs/compiler-rt-sanitizers:6.0.0".
    (dependency required by "@preserved-rebuild" [argument])

    Checking the tree with equery shows:

    # equery l -po compiler-rt-sanitizers
     * Searching for compiler-rt-sanitizers ...
    [--O] [  ] sys-libs/compiler-rt-sanitizers-4.0.1:4.0.1
    [--O] [  ] sys-libs/compiler-rt-sanitizers-5.0.2:5.0.2
    [I--] [??] sys-libs/compiler-rt-sanitizers-6.0.0:6.0.0
    [--O] [  ] sys-libs/compiler-rt-sanitizers-6.0.1:6.0.1
    [I-O] [  ] sys-libs/compiler-rt-sanitizers-7.0.0:7.0.0
    [--O] [M ] sys-libs/compiler-rt-sanitizers-7.0.1_rc2:7.0.1
    [--O] [ -] sys-libs/compiler-rt-sanitizers-7.0.9999:7.0.1
    [--O] [ -] sys-libs/compiler-rt-sanitizers-9999:8.0.0

    genlop -t shows version 7.0.0 was installed on Dec 11th

    # genlop -t compiler-rt-sanitizers
     * sys-libs/compiler-rt-sanitizers
    
         Thu Mar 29 09:44:13 2018 >>> sys-libs/compiler-rt-sanitizers-6.0.0
           merge time: 55 seconds.
    
         Sun Apr 29 15:39:57 2018 >>> sys-libs/compiler-rt-sanitizers-6.0.0
           merge time: 53 seconds.
    
         Tue May  8 11:18:52 2018 >>> sys-libs/compiler-rt-sanitizers-6.0.0
           merge time: 55 seconds.
    
         Tue Dec 11 20:18:38 2018 >>> sys-libs/compiler-rt-sanitizers-7.0.0
           merge time: 50 seconds.

     

    Since 6.0.0 is no longer in the tree, should I remove it?

    # emerge -C =compiler-rt-sanitizers-6.0.0 -a
     * This action can remove important packages! In order to be safer, use
     * `emerge -pv --depclean <atom>` to check for reverse dependencies before
     * removing packages.
    
    >>> These are the packages that would be unmerged:
    
     sys-libs/compiler-rt-sanitizers
        selected: 6.0.0 
       protected: none 
         omitted: 7.0.0 
    
    All selected packages: =sys-libs/compiler-rt-sanitizers-6.0.0
    
    >>> 'Selected' packages are slated for removal.
    >>> 'Protected' and 'omitted' packages will not be removed.
    
    Would you like to unmerge these packages? [Yes/No]

     

    Would that be a place to start to fix this issue?  If it's something else, please advise.

     

    I also check what packages depend on compiler-rt-sanitizers.  Looks like clang-runtime-6.0.0 is still installed and not in the tree too

    # equery d compiler-rt-sanitizers
     * These packages depend on compiler-rt-sanitizers:
    sys-devel/clang-runtime-6.0.0 (~sys-libs/compiler-rt-sanitizers-6.0.0:6.0.0)
    sys-devel/clang-runtime-7.0.0 (sanitize ? ~sys-libs/compiler-rt-sanitizers-7.0.0:7.0.0)
    
    # equery l -po clang-runtime
     * Searching for clang-runtime ...
    [--O] [  ] sys-devel/clang-runtime-3.9.1:0
    [--O] [  ] sys-devel/clang-runtime-4.0.1:4.0.1
    [--O] [  ] sys-devel/clang-runtime-4.0.1-r1:4.0.1
    [--O] [  ] sys-devel/clang-runtime-5.0.2:5.0.2
    [I--] [??] sys-devel/clang-runtime-6.0.0:6.0.0
    [--O] [  ] sys-devel/clang-runtime-6.0.1:6.0.1
    [I-O] [  ] sys-devel/clang-runtime-7.0.0:7.0.0
    [--O] [M ] sys-devel/clang-runtime-7.0.1_rc2:7.0.1
    [--O] [ -] sys-devel/clang-runtime-7.0.9999:7.0.1
    [--O] [ -] sys-devel/clang-runtime-9999:8.0.0
    
    
    # genlop -t clang-runtime
     * sys-devel/clang-runtime
    
         Mon Nov 20 20:14:24 2017 >>> sys-devel/clang-runtime-3.9.1
           merge time: 4 seconds.
    
         Thu Mar 29 09:44:34 2018 >>> sys-devel/clang-runtime-6.0.0
           merge time: 4 seconds.
    
         Tue Dec 11 20:18:43 2018 >>> sys-devel/clang-runtime-7.0.0
           merge time: 4 seconds.

     

  9. I did remove xorg-server as instructed in the guide.  I also cut and pasted the sed commands.

    My major fault I believe was that I had done a partial 1.2 upgrade back around May.  By partial I mean not all of the kits moved to 1.2, only a selection of kits were specified as 1.2-prime.  I followed those instructions and successfully upgraded.  I believe I posted my ego.conf file in my first post of this thread.  I didn't  upgrade (ego sync & emerge world -uDNav) that installation, I just jumped right into the 1.3 upgrade guide.  So yes, my mistake, but I did follow the guides, I just failed to prep the system to a current state.

  10. I had to fix some issues -- don't remember what exactly the error was -- about too many versions trying to be installed.  It suggested to use --verbose-conflicts but that didn't work.  Basically I had to reinstall any [installed] package(s) with a lower version dependency.  After I got those cleaned up, I attacked the errors like in my last post.  In the last post, I would have run `emerge libcanberra --ignore-world -1av`.  After sucessfully installing, then I would `emerge world -uDNav` again and deal with the next problem.  Had to uninstall gparted.  I couldn't fix that one.  I also got desperate and tried `emerge world -epv` (--empty-tree).  That actually gave me some good hints too. I had to fix an entry about chromium -~amd64 and add a USE entry.  See the end of the output of `emerge world -epv` below.

    Total: 1398 packages (474 upgrades, 4 downgrades, 66 new, 15 in new slots, 839 reinstalls, 4 uninstalls), Size of downloads: 3,673,855 KiB
    Conflict: 9 blocks
    
    !!! The following update has been skipped due to unsatisfied dependencies:
    
    sys-block/gparted:0
    
      selected: (sys-block/gparted-0.29.0:0/0::nokit, installed)
      skipped: (sys-block/gparted-0.29.0:0/0::nokit, ebuild scheduled for merge) (see unsatisfied dependency below)
    
    emerge: there are no ebuilds to satisfy ">=dev-cpp/gtkmm-2.22:2.4".
    (dependency required by "sys-block/gparted-0.29.0::nokit" [ebuild])
    
    
    The following keyword changes are necessary to proceed:
     (see "package.accept_keywords" in the portage(5) man page for more details)
    # required by @selected
    # required by @world (argument)
    =www-client/chromium-71.0.3578.30 ~amd64
    
    The following USE changes are necessary to proceed:
     (see "package.use" in the portage(5) man page for more details)
    # required by www-client/chromium-71.0.3578.30::net-kit
    # required by @selected
    # required by @world (argument)
    >=net-libs/nodejs-9.11.2 inspector
    
    !!! Problems have been detected with your world file
    !!! Please run emaint --check world
    
    
    !!! Ebuilds for the following packages are either all
    !!! masked or don't exist:
    sys-block/gparted

    After that I had one more package to rebuild and I finally got a sane output to emerge world -uDNav.  I've attached that output in a file.  It's large and in charge.

     

    emerge-world-uDNpv.txt

  11. It merged, but now other programs show up.  I'm afraid it will just keep continuing until I've emerge 1256 packages manually ?

    I've run `emerge world -uDNav` several times and the output changes but the "there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]" " remains.

    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]".
    (dependency required by "media-libs/libcanberra-0.30-r5::gentoo" [installed])
    (dependency required by "media-sound/pavucontrol-3.0::media-kit" [installed])
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])
    ==================================================================================
    
    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    The following packages are causing rebuilds:
    
      (dev-db/lmdb-0.9.22:0/0.9.22::core-server-kit, ebuild scheduled for merge) causes rebuilds for:
        (net-nds/openldap-2.4.45:0/0::net-kit, ebuild scheduled for merge)
      (x11-base/xorg-server-1.20.1:0/1.20.1::xorg-kit, ebuild scheduled for merge) causes rebuilds for:
        (x11-drivers/xf86-input-keyboard-1.9.0:0/0::xorg-kit, ebuild scheduled for merge)
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.34.3:2[abi_x86_64(-)]".
    (dependency required by "media-libs/libquvi-0.9.4-r1::gentoo" [installed])
    (dependency required by "dev-libs/totem-pl-parser-3.26.1::gnome-kit[quvi]" [ebuild])
    (dependency required by "media-libs/grilo-0.3.6::gnome-kit[playlist]" [ebuild])
    (dependency required by "gnome-base/gnome-control-center-3.30.2::gnome-kit" [ebuild])
    (dependency required by "net-libs/gnome-online-accounts-3.30.0::gnome-kit[gnome]" [ebuild])
    (dependency required by "gnome-base/gvfs-1.38.1::gnome-kit[gnome-online-accounts]" [ebuild])
    (dependency required by "sci-geosciences/geocode-glib-3.26.0::gnome-kit" [ebuild])
    (dependency required by "gnome-base/gnome-settings-daemon-3.30.1.2::gnome-kit" [ebuild])
    (dependency required by "gnome-base/gnome-session-3.30.1::gnome-kit" [ebuild])
    ==================================================================================
    
    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    The following packages are causing rebuilds:
    
      (x11-base/xorg-server-1.20.1:0/1.20.1::xorg-kit, ebuild scheduled for merge) causes rebuilds for:
        (x11-drivers/xf86-input-keyboard-1.9.0:0/0::xorg-kit, ebuild scheduled for merge)
      (dev-db/lmdb-0.9.22:0/0.9.22::core-server-kit, ebuild scheduled for merge) causes rebuilds for:
        (net-nds/openldap-2.4.45:0/0::net-kit, ebuild scheduled for merge)
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]".
    (dependency required by "media-libs/libcanberra-0.30-r5::gentoo" [installed])
    (dependency required by "media-video/cheese-3.30.0::gnome-kit" [ebuild])
    (dependency required by "gnome-base/gnome-control-center-3.30.2::gnome-kit[v4l]" [ebuild])
    (dependency required by "net-libs/gnome-online-accounts-3.30.0::gnome-kit[gnome]" [ebuild])
    (dependency required by "gnome-base/gvfs-1.38.1::gnome-kit[gnome-online-accounts]" [ebuild])
    (dependency required by "app-text/evince-3.30.2::gnome-kit" [ebuild])
    (dependency required by "gnome-extra/sushi-3.30.0::gnome-kit" [ebuild])
    (dependency required by "gnome-base/nautilus-3.30.3-r1::gnome-kit[previewer]" [ebuild])
    (dependency required by "app-cdr/brasero-3.12.2-r1::gnome-kit[nautilus]" [ebuild])
    (dependency required by "media-sound/rhythmbox-3.4.2::media-kit[cdr]" [ebuild])
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])
    ==================================================================================
    
    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.32:2[abi_x86_64(-)]".
    (dependency required by "media-libs/libcanberra-0.30-r5::gentoo" [installed])
    (dependency required by "x11-wm/mutter-3.30.2::gnome-kit" [ebuild])
    (dependency required by "gnome-extra/gnome-shell-extensions-3.30.1::gnome-kit" [ebuild])
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])
    

     

  12. Still stuck at this point.

    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.34.3:2[abi_x86_64(-)]".
    (dependency required by "net-libs/libnice-0.1.13::gentoo" [installed])
    (dependency required by "media-plugins/gst-plugins-libnice-0.1.13-r100::gentoo" [installed])
    (dependency required by "net-libs/farstream-0.2.8-r1::gentoo" [installed])
    (dependency required by "net-im/pidgin-2.13.0::net-kit[gstreamer]" [installed])
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])


    Would this fix it?

    # emerge libnice gst-plugins-libnice farstream pidgin -1av --ignore-world
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] net-libs/libnice-0.1.13::gnome-kit [0.1.13::gentoo] USE="introspection upnp" 0 KiB
    [ebuild   R    ] media-plugins/gst-plugins-libnice-0.1.13-r100:1.0::media-kit [0.1.13-r100:1.0::gentoo] 0 KiB
    [ebuild   R    ] net-libs/farstream-0.2.8-r1:0.2/5::gnome-kit [0.2.8-r1:0.2/5::gentoo] USE="introspection -test -upnp" 0 KiB
    [ebuild   R    ] net-im/pidgin-2.13.0:0/2::net-kit  USE="dbus gstreamer gtk ncurses nls python xscreensaver (-aqua) -debug -doc -eds -gadu -gnutls -groupwise -idn -meanwhile -networkmanager -perl -pie -prediction -sasl -silc -spell -tcl -tk -zephyr -zeroconf" PYTHON_TARGETS="python2_7" 0 KiB
    
    Total: 4 packages (4 reinstalls), Size of downloads: 0 KiB
    
    Would you like to merge these packages? [Yes/No] 

     

  13. 1 minute ago, Oleg Vinichenko said:

    add gdbus-codegen into emerge list os it looks like

     emerge -1av glib gdbus-codegen at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world

    OK.  Done.  Looks good.

    # emerge -1av glib gdbus-codegen at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild   R    ] dev-util/gdbus-codegen-2.58.1::gnome-kit  PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-libs/glib-2.58.1:2::gnome-kit  USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap -test -utils" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit  USE="icu -debug -systemd -test" 0 KiB
    [ebuild   R    ] dev-libs/atk-2.30.0::gnome-kit  USE="introspection nls -doc" 0 KiB
    [ebuild  N     ] media-libs/graphene-1.8.2::media-kit  USE="introspection -doc -test" CPU_FLAGS_X86="sse2" 125 KiB
    [ebuild   R    ] dev-libs/libgusb-0.3.0::gnome-kit  USE="introspection vala -static-libs" 0 KiB
    [ebuild   R    ] app-accessibility/at-spi2-core-2.30.0:2::gnome-kit  USE="X introspection" 0 KiB
    [ebuild   R    ] dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit  USE="dbus egl gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev -gles2 -ibus -test -tslib -tuio -vnc" 0 KiB
    [ebuild   R    ] x11-misc/colord-1.3.5:0/2::gnome-kit  USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner -systemd -vala" 0 KiB
    [ebuild  NS    ] x11-libs/gtk+-3.94.0:4::gnome-kit [2.24.32-r1:2::gnome-kit, 3.24.1:3::gnome-kit] USE="X colord cups introspection (-aqua) -broadway -cloudprint -docs -examples -test -vim-syntax -vulkan -wayland -xinerama" 13,189 KiB
    
    Total: 10 packages (1 new, 1 in new slot, 8 reinstalls), Size of downloads: 13,313 KiB
    
    Would you like to merge these packages? [Yes/No] 

    Proceed?

  14. I added python_single_target_python2_7 and that eliminated the unmet requirements.  Now I have a new snag

    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    
    emerge: there are no ebuilds to satisfy ">=dev-libs/glib-2.34.3:2[abi_x86_64(-)]".
    (dependency required by "media-libs/libquvi-0.9.4-r1::gentoo" [installed])
    (dependency required by "dev-libs/totem-pl-parser-3.26.1::gnome-kit[quvi]" [ebuild])
    (dependency required by "media-libs/grilo-0.3.6::gnome-kit[playlist]" [ebuild])
    (dependency required by "gnome-base/gnome-control-center-3.30.2::gnome-kit" [ebuild])
    (dependency required by "net-libs/gnome-online-accounts-3.30.0::gnome-kit[gnome]" [ebuild])

    How do I get around this one?

  15. Got pass `emerge system -uDNav --ignore-world`.  I had to remove nearly all the x11-proto/ packages due to file collisions with xorg-proto.

    Now I'm attempting to run `emerge world -uDNav` as per the 1.3 upgrade guide.  I'm hitting a snag with "unmet requirements".  I know how to add the requirement to my package.use file, but I am unsure of the correct selection.

    # emerge world -uDNav
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies \
    
    !!! Problem resolving dependencies for gnome-extra/chrome-gnome-shell from @selected
    ... done!
    
    !!! The ebuild selected to satisfy "gnome-extra/chrome-gnome-shell" has unmet requirements.
    - gnome-extra/chrome-gnome-shell-9::gnome-kit USE="" PYTHON_SINGLE_TARGET="-python2_7 -python3_4 -python3_5" PYTHON_TARGETS="python2_7 -python3_4 -python3_5"
    
      The following REQUIRED_USE flag constraints are unsatisfied:
        exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 )
    
      The above constraints are a subset of the following complete expression:
        exactly-one-of ( python_single_target_python2_7 python_single_target_python3_4 python_single_target_python3_5 ) python_single_target_python2_7? ( python_targets_python2_7 ) python_single_target_python3_4? ( python_targets_python3_4 ) python_single_target_python3_5? ( python_targets_python3_5 )
    
    (dependency required by "@selected" [set])
    (dependency required by "@world" [argument])

    Should I add python_single_target2_7 or 3_4 ?  I don't think 3.5 is installed on my system.  Let me check...

    # equery l -po python
     * Searching for python ...
    [I-O] [  ] dev-lang/python-2.7.15:2.7
    [I-O] [  ] dev-lang/python-3.4.8-r1:3.4/3.4m
    [--O] [  ] dev-lang/python-3.5.5-r1:3.5/3.5m
    [I-O] [  ] dev-lang/python-3.6.6:3.6/3.6m
    [--O] [M ] dev-lang/python-3.7.0:3.7/3.7m

    Nope, it's not.

    On another note, what should my eselect python list show.  I modified it but don't know if it's right.

     eselect python list
    Available Python interpreters, in order of preference:
      [1]   python3.6
      [2]   python3.4 (fallback)
      [3]   python2.7 (fallback)

    Is that right, or should I modify it?

    Thanks in advance.

  16. Anything that helps automatically solves conflicts I support 100%.  Ever time I see them I just glaze over and don't know where to start.  Making the wrong choice can make things even worse.

    Thanks for helping me out.  I don't think I would have made it without.  But as usual with funtoo and gentoo, I learned a great deal.

  17. I think it took me some practice to understand your tip about the "installed" packages.  Running `emerge system -uDNav --ignore-world` would almost work.  There were two "installed" files -- qtcore-4.8.7-r4 and qtgui-4.8.7.  I update those to current versions using `emerge qtcore qtgui  --ignore-world -av` and then ran `emerge system -uDNav --ignore-world again and it still failed.  I used quickpkg to back all the qtcore and qtqui versions up, then removed the old 4.8.7 versions.   Ran the `emerge system -uDNav --ignore-world` command again and the output changed, wanting to add

    # required by net-print/cups-filters-1.21.3::net-kit
    # required by @__auto_slot_operator_replace_installed__ (argument)
    =app-text/poppler-0.68.0 **

    into my package.keywords file.  After that, ran the `emerge system -uDNav --ignore-world` command and voila,

    # emerge system -uDNav --ignore-world
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild     U  ] dev-lang/python-exec-2.4.6:2::python-kit [2.4.5:2::python-kit] PYTHON_TARGETS="(jython2_7) (pypy) (pypy3) (python2_7) (python3_4) (python3_5) (python3_6) -python3_7" 86 KiB
    [ebuild   R    ] virtual/libintl-0-r2::core-kit [0-r2::gentoo] ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild   R    ] app-arch/bzip2-1.0.6-r9::core-kit  USE="-static -static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild   R    ] virtual/libiconv-0-r2::core-kit [0-r2::gentoo] ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] sys-devel/gnuconfig-20180101::core-kit [20170101::gentoo] 51 KiB
    [ebuild     U  ] sys-devel/automake-wrapper-11::core-kit [10::gentoo] 0 KiB
    [ebuild     U  ] sys-devel/autoconf-wrapper-13-r1::core-kit [13::gentoo] 0 KiB
    [ebuild     U  ] sys-apps/debianutils-4.8.6::core-kit [4.8.4::core-kit] USE="installkernel -static" 153 KiB
    [ebuild  N     ] dev-lang/mujs-1.0.5::lang-kit  USE="-static-libs" 117 KiB
    [ebuild     U  ] dev-libs/libpthread-stubs-0.4-r1::xorg-kit [0.4::xorg-kit] USE="(-static-libs%)" 0 KiB
    [ebuild   R    ] dev-libs/lzo-2.10:2::dev-kit [2.10:2::gentoo] USE="-examples -static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] sys-devel/llvm-common-7.0.0::llvm-kit [6.0.0::llvm-kit] 27,661 KiB
    [ebuild  N     ] sys-apps/miscfiles-1.5-r3::nokit  USE="-minimal" 1,703 KiB
    [ebuild  N     ] app-shells/gentoo-bashcomp-20180302::nokit  21 KiB
    [ebuild     U  ] dev-util/pkgconf-1.5.1:0/3::core-kit [1.3.90:0/0::core-kit] USE="(pkg-config) {-test}" 283 KiB
    [ebuild     U  ] sys-apps/opentmpfiles-0.2::core-kit [0.1.3::nokit] USE="(-selinux)" 6 KiB
    [ebuild     U  ] x11-misc/util-macros-1.19.2-r1::xorg-kit [1.19.1::xorg-kit] 83 KiB
    [ebuild     U  ] dev-util/gperf-3.1::core-kit [3.0.4::core-kit] 1,188 KiB
    [ebuild     U  ] dev-util/re2c-1.1.1::core-kit [1.0.3::core-kit] 5,769 KiB
    [ebuild     U  ] sys-devel/autoconf-archive-2018.03.13::core-kit [2017.09.28::core-kit] 635 KiB
    [ebuild   R    ] virtual/pkgconfig-0-r1::core-kit [0-r1::gentoo] ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] sys-libs/timezone-data-2018g::core-hw-kit [2017c::core-kit] USE="nls -leaps_timezone" 594 KiB
    [ebuild     U  ] sys-devel/gcc-config-2.0::core-kit [1.9.1::core-kit] 15 KiB
    [ebuild     U  ] sys-libs/e2fsprogs-libs-1.44.4::core-kit [1.43.8::core-kit] USE="-static-libs (-nls%*)" 5,238 KiB
    [ebuild     U  ] dev-libs/fribidi-1.0.5::dev-kit [0.19.7::gentoo] USE="-static-libs" 2,034 KiB
    [ebuild     U  ] virtual/os-headers-0-r1::core-kit [0::gentoo] 0 KiB
    [ebuild     U  ] dev-libs/libbsd-0.9.1::core-kit [0.8.6::core-kit] USE="-static-libs" 379 KiB
    [ebuild     U  ] dev-libs/libksba-1.3.5-r2::core-kit [1.3.5-r1::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] app-arch/xz-utils-5.2.4-r2::core-kit [5.2.3::core-kit] USE="extra-filters nls threads -static-libs" 1,536 KiB
    [ebuild     U  ] dev-libs/libunistring-0.9.10:0/2::core-kit [0.9.8:0/2::dev-kit] USE="-doc -static-libs" 3,658 KiB
    [ebuild     U  ] dev-libs/libassuan-2.5.1-r1::core-kit [2.5.1::core-kit] USE="-static-libs" 0 KiB
    [ebuild     U  ] media-libs/giflib-5.1.4-r2:0/7::media-kit [5.1.4:0/7::gentoo] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] dev-libs/npth-1.6-r1::core-kit [1.5::core-kit] USE="-static-libs" 294 KiB
    [ebuild     U  ] net-firewall/iptables-1.8.1-r1:0/12::core-kit [1.4.21-r4:0/10::gentoo] USE="ipv6 -conntrack -netlink -nftables% -pcap -static-libs" 663 KiB
    [ebuild     U  ] dev-libs/gmp-6.1.2-r1:0/10.4::core-kit [6.1.2:0/10.4::core-kit] USE="asm cxx -doc -static-libs*" 0 KiB
    [ebuild     U  ] app-portage/portage-utils-0.73::core-kit [0.65::core-kit] USE="nls -static" 1,549 KiB
    [ebuild     U  ] dev-libs/vala-common-0.42.3::gnome-kit [0.32.1::gentoo] 3,261 KiB
    [ebuild   R    ] dev-libs/mpfr-4.0.1:0/6::core-kit  USE="-static-libs*" 0 KiB
    [ebuild     U  ] dev-libs/mpc-1.1.0-r1:0/3::core-kit [1.1.0:0/3.1::core-kit] USE="-static-libs*" 0 KiB
    [ebuild     U  ] dev-libs/gobject-introspection-common-1.58.1::gnome-kit [1.48.0::gentoo] 1,346 KiB
    [ebuild   R    ] virtual/jpeg-0-r2::media-kit [0-r2::gentoo] USE="-static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] net-mail/mailbase-1.5::core-kit [1.1::gentoo] USE="pam" 0 KiB
    [ebuild     U  ] virtual/perl-Carp-1.420.0::perl-kit [1.400.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Exporter-5.720.0-r3::perl-kit [5.720.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Encode-2.880.0::perl-kit [2.800.0-r2::gentoo] 0 KiB
    [ebuild   R    ] virtual/libudev-232:0/1::core-kit [232:0/1::gentoo] USE="static-libs -systemd" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] dev-libs/libusb-1.0.22:1::core-kit [1.0.21:1::gentoo] USE="udev -debug -doc -examples -static-libs {-test}" 585 KiB
    [ebuild     U  ] sys-apps/hwids-20180917::core-kit [20171003::core-kit] USE="net pci udev usb" 3,137 KiB
    [ebuild     U  ] virtual/dev-manager-0-r2::core-kit [0::gentoo] 0 KiB
    [ebuild     U  ] net-misc/dhcpcd-7.0.8::core-hw-kit [7.0.0::core-kit] USE="embedded ipv6 udev" 206 KiB
    [ebuild  N     ] app-shells/bash-completion-2.8::nokit  USE="{-test}" 283 KiB
    [ebuild   R    ] net-misc/ifenslave-1.1.0-r6::core-kit [1.1.0-r6::gentoo] KERNEL="(linux%*)" 0 KiB
    [ebuild     U  ] virtual/perl-libnet-3.100.0::perl-kit [3.80.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-IO-1.380.0::perl-kit [1.360.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/opengl-7.0-r2::xorg-kit [7.0-r1::gentoo] 0 KiB
    [ebuild   R    ] media-libs/glu-9.0.0-r1::media-kit  USE="-static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] virtual/glu-9.0-r2::xorg-kit [9.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-MIME-Base64-3.150.0-r4::perl-kit [3.150.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Compress-Raw-Zlib-2.74.0::perl-kit [2.69.0-r1::gentoo] 0 KiB
    [ebuild     U  ] sys-apps/man-pages-4.16::core-kit [4.14::core-kit] USE="nls" L10N="-da -de -fr -it -ja -nl -pl -ru -zh-CN" 1,592 KiB
    [ebuild   R    ] virtual/python-ipaddress-1.0-r1::python-modules-kit  PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild     U  ] virtual/perl-Digest-MD5-2.550.0::perl-kit [2.540.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/ttf-fonts-1-r1::xorg-kit [1::xorg-kit] 0 KiB
    [ebuild     U  ] virtual/perl-XSLoader-0.270.0::perl-kit [0.210.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Time-Local-1.250.0-r1::perl-kit [1.230.0-r4::gentoo] 0 KiB
    [ebuild     U  ] sys-apps/corenetwork-1.6.5::core-kit [1.6.3::gentoo] 8 KiB
    [ebuild     U  ] app-admin/perl-cleaner-2.26-r1::perl-kit [2.23::gentoo] 8 KiB
    [ebuild     U  ] virtual/libelf-3:0/1::core-kit [1:0/1::nokit] 0 KiB
    [ebuild     U  ] virtual/perl-Digest-SHA-5.960.0::perl-kit [5.950.0-r4::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Compress-Raw-Bzip2-2.74.0-r1::perl-kit [2.69.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-IO-Compress-2.74.0-r1::perl-kit [2.69.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-IO-Socket-IP-0.380.0::perl-kit [0.370.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Storable-2.620.0::perl-kit [2.560.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-parent-0.236.0-r1::perl-kit [0.234.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Time-HiRes-1.974.100-r2::perl-kit [1.973.300-r1::gentoo] 0 KiB
    [ebuild     U  ] media-fonts/liberation-fonts-2.00.1-r3::xorg-kit [2.00.1-r2::gentoo] USE="X -fontforge" 0 KiB
    [ebuild     U  ] virtual/perl-Getopt-Long-2.490.0::perl-kit [2.480.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Parse-CPAN-Meta-2.150.10-r1::perl-kit [1.441.700-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-CPAN-Meta-YAML-0.18.0-r3::perl-kit [0.18.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-version-0.991.700::perl-kit [0.991.600-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-podlators-4.90.0::perl-kit [4.70.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Text-ParseWords-3.300.0-r4::perl-kit [3.300.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Perl-OSType-1.10.0-r1::perl-kit [1.9.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-Module-Metadata-1.0.33-r1::perl-kit [1.0.31-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-ExtUtils-ParseXS-3.340.0::perl-kit [3.310.0-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-ExtUtils-Manifest-1.700.0-r5::perl-kit [1.700.0-r3::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-ExtUtils-Install-2.40.0-r3::perl-kit [2.40.0-r2::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-ExtUtils-CBuilder-0.280.225-r2::perl-kit [0.280.225-r1::gentoo] 0 KiB
    [ebuild     U  ] virtual/perl-CPAN-Meta-2.150.10-r1::perl-kit [2.150.5-r1::gentoo] 0 KiB
    [ebuild  NS    ] sys-devel/automake-1.16.1-r1:1.16::core-kit [1.11.6-r2:1.11::core-kit, 1.13.4-r1:1.13::core-kit, 1.15.1-r1:1.15::core-kit] USE="{-test}" 1,499 KiB
    [ebuild     U  ] sys-devel/libtool-2.4.6-r5:2::core-kit [2.4.6-r4:2::core-kit] USE="-vanilla" 0 KiB
    [ebuild     U  ] sys-libs/zlib-1.2.11-r3::core-kit [1.2.11-r2::core-kit] USE="minizip static-libs" 0 KiB
    [ebuild     U  ] dev-libs/expat-2.2.6::core-kit [2.2.5::core-kit] USE="unicode -examples -static-libs" 502 KiB
    [ebuild     U  ] dev-libs/icu-63.1-r1:0/63.1::core-kit [60.2:0/60.2::core-kit] USE="-debug -doc -examples -static-libs" 23,191 KiB
    [ebuild   R    ] dev-libs/nettle-3.4:0/6.2::security-kit  USE="gmp -doc (-neon) -static-libs {-test}" ABI_X86="(64) (-32*) (-x32)" CPU_FLAGS_X86="aes" 0 KiB
    [ebuild   R    ] x11-libs/pixman-0.34.0::xorg-kit [0.34.0::gentoo] USE="(-altivec) (-iwmmxt) (-loongson2f) (-neon) -static-libs" ABI_X86="(64) (-32*) (-x32)" CPU_FLAGS_X86="mmxext sse2 ssse3" 0 KiB
    [ebuild     U  ] dev-libs/nspr-4.20::dev-kit [4.19::dev-kit] USE="-debug" 1,115 KiB
    [ebuild     U  ] net-libs/libtirpc-1.1.4:0/3::core-kit [1.0.3:0/3::net-kit] USE="ipv6 -kerberos -static-libs" 499 KiB
    [ebuild   R    ] sys-libs/gpm-1.20.7-r4::core-kit  USE="(-selinux) -static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] dev-libs/jemalloc-5.1.0:0/2::dev-kit [5.0.1:0/2::dev-kit] USE="-debug -hardened -lazy-lock -static-libs -stats -xmalloc (-hugepages%*)" 504 KiB
    [ebuild     U  ] net-libs/rpcsvc-proto-1.4::core-kit [1.3::core-kit] 58 KiB
    [ebuild   R    ] net-misc/bridge-utils-1.6::core-kit  USE="(-selinux)" KERNEL="(linux%*)" 0 KiB
    [ebuild     U  ] dev-libs/libuv-1.23.2:0/1::core-kit [1.18.0:0/1::core-kit] USE="-static-libs" 1,165 KiB
    [ebuild     U  ] media-libs/libpng-1.6.35-r1:0/16::media-kit [1.6.34:0/16::media-kit] USE="apng (-neon) -static-libs" CPU_FLAGS_X86="sse" 1,001 KiB
    [ebuild     U  ] net-misc/curl-7.62.0::core-kit [7.61.0::core-kit] USE="ipv6 ssl -adns -brotli -http2 -idn -kerberos -ldap -metalink -rtmp -samba -ssh -static-libs {-test} -threads" CURL_SSL="openssl -axtls -gnutls -libressl -mbedtls -nss (-winssl)" 2,945 KiB
    [ebuild     U  ] app-text/qpdf-8.2.1:0/21::text-kit [8.1.0:0/21::text-kit] USE="-doc -examples -perl -static-libs {-test}" 8,063 KiB
    [ebuild     U  ] x11-libs/libpciaccess-0.14::xorg-kit [0.13.5::xorg-kit] USE="zlib -static-libs" 353 KiB
    [ebuild     U  ] media-libs/freetype-2.9.1-r4:2::xorg-kit [2.8:2::xorg-kit] USE="X adobe-cff bzip2 cleartype_hinting png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" 1,882 KiB
    [ebuild     U  ] sys-libs/ncurses-6.1-r3:0/6::core-kit [6.0-r3:0/6::core-kit] USE="cxx gpm unicode -ada -debug -doc -minimal -profile -static-libs {-test} -threads -tinfo -trace" 3,287 KiB
    [uninstall     ] sys-libs/slang-2.3.1a::core-kit  USE="pcre png readline zlib -cjk -static-libs" 
    [blocks b      ] <sys-libs/slang-2.3.2_pre23 ("<sys-libs/slang-2.3.2_pre23" is blocking sys-libs/ncurses-6.1-r3)
    [ebuild     U  ] sys-libs/readline-7.0_p5:0/7::core-kit [7.0_p3:0/7::core-kit] USE="-static-libs -utils" 4 KiB
    [ebuild  r  U  ] sys-libs/gdbm-1.18.1:0/6::core-kit [1.14.1:0/5::core-kit] USE="berkdb nls readline -static-libs (-exporter%)" 920 KiB
    [ebuild     U  ] dev-db/sqlite-3.25.2:3::core-server-kit [3.21.0:3::core-kit] USE="icu readline -debug -doc -secure-delete -static-libs -tcl {-test} -tools" 2,700 KiB
    [ebuild     U  ] dev-libs/libpcre-8.42:3::core-kit [8.41-r1:3::core-kit] USE="bzip2 cxx jit pcre16 readline recursion-limit (unicode) zlib -libedit -pcre32 -static-libs" 1,534 KiB
    [ebuild     U  ] dev-libs/libpcre2-10.32::core-kit [10.30::dev-kit] USE="bzip2 jit pcre16 readline recursion-limit unicode zlib -libedit -pcre32 -static-libs" 1,604 KiB
    [ebuild     U  ] sys-devel/bc-1.07.1-r2::core-kit [1.07.1-r1::core-kit] USE="readline -forced-sandbox% -libedit -static" 0 KiB
    [ebuild  rR    ] dev-lang/perl-5.26.2-r1:0/5.26::perl-kit  USE="berkdb gdbm -debug -doc -ithreads" 0 KiB
    [ebuild  rR    ] dev-lang/python-3.6.6:3.6/3.6m::python-kit  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -bluetooth -build -examples -hardened -libressl {-test} -tk -wininst" 0 KiB
    [ebuild  rR    ] dev-lang/python-2.7.15:2.7::python-kit  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) (wide-unicode) xml (-berkdb) -bluetooth -build -doc -examples -hardened -libressl -tk -wininst" 0 KiB
    [ebuild  rR    ] dev-lang/python-3.4.8-r1:3.4/3.4m::python-kit  USE="gdbm ipv6 ncurses readline sqlite ssl (threads) xml -bluetooth -build -examples -hardened -libressl -tk -wininst" 0 KiB
    [ebuild     U  ] sys-apps/less-542::core-kit [529::core-kit] USE="pcre unicode" 336 KiB
    [ebuild  rR    ] dev-perl/HTTP-Date-6.20.0-r1::perl-kit [6.20.0-r1::gentoo] 0 KiB
    [ebuild  rR    ] dev-perl/LWP-MediaTypes-6.20.0-r1::perl-kit [6.20.0-r1::gentoo] 0 KiB
    [ebuild  rR    ] dev-perl/XML-Parser-2.440.0::perl-kit [2.440.0::gentoo] 0 KiB
    [ebuild   R    ] dev-python/idna-2.7::python-modules-kit  PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild     U  ] sys-apps/file-5.35::core-kit [5.32-r1::core-kit] USE="python zlib -static-libs" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5 -python3_7%" 846 KiB
    [ebuild  rR    ] dev-perl/Encode-Locale-1.50.0::perl-kit [1.50.0::gentoo] USE="{-test}" 0 KiB
    [ebuild   R    ] sys-libs/cracklib-2.9.6-r1::core-kit  USE="nls python zlib -static-libs" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
    [ebuild   R    ] dev-python/six-1.11.0::python-modules-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild  rR    ] dev-perl/IO-HTML-1.1.0::perl-kit [1.1.0::gentoo] USE="{-test}" 0 KiB
    [ebuild  rR    ] dev-perl/HTML-Tagset-3.200.0-r1::perl-kit [3.200.0-r1::gentoo] 0 KiB
    [ebuild  rR    ] mail-mta/postfix-3.2.4::core-kit  USE="berkdb cdb eai pam sasl ssl -doc -dovecot-sasl -hardened -ldap -ldap-bind -libressl -lmdb -mbox -memcached -mysql -nis -postgres (-selinux) -sqlite" 0 KiB
    [ebuild  rR    ] dev-perl/Digest-HMAC-1.30.0-r1::perl-kit [1.30.0-r1::gentoo] 0 KiB
    [ebuild  rR    ] dev-perl/TimeDate-2.300.0::perl-kit [2.300.0::gentoo] 0 KiB
    [ebuild  N     ] dev-perl/Text-Iconv-1.700.0-r2::perl-kit  11 KiB
    [ebuild     U  ] dev-perl/Net-SSLeay-1.820.0::perl-kit [1.800.0::gentoo] USE="-examples -libressl -minimal {-test}" 390 KiB
    [ebuild     U  ] dev-perl/Socket6-0.280.0::perl-kit [0.270.0::gentoo] 65 KiB
    [ebuild  NS    ] dev-lang/spidermonkey-52.9.1_pre1:52::net-kit [1.8.5-r6:0/mozjs185::lang-kit, 24.2.0-r5:24::lang-kit] USE="system-icu -custom-cflags -custom-optimization -debug -minimal {-test}" 29,477 KiB
    [ebuild     U  ] sys-libs/libcap-ng-0.7.9::core-kit [0.7.8::core-kit] USE="python -static-libs" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 439 KiB
    [ebuild   R    ] dev-python/pyelftools-0.24::python-modules-kit [0.24::nokit] USE="-examples" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
    [ebuild     U  ] dev-python/mwparserfromhell-0.5.2::python-modules-kit [0.5::python-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 147 KiB
    [ebuild   R    ] dev-python/chardet-3.0.4::python-modules-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/asn1crypto-0.24.0::python-modules-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/PySocks-1.6.8::python-modules-kit  USE="{-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild     U  ] dev-python/ipaddress-1.0.22::python-modules-kit [1.0.19::nokit] PYTHON_TARGETS="python2_7 python3_6%* -pypy -pypy3% -python3_4% -python3_5% -python3_7%" 33 KiB
    [ebuild  N     ] dev-perl/Sub-Name-0.210.0::perl-kit  USE="-suggested {-test}" 80 KiB
    [ebuild     U  ] sys-apps/usbutils-010-r1::core-kit [009::core-kit] USE="python" PYTHON_SINGLE_TARGET="python3_6%* -python3_4% -python3_5% -python3_7%" PYTHON_TARGETS="python3_6%* -python3_4% -python3_5% -python3_7% (-python2_7%*)" 302 KiB
    [ebuild     U  ] dev-util/ninja-1.8.2-r2::core-kit [1.8.2::core-kit] USE="-doc -emacs {-test} -vim-syntax -zsh-completion" 200 KiB
    [ebuild     U  ] dev-perl/Module-Build-0.422.400::perl-kit [0.421.800::gentoo] USE="{-test}" 298 KiB
    [ebuild     U  ] sys-apps/help2man-1.47.8::core-kit [1.47.5::core-kit] USE="nls" 196 KiB
    [ebuild  rR    ] dev-perl/Text-CharWidth-0.40.0-r1::perl-kit [0.40.0-r1::gentoo] 0 KiB
    [ebuild  N     ] dev-python/markupsafe-1.0::python-modules-kit  PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 15 KiB
    [ebuild     U  ] dev-perl/TermReadKey-2.370.0::perl-kit [2.330.0::gentoo] USE="-examples%" 84 KiB
    [ebuild     U  ] dev-python/cython-0.29::python-modules-kit [0.28.4::python-modules-kit] USE="-doc -emacs {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7" 1,990 KiB
    [ebuild   R    ] dev-python/ply-3.11:0/3.11::python-modules-kit  USE="-examples" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild     U  ] dev-lang/nasm-2.13.03-r1::lang-kit [2.13.01::gentoo] USE="-doc" 788 KiB
    [ebuild     U  ] virtual/perl-JSON-PP-2.274.0.200_rc::perl-kit [2.273.0-r4::gentoo] 0 KiB
    [ebuild     U  ] sys-devel/automake-1.15.1-r2:1.15::core-kit [1.15.1-r1:1.15::core-kit] USE="{-test%}" 0 KiB
    [ebuild     U  ] app-misc/pax-utils-1.2.3-r2::core-kit [1.2.2-r2::core-kit] USE="python -caps -debug -seccomp" PYTHON_SINGLE_TARGET="python3_6%* -python2_7% -python3_4% -python3_5%" PYTHON_TARGETS="python2_7%* python3_6%* -python3_4% -python3_5%" 647 KiB
    [ebuild  rR    ] dev-perl/HTML-Parser-3.720.0::perl-kit [3.720.0::gentoo] USE="{-test}" 0 KiB
    [ebuild   R    ] sys-apps/kmod-25::core-kit  USE="python tools zlib -debug -doc -lzma -static-libs" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 0 KiB
    [ebuild  rR    ] dev-perl/Authen-SASL-2.160.0-r1::perl-kit [2.160.0-r1::gentoo] USE="-kerberos" 0 KiB
    [ebuild  rR    ] dev-perl/File-Listing-6.40.0-r1::perl-kit [6.40.0-r1::gentoo] 0 KiB
    [ebuild  rR    ] dev-perl/Tie-IxHash-1.230.0::perl-kit [1.230.0::gentoo] USE="{-test}" 0 KiB
    [ebuild     U  ] net-dns/libidn2-2.0.5::core-kit [2.0.4::core-kit] USE="-static-libs" 2,043 KiB
    [ebuild  N     ] dev-perl/XML-XPath-1.420.0::perl-kit  USE="-examples {-test}" 55 KiB
    [ebuild     U  ] dev-perl/Try-Tiny-0.300.0::perl-kit [0.240.0::perl-kit] USE="-minimal {-test}" 34 KiB
    [ebuild     U  ] dev-perl/IO-Socket-INET6-2.720.0-r1::perl-kit [2.720.0::gentoo] 0 KiB
    [ebuild     U  ] x11-libs/libdrm-2.4.94::xorg-kit [2.4.83::xorg-kit] USE="libkms -valgrind (-static-libs%)" VIDEO_CARDS="intel -amdgpu (-exynos) (-freedreno) -nouveau (-omap) -radeon (-tegra) (-vc4) (-vivante) -vmware" 810 KiB
    [ebuild     U  ] dev-perl/MailTools-2.190.0::perl-kit [2.140.0::gentoo] USE="-examples% {-test}" 55 KiB
    [ebuild  rR    ] dev-perl/Text-WrapI18N-0.60.0-r1::perl-kit [0.60.0-r1::gentoo] 0 KiB
    [ebuild  N     ] dev-python/mako-1.0.7::python-modules-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 552 KiB
    [ebuild     U  ] dev-perl/SGMLSpm-1.1-r1::perl-kit [1.03-r7::gentoo] 112 KiB
    [ebuild   R    ] dev-python/pycparser-2.17::python-modules-kit [2.17::gentoo] USE="{-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7%" 0 KiB
    [ebuild     U  ] sys-apps/sandbox-2.13::core-kit [2.12::core-kit] 416 KiB
    [ebuild     U  ] sys-apps/pciutils-3.6.2::core-kit [3.5.6::core-kit] USE="kmod udev zlib -dns -static-libs" 463 KiB
    [ebuild   R    ] dev-python/cffi-1.11.5:0/1.11.5::python-modules-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/cryptography-2.3::core-kit [2.3::python-modules-kit] USE="-libressl {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/pyopenssl-17.5.0::python-modules-kit  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/urllib3-1.23::python-modules-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/requests-2.19.1-r1::python-modules-kit  USE="ssl -socks5" PYTHON_TARGETS="python2_7 python3_6* -pypy -pypy3 -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild   R    ] dev-python/appi-0.2.1:0/0.2::core-kit [0.2.1:0/0.2::python-kit] PYTHON_TARGETS="python3_6* -python3_4* -python3_5 -python3_7%" 0 KiB
    [ebuild     U  ] dev-util/gdbus-codegen-2.58.1::gnome-kit [2.48.2::gnome-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,792 KiB
    [ebuild     U  ] dev-libs/glib-2.58.1:2::gnome-kit [2.48.2:2::gentoo] USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap {-test} -utils (-debug%)" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [ebuild  N     ] dev-util/glib-utils-2.58.1::gnome-kit  0 KiB
    [ebuild     U  ] dev-util/gtk-doc-am-1.29::gnome-kit [1.25-r1::gentoo] PYTHON_SINGLE_TARGET="python3_6%* -python3_7%" PYTHON_TARGETS="python3_6%* -python3_7%" 716 KiB
    [ebuild   R    ] dev-libs/libxml2-2.9.8:2::core-kit  USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5" 0 KiB
    [ebuild     U  ] sys-devel/gettext-0.19.8.1-r1::core-kit [0.19.8.1::core-kit] USE="acl cxx ncurses nls openmp static-libs -cvs -doc -emacs -git -java" 0 KiB
    [ebuild     UD ] dev-util/itstool-2.0.2::core-kit [2.0.4::core-kit] PYTHON_SINGLE_TARGET="(-python3_4%*) (-python3_5%) (-python3_6%)" PYTHON_TARGETS="python2_7%* (-python3_4%*) (-python3_5%) (-python3_6%)" 95 KiB
    [ebuild     U  ] sys-apps/sed-4.5::core-kit [4.4::gentoo] USE="acl nls -forced-sandbox% (-selinux) -static" 1,245 KiB
    [ebuild     U  ] x11-misc/shared-mime-info-1.10::desktop-kit [1.9::desktop-kit] USE="{-test}" 603 KiB
    [ebuild     U  ] sys-apps/attr-2.4.48-r3::core-kit [2.4.47-r2::gentoo] USE="nls -debug% -static-libs" 457 KiB
    [ebuild     U  ] sys-devel/make-4.2.1-r4::core-kit [4.2.1-r1::core-kit] USE="nls -guile -static" 0 KiB
    [ebuild     U  ] sys-devel/bison-3.2.1::core-kit [3.0.4-r1::gentoo] USE="nls -examples -static {-test}" 2,051 KiB
    [ebuild  NS    ] sys-devel/binutils-2.31.1-r1:2.31::core-kit [2.29.1-r1:2.29.1::core-kit] USE="cxx nls -doc -multitarget -static-libs {-test}" 20,001 KiB
    [ebuild     U  ] sys-apps/gawk-4.2.1-r1::core-kit [4.2.0::core-kit] USE="nls readline -forced-sandbox% -mpfr" 2,916 KiB
    [ebuild     U  ] net-libs/gnutls-3.5.19-r1:0/30::core-kit [3.5.16:0/30::core-kit] USE="cxx idn nls openssl tls-heartbeat zlib -dane -doc -examples -guile -openpgp -pkcs11 -seccomp -sslv2 -sslv3 -static-libs {-test} -test-full -tools -valgrind" 7,071 KiB
    [ebuild     U  ] app-editors/nano-3.2::core-kit [2.9.2::core-kit] USE="magic ncurses nls spell unicode -debug -justify -minimal -slang -static" 2,876 KiB
    [ebuild     U  ] sys-apps/diffutils-3.6-r1::core-kit [3.6::core-kit] USE="nls -static" 0 KiB
    [ebuild     U  ] sys-process/psmisc-23.2-r1::core-kit [23.1::core-kit] USE="X ipv6 nls (-selinux)" 297 KiB
    [ebuild     U  ] sys-libs/binutils-libs-2.31.1-r1:0/2.31.1-r1::core-kit [2.29.1-r1:0/2.29.1::core-kit] USE="nls -64-bit-bfd -multitarget -static-libs" 0 KiB
    [ebuild     U  ] dev-libs/elfutils-0.173::core-kit [0.170-r1::core-kit] USE="bzip2 nls utils -lzma -static-libs {-test} (-threads)" 8,482 KiB
    [ebuild  rR    ] net-misc/wget-1.19.5::core-kit  USE="ipv6 nls pcre ssl zlib -debug -gnutls -idn -libressl -ntlm -static {-test} -uuid" 0 KiB
    [ebuild  rR    ] www-client/lynx-2.8.9_pre16::net-kit [2.8.9_pre16::gentoo] USE="bzip2 ipv6 nls ssl unicode -cjk -gnutls -idn -libressl" 0 KiB
    [ebuild  rR    ] app-crypt/rhash-1.3.6-r1::nokit  USE="nls ssl -debug -libressl -static-libs" 0 KiB
    [ebuild   R    ] app-text/opensp-1.5.2-r6::core-kit  USE="nls -doc -static-libs {-test}" ELIBC="(glibc%*)" 0 KiB
    [ebuild     U  ] dev-libs/gobject-introspection-1.58.1::gnome-kit [1.48.0::gentoo] USE="-cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python3_6%* -python2_7% -python3_4% -python3_5% -python3_7%" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [blocks b      ] <dev-libs/gobject-introspection-1.58.1 ("<dev-libs/gobject-introspection-1.58.1" is blocking dev-libs/gobject-introspection-common-1.58.1)
    [ebuild     U  ] sys-apps/acl-2.2.53::core-kit [2.2.52-r1::gentoo] USE="nls -static-libs" 513 KiB
    [ebuild     U  ] sys-libs/libcap-2.25-r1::core-kit [2.25::gentoo] USE="pam -static-libs" 0 KiB
    [ebuild     U  ] sys-devel/patch-2.7.6-r2::core-kit [2.7.5::gentoo] USE="xattr -static {-test}" 766 KiB
    [ebuild   R    ] dev-python/pyxattr-0.6.1::python-modules-kit  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5 -python3_7" 0 KiB
    [ebuild     U  ] virtual/editor-0-r2::editors-kit [0-r1::editors-kit] 0 KiB
    [ebuild  rR    ] sys-apps/iproute2-4.14.1-r3::core-kit  USE="berkdb iptables ipv6 -atm -minimal (-selinux)" 0 KiB
    [ebuild     U  ] gnome-extra/yelp-xsl-3.30.1::gnome-kit [3.20.1::gentoo] 507 KiB
    [ebuild     U  ] app-text/openjade-1.3.2-r8::core-kit [1.3.2-r7::core-kit] USE="-static-libs" 0 KiB
    [ebuild     U  ] sys-apps/coreutils-8.30::core-kit [8.29::core-kit] USE="acl nls split-usr%* xattr -caps -gmp -hostname -kill -multicall (-selinux) -static {-test} -vanilla" 5,240 KiB
    [ebuild     U  ] dev-libs/atk-2.30.0::gnome-kit [2.20.0::gentoo] USE="introspection nls -doc% (-test%)" 0 KiB
    [ebuild     U  ] gnome-base/gsettings-desktop-schemas-3.28.1::gnome-kit [3.20.0::gentoo] USE="introspection" 638 KiB
    [ebuild     U  ] net-misc/iputils-20171016_pre-r1::core-kit [20121221-r2::gentoo] USE="arping%* filecaps%* ipv6 ssl -SECURITY_HAZARD -caps -clockdiff% -doc -gcrypt% -idn -libressl% -nettle% -rarpd% -rdisc% -static -tftpd% -tracepath% -traceroute% (-gnutls%)" 220 KiB
    [ebuild  rR    ] app-text/po4a-0.47-r2::core-kit  USE="{-test}" 0 KiB
    [ebuild     U  ] app-text/yelp-tools-3.28.0::gnome-kit [3.18.0::gentoo] 206 KiB
    [ebuild     U  ] app-admin/eselect-1.4.13::core-kit [1.4.10::core-kit] USE="-doc -emacs -vim-syntax" 174 KiB
    [ebuild     U  ] x11-themes/gnome-themes-standard-3.22.3::gnome-kit [3.20.2::gentoo] USE="(-gtk%*)" 2,837 KiB
    [ebuild     U  ] sys-apps/man-db-2.8.4::core-kit [2.7.6.1-r2::core-kit] USE="berkdb gdbm manpager nls zlib -seccomp% (-selinux) -static-libs" 1,738 KiB
    [ebuild     U  ] dev-util/gtk-doc-1.29::gnome-kit [1.25-r1::gnome-kit] USE="-debug -doc -emacs -highlight -vim" PYTHON_SINGLE_TARGET="python3_6%* -python3_7%" PYTHON_TARGETS="python3_6%* -python3_7% (-python2_7%*)" 0 KiB
    [blocks b      ] <dev-util/gtk-doc-1.29 ("<dev-util/gtk-doc-1.29" is blocking dev-util/gtk-doc-am-1.29)
    [ebuild     U  ] sys-apps/portage-2.3.47::core-kit [2.3.41::core-kit] USE="(ipc) native-extensions xattr -build -doc -epydoc -linguas_ru (-selinux)" PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5 -python3_7%" 1,346 KiB
    [ebuild     U  ] dev-libs/libcroco-0.6.12-r1:0.6::gnome-kit [0.6.11-r1:0.6::gnome-kit] USE="{-test}" 471 KiB
    [ebuild     U  ] app-crypt/p11-kit-0.23.9::gnome-kit [0.23.2::gnome-kit] USE="asn1 libffi trust -debug" 1,066 KiB
    [ebuild     U  ] app-portage/gentoolkit-0.4.2-r1::core-kit [0.4.1::core-kit] PYTHON_TARGETS="python2_7 python3_6* -pypy -python3_4* -python3_5 -python3_7%" 3,141 KiB
    [ebuild     U  ] virtual/package-manager-1::core-kit [0::gentoo] 0 KiB
    [ebuild     U  ] sys-libs/pam-1.3.0-r3::core-kit [1.3.0-r2::core-kit] USE="berkdb cracklib filecaps nls pie -audit -debug -nis (-selinux) {-test} -vim-syntax" 0 KiB
    [ebuild     U  ] sys-apps/util-linux-2.33::core-kit [2.31.1-r1::core-kit] USE="cramfs ncurses nls pam python readline static-libs suid unicode -build -caps -fdformat -kill (-selinux) -slang -systemd {-test} -tty-helpers (-udev)" PYTHON_SINGLE_TARGET="(-python2_7%) (-python3_4%*) (-python3_5%) (-python3_6%)" PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,554 KiB
    [ebuild     U  ] media-libs/fontconfig-2.13.0-r4:1.0::xorg-kit [2.11.1-r2:1.0::gentoo] USE="-doc -static-libs" 1,661 KiB
    [ebuild     U  ] sys-fs/eudev-3.2.7::core-kit [3.2.5::core-kit] USE="hwdb introspection kmod rule-generator static-libs (-selinux) {-test}" 1,849 KiB
    [ebuild     U  ] sys-fs/e2fsprogs-1.44.4::core-kit [1.43.8::core-kit] USE="nls -fuse -static-libs" 0 KiB
    [ebuild     U  ] sys-fs/xfsprogs-4.19.0::core-kit [4.14.0::core-kit] USE="icu%* nls readline -libedit -static-libs (-static%)" 1,185 KiB
    [ebuild     U  ] app-arch/libarchive-3.3.3:0/13::core-kit [3.3.2:0/13::core-kit] USE="acl bzip2 e2fsprogs iconv lzma threads xattr zlib -expat -libressl -lz4 -lzo -nettle -static-libs" 6,383 KiB
    [ebuild     U  ] dev-util/cmake-3.12.3::core-kit [3.10.1::core-kit] USE="ncurses -doc -emacs -qt5 -system-jsoncpp {-test} (-server%)" 8,192 KiB
    [ebuild     U  ] media-gfx/graphite2-1.3.12-r1::media-kit [1.3.10::media-kit] USE="-perl {-test}" 6,512 KiB
    [ebuild  NS    ] sys-devel/llvm-7.0.0-r1:7::llvm-kit [5.0.1:5::llvm-kit, 6.0.0:6::llvm-kit] USE="libffi ncurses xml -debug -doc -exegesis -gold -libedit {-test} -xar" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 119 KiB
    [ebuild     U  ] media-libs/libjpeg-turbo-2.0.1::media-kit [1.5.3::media-kit] USE="-java -static-libs" 2,109 KiB
    [ebuild     U  ] net-libs/libssh2-1.8.0-r2::net-kit [1.8.0-r1::net-kit] USE="zlib -gcrypt -libressl -mbedtls% (-static-libs%) (-test%)" 0 KiB
    [ebuild  N     ] sys-auth/elogind-239.1::nokit  USE="acl pam policykit -debug -doc (-selinux)" 1,098 KiB
    [ebuild     U  ] sys-process/procps-3.3.15-r1:0/6::core-kit [3.3.12-r2:0/5::core-kit] USE="elogind* kill ncurses nls unicode -modern-top (-selinux) -static-libs -systemd {-test}" 884 KiB
    [ebuild     U  ] dev-lang/rust-1.29.2:stable/1.29::net-kit [1.25.0:stable/1.25::lang-kit] USE="jemalloc -cargo% -clippy% -debug -doc -libressl% -rls% -rustfmt% -wasm% (-extended%)" CPU_FLAGS_X86="sse2%*" LLVM_TARGETS="(X86%*) -AArch64% -AMDGPU% -ARM% -BPF% -Hexagon% -Lanai% -MSP430% -Mips% -NVPTX% -PowerPC% -Sparc% -SystemZ% -XCore%" 191,416 KiB
    [ebuild     U  ] virtual/rust-1.29.2::net-kit [1.25.0::lang-kit] 0 KiB
    [ebuild     U  ] dev-util/cargo-0.30.0::net-kit [0.26.0::dev-kit] USE="-debug -doc -libressl" 22,612 KiB
    [ebuild  N     ] virtual/cargo-1.29.2::net-kit  0 KiB
    [ebuild     U  ] virtual/perl-Scalar-List-Utils-1.460.200_rc::perl-kit [1.460.0-r1::gentoo] 0 KiB
    [uninstall     ] perl-core/Scalar-List-Utils-1.460.0::gentoo  USE="{-test}" 
    [blocks b      ] <perl-core/Scalar-List-Utils-1.460.200_rc ("<perl-core/Scalar-List-Utils-1.460.200_rc" is blocking virtual/perl-Scalar-List-Utils-1.460.200_rc)
    [ebuild     U  ] dev-perl/URI-1.730.0::perl-kit [1.710.0::gentoo] USE="{-test}" 105 KiB
    [ebuild     U  ] dev-perl/IO-Socket-SSL-2.52.0::perl-kit [2.43.0::gentoo] USE="-examples -idn" 217 KiB
    [ebuild  rR    ] dev-perl/IPC-System-Simple-1.250.0::perl-kit [1.250.0::gentoo] USE="{-test}" 0 KiB
    [ebuild     U  ] dev-perl/Error-0.170.250::perl-kit [0.170.240::gentoo] USE="{-test}" 32 KiB
    [ebuild     U  ] dev-perl/HTTP-Message-6.130.0::perl-kit [6.110.0::gentoo] USE="{-test}" 73 KiB
    [ebuild  rR    ] dev-perl/File-BaseDir-0.70.0::perl-kit [0.70.0::gentoo] USE="{-test}" 0 KiB
    [ebuild     U  ] dev-perl/Net-HTTP-6.170.0::perl-kit [6.120.0::gentoo] USE="-minimal {-test}" 38 KiB
    [ebuild     U  ] dev-perl/WWW-RobotRules-6.20.0-r1::perl-kit [6.20.0::gentoo] 0 KiB
    [ebuild     U  ] dev-perl/Net-SMTP-SSL-1.40.0::perl-kit [1.30.0::gentoo] USE="{-test}" 3 KiB
    [ebuild     U  ] dev-perl/HTTP-Cookies-6.40.0::perl-kit [6.10.0::gentoo] USE="{-test%}" 39 KiB
    [ebuild     U  ] dev-perl/HTTP-Negotiate-6.10.0-r1::perl-kit [6.10.0::gentoo] 0 KiB
    [ebuild     U  ] dev-perl/HTTP-Daemon-6.10.0-r2::perl-kit [6.10.0-r1::gentoo] 0 KiB
    [ebuild     U  ] dev-perl/libwww-perl-6.270.0::perl-kit [6.150.0::gentoo] USE="ssl {-test%}" 160 KiB
    [ebuild  N     ] dev-perl/XML-Twig-3.520.0::perl-kit  USE="nls {-test}" 399 KiB
    [ebuild     U  ] dev-perl/LWP-Protocol-https-6.70.0::perl-kit [6.60.0::gentoo] USE="{-test%}" 9 KiB
    [ebuild  N     ] x11-base/xcb-proto-1.13::xorg-kit  PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 149 KiB
    [uninstall     ] x11-proto/xcb-proto-1.12-r2::xorg-kit  PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 
    [blocks b      ] x11-proto/xcb-proto ("x11-proto/xcb-proto" is blocking x11-base/xcb-proto-1.13)
    [ebuild  N     ] perl-core/File-Path-2.130.0::perl-kit  31 KiB
    [ebuild     U  ] virtual/perl-File-Path-2.130.0::perl-kit [2.120.100_rc-r1::gentoo] 0 KiB
    [blocks b      ] >perl-core/File-Path-2.120.100_rc-r999 (">perl-core/File-Path-2.120.100_rc-r999" is blocking virtual/perl-File-Path-2.120.100_rc-r1)
    [ebuild  rR    ] dev-perl/File-DesktopEntry-0.220.0::perl-kit [0.220.0::gentoo] USE="{-test}" 0 KiB
    [ebuild  rR    ] dev-perl/File-MimeInfo-0.280.0::perl-kit [0.280.0::gentoo] USE="{-test}" 0 KiB
    [ebuild   R    ] sys-auth/pambase-20150213-r3::core-kit  USE="cracklib elogind* gnome-keyring nullok sha512 -consolekit* -debug -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc -securetty (-selinux) -systemd" 0 KiB
    [ebuild     U  ] sys-auth/polkit-0.115-r1::gnome-kit [0.113-r3::gentoo] USE="elogind* gtk introspection nls pam -examples -jit -kde (-selinux) {-test}" 1,515 KiB
    [ebuild     U  ] sys-apps/openrc-0.35.5-r1::core-kit [0.35.5::core-kit] USE="bash-completion ncurses pam unicode -audit -debug -netifrc -newnet (-prefix) (-selinux) -static-libs -zsh-completion" 0 KiB
    [ebuild     U  ] sys-apps/shadow-4.6::core-kit [4.5-r1::core-kit] USE="acl cracklib nls pam xattr -audit (-selinux) -skey" 3,716 KiB
    [ebuild     U  ] net-misc/openssh-7.9_p1::core-kit [7.6_p1-r1::core-kit] USE="X pam pie ssl -X509 -audit -bindist -debug -hpn -kerberos -ldns -libedit -libressl -livecd -sctp (-selinux) -static {-test} (-ldap%) (-skey%)" 1,529 KiB
    [ebuild     U  ] app-crypt/gnupg-2.2.11::core-kit [2.2.4-r1::core-kit] USE="bzip2 nls readline smartcard ssl%* -doc -ldap (-selinux) -tofu -tools -usb -user-socket% -wks-server (-gnutls%*)" 6,497 KiB
    [ebuild     U  ] x11-libs/libX11-1.6.6::xorg-kit [1.6.5::xorg-kit] USE="ipv6 -doc -static-libs {-test}" 2,288 KiB
    [ebuild     U  ] x11-libs/libXext-1.3.3-r1::xorg-kit [1.3.3::gentoo] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] sys-apps/dbus-1.12.10::core-kit [1.12.2::core-kit] USE="X elogind* -debug -doc (-selinux) -static-libs -systemd {-test} -user-session" 2,025 KiB
    [ebuild  N     ] dev-perl/Net-DBus-1.1.0::perl-kit  USE="{-test}" 2,027 KiB
    [ebuild     U  ] x11-libs/cairo-1.16.0-r1::gnome-kit [1.14.8::gnome-kit] USE="X glib opengl svg (-aqua) -debug (-gles2) -static-libs -utils% -valgrind -xcb (-directfb%)" 41,014 KiB
    [ebuild     U  ] media-libs/harfbuzz-2.1.1:0/0.9.18::media-kit [1.7.5:0/0.9.18::media-kit] USE="cairo glib graphite icu introspection truetype -debug -fontconfig -static-libs {-test}" 4,284 KiB
    [ebuild     U  ] x11-libs/libXt-1.1.5-r1::xorg-kit [1.1.5::gentoo] USE="-static-libs {-test%}" 0 KiB
    [ebuild     U  ] x11-libs/libXrender-0.9.10-r1::xorg-kit [0.9.10::gentoo] USE="-static-libs" 0 KiB
    [ebuild  N     ] dev-perl/X11-Protocol-0.560.0-r2::perl-kit  USE="-examples {-test}" 99 KiB
    [ebuild     U  ] x11-misc/xdg-utils-1.1.2-r1::gnome-kit [1.1.1-r1::gnome-kit] USE="-doc (-perl%*)" 290 KiB
    [ebuild     U  ] net-print/cups-2.2.9::net-kit [2.2.8-r1::net-kit] USE="X acl dbus pam python ssl threads -debug -java -kerberos -lprng-compat (-selinux) -static-libs -systemd -usb -xinetd -zeroconf" PYTHON_TARGETS="python2_7" 10,160 KiB
    [ebuild     U  ] x11-libs/libXfixes-5.0.3-r1::xorg-kit [5.0.3::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXcursor-1.1.15::xorg-kit [1.1.14-r1::xorg-kit] USE="-static-libs" 324 KiB
    [ebuild     U  ] x11-libs/libXmu-1.1.2-r1::xorg-kit [1.1.2::gentoo] USE="ipv6 -doc -static-libs" 0 KiB
    [ebuild     U  ] x11-apps/xset-1.2.4::xorg-kit [1.2.3::xorg-kit] 143 KiB
    [ebuild     U  ] x11-libs/libXi-1.7.9-r1::xorg-kit [1.7.9::xorg-kit] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/pango-1.42.4::gnome-kit [1.40.3::gentoo] USE="X introspection {-test}" 815 KiB
    [ebuild     U  ] x11-libs/libXrandr-1.5.1-r1::xorg-kit [1.5.1::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXdamage-1.1.4-r2::xorg-kit [1.1.4-r1::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] gnome-base/librsvg-2.45.0:2::gnome-kit [2.40.16:2::gentoo] USE="introspection -tools (-vala%)" 12,587 KiB
    [ebuild     U  ] x11-themes/adwaita-icon-theme-3.30.1::gnome-kit [3.20::gentoo] USE="-branding" 19,465 KiB
    [ebuild   R    ] media-libs/freeglut-3.0.0::media-kit [3.0.0::gentoo] USE="-debug -static-libs" ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     U  ] media-libs/libwebp-1.0.0:0/7::media-kit [0.6.1:0/7::media-kit] USE="gif jpeg opengl png (-neon) -static-libs -swap-16bit-csp -tiff* (-experimental%)" CPU_FLAGS_X86="avx2 sse2 sse4_1" 3,930 KiB
    [ebuild     U  ] media-libs/jasper-2.0.14:0/4::media-kit [2.0.12:0/4::media-kit] USE="jpeg opengl -doc {-test%}" 1,282 KiB
    [ebuild     U  ] media-libs/tiff-4.0.10::media-kit [4.0.9::media-kit] USE="cxx jpeg webp%* zlib -jbig -lzma -static-libs {-test} -zstd%" 2,347 KiB
    [ebuild     U  ] x11-libs/gdk-pixbuf-2.38.0:2::gnome-kit [2.36.9:2::gnome-kit] USE="X introspection jpeg jpeg2k tiff -doc% {-test} (-debug%)" 5,107 KiB
    [ebuild     U  ] media-libs/openjpeg-2.3.0-r1:2/7::media-kit [2.3.0:2/7::media-kit] USE="-doc -static-libs {-test}" 0 KiB
    [ebuild     U  ] media-libs/gd-2.2.5-r1:2/3::media-kit [2.2.5:2/3::media-kit] USE="fontconfig* jpeg png tiff truetype webp zlib -static-libs -xpm" 0 KiB
    [ebuild     U *] app-text/poppler-0.68.0:0/79::gnome-kit [0.52.0-r2:0/66::gnome-kit] USE="cairo curl cxx introspection jpeg jpeg2k lcms png tiff utils -cjk -debug -doc -nss -qt5 (-qt4%*)" 1,427 KiB
    [ebuild     U  ] app-text/mupdf-1.14.0-r2:0/1.14.0::text-kit [1.12.0:0/1.12.0::text-kit] USE="X curl javascript* opengl openssl vanilla* -libressl -static-libs (-lcms%) (-static%)" 40,628 KiB
    [ebuild     U  ] dev-util/gtk-update-icon-cache-3.24.0::gnome-kit [3.20.9::gentoo] 364 KiB
    [ebuild     U  ] x11-libs/libSM-1.2.2-r2::xorg-kit [1.2.2-r1::gentoo] USE="ipv6 uuid -doc -static-libs" 0 KiB
    [ebuild     U  ] dev-vcs/git-2.19.1::core-kit [2.15.2::core-kit] USE="blksha1 curl gnome-keyring gpg iconv nls pcre pcre-jit perl python threads webdav -cgi -cvs -doc -emacs -highlight -libressl -mediawiki -mediawiki-experimental (-ppcsha1) -subversion {-test} -tk -xinetd" PYTHON_TARGETS="python2_7" 5,528 KiB
    [ebuild     U  ] x11-base/xorg-proto-2018.4_p20180627-r2::core-gl-kit [2018.4-r1::xorg-kit] 0 KiB
    [ebuild     UD ] x11-proto/glproto-1.4.17:0/stub::core-gl-kit [1.4.17-r1:0/0::gentoo] 0 KiB
    [ebuild  N     ] x11-proto/xproxymngproto-1.0.3:0/stub::core-gl-kit  0 KiB
    [ebuild  N     ] x11-proto/printproto-1.0.5:0/stub::core-gl-kit  0 KiB
    [ebuild  N     ] x11-proto/lg3dproto-5.0:0/stub::core-gl-kit  0 KiB
    [ebuild  N     ] x11-proto/xcalibrateproto-0.1.0:0/stub::core-gl-kit  0 KiB
    [ebuild     UD ] x11-proto/fixesproto-5.0:0/stub::core-gl-kit [5.0-r1:0/0::gentoo] 0 KiB
    [ebuild     U  ] x11-proto/dri3proto-1.2:0/stub::core-gl-kit [1.0:0/0::gentoo] 0 KiB
    [ebuild     UD ] x11-proto/compositeproto-0.4.2:0/stub::core-gl-kit [0.4.2-r1:0/0::gentoo] 0 KiB
    [ebuild  N     ] x11-proto/evieproto-1.1.1:0/stub::core-gl-kit  0 KiB
    [ebuild     UD ] x11-proto/renderproto-0.11.1:0/stub::core-gl-kit [0.11.1-r1:0/0::gentoo] 0 KiB
    [ebuild   R    ] x11-proto/inputproto-2.3.2:0/stub::core-gl-kit [2.3.2:0/0::gentoo] ABI_X86="(64) (-32*) (-x32)" 0 KiB
    [ebuild     UD ] x11-proto/xf86dgaproto-2.1:0/stub::core-gl-kit [2.1-r2:0/0::gentoo] 0 KiB
    [ebuild  N     ] x11-proto/fontcacheproto-0.1.3:0/stub::core-gl-kit  0 KiB
    [ebuild     U  ] x11-proto/xproto-7.0.32:0/stub::core-gl-kit [7.0.31:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild     UD ] x11-proto/recordproto-1.14.2:0/stub::core-gl-kit [1.14.2-r1:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild   R    ] x11-proto/trapproto-3.4.3:0/stub::core-gl-kit [3.4.3:0/0::gentoo] 0 KiB
    [ebuild     UD ] x11-proto/xf86bigfontproto-1.2.0:0/stub::core-gl-kit [1.2.0-r1:0/0::gentoo] 0 KiB
    [ebuild     U  ] x11-proto/randrproto-1.6.0:0/stub::core-gl-kit [1.5.0:0/0::gentoo] 0 KiB
    [ebuild     U  ] x11-proto/xf86rushproto-1.2.2:0/stub::core-gl-kit [1.1.2-r1:0/0::gentoo] 0 KiB
    [ebuild     UD ] x11-proto/xf86vidmodeproto-2.3.1:0/stub::core-gl-kit [2.3.1-r1:0/0::gentoo] 0 KiB
    [ebuild   R    ] x11-proto/xf86miscproto-0.9.3:0/stub::core-gl-kit [0.9.3:0/0::gentoo] 0 KiB
    [ebuild     UD ] x11-proto/xineramaproto-1.2.1:0/stub::core-gl-kit [1.2.1-r1:0/0::gentoo] 0 KiB
    [ebuild     UD ] x11-proto/damageproto-1.2.1:0/stub::core-gl-kit [1.2.1-r1:0/0::gentoo] 0 KiB
    [ebuild  N     ] x11-proto/dmxproto-2.3.1:0/stub::core-gl-kit  0 KiB
    [ebuild     UD ] x11-proto/dri2proto-2.8:0/stub::core-gl-kit [2.8-r1:0/0::gentoo] 0 KiB
    [ebuild   R    ] x11-proto/xextproto-7.3.0:0/stub::core-gl-kit [7.3.0:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild   R    ] x11-proto/xcmiscproto-1.2.2:0/stub::core-gl-kit [1.2.2:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild     U  ] x11-proto/presentproto-1.2:0/stub::core-gl-kit [1.1:0/0::xorg-kit] 0 KiB
    [ebuild   R    ] x11-proto/resourceproto-1.2.0:0/stub::core-gl-kit [1.2.0:0/0::gentoo] 0 KiB
    [ebuild   R    ] x11-proto/bigreqsproto-1.1.2:0/stub::core-gl-kit [1.1.2:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild     UD ] x11-proto/xf86driproto-2.1.1:0/stub::core-gl-kit [2.1.1-r1:0/0::gentoo] 0 KiB
    [ebuild   R    ] x11-proto/fontsproto-2.1.3:0/stub::core-gl-kit [2.1.3:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild  N     ] x11-proto/applewmproto-1.4.2:0/stub::core-gl-kit  0 KiB
    [ebuild     UD ] x11-proto/scrnsaverproto-1.2.2:0/stub::core-gl-kit [1.2.2-r1:0/0::gentoo] USE="(-doc%)" 0 KiB
    [ebuild  N     ] x11-proto/windowswmproto-1.0.4:0/stub::core-gl-kit  0 KiB
    [ebuild   R    ] x11-proto/kbproto-1.0.7:0/stub::core-gl-kit [1.0.7:0/0::gentoo] 0 KiB
    [ebuild     U  ] x11-libs/libICE-1.0.9-r2::xorg-kit [1.0.9-r1::xorg-kit] USE="ipv6 -doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXpm-3.5.12-r1::xorg-kit [3.5.12::xorg-kit] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXcomposite-0.4.4-r2::xorg-kit [0.4.4-r1::gentoo] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXxf86vm-1.1.4-r1::xorg-kit [1.1.4::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXau-1.0.8-r1::xorg-kit [1.0.8::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-apps/xprop-1.2.3::xorg-kit [1.2.2::xorg-kit] 146 KiB
    [ebuild     U  ] x11-libs/libXdmcp-1.1.2-r2::xorg-kit [1.1.2-r1::gentoo] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libxshmfence-1.3-r1::xorg-kit [1.2::xorg-kit] USE="-static-libs" 302 KiB
    [ebuild     U  ] x11-libs/libXft-2.3.2-r1::xorg-kit [2.3.2::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXtst-1.2.3-r1::xorg-kit [1.2.3::gentoo] USE="-doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libfontenc-1.1.3-r1::xorg-kit [1.1.3::gentoo] USE="-static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libXaw-1.0.13-r1::xorg-kit [1.0.13::gentoo] USE="-deprecated -doc -static-libs" 0 KiB
    [ebuild     U  ] x11-libs/libxcb-1.13:0/1.12::xorg-kit [1.12-r2:0/1.12::gentoo] USE="xkb -doc (-selinux) -static-libs {-test}" 499 KiB
    [ebuild     U  ] app-accessibility/at-spi2-core-2.30.0:2::gnome-kit [2.20.2:2::gentoo] USE="X introspection" 0 KiB
    [ebuild     U  ] x11-apps/mkfontscale-1.1.3::xorg-kit [1.1.2::xorg-kit] 142 KiB
    [ebuild     U  ] app-accessibility/at-spi2-atk-2.30.0:2::gnome-kit [2.20.1:2::gentoo] USE="{-test}" 93 KiB
    [ebuild     U  ] x11-libs/gtk+-2.24.32-r1:2::gnome-kit [2.24.31:2::gentoo] USE="cups introspection (-aqua) -examples {-test} -vim-syntax -xinerama (-debug%)" 12,326 KiB
    [ebuild  N     ] x11-themes/gtk-engines-adwaita-3.28::gnome-kit  2,885 KiB
    [ebuild  N     ] media-gfx/graphviz-2.40.1-r1::media-kit  USE="X cairo gtk nls pdf python -devil -doc -examples -gdk-pixbuf -gts (-guile) -java -lasi -perl -postscript -qt5 -ruby -static-libs -svg -tcl" PYTHON_TARGETS="python2_7" 25,033 KiB
    [ebuild  NS    ] dev-lang/vala-0.40.11:0.40::gnome-kit [0.26.2:0.26::gnome-kit, 0.32.1:0.32::gentoo] USE="{-test}" 3,306 KiB
    [ebuild     U  ] gnome-base/dconf-0.30.1::gnome-kit [0.26.0::gentoo] USE="{-test}" 102 KiB
    [ebuild     U  ] dev-libs/libgusb-0.3.0::gnome-kit [0.2.9::gentoo] USE="introspection vala* -static-libs" 37 KiB
    [ebuild     U  ] x11-misc/colord-1.3.5:0/2::gnome-kit [1.3.4:0/2::gentoo] USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner -systemd -vala" 1,234 KiB
    [ebuild     U  ] app-crypt/libsecret-0.18.6::gnome-kit [0.18.5::gentoo] USE="crypt introspection vala* -debug {-test}" 477 KiB
    [ebuild     U  ] media-libs/mesa-18.2.4::core-gl-kit [17.2.8::xorg-kit] USE="classic dri3 egl gallium gbm gles2 llvm xa -d3d9 -debug -gles1 -lm_sensors% -opencl -osmesa -pax_kernel -pic (-selinux) {-test%} -unwind -vaapi -valgrind -vdpau -vulkan -wayland -xvmc (-bindist%) (-nptl%*) (-openmax%)" VIDEO_CARDS="i965 intel (-freedreno) -i915 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl (-vivante) -vmware" 11,111 KiB
    [uninstall     ] app-eselect/eselect-mesa-0.0.10-r1::gentoo 
    [blocks b      ] app-eselect/eselect-mesa ("app-eselect/eselect-mesa" is blocking media-libs/mesa-18.2.4)
    [ebuild     U  ] media-libs/libepoxy-1.5.2::xorg-kit [1.4.3::xorg-kit] USE="X {-test}" 318 KiB
    [ebuild     U  ] x11-libs/gtk+-3.24.1:3::gnome-kit [3.20.10:3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -examples {-test} -vim-syntax -wayland -xinerama" 18,856 KiB
    [blocks b      ] <x11-libs/gtk+-3.22.2:3 ("<x11-libs/gtk+-3.22.2:3" is blocking dev-util/gtk-update-icon-cache-3.24.0)
    [ebuild     U  ] app-crypt/gcr-3.28.0:0/1::gnome-kit [3.20.0:0/1::gentoo] USE="gtk introspection vala -debug {-test}" 1,298 KiB
    [ebuild     U  ] app-text/ghostscript-gpl-9.25-r1::text-kit [9.21::text-kit] USE="X cups dbus gtk tiff unicode -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 32,258 KiB
    [ebuild     U  ] app-crypt/pinentry-1.1.0-r3::core-kit [1.0.0-r2::core-kit] USE="gnome-keyring gtk ncurses -caps -emacs -fltk% -qt5 -static" 457 KiB
    [ebuild     U  ] net-print/cups-filters-1.21.3::net-kit [1.20.4::net-kit] USE="dbus foomatic jpeg pdf png postscript tiff -ipp_autosetup -ldap -pclm -perl -static-libs {-test} -zeroconf" 1,440 KiB
    [ebuild     U  ] gnome-base/gnome-keyring-3.28.2::gnome-kit [3.20.0::gentoo] USE="caps filecaps pam ssh-agent (-selinux) {-test}" 1,292 KiB
    
    Total: 376 packages (256 upgrades, 14 downgrades, 28 new, 5 in new slots, 73 reinstalls, 4 uninstalls), Size of downloads: 761,058 KiB
    Conflict: 8 blocks
    
    The following packages are causing rebuilds:
    
      sys-libs/gdbm-1.18.1:0/6::core-kit, ebuild scheduled for merge causes rebuilds for:
        dev-lang/python-3.6.6:3.6/3.6m::python-kit, ebuild scheduled for merge
        dev-lang/python-2.7.15:2.7/2.7::python-kit, ebuild scheduled for merge
        dev-lang/python-3.4.8-r1:3.4/3.4m::python-kit, ebuild scheduled for merge
        sys-apps/man-db-2.8.4:0/0::core-kit, ebuild scheduled for merge
        dev-lang/perl-5.26.2-r1:0/5.26::perl-kit, ebuild scheduled for merge
      net-firewall/iptables-1.8.1-r1:0/12::core-kit, ebuild scheduled for merge causes rebuilds for:
        sys-apps/iproute2-4.14.1-r3:0/0::core-kit, ebuild scheduled for merge
      dev-libs/icu-63.1-r1:0/63.1::core-kit, ebuild scheduled for merge causes rebuilds for:
        mail-mta/postfix-3.2.4:0/0::core-kit, ebuild scheduled for merge
    
    Would you like to merge these packages? [Yes/No] no
    

    Looks like I'm good to go.  :)  Until I hit another snag.  Hopefully I won't.

  18. Got a blocker with this one:

    # emerge dev-libs/glib gtk+ gobject-introspection glib-utils gtk-update-icon-cache qtgui qtcore -av --ignore-world
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild     U  ] dev-python/setuptools-40.0.0::python-modules-kit [36.4.0::python-modules-kit] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7%" 830 KiB
    [ebuild     U  ] dev-python/certifi-2018.8.24::python-modules-kit [2018.4.16::python-modules-kit] PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7" 144 KiB
    [ebuild     U  ] dev-util/meson-0.48.2::core-kit [0.44.1::dev-kit] PYTHON_TARGETS="python3_6* -python3_5 -python3_7% (-python3_4%*)" 1,281 KiB
    [ebuild     U  ] dev-util/gdbus-codegen-2.58.1::gnome-kit [2.48.2::gnome-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,792 KiB
    [ebuild     U  ] dev-libs/glib-2.58.1:2::gnome-kit [2.48.2:2::gentoo] USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap {-test} -utils (-debug%)" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [ebuild     U  ] dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r2:5/5.9::kde-kit] USE="icu -debug -systemd {-test}" 45,855 KiB
    [ebuild  N     ] dev-util/glib-utils-2.58.1::gnome-kit  0 KiB
    [ebuild     U  ] dev-qt/qtdbus-5.11.2:5/5.11::core-ui-kit [5.9.4:5/5.9::kde-kit] USE="-debug {-test}" 0 KiB
    [ebuild     U  ] dev-libs/gobject-introspection-common-1.58.1::gnome-kit [1.48.0::gentoo] 1,346 KiB
    [ebuild     U  ] dev-libs/gobject-introspection-1.58.1::gnome-kit [1.48.0::gentoo] USE="-cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python3_6%* -python2_7% -python3_4% -python3_5% -python3_7%" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [blocks b      ] <dev-libs/gobject-introspection-1.58.1 ("<dev-libs/gobject-introspection-1.58.1" is blocking dev-libs/gobject-introspection-common-1.58.1)
    [ebuild  N     ] media-libs/graphene-1.8.2::media-kit  USE="introspection -doc {-test}" CPU_FLAGS_X86="sse2" 125 KiB
    [ebuild     U  ] dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r3:5/5.9::kde-kit] USE="dbus egl* gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev -gles2 -ibus {-test} -tslib -tuio -vnc" 0 KiB
    [ebuild     U  ] dev-util/gtk-update-icon-cache-3.24.0::gnome-kit [3.20.9::gentoo] 364 KiB
    [ebuild  NS    ] x11-libs/gtk+-3.94.0:4::gnome-kit [2.24.31:2::gentoo, 3.20.10:3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -docs -examples {-test} -vim-syntax -vulkan -wayland -xinerama" 13,189 KiB
    [blocks B      ] <x11-libs/gtk+-3.22.2:3 ("<x11-libs/gtk+-3.22.2:3" is blocking dev-util/gtk-update-icon-cache-3.24.0)
    
    Total: 14 packages (11 upgrades, 2 new, 1 in new slot), Size of downloads: 67,922 KiB
    Conflict: 2 blocks (1 unsatisfied)
    
    Oops! Conflicts have been encountered:
    
    >>> dev-libs/glib, wants dev-libs/glib
    >>> dev-util/glib-utils-2.58.1:0/0::gnome-kit, ebuild scheduled for merge, wants ~dev-libs/glib-2.58.1
    >>> dev-util/gdbus-codegen-2.58.1:0/0::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.58.1:2
    >>> dev-libs/gobject-introspection-1.58.1:0/0::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.58:2
    >>> dev-util/gtk-update-icon-cache-3.24.0:0/0::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.49.4:2
    >>> x11-libs/gtk+-3.94.0:4/4::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.53.7:2
    >>> app-accessibility/at-spi2-core-2.20.2:2/2::gentoo, installed, wants >=dev-libs/glib-2.36:2[]
    >>> app-accessibility/at-spi2-atk-2.20.1:2/2::gentoo, installed, wants >=dev-libs/glib-2.32:2[]
    >>> dev-qt/qtgui-4.8.7:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> x11-misc/colord-1.3.4:0/2::gentoo, installed, wants >=dev-libs/glib-2.44.0:2[]
    >>> dev-libs/atk-2.20.0:0/0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> dev-qt/qtcore-4.8.7-r4:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> x11-libs/gtk+-2.24.31:2/2::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> x11-libs/gtk+-3.20.10:3/3::gentoo, installed, wants >=dev-libs/glib-2.45.8:2[]
    >>> dev-libs/libgusb-0.2.9:0/0::gentoo, installed, wants >=dev-libs/glib-2.28:2[]
    
    My candidates are:
    
    >>> dev-libs/glib-2.58.1:2/2::gnome-kit, ebuild scheduled for merge has SLOT 2/2
    >>> dev-libs/glib-2.48.2:2/2::gentoo, installed has SLOT 2/2
    
    We hope this informational output has been useful in identifying the
    problem. We are continually working to reduce conflicts. Do not
    hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)
    
    
     * Error: The above package list contains packages which cannot be
     * installed at the same time on the same system.
    
      dev-util/gtk-update-icon-cache-3.24.0:0/0::gnome-kit, ebuild scheduled for merge pulled in by
        >=dev-util/gtk-update-icon-cache-3 required by x11-libs/gtk+-3.94.0:4/4::gnome-kit, ebuild scheduled for merge
        gtk-update-icon-cache
        >=dev-util/gtk-update-icon-cache-2 required by x11-libs/gtk+-2.24.31:2/2::gentoo, installed
        >=dev-util/gtk-update-icon-cache-3 required by x11-libs/gtk+-3.20.10:3/3::gentoo, installed
    
      x11-libs/gtk+-3.20.10:3/3::gentoo, installed pulled in by
        x11-libs/gtk+:3 required by app-text/ghostscript-gpl-9.21:0/0::text-kit, installed
        >=x11-libs/gtk+-3.12:3[X,introspection] required by app-crypt/gcr-3.20.0:0/1::gentoo, installed
        x11-libs/gtk+:3 required by gnome-extra/polkit-gnome-0.105-r1:0/0::gentoo, installed
    
    
    For more information about Blocked Packages, please refer to the following
    section of the Gentoo Linux x86 Handbook (architecture is irrelevant):
    
    https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages

     

  19. 9 minutes ago, drobbins said:

    Yeah, the first output looked close, try adding --ignore-world which you forgot to.

    1 hour ago, overkill said:

    # emerge -1av glib at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world

    It was there.  No matter what, it seems dev-libs/glib is the stickler.  There is no glib-2.48.2 and no gdbus-codegen-2.48.2 in the tree:

    # equery l -po dev-libs/glib
     * Searching for glib in dev-libs ...
    [I--] [??] dev-libs/glib-2.48.2:2
    [--O] [  ] dev-libs/glib-2.58.1:2
    
    # equery l -po gdbus-codegen
     * Searching for gdbus-codegen ...
    [I--] [??] dev-util/gdbus-codegen-2.48.2:0
    [--O] [  ] dev-util/gdbus-codegen-2.58.1:0

    Should I just emerge both with --nodeps?

     

     

  20. Still hangs up  on dev-libs/glib.

    # emerge -1av glib at-spi2-core gtk+ atk qtcore colord qtgui libgusb --ignore-world
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild     U  ] dev-python/setuptools-40.0.0::python-modules-kit [36.4.0::python-modules-kit] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7%" 830 KiB
    [ebuild     U  ] dev-python/certifi-2018.8.24::python-modules-kit [2018.4.16::python-modules-kit] PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7" 144 KiB
    [ebuild     U  ] dev-util/meson-0.48.2::core-kit [0.44.1::dev-kit] PYTHON_TARGETS="python3_6* -python3_5 -python3_7% (-python3_4%*)" 1,281 KiB
    [ebuild     U  ] dev-util/gdbus-codegen-2.58.1::gnome-kit [2.48.2::gnome-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,792 KiB
    [ebuild     U  ] dev-libs/glib-2.58.1:2::gnome-kit [2.48.2:2::gentoo] USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap {-test} -utils (-debug%)" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [ebuild     U  ] dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r2:5/5.9::kde-kit] USE="icu -debug -systemd {-test}" 45,855 KiB
    [ebuild     U  ] dev-qt/qtdbus-5.11.2:5/5.11::core-ui-kit [5.9.4:5/5.9::kde-kit] USE="-debug {-test}" 0 KiB
    [ebuild     U  ] dev-libs/atk-2.30.0::gnome-kit [2.20.0::gentoo] USE="introspection nls -doc% (-test%)" 284 KiB
    [ebuild     U  ] app-accessibility/at-spi2-core-2.30.0:2::gnome-kit [2.20.2:2::gentoo] USE="X introspection" 184 KiB
    [ebuild  N     ] media-libs/graphene-1.8.2::media-kit  USE="introspection -doc {-test}" CPU_FLAGS_X86="sse2" 125 KiB
    [ebuild     U  ] dev-libs/libgusb-0.3.0::gnome-kit [0.2.9::gentoo] USE="introspection vala* -static-libs" 37 KiB
    [ebuild     U  ] dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r3:5/5.9::kde-kit] USE="dbus egl* gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev -gles2 -ibus {-test} -tslib -tuio -vnc" 0 KiB
    [ebuild     U  ] x11-misc/colord-1.3.5:0/2::gnome-kit [1.3.4:0/2::gentoo] USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner -systemd -vala" 1,234 KiB
    [ebuild  NS    ] x11-libs/gtk+-3.94.0:4::gnome-kit [2.24.31:2::gentoo, 3.20.10:3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -docs -examples {-test} -vim-syntax -vulkan -wayland -xinerama" 13,189 KiB
    
    Total: 14 packages (12 upgrades, 1 new, 1 in new slot), Size of downloads: 67,951 KiB
    
    Oops! Conflicts have been encountered:
    
    >>> dev-util/gdbus-codegen-2.58.1:0/0::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.58.1:2
    >>> dev-libs/glib, wants glib
    >>> x11-libs/gtk+-3.94.0:4/4::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.53.7:2
    >>> dev-qt/qtgui-4.8.7:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> app-accessibility/at-spi2-atk-2.20.1:2/2::gentoo, installed, wants >=dev-libs/glib-2.32:2[]
    >>> dev-qt/qtcore-4.8.7-r4:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> x11-libs/gtk+-2.24.31:2/2::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> x11-libs/gtk+-3.20.10:3/3::gentoo, installed, wants >=dev-libs/glib-2.45.8:2[]
    
    My candidates are:
    
    >>> dev-libs/glib-2.58.1:2/2::gnome-kit, ebuild scheduled for merge has SLOT 2/2
    >>> dev-libs/glib-2.48.2:2/2::gentoo, installed has SLOT 2/2
    
    
    
    We hope this informational output has been useful in identifying the
    problem. We are continually working to reduce conflicts. Do not
    hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

     

    Same command without --ignore-world has more conflicts:

     

    # emerge -1av glib at-spi2-core gtk+ atk qtcore colord qtgui libgusb
    
    These are the packages that would be merged, in order:
    
    Calculating dependencies... done!
    [ebuild     U  ] dev-python/setuptools-40.0.0::python-modules-kit [36.4.0::python-modules-kit] USE="{-test}" PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7%" 830 KiB
    [ebuild     U  ] dev-python/certifi-2018.8.24::python-modules-kit [2018.4.16::python-modules-kit] PYTHON_TARGETS="python2_7 python3_4 python3_6* -pypy -pypy3 -python3_5 -python3_7" 144 KiB
    [ebuild     U  ] dev-util/meson-0.48.2::core-kit [0.44.1::dev-kit] PYTHON_TARGETS="python3_6* -python3_5 -python3_7% (-python3_4%*)" 1,281 KiB
    [ebuild     U  ] dev-util/gdbus-codegen-2.58.1::gnome-kit [2.48.2::gnome-kit] PYTHON_TARGETS="python2_7 python3_6* -python3_4* -python3_5 -python3_7%" 4,792 KiB
    [ebuild     U  ] dev-libs/glib-2.58.1:2::gnome-kit [2.48.2:2::gentoo] USE="dbus mime xattr (-fam) (-selinux) -static-libs -systemtap {-test} -utils (-debug%)" PYTHON_TARGETS="python2_7 python3_6%* -python3_4% -python3_5% -python3_7%" 0 KiB
    [ebuild     U  ] dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r2:5/5.9::kde-kit] USE="icu -debug -systemd {-test}" 45,855 KiB
    [ebuild     U  ] dev-qt/qtdbus-5.11.2:5/5.11::core-ui-kit [5.9.4:5/5.9::kde-kit] USE="-debug {-test}" 0 KiB
    [ebuild     U  ] dev-libs/atk-2.30.0::gnome-kit [2.20.0::gentoo] USE="introspection nls -doc% (-test%)" 284 KiB
    [ebuild     U  ] app-accessibility/at-spi2-core-2.30.0:2::gnome-kit [2.20.2:2::gentoo] USE="X introspection" 184 KiB
    [ebuild  N     ] media-libs/graphene-1.8.2::media-kit  USE="introspection -doc {-test}" CPU_FLAGS_X86="sse2" 125 KiB
    [ebuild     U  ] dev-libs/libgusb-0.3.0::gnome-kit [0.2.9::gentoo] USE="introspection vala* -static-libs" 37 KiB
    [ebuild     U  ] dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit [5.9.4-r3:5/5.9::kde-kit] USE="dbus egl* gif jpeg libinput png udev xcb -accessibility -debug -eglfs -evdev -gles2 -ibus {-test} -tslib -tuio -vnc" 0 KiB
    [ebuild     U  ] x11-misc/colord-1.3.5:0/2::gnome-kit [1.3.4:0/2::gentoo] USE="gusb introspection policykit udev -argyllcms -examples -extra-print-profiles -scanner -systemd -vala" 1,234 KiB
    [ebuild  NS    ] x11-libs/gtk+-3.94.0:4::gnome-kit [2.24.31:2::gentoo, 3.20.10:3::gentoo] USE="X colord cups introspection (-aqua) -broadway -cloudprint -docs -examples {-test} -vim-syntax -vulkan -wayland -xinerama" 13,189 KiB
    
    Total: 14 packages (12 upgrades, 1 new, 1 in new slot), Size of downloads: 67,951 KiB
    
    Oops! Conflicts have been encountered:
    
    >>> dev-qt/qtcore, wants qtcore
    >>> dev-qt/qtdbus-5.11.2:5/5.11::core-ui-kit, ebuild scheduled for merge, wants ~dev-qt/qtcore-5.11.2
    >>> dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit, ebuild scheduled for merge, wants ~dev-qt/qtcore-5.11.2
    >>> dev-qt/qtdbus-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtopengl-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtxml-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtprintsupport-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtsvg-5.9.4-r1:5/5.9::kde-kit, installed, wants dev-qt/qtcore:5/5.9
    >>> dev-qt/linguist-tools-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtgui-5.9.4-r3:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtmultimedia-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtnetwork-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    >>> dev-qt/qtwidgets-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtcore-5.9.4
    
    My candidates are:
    
    >>> dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit, ebuild scheduled for merge has SLOT 5/5.11
    >>> dev-qt/qtcore-5.9.4-r2:5/5.9::kde-kit, installed has SLOT 5/5.9
    
    >>> dev-qt/qtgui, wants qtgui
    >>> dev-qt/qtprintsupport-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4[-gles2]
    >>> dev-qt/qtwidgets-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4[dbus]
    >>> dev-qt/qtsvg-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4
    >>> dev-qt/qtwidgets-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4[-gles2,png,xcb]
    >>> dev-qt/qtopengl-5.9.4:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4[-gles2]
    >>> dev-qt/qtmultimedia-5.9.4-r1:5/5.9::kde-kit, installed, wants ~dev-qt/qtgui-5.9.4[-gles2]
    
    My candidates are:
    
    >>> dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit, ebuild scheduled for merge has SLOT 5/5.11
    >>> dev-qt/qtgui-5.9.4-r3:5/5.9::kde-kit, installed has SLOT 5/5.9
    
    >>> x11-libs/gtk+-3.94.0:4/4::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.53.7:2
    >>> dev-libs/glib, wants glib
    >>> dev-util/gdbus-codegen-2.58.1:0/0::gnome-kit, ebuild scheduled for merge, wants >=dev-libs/glib-2.58.1:2
    >>> media-plugins/gst-plugins-faad-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-a52dec-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> dev-libs/dbus-glib-0.108:0/0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> www-plugins/adobe-flash-30.0.0.134:22/22::net-kit, installed, wants dev-libs/glib:2[]
    >>> app-accessibility/at-spi2-atk-2.20.1:2/2::gentoo, installed, wants >=dev-libs/glib-2.32:2[]
    >>> media-libs/gst-plugins-good-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> gnome-base/gconf-3.2.6-r4:2/2::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-libs/libcanberra-0.30-r5:0/0::gentoo, installed, wants >=dev-libs/glib-2.32:2[]
    >>> media-plugins/gst-plugins-wavpack-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-cdparanoia-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> net-misc/networkmanager-1.10.2:0/0::gnome-kit, installed, wants >=dev-libs/glib-2.37.6:2[]
    >>> gnome-base/libgnome-keyring-3.12.0-r1:0/0::gentoo, installed, wants >=dev-libs/glib-2.16.0:2[]
    >>> media-plugins/gst-plugins-resindvd-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-libs/libquvi-0.9.4-r1:0/8::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-libs/gst-plugins-ugly-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> dev-libs/fribidi-0.19.7:0/0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-plugins/gst-plugins-mad-1.10.5:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-libs/gstreamer-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> media-libs/gst-plugins-ugly-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> dev-qt/qtgui-4.8.7:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> media-plugins/gst-plugins-dvdread-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> x11-libs/gtk+-3.20.10:3/3::gentoo, installed, wants >=dev-libs/glib-2.45.8:2[]
    >>> media-plugins/gst-plugins-libmms-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-jpeg-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> x11-libs/libnotify-0.7.6-r3:0/0::gentoo, installed, wants >=dev-libs/glib-2.26:2[]
    >>> dev-cpp/glibmm-2.48.1:2/2::gnome-kit, installed, wants >=dev-libs/glib-2.48.0:2[]
    >>> media-plugins/gst-plugins-flac-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-taglib-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> net-libs/rest-0.8.0:0.7/0.7::gentoo, installed, wants >=dev-libs/glib-2.24:2[]
    >>> net-libs/libsoup-2.54.1-r1:2.4/2.4::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> dev-libs/json-glib-1.2.2:0/0::gentoo, installed, wants >=dev-libs/glib-2.37.6:2[]
    >>> media-plugins/gst-plugins-libav-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> media-plugins/gst-plugins-vpx-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> gnome-base/libglade-2.6.4-r2:2.0/2.0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-plugins/gst-plugins-soup-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-sound/pulseaudio-11.1:0/0::media-kit, installed, wants >=dev-libs/glib-2.4.0:2[]
    >>> media-plugins/gst-plugins-mpg123-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-libs/gst-plugins-base-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> media-plugins/gst-plugins-mpeg2dec-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> net-libs/glib-networking-2.48.2:0/0::gentoo, installed, wants >=dev-libs/glib-2.46.0:2[]
    >>> media-plugins/gst-plugins-x264-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> dev-qt/qtcore-4.8.7-r4:4/4::kde-kit, installed, wants dev-libs/glib:2[]
    >>> media-plugins/gst-plugins-lame-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-libs/gst-plugins-good-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> net-libs/gupnp-0.20.18:0/4::gentoo, installed, wants >=dev-libs/glib-2.40:2[]
    >>> media-libs/gst-plugins-bad-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> net-libs/gupnp-igd-0.2.4:0/0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> net-libs/libnice-0.1.13:0/0::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-plugins/gst-plugins-v4l2-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-pulse-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-plugins/gst-plugins-assrender-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> x11-libs/gtk+-2.24.31:2/2::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> net-libs/gssdp-0.14.16:0/3::gentoo, installed, wants >=dev-libs/glib-2.34.3:2[]
    >>> media-libs/gst-plugins-bad-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.40.0:2[]
    >>> media-plugins/gst-plugins-dts-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    >>> media-libs/gst-plugins-base-1.12.3:1.0/1.0::media-kit, installed, wants >=dev-libs/glib-2.38.2-r1:2[]
    
    My candidates are:
    
    >>> dev-libs/glib-2.58.1:2/2::gnome-kit, ebuild scheduled for merge has SLOT 2/2
    >>> dev-libs/glib-2.48.2:2/2::gentoo, installed has SLOT 2/2
    
    >>> dev-qt/qtgui-5.11.2-r1:5/5.11::core-ui-kit, ebuild scheduled for merge, wants ~dev-qt/qtdbus-5.11.2
    >>> dev-qt/qtgui-5.9.4-r3:5/5.9::kde-kit, installed, wants ~dev-qt/qtdbus-5.9.4
    
    My candidates are:
    
    >>> dev-qt/qtdbus-5.11.2:5/5.11::core-ui-kit, ebuild scheduled for merge has SLOT 5/5.11
    >>> dev-qt/qtdbus-5.9.4:5/5.9::kde-kit, installed has SLOT 5/5.9
    
    
    
    We hope this informational output has been useful in identifying the
    problem. We are continually working to reduce conflicts. Do not
    hesitate to report a bug at https://bugs.funtoo.org. Thank you! :)

     

    I don't understand why desktop related packages get pulled in with a @system merge.  I guess it's a dependency thing.

×
×
  • Create New...