Jump to content

anaxamander

Members
  • Content Count

    5
  • Joined

  • Last visited

  1. Hey! Sorry for the long delay on response here. I want to avoid this phenomenon so I figured I'd post what I did to solve my problem. I ran emerge --ask -e @world and now everything is happy! I'll definitely be fixing my USE flags, but I just wanted to post what worked for me so people can find it in future. Thank you to everyone who posted suggestions.
  2. Hi, thank you for the clarifications! I have to admit I'm still relatively new to how all of these parts fit together. When I try to run the `emerge -pe @system`, I get the following: -su-4.3# emerge -pe @system These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] app-arch/xz-utils-5.2.2 [5.2.1-r1] [ebuild R ] dev-lang/python-exec-2.0.2 PYTHON_TARGETS="(python3_5%*)" [ebuild R ] virtual/libintl-0-r1 [ebuild R ] app-arch/bzip2-1.0.6-r7 [ebuild R ] virtual/libiconv-0-r2 [ebuild R ] dev-qt/qtchooser-0_p2
  3. Hi, thank you for replying again. I tried another sync and see the same error messages. However, if I modify the jinja ebuild to include the suggested IUSEs, the error message changes to pygments reporting the same problem. emerge: there are no ebuilds built with USE flags to satisfy "dev-python/pygments[python_abis_2.7,python_abis_3.3]". !!! One of the following packages is required to complete your request: - dev-python/pygments-2.0.2::gentoo (Missing IUSE: python_abis_3.3 python_abis_2.7) - dev-python/pygments-2.0.1-r1::gentoo (Missing IUSE: python_abis_3.3 python_abis_2.7) - dev-pyth
  4. Hi, thank you for replying. This seems to have produced more verbose problem output: -su-4.3# emerge -a -v -p -t --with-bdeps=y --backtrack=30 -D -N -1 portage These are the packages that would be merged, in reverse order: Calculating dependencies... done! !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-libs/libxml2:2 (dev-libs/libxml2-2.9.2-r1001::gentoo, installed) pulled in by >=dev-libs/libxml2-2.8.0:2[python,python_abis_2.7] required by (dev-libs/libxslt-1.1.28-r1002::gent
  5. I have other slot conflicts / other issues on other upgrades as you can see, but I'd like to fix this first so I have the new version of portage (that "_strongly_ recommended" message seems important). I did an `emerge --sync` yesterday and now I get the following when I try to do `emerge --oneshot portage`: -su-4.3# emerge --oneshot portage Calculating dependencies... done! [ebuild N ] sys-apps/install-xattr-0.5 [ebuild rR ] sys-devel/bc-1.06.95-r2 [ebuild U ] dev-python/packaging-15.3-r2 [15.3] PYTHON_TARGETS="python2_7%* python3_3%* -pypy% -pypy3% -python3_4% -python3_5
×
×
  • Create New...