Jump to content
funtoo forums

eusanpe

Members
  • Content count

    9
  • Joined

  • Last visited

  1. Multiple Nics Configuration

    Hello all, I have a Funtoo system with two nics. eth0---> IP:: 192.168.3.40 ---> Gateway: 192.168.3.1 eth1---> IP: 192.168.20.120---> Gateway 192.168.20.1 What I would like is to add a gateway for each nic. I am trying to figure this out with the netif scripts. Is there a way to assign static DNS Servers per nic? Currently the DNS Servers for eth0 are added to resolv.conf and then the DNS Server for eth1 is added afterwards. Thanks, Tony netif.eth0 template="interface" ipaddr="192.168.3.40/24" #gateway="192.168.3.1" nameservers="192.168.2.10 192.168.2.11" domain="xxxxxx.com" netif.eth1 template="interface" ipaddr="192.168.20.120/24" gateway="192.168.20.1" nameservers="192.168.20.1" netstat # netstat -rn Kernel IP routing table Destination Gateway Genmask Flags MSS Window irtt Iface 0.0.0.0 192.168.20.1 0.0.0.0 UG 0 0 0 eth1 127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo 192.168.3.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0 192.168.20.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
  2. Hello All, I am messing with Devmon to automatically mount a USB drive. The command I have in a config file is: devmon --exec-on-drive "pcmanfm %d" This will open all directories on a mounted USB drive when the drive is inserted. This works great for one word directories. The issue is when opening a directory when it has a space in the name (two word directories). I get an error message that it isn't recognized. I tried using Dolphin and the same thing happens. If I open PCManFM or Dolphin manually then things are fine. How can I open them automatically? Thanks, Tony
  3. OpenRC 0.18

    Thank you cardinal...I got it working now by downgrading. I had unmasked openrc-0.12.r4 a while ago and accidentally put >=sys-apps/openrc-0.12.4-r4 instead of =sys-apps/openrc-0.12.4-r4....duh! Thank you again... Tony
  4. OpenRC 0.18

    Hello All, I performed a world update and now netif.eth0 doesn't work. I get the following error: ERROR: netif.eth0 needs service(s) netif netif.eth0 is linked to netif.tmpl. It was working previously until the update to OpenRC-0.18 from OpenRC-0.12.4-r4. CoreNetwork-1.5.2 was installed also. Does anyone have any ideas how to fix this? My network interface is down. Thanks, Tony
  5. Need Help with NetworkManager/WPA_Supplicant

    I reoved the networkmanage.conf and it seems to be working now. The 'addwifi' didn't seem t work. Turns out it doesn't like '!!' exclamation points in the password setting. Thanks for your help Tony BTW...I just recompiled networkmanager to get rid of the error above.
  6. Need Help with NetworkManager/WPA_Supplicant

    I trie to do what ya said and then I got another error for 'Addwifi'. It used to be so easy, lol! sudo addwifi -S wpa -K 'Wnhj853ycat' clinistar1-5Ghz Error: nmcli (0.9.10.0) and NetworkManager (unknown) versions don't match. Force execution using --nocheck, but the results are unpredictable. Traceback (most recent call last): File "/usr/sbin/addwifi", line 164, in <module> main() File "/usr/sbin/addwifi", line 161, in main block_until_created(args.ssid, args.retries, args.interval) File "/usr/sbin/addwifi", line 81, in block_until_created nmcli_con_list = check_output(['nmcli', 'con', 'show'], universal_newlines=True) File "/usr/lib64/python3.3/subprocess.py", line 589, in check_output raise CalledProcessError(retcode, process.args, output=output) subprocess.CalledProcessError: Command '['nmcli', 'con', 'show']' returned non-zero exit status 9 Exit 1 Thanks, Tony
  7. Hello All, I had to do a full install of my laptop. It had been running fine since the Jackass days on Gentoo. Dang Raid0 and old backups. Anyway I redid my laptop and I am having trouble with Networkmanager. Here is what is in NeworkManager.conf [main] plugins=ifupdown,keyfile [ifupdown] managed=false wpa_supplicant.conf network={ ssid="clinistar1-5Ghz" psk="xxxxxxxxxxxx" } If I run 'rc-status', networkmanager is crashed and wpa_supplicant is up. I have network connectivity but only on the one defined in wpa_supplicant. I do not get any selections nor does KDE Neworkmanagement fire anymore. I need this because I have multilple selections in the house and VPN. Can anyone help? Thanks, Tony
  8. (Solved) Issue with Libgcrypt

    Hello all, I am having trouble emerging icaclient, nswrapperplugin or anything that uses libgcrypt. I am getting this error: % sudo emerge -pv icaclient These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy ">=dev-libs/libgcrypt-1.5.3-r100:11[abi_x86_32(-)]". (dependency required by "app-emulation/emul-linux-x86-baselibs-20140508-r14[abi_x86_32]" [ebuild]) (dependency required by "app-emulation/emul-linux-x86-gtklibs-20140508-r3" [ebuild]) (dependency required by "net-misc/icaclient-12.1.0[amd64]" [ebuild]) (dependency required by "icaclient" [argument]) I can't figure out how to make this work. I can emerge icaclient with --nodeps and icaclient works fine but the next time I do an emerge @world, I get the above libgcrypt error. Does anyone have any ideas? I have ABI_X86 = "64 32" and I have tried both use flags and nothing. dev-libs/libgcrypt abi_x86_32 dev-libs/libgcrypt -abi_x86_32 Here are some other settings. Thanks, Tony emerge --info % sudo emerge --info Portage 2.3.6-r9 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.16.0-pf1 x86_64) ================================================================= System uname: Linux-3.16.0-pf1-x86_64-Intel-R-_Core-TM-_i7-3920XM_CPU_@_2.90GHz-with-gentoo-2.2.0 KiB Mem: 32987512 total, 15029592 free KiB Swap: 4194300 total, 4159948 free Timestamp of tree: Unknown ld GNU ld (Gentoo 2.23.2 p1.0) 2.23.2 ccache version 3.1.9 [enabled] app-shells/bash: 4.2_p53 dev-java/java-config: 2.2.0-r1000 dev-lang/perl: 5.20.1 dev-lang/python: 2.7.8-r1000, 3.3.5-r1000 dev-util/ccache: 3.1.9-r3 dev-util/cmake: 3.0.2 sys-apps/baselayout: 2.2.0-r6 sys-apps/openrc: 0.12.3-r3 sys-apps/sandbox: 2.6-r2 sys-devel/autoconf: 2.13, 2.69 sys-devel/automake: 1.11.6, 1.13.4 sys-devel/binutils: 2.23.2 sys-devel/gcc: 4.8.2-r3 sys-devel/gcc-config: 1.8 sys-devel/libtool: 2.4.2-r1 sys-devel/make: 4.1 sys-kernel/linux-headers: 3.13 (virtual/os-headers) sys-libs/glibc: 2.18-r1 Repositories: gentoo overlays local_portage ACCEPT_KEYWORDS="amd64 ~amd64" ACCEPT_LICENSE="* -@EULA Oracle-BCLA-JavaSE AdobeFlash-10.3 AdobeFlash-11.x PUEL skype-4.0.0.7-copyright TeamViewer" CBUILD="x86_64-pc-linux-gnu" CFLAGS="-march=corei7 -O2 -pipe" CHOST="x86_64-pc-linux-gnu" CONFIG_PROTECT="$CONFIG_PROTECT /etc /usr/lib/oss/conf/ /usr/share/config /usr/share/gnupg/qualified.txt" CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.6/ext-active/ /etc/php/cgi-php5.6/ext-active/ /etc/php/cli-php5.6/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/splash /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c" CXXFLAGS="-march=corei7 -O2 -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="assume-digests binpkg-logs buildpkg ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch xattr" FFLAGS="" GENTOO_MIRRORS="http://distfiles.gentoo.org" LANG="en_US.utf8" LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed" MAKEOPTS="-j9" PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage" PORTDIR_OVERLAY="/usr/local/portage/overlays /usr/local/portage" SYNC="git://github.com/funtoo/ports-2012.git" SYNC_USER="root" USE="X acl alsa amd64 berkdb bzip2 cracklib crypt cups cxx fglrx gdbm gtk gtk3 iconv icu introspection kde midi mmx modules mudflap multilib ncurses nls nptl opengl openmp oss oss4 pam pcre pulseaudio qt3support qt4 readline sdl sse sse2 ssl tcpd unicode v4l v4l2 xattr xinerama xml zeroconf zlib" ABI_X86="64 32" ALSA_CARDS="snd-hda-intel" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" SANE_BACKENDS="canon_dr gt68xx genesys" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK Package Mask: =media-libs/libgphoto2-2.5.2-r1 >sys-fs/lvm2-2.02.45 <x11-base/xorg-server-1.14.3 =net-misc/networkmanager-vpnc-0.9.10.0 =dev-util/gdbus-codegen-2.40.2-r1000 >x11-base/xorg-server-1.15.2 <x11-base/xorg-server-1.15.2 =net-misc/networkmanager-pptp-0.9.10.0 =dev-libs/libnl-3.2.25 #app-emulation/emul-linux-x86-baselibs app-emulation/emul-linux-x86-compat app-emulation/emul-linux-x86-cpplibs app-emulation/emul-linux-x86-db app-emulation/emul-linux-x86-gstplugins #app-emulation/emul-linux-x86-gtklibs app-emulation/emul-linux-x86-gtkmmlibs app-emulation/emul-linux-x86-java app-emulation/emul-linux-x86-jna app-emulation/emul-linux-x86-medialibs app-emulation/emul-linux-x86-motif #app-emulation/emul-linux-x86-opengl #app-emulation/emul-linux-x86-qtlibs #app-emulation/emul-linux-x86-xlibs Update... I performed an emerge --nodeps emul-linux-x86-baselibs and emul-linux-x86-gtklibs and this fixed the issue. In package.use have the following: app-emulation/emul-linux-x86-baselibs -abi_x86_32 app-emulation/emul-linux-x86-gtklibs -abi_x86_32
  9. Samba-4.1.9 Compile Issue (SOLVED)

    Hello all, Has anyone had issues compiling Samba-4.1.9? I am getting an error saying: Checking for system subunit : not found ERROR: System library subunit of version 0.0.0 not found, and bundling disabled * ERROR: net-fs/samba-4.1.9 failed (configure phase): * configure failed * * Call stack: * ebuild.sh, line 93: Called src_configure * environment, line 4104: Called waf-utils_src_configure '--enable-fhs' '--sysconfdir=/etc' '--localstatedir=/var' '--with-modulesdir=/usr/lib64/samba' '--with-pammodulesdir=/lib64/security' '--with-piddir=/var/run/samba' '--disable-rpath' '--disable-rpath-install' '--nopyc' '--nopyo' '--bundled-libraries=NONE' '--builtin-libraries=NONE' '--with-dnsupdate' '--with-acl-support' '--with-ads' '--with-aio-support' '--disable-avahi' '--without-cluster-support' '--enable-cups' '--without-dmapi' '--with-fam' '--disable-gnutls' '--enable-iprint' '--with-ldap' '--with-pam' '--with-pam_smbpass' '--with-quotas' '--with-syslog' '--with-winbind' '--with-shared-modules=idmap_ad' * environment, line 4978: Called die * The specific snippet of code: * CCFLAGS="${CFLAGS}" LINKFLAGS="${CFLAGS} ${LDFLAGS}" "${WAF_BINARY}" "--prefix=${EPREFIX}/usr" "${libdir}" "$@" configure || die "configure failed"; * * If you need support, post the output of `emerge --info '=net-fs/samba-4.1.9'`, * the complete build log and the output of `emerge -pqv '=net-fs/samba-4.1.9'`. * The complete build log is located at '/var/tmp/portage/net-fs/samba-4.1.9/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/net-fs/samba-4.1.9/temp/environment'. * Working directory: '/var/tmp/portage/net-fs/samba-4.1.9/work/samba-4.1.9' * S: '/var/tmp/portage/net-fs/samba-4.1.9/work/samba-4.1.9' I removed dev-python/subunit-0.0.18-r1000 and reinstalled it but to no avail. Here are some settings: emerge --info Portage 2.3.6-r8 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.8.2, glibc-2.18-r1, 3.14.5-gentoo x86_64) ================================================================= System uname: Linux-3.14.5-gentoo-x86_64-Intel-R-_Xeon-R-_CPU_E5-2630_0_@_2.30GHz-with-gentoo-2.2.0 KiB Mem: 4043272 total, 2763064 free KiB Swap: 4194300 total, 4194300 free Timestamp of tree: Unknown ld GNU ld (GNU Binutils) 2.23.2 app-shells/bash: 4.2_p45-r1 dev-lang/python: 2.7.8-r1000, 3.3.5-r1000 dev-util/cmake: 2.8.12.2-r1 sys-apps/baselayout: 2.2.0-r6 sys-apps/openrc: 0.12.3-r3 sys-apps/sandbox: 2.6-r2 sys-devel/autoconf: 2.69 sys-devel/automake: 1.13.4 sys-devel/binutils: 2.23.2 sys-devel/gcc: 4.8.2-r2 sys-devel/gcc-config: 1.8 sys-devel/libtool: 2.4.2-r1 sys-devel/make: 4.0-r1 sys-kernel/linux-headers: 3.13 (virtual/os-headers) sys-libs/glibc: 2.18-r1 Repositories: gentoo x-portage ACCEPT_KEYWORDS="amd64 ~amd64" ACCEPT_LICENSE="* -@EULA" CBUILD="x86_64-pc-linux-gnu" CFLAGS="-march=native -O2 -pipe" CHOST="x86_64-pc-linux-gnu" CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt" CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo" CXXFLAGS="-march=native -O2 -pipe" DISTDIR="/usr/portage/distfiles" FEATURES="assume-digests binpkg-logs buildpkg config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch" FFLAGS="" GENTOO_MIRRORS="http://distfiles.gentoo.org" LANG="en_US.UTF-8" LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed" MAKEOPTS="-j2" PKGDIR="/usr/portage/packages" PORTAGE_CONFIGROOT="/" PORTAGE_TMPDIR="/var/tmp" PORTDIR="/usr/portage" PORTDIR_OVERLAY="/usr/local/portage" SYNC="git://github.com/funtoo/ports-2012.git" SYNC_USER="root" USE="acl amd64 berkdb bzip2 cracklib crypt cxx dbus gdbm geoip iconv icu mmx modules mudflap multilib ncurses nls nptl openmp pam pcre python readline resolvconf spell sse sse2 ssl tcpd unicode urandom xml zlib" ABI_X86="64" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby19 ruby20 ruby21" USERLAND="GNU" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK I was able to run the configure script from the source code and it worked fine. The configure script running from the ebuild is the issue. Thanks, Tony UPDATE - 11:53 PM CST I noticed that Samba-4.1.6 compiled just fine but Samba-4.1.9 didn't. I ran a diff of the two ebuilds and found the difference. Samba-4.1.6.ebuild portion - (This compiles fine) src_configure() { local myconf='' use "cluster" && myconf+=" --with-ctdb-dir=/usr" use "test" && myconf+=" --enable-selftest" myconf="${myconf} \ --enable-fhs \ --sysconfdir=/etc \ --localstatedir=/var \ --with-modulesdir=/usr/$(get_libdir)/samba \ --with-pammodulesdir=/$(get_libdir)/security \ --with-piddir=/var/run/${PN} \ --disable-rpath \ --disable-rpath-install \ --nopyc \ --nopyo \ --bundled-libraries=ntdb \ --builtin-libraries=ntdb \ $(use_with addns dnsupdate) \ $(use_with acl acl-support) \ $(use_with ads) \ $(use_with aio aio-support) \ $(use_enable avahi) \ $(use_with cluster cluster-support) \ $(use_enable cups) \ $(use_with dmapi) \ $(use_with fam) \ $(use_enable gnutls) \ $(use_enable iprint) \ $(use_with ldap) \ --with-pam \ --with-pam_smbpass \ $(use_with quota quotas) \ $(use_with syslog) \ $(use_with winbind) " use "ads" && myconf+=" --with-shared-modules=idmap_ad" You will notice that the configure options --bundled-libraries and --builtin-libraries are set to 'ntdb' Samba-4.1.9.ebuild portion - (This does not compile) src_configure() { local myconf='' use "cluster" && myconf+=" --with-ctdb-dir=/usr" use "test" && myconf+=" --enable-selftest" myconf="${myconf} \ --enable-fhs \ --sysconfdir=/etc \ --localstatedir=/var \ --with-modulesdir=/usr/$(get_libdir)/samba \ --with-pammodulesdir=/$(get_libdir)/security \ --with-piddir=/var/run/${PN} \ --disable-rpath \ --disable-rpath-install \ --nopyc \ --nopyo \ --bundled-libraries=NONE \ --builtin-libraries=NONE \ $(use_with addns dnsupdate) \ $(use_with acl acl-support) \ $(use_with ads) \ $(use_with aio aio-support) \ $(use_enable avahi) \ $(use_with cluster cluster-support) \ $(use_enable cups) \ $(use_with dmapi) \ $(use_with fam) \ $(use_enable gnutls) \ $(use_enable iprint) \ $(use_with ldap) \ --with-pam \ --with-pam_smbpass \ $(use_with quota quotas) \ $(use_with syslog) \ $(use_with winbind) " use "ads" && myconf+=" --with-shared-modules=idmap_ad" You will notice that the configure options --bundled-libraries and --builtin-libraries are set to 'NONE' I set them to 'ntdb' like the Samba-4.1.6.ebuild and everything compiled fine.
×