Jump to content

linuxbigot

Members
  • Content Count

    48
  • Joined

  • Last visited

  • Days Won

    2

Reputation Activity

  1. Trolling
    linuxbigot reacted to overkill in kde4 how to stay with it...   
    P is the "portage" overlay, I = installed
     
    You should read the manual for equery.  It's a tool you need to learn if you are going to use funtoo or gentoo.
     
     
    # man equery
  2. Trolling
    linuxbigot reacted to overkill in kde4 how to stay with it...   
    You would need to mask any version greater than the desired version.
     
    Use equery to check available versions on your box
     
    # equery l -po konsole  * Searching for konsole ... [-P-] [  ] kde-apps/konsole-4.14.3:4/4.14 [-P-] [  ] kde-apps/konsole-4.14.3-r1:4/4.14 [-P-] [  ] kde-apps/konsole-4.14.3-r2:4/4.14 [-P-] [  ] kde-apps/konsole-15.08.3:5  
    Mask anything greater than your desired version
     
    # echo ">kde-apps/konsole-4.14.3-r2" >> /etc/portage/package.mask  
    Check again with equery to make sure that there are no typos and the mask is successful.  There should be an "M" next to masked versions.
     
    # equery l -po konsole  * Searching for konsole ... [-P-] [  ] kde-apps/konsole-4.14.3:4/4.14 [-P-] [  ] kde-apps/konsole-4.14.3-r1:4/4.14 [-P-] [  ] kde-apps/konsole-4.14.3-r2:4/4.14 [-P-] [M ] kde-apps/konsole-15.08.3:5  
    Now try to install konsole again using the "ask" flag.
     
    # emerge konsole -av
  3. Trolling
    linuxbigot got a reaction from maldoror in btrfs install...   
    Absolutly right Sir !
  4. Trolling
    linuxbigot got a reaction from maldoror in btrfs install...   
    I'm plannin to install Funtoo but with btrfs: it is enough mkfs.btrfs  /dev/sda4 ?
     
    tia!
  5. Trolling
    linuxbigot reacted to j-g- in debian-sources for...   
    Sure is doable and is really easy, as installing any other kernel sources, just try putting the ebuild in your local overlay. or adding the funtoo overlay with a lower priority than ::gentoo on repos.conf, and emerging the sources, is not like a kernel has any runtime dependencies right? it is the runtime dependency to start a user space. I have never used debian-sources but I looked at the ebuild and I saw nothing there that could make it not work on gentoo, but I don't feel like trying I don't like debian-sources.
  6. Trolling
    linuxbigot reacted to iwoloschin in debian-sources for...   
    Doesn't Gentoo already have debian-sources?
     
    If not, it's probably doable, though it might take a bit of work.  You could do it manually, just download the tarball and unzip it to /usr/src/debian-sources-version-whatever and configure and go.  That's actually probably really easy, assuming you know where the tarball is.  If you don't, you could set up a local overlay and copy Funtoo's debian-sources ebuild over, set your use flags, and off you go.  You may need to copy over dependencies too, but probably not difficult to figure that out.
     
    So doable?  Sure!  Easy?  No idea!  But let us know, and tell us how you did it, because that knowledge may help someone else some day!
  7. Trolling
    linuxbigot got a reaction from duncan.britton in What Badly Pimped-out Vehicle is the Best Visual Metaphor for Systemd?   
    what bout this:
     

  8. Trolling
    linuxbigot got a reaction from aryvandaar in What Badly Pimped-out Vehicle is the Best Visual Metaphor for Systemd?   
    what bout this:
     

  9. Trolling
    linuxbigot got a reaction from Tassie_Tux in What Badly Pimped-out Vehicle is the Best Visual Metaphor for Systemd?   
    what bout this:
     

  10. Trolling
    linuxbigot got a reaction from pytony in What Badly Pimped-out Vehicle is the Best Visual Metaphor for Systemd?   
    what bout this:
     

  11. Trolling
    linuxbigot reacted to Oleg Vinichenko in avoid systemd...   
    this does not relate to 'avoiding systemd'. It tells to enable policykit USE flag for consolekit package. Are you trying to use KDE? You'll need to enable kde profile to avoid USE flag problems. 
    epro mix-in +kde
  12. Trolling
    linuxbigot got a reaction from 666threesixes666 in emerge -a www-client/firefox-bin...   
    You ROCK homies !!!
     
    I'm writin from fireshit-bin on ICEWM
     
    :emobounce:
  13. Trolling
    linuxbigot reacted to Oleg Vinichenko in emerge -a www-client/firefox-bin...   
    for this it's better to set a desktop profile, it will resolve most of USE flags problems. I suspect only core profile used here.
    epro flavor desktop
  14. Trolling
    linuxbigot reacted to 666threesixes666 in emerge -a www-client/firefox-bin...   
    The following USE changes are necessary to proceed:
    (see "package.use" in the portage(5) man page for more details)
    # required by x11-libs/gtk+-2.24.27
    # required by www-client/firefox-bin-38.0.1
    # required by www-client/firefox-bin (argument)
    =x11-libs/cairo-1.14.2 X
    # required by x11-libs/gtk+-2.24.27
    # required by www-client/firefox-bin-38.0.1
    # required by www-client/firefox-bin (argument)
    >=x11-libs/gdk-pixbuf-2.31.1 X
     
    ie add to /etc/portage/make.conf
    USE="X"
     
    or
     
    mkdir -p /etc/portage/package.use
    echo "x11-libs/cairo X" >> /etc/portage/package.use/cairo
    echo "x11-libs/gdk-pixbuf X" >> /etc/portage/package.use/gdk-pixbuf
  15. Trolling
    linuxbigot reacted to vkraven in btrfs install...   
    Some googling tells me that's a Sandy Bridge CPU. I'm not completely certain, however, if intel64-sandybridge will work since the wiki page does say Core i3/5/7, although I can't think of any reason why it shouldn't.
     
    Should you want to play it a little safer though, you could go with corei7.
  16. Trolling
    linuxbigot reacted to 666threesixes666 in btrfs install...   
    you should be able to skip the bootloader part of the install however you'll have to manually insert funtoo via debians methods of boot/grub
  17. Trolling
    linuxbigot reacted to overkill in btrfs install...   
    It's a sandybridge.  Why not http://www.funtoo.org/Intel64-sandybridge ?
×
×
  • Create New...