Jump to content
funtoo forums

ainsley31415926

Members
  • Content Count

    31
  • Joined

  • Last visited

About ainsley31415926

  • Rank
    Advanced Member

Recent Profile Visitors

517 profile views
  1. Upgraded from 1.3 to 1.4, followed each step. Now python is weird: eselect python update Switching to python3.7 eselect python list Available Python interpreters, in order of preference: [1] python3.7 [2] python3.6 [3] python2.7 emerge -C =dev-lang/python-3.6* * This action can remove important packages! In order to be safer, use * `emerge -pv --depclean <atom>` to check for reverse dependencies before * removing packages. * Not unmerging package dev-lang/python-3.6.8 since there is no valid reason * for Portage to unmerge currently used Python interpreter. emerge -pv --depclean =dev-lang/python-3.6* Calculating dependencies... done! dev-lang/python-3.6.8 pulled in by: @system requires dev-lang/python ...
  2. I may have got around this by copying /bin/rm /bin/chgrp /bin/chmod from another computer These three commands were all giving the lib/xfts.c:41: xfts_open: Assertion `errno != EINVAL' failed error
  3. The first few steps worked, I presume because everything so far updated: emerge -p gcc glibc libnsl libtirpc rpcsvc-proto These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] net-libs/libtirpc-1.0.3 [ebuild R ] net-libs/libnsl-1.2.0 [ebuild R ] net-libs/rpcsvc-proto-1.3 [ebuild R ] sys-libs/glibc-2.26-r6 [ebuild R ] sys-devel/gcc-7.3.1
  4. I followed the steps up to emerging system, but emerge fails at this point Nothing will merge and I get errors like this: chgrp: lib/xfts.c:41: xfts_open: Assertion `errno != EINVAL' failed. Even if I try to remove a file I get rm temp1 rm: lib/xfts.c:41: xfts_open: Assertion `errno != EINVAL' failed.
  5. It looks like I need to remove use flag client-libs from mariadb If I do that then dev-db/mariadb-connector-c and dev-db/mysql-connector-c Start to install with a world update
  6. hmmmmm The command my_print_defaults is installed by dev-db/mysql-connector-c But if I try to install dev-db/mysql-connector-c I get -p dev-db/mysql-connector-c These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] dev-db/mysql-connector-c-6.1.11 USE="ssl -static-libs" [blocks B ] dev-db/mysql-connector-c ("dev-db/mysql-connector-c" is blocking dev-db/mariadb-10.2.14) [blocks B ] dev-db/mariadb[client-libs(+)] ("dev-db/mariadb[client-libs(+)]" is blocking dev-db/mysql-connector-c-6.1.11) * Error: The above package list contains packages which cannot be * installed at the same time on the same system. dev-db/mariadb-10.2.14:0/18::dev-kit, installed pulled in by dev-db/mariadb required by @selected dev-db/mysql-connector-c-6.1.11:0/18::dev-kit, ebuild scheduled for merge pulled in by dev-db/mysql-connector-c
  7. I have upgraded to 1.2-prime. But now I cant start mariadb /etc/init.d/mysql: line 18: my_print_defaults: command not found
  8. I get emerge: there are no ebuilds to satisfy "=virtual/mysql-5.6-r10". eix virtual/mysql [I] virtual/mysql [1] Available versions: (~)5.5-r1 5.6-r6(0/18) (~)5.6-r7(0/18) (~)5.6-r8(0/18) 5.6-r9(0/18) {embedded minimal +server static static-libs ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32"} Installed versions: 5.6-r9(0/18)(05:59:25 PM 05/13/2018)(server -embedded -static) Description: Virtual for MySQL database server
  9. ego kit /var/git/meta-repo (updated 3 hours 36 minutes ago): kit active branch default stability core-kit 1.0-prime (same) prime core-hw-kit master (same) prime security-kit 1.0-prime (same) prime xorg-kit 1.19-prime (same) prime gnome-kit 3.20-prime (same) prime kde-kit 5.12-prime (same) prime media-kit 1.1-prime (same) prime perl-kit 5.24-prime (same) prime python-kit 3.4-prime (same) prime php-kit master (same) prime java-kit 1.1-prime (same) prime ruby-kit 1.1-prime (same) prime haskell-kit 1.1-prime (same) prime ml-lang-kit 1.2-prime (same) prime lisp-scheme-kit 1.1-prime (same) prime lang-kit 1.1-prime (same) prime llvm-kit 1.2-prime (same) prime dev-kit 1.1-prime (same) prime xfce-kit 4.12-prime (same) prime desktop-kit 1.1-prime (same) prime editors-kit master (same) prime net-kit master (same) prime text-kit master (same) prime science-kit master (same) prime games-kit master (same) prime nokit master (same) prime NOTE: This information comes from /etc/ego.conf and meta-repo metadata. After making changes to ego.conf, be sure to run ego sync in so that the individual kit repositories on disk are synchronized with the kit branches shown above. equery d dev-db/mysql * These packages depend on dev-db/mysql: virtual/libmysqlclient-18 (dev-db/mysql:0/18[client-libs(+),static-libs?,abi_x86_32(-)?,abi_x86_64(-)?,abi_x86_x32(-)?,abi_mips_n32(-)?,abi_mips_n64(-)?,abi_mips_o32(-)?,abi_ppc_32(-)?,abi_ppc_64(-)?,abi_s390_32(-)?,abi_s390_64(-)?]) virtual/mysql-5.6-r9 (=dev-db/mysql-5.6*[embedded?,server?,static?]) I did try reinstalling virtual/libmysqlclient
  10. I tried the client libraries flag both ways and a number of other options, to no affect. I also uninstalled, reinstalled virtual/mysql which did not help I eventually updated mariadb with -O and installed everything else individually The problem still remains: e -puND --tree world These are the packages that would be merged, in reverse order: Calculating dependencies... done! [nomerge ] virtual/mysql-5.6-r9 [ebuild N ] dev-db/mysql-5.6.39 USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -numa -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" [blocks B ] dev-db/mariadb ("dev-db/mariadb" is blocking dev-db/mysql-5.6.39) [blocks B ] dev-db/mysql ("dev-db/mysql" is blocking dev-db/mariadb-10.2.14) I just installed Funtoo from scratch on this machine a couple of weeks ago. Other Funtoo installs seem to have the same problem
  11. mariadb is installed but if I try to update it , emerge tries to install mysql e -pu --tree mariadb These are the packages that would be merged, in reverse order: Calculating dependencies... done! [nomerge ] dev-db/mariadb-10.2.14 [10.2.9] USE="client-libs%*" [ebuild N ] virtual/mysql-5.6-r9 USE="server -embedded -static" [ebuild N ] dev-db/mysql-5.6.39 USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -numa -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" [ebuild U ] dev-db/mariadb-10.2.14 [10.2.9] USE="client-libs%*" [blocks B ] dev-db/mariadb ("dev-db/mariadb" is blocking dev-db/mysql-5.6.39) [blocks B ] dev-db/mysql ("dev-db/mysql" is blocking dev-db/mariadb-10.2.14, dev-db/mariadb-10.2.9)
  12. AHA - I had a dependency nightmare, which I just managed to fudge my way around. After this I managed an update and those errors seem to have vanished.
  13. Have I missed something? Suddenly I am getting a whole raft of errors on several machines. eg e -puND world Calculating dependencies - * ERROR: www-client/firefox-58.0.1::net-kit failed (depend phase): * mozcoreconf-v5.eclass could not be found by inherit() * * Call stack: * ebuild.sh, line 617: Called source '/var/git/meta-repo/kits/net-kit/www-client/firefox/firefox-58.0.1.ebuild' * firefox-58.0.1.ebuild, line 32: Called inherit 'check-reqs' 'flag-o-matic' 'toolchain-funcs' 'eutils' 'gnome2-utils' 'mozconfig-v6.58' 'pax-utils' 'xdg-utils' 'autotools' 'mozlinguas-v2' * ebuild.sh, line 313: Called __qa_source '/var/git/meta-repo/kits/net-kit/eclass/mozconfig-v6.58.eclass' * ebuild.sh, line 108: Called source '/var/git/meta-repo/kits/net-kit/eclass/mozconfig-v6.58.eclass' * mozconfig-v6.58.eclass, line 29: Called inherit 'flag-o-matic' 'toolchain-funcs' 'mozcoreconf-v5' * ebuild.sh, line 290: Called die * The specific snippet of code: * [[ -z ${location} ]] && die "${1}.eclass could not be found by inherit()"
×
×
  • Create New...