Jump to content

esa1966

Members
  • Content Count

    12
  • Joined

  • Last visited

  1. Hi, Thank for the feedback about the bug. Finally, I completely crashed my Funtoo BOX :huh: because I did a lot of mistake and a revdep-rebuild erased almost all of the sbin and bin folder. I fix it very quickly with a Minimal boot cd (copy bin and sbin from the CD to the HDD). But, my XBMC didn't start due to this bug with OPENGL :( And now since several days. So, I decided to use one of my Raspberry to install XBMC (I selected OPENELEC). The XBMC was running again in less than one hour! It confirms me that a FUNTOO/GENTOO box with a graphic environment is far more complex to be
  2. Topic closed : see solution here http://forums.slimdevices.com/showthread.php?99648-Howto-build-a-self-contained-LMS&s=1b99033b65772166c641fee379c06f49
  3. Hi, You are right : if add "x11-base/xorg-server ~x86" to package.keywords Then it doesn't complain : [ebuild N ] x11-libs/libXvMC-1.0.8::gentoo USE="-static-libs" 299 KiB [ebuild N ] app-admin/eselect-1.4.5::gentoo USE="-doc -emacs -vim-syntax" 172 KiB [ebuild N ] app-eselect/eselect-xvmc-0.4::gentoo 0 KiB [ebuild N ] app-eselect/eselect-opengl-1.3.1-r3::gentoo 3 KiB [ebuild N ] x11-proto/glproto-1.4.17-r1::gentoo 124 KiB [ebuild N ] x11-misc/xkeyboard-config-2.14::gentoo 932 KiB [ebuild N ] media-libs/mesa-10.5.2::gentoo USE="classic dri3 egl
  4. Very similar configuration : epro show === Enabled Profiles: === arch: x86-32bit build: stable subarch: atom_32 flavor: workstation mix-ins: X === All inherited flavors from workstation flavor: === core (from workstation flavor) minimal (from core flavor) === All inherited mix-ins from workstation flavor: === X (from workstation flavor) audio (from workstation flavor) dvd (from workstation flavor)
  5. Hi Cardinal, I certainly installed a unstable version of a package. How can I trace the package taht want to install " >=app-eselect/eselect-opengl-1.3.0" that is unstable? I also see that "media-libs/mesa-10.5.2" want to install. Using "equery g media-libs/mesa-10.5.2" gives me : * Searching for mesa10.5.2 in media-libs ... * dependency graph for media-libs/mesa-10.5.2 `-- media-libs/mesa-10.5.2 unknown `-- app-eselect/eselect-mesa-0.0.10 (app-eselect/eselect-mesa) x86 `-- app-eselect/eselect-opengl-1.3.1-r3 (>=app-eselect/eselect-opengl-1.3.0) unknown `--
  6. Hi, Emerge World give me error. [ebuild U ] net-wireless/wireless-regdb-20150925 [20150605] [ebuild U ] dev-libs/libltdl-2.4.4 [2.4.3] [ebuild U ] media-libs/libpng-1.6.18 [1.6.16] [ebuild U ] sys-devel/libtool-2.4.4 [2.4.3-r2] [ebuild UD ] x11-libs/libdrm-2.4.59 [2.4.61] [ebuild U ] x11-libs/pixman-0.32.8 [0.32.6] [ebuild r U ] dev-libs/nettle-3.1.1 [2.7.1-r4] CPU_FLAGS_X86="-aes%" [ebuild U ] dev-libs/openssl-1.0.2d [1.0.1p] USE="asm%* -sctp%" [ebuild R ] sys-libs/readline-6.3_p8-r2 USE="-utils%" [ebuild UD ] sys-apps/attr-2.4.47-r2 [2.4.4
  7. Hi, I wonder if I can download the portage snapshot from gentoo because I don't find the Funto historical sanpshot. http://Download portage snapshot Then emerge -av --update --deep world Is it a solution to clean everything about perl 5.20? Currently, I can't do a emerge --depclean because of this : * Dependencies could not be completely resolved due to * the following required packages not being installed: * * dev-lang/perl:0/5.20=[-build(-)] pulled in by: * perl-core/File-Temp-0.230.400-r1 * * ~app-admin/apache-tools-2.2.27 pulled in by: * www-servers
  8. After 8 hours of debug with different NVIDIA drivers, I find a solution. Now, the question is why it happens ? I think I will block the next upgrade because I spend a lot of time with NVIDIA Drivers (for XBMC), PERL (for SqueezeBox). Solution with nvidia-331.113. This is an old drivers but I was able to make it running again so I place the solution : Check that all the links libGL.xxx link to the latest nvidia version : ldconfig -p | grep libGL libGLU.so.1 (libc6) => /usr/lib/libGLU.so.1 libGLU.so (libc6) => /usr/lib/libGLU.so libGLEWmx.so.1.12 (li
  9. Hi, I spend hours to find a solution but without success. Last emerge installed the NVIDIA drivers 340.76. My last working drivers was : x11-drivers/nvidia-drivers-340.58 or 340.65 (ION card support only version below 341.0.0 ). After this : GLX is no more loaded ? in Xorg.0.log I can see : (EE) Failed to load /usr/lib/xorg/modules/extensions/libglx.so: /usr/lib/xorg/modules/extensions/libglx.so$ [ 314.201] (II) UnloadModule: "glx" (EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X [ 314.223] (EE) NVIDIA(0): log file that the GLX module has b
  10. Hi, Finally, I was able to install perl 5.20 with this command : emerge -uNav world Same command than above but without the "--deep" option. # emerge -uNav world * IMPORTANT: 3 news items need reading for repository 'gentoo'. * Use eselect news to read news items. These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] sys-devel/gnuconfig-20150304 [20140212] 46 kB [ebuild U ] sys-apps/dmidecode-2.12-r1 [2.11] USE="(-selinux)" 54 kB [ebuild U ] app-portage/portage-utils-0.54 [0.53] USE="nls -static" 499 kB [ebuild U
  11. Hi, I do the following emerge : emerge --update --deep --newuse @world The result is the following : 06-04-2015 Mon Apr 6 17:50:42 CEST 2015 * IMPORTANT: 3 news items need reading for repository 'gentoo'. * Use eselect news to read news items. Calculating dependencies .. ... ............ ...... ....... .. ... ..... .. ...... done! [ebuild U ] virtual/libiconv-0-r2 [0-r1] [ebuild U ] sys-devel/gnuconfig-20150304 [20140212] [ebuild U ] sys-libs/timezone-data-2015a [2014j] [ebuild U ] sys-apps/dmidecode-2.12-r1 [2.11] [ebuild R ] app-arch/cabextract-1.4 USE="-extras% (-extra-tools%)" [eb
  12. Hi, I have squeezeboxserver installed that use perl 5.18. Now, I think it could also use perl 5.20. When I do an upgrade world, I have : !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.20.1-r4::gentoo, ebuild scheduled for merge) pulled in by =dev-lang/perl-5.20* required by (virtual/perl-Scalar-List-Utils-1.380.0::gentoo, ebuild scheduled for merge) (and 33 more with the same problem) (dev-lang/perl-5.18.2-r2::gentoo, ebuild scheduled for merge)
×
×
  • Create New...