Jump to content
funtoo forums

musicweb

Members
  • Content Count

    6
  • Joined

  • Last visited

  1. Good points.... thanks for the input. We are also thinking of a new server instead, as ours is over 12 years old.
  2. Question..... If I set up a hard drive here in the USA, and install Funtoo on it, then send the drive to Canada, will the OS recognize the new server it will be installed in and reconfigure itself?
  3. Is it possible to get a portage ebuild and put it in the sys-apps folder that will work with my x86? Can I download such a file somewhere? Problem is.... I'm in the USA and the server is in Canada.
  4. So why are there 2 portages in sys-apps that are not listed on the portage site as stable for my system? If I'm running x86 system, why are there no supported files in the portage tree?
  5. tried that.... emerge --sync --- EAPI '0' does not support 'use.stable.mask': '/usr/portage/profiles/base/use.stable.mask' --- EAPI '0' does not support 'package.use.stable.mask': '/usr/portage/profiles/base/package.use.stable.mask' --- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0' >>> Starting git pull... remote: Counting objects: 791, done. remote: Compressing objects: 100% (373/373), done. Receiving objects: 100% (791/791), 196.00 KiB, done. remote: Total 791 (delta 513), reused 690 (delta 412) Resolving deltas: 100% (513/513), completed with 268 local objects. From git://github.com/funtoo/ports-2012 e1ba0b1..cd61900 funtoo.org -> origin/funtoo.org Updating e1ba0b1..cd61900 Fast-forward >>> Git pull in /usr/portage successful --- EAPI '0' does not support 'use.stable.mask': '/usr/portage/profiles/base/use.stable.mask' --- EAPI '0' does not support 'package.use.stable.mask': '/usr/portage/profiles/base/package.use.stable.mask' --- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0' * An update to portage is available. It is _highly_ recommended * that you update portage now, before any other packages are updated. * To update portage, run 'emerge --oneshot portage' now. and... emerge -avuND world --- EAPI '0' does not support 'use.stable.mask': '/usr/portage/profiles/base/use.stable.mask' --- EAPI '0' does not support 'package.use.stable.mask': '/usr/portage/profiles/base/package.use.stable.mask' --- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0' * IMPORTANT: 3 news items need reading for repository 'gentoo'. * Use eselect news to read news items. These are the packages that would be merged, in order: Calculating dependencies | !!! Problem resolving dependencies for sys-apps/file from @system ... done! !!! The ebuild selected to satisfy "sys-apps/file" has unmet requirements. - sys-apps/file-5.22-r1000::gentoo USE="python zlib -python_abis_2.6 -python_abis_2.7 -python_abis_2.7-pypy -python_abis_3.1 -python_abis_3.2 -python_abis_3.2-pypy -python_abis_3.3 -python_abis_3.4 (-python_abis_3.5) -static-libs" The following REQUIRED_USE flag constraints are unsatisfied: python? ( any-of ( python_abis_2.6 python_abis_2.7 python_abis_3.1 python_abis_3.2 python_abis_3.3 python_abis_3.4 python_abis_3.5 python_abis_2.7-pypy python_abis_3.2-pypy ) ) (dependency required by "@system" [set]) (dependency required by "@world" [argument]) also tried.... emerge --oneshot portage --- EAPI '0' does not support 'use.stable.mask': '/usr/portage/profiles/base/use.stable.mask' --- EAPI '0' does not support 'package.use.stable.mask': '/usr/portage/profiles/base/package.use.stable.mask' --- Invalid atom in /usr/portage/profiles/base/package.use.force: Slot deps are not allowed in EAPI 0: 'app-shells/bash:0' * IMPORTANT: 3 news items need reading for repository 'gentoo'. * Use eselect news to read news items. Calculating dependencies... done! !!! All ebuilds that could satisfy "portage" have been masked. !!! One of the following masked packages is required to complete your request: - sys-apps/portage-2.3.7::gentoo (masked by: package.mask, mirror in RESTRICT) - sys-apps/portage-2.3.6-r9::gentoo (masked by: package.mask, mirror in RESTRICT) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook.
  6. We are trying to update our server. It hasn't been done in almost 2 years because it was offline for personal reasons. When trying to update through normal Gentoo channels, we get errors.... and the guys on the Gentoo forum say it's a Funtoo problem. So here we are.... When I try to fix portage, I get this: wmmw ~ # cd /tmp wmmw tmp # wget https://www.github.com/funtoo/portage-funtoo/tarball/funtoo-2.3.6-r2 --2015-01-10 07:26:45-- https://www.github.com/funtoo/portage-funtoo/tarball/funtoo-2.3.6-r2 Resolving www.github.com... 192.30.252.131 Connecting to www.github.com|192.30.252.131|:443... connected. HTTP request sent, awaiting response... 301 Moved Permanently Location: https://github.com/funtoo/portage-funtoo/tarball/funtoo-2.3.6-r2 [following] --2015-01-10 07:26:45-- https://github.com/funtoo/portage-funtoo/tarball/funtoo-2.3.6-r2 Resolving github.com... 192.30.252.131 Connecting to github.com|192.30.252.131|:443... connected. HTTP request sent, awaiting response... 302 Found Location: https://codeload.github.com/funtoo/portage-funtoo/legacy.tar.gz/funtoo-2.3.6-r2 [following] --2015-01-10 07:26:45-- https://codeload.github.com/funtoo/portage-funtoo/legacy.tar.gz/funtoo-2.3.6-r2 Resolving codeload.github.com... 192.30.252.147 Connecting to codeload.github.com|192.30.252.147|:443... connected. HTTP request sent, awaiting response... 200 OK Length: unspecified [application/x-gzip] Saving to: `funtoo-2.3.6-r2' [ <=> ] 1,049,943 582K/s in 1.8s 2015-01-10 07:26:48 (582 KB/s) - `funtoo-2.3.6-r2' saved [1049943] wmmw tmp # tar xf funtoo-2.3.6-r2 wmmw tmp # cd funtoo-portage-funtoo-e491673 wmmw funtoo-portage-funtoo-e491673 # rm -rf /usr/lib/portage/* wmmw funtoo-portage-funtoo-e491673 # cp -a bin pym /usr/lib/portage/ wmmw funtoo-portage-funtoo-e491673 # ln -s /usr/lib/portage/bin/emerge /usr/bin/emerge ln: failed to create symbolic link ?/usr/bin/emerge?: File exists Any ideas as to why?
×
×
  • Create New...