Jump to content
funtoo forums

gumtree.jack

Members
  • Content Count

    15
  • Joined

  • Last visited

  • Days Won

    1

gumtree.jack last won the day on September 3 2016

gumtree.jack had the most liked content!

1 Follower

About gumtree.jack

  • Rank
    Member

Personal

  • Location
    Poland
  1. Sandro: Thanks for idea with irc channel, I will join soon. If we are talking about backup app I dont care what its will be. My goal is to make start point of my fresh funtoo instalation(doing everthing again is suicide :) ). I was trying kbackup (after finish copying files he was finishing for few hours (teoretycy he was comperssing so I left it for night but it didnt finish so I cancel it and everything was gone), then obnam - I didnt see he was finish - just stop in some moment :/. Im ready to try all available apps to make my start point. If u guys can advise me simple automatic(perfect I would be if I dont have to choose folderst to dont miss something important) backup app to make my start point I will be grateful. I was thinking about mondorescue or filezilla but I have windows and funtoo lvm encrypted system on 1.8TB disk - can I make a live dvd with it? cardinal: I recompile libsecret with +vala +introspection USE flags and emerge deja-dup with no problems :) thanks for that. After years with debian stable funtoo/portage world is very new and weird :P
  2. Im trying to backup my fresh funtoo system to dont have to do all that thing ever again :) I wish to install deja-dup but portage says NO. emerge app-backup/deja-dup Calculating dependencies... done! emerge: there are no ebuilds built with USE flags to satisfy "app-crypt/libsecret[vala]". !!! One of the following packages is required to complete your request: - app-crypt/libsecret-0.18.5::gentoo (Change USE: +vala, this change violates use flag constraints defined by app-crypt/libsecret-0.18.5: 'vala? ( introspection )') (dependency required by "app-backup/deja-dup-34.2::gentoo" [ebuild]) (dependency required by "app-backup/deja-dup" [argument]) Any ideas?
  3. egencache --update-use-local-desc usage: egencache [options] <action> ... [atom] ... egencache: error: --repo option is required I had to add missing --repo gentoo and its emerging so should be ok :) Thanks But btw is it portage issue? Sometimes I cant emerge some apps because portage errors and I dont know should I reported everything as a bug, post it here or do something else?
  4. Hi Guys, Im trying to install p7zip and portage refuse cooperation. emerge p7zip Calculating dependencies \ !!! Problem resolving dependencies for app-arch/p7zip ... done! !!! The ebuild selected to satisfy "p7zip" has unmet requirements. - app-arch/p7zip-16.02-r1::gentoo USE="kde pch -doc -rar (-static) -wxwidgets" ABI_X86="-x32" The following REQUIRED_USE flag constraints are unsatisfied: kde? ( wxwidgets ) Is it a bug to report or I can do something from my site?
  5. I fighting with new system few days now and still cant fix few fings. In Device notifier when I plug usb disk I cannot open it. Dosent matter usb disk, flash disk - nothing. Im not authorized to mount this device. But when I open dolphin I can open it by one click (but then its open so many thimes how many times I klick it in device notifier. Im in usb plugdev and disk groups. I dont have more ideas what to do. Mayby some of U had same problem or just know where to fix it , feel free to help :)
  6. Hello, I'm back :) After some time I decided to give another chance to funtoo and I crashed in the same moment. I start read and try diffrent things and finally I DID IT :) So short version what I did, mayby someone will have the same problem: - add "iommu=soft" in kernel params line in /etc/boot.conf (nothing change but I left it like that) - recompile debian-sources by genkernel and add support for IOMMU and xHCI HCD (USB 3.0) support <*> EHCI HCD (USB 2.0) support < > OHCI HCD support <*> UHCI I have checked everything and now it works on new kernel and Im happy Funtoo user :D Cheers
  7. I dont have installed x11-drivers/xf86-input-evdev. Ive just installed base system from: http://www.funtoo.org/Install http://www.funtoo.org/Rootfs_over_encrypted_lvm and its first reboot after building debian-sources, boot-update etc. It looks like kernel cant use this keyboard. Its verry weird, grub knows what to do but krenel dont. I can try install x serwer and x11-drivers/xf86-input-evdev under chroot if there is chance to fix this.
  8. I was installing Funtoo with full disk enryption for current corei7: http://www.funtoo.org/Rootfs_over_encrypted_lvm Everything went ok, but keybord stop work after grub like it was unpluged. In grub one of the light is shining and when I push enter button Im stopping counting. Jutst after this light is turning off and I cant type password to my disk. Ive install linux-firmware but mayby I shoul install something more or put somethin in to boot sequence? Any ideas?
  9. I was doing stable installation with Funtoo Install guide. I tried current branch for i7 and kernel compiled without any problems so it must be a bug. Now I have other problem :)
  10. Im making fresh install and I have problem before building the kernel. After emerge -1 @kernel command there are installing depences like cryptsetup but it faild because it cannot find kernel in /usr/src/linux. Sounds logical because kernel will be next to install. Is it a bug or Im doing something bad? /usr/lib64/libgcrypt.so.20: undefined reference to `gpg_err_code_from_syserror@GPG_ERROR_1.0' /usr/lib64/libgcrypt.so.20: undefined reference to `gpg_err_code_from_errno@GPG_ERROR_1.0' /usr/lib64/libgcrypt.so.20: undefined reference to `gpg_err_set_errno@GPG_ERROR_1.0' /usr/lib64/libgcrypt.so.20: undefined reference to `gpg_strsource@GPG_ERROR_1.0' /usr/lib64/libgcrypt.so.20: undefined reference to `gpg_strerror@GPG_ERROR_1.0' collect2: error: ld returned 1 exit status make[2]: *** [veritysetup] Error 1 make[2]: *** Waiting for unfinished jobs.... make[2]: Leaving directory `/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5/src' make[1]: *** [all-recursive] Error 1 make[1]: Leaving directory `/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5' make: *** [all] Error 2 * ERROR: sys-fs/cryptsetup-1.6.5 failed (compile phase): * emake failed * * If you need support, post the output of `emerge --info '=sys-fs/cryptsetup-1.6.5'`, * the complete build log and the output of `emerge -pqv '=sys-fs/cryptsetup-1.6.5'`. * The complete build log is located at '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/temp/environment'. * Working directory: '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5' * S: '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5' >>> Failed to emerge sys-fs/cryptsetup-1.6.5, Log file: >>> '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/temp/build.log' * Messages for package sys-fs/cryptsetup-1.6.5: * Unable to find kernel sources at /usr/src/linux * Unable to calculate Linux Kernel version for build, attempting to use running version * ERROR: sys-fs/cryptsetup-1.6.5 failed (compile phase): * emake failed * * If you need support, post the output of `emerge --info '=sys-fs/cryptsetup-1.6.5'`, * the complete build log and the output of `emerge -pqv '=sys-fs/cryptsetup-1.6.5'`. * The complete build log is located at '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/temp/environment'. * Working directory: '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5' * S: '/var/tmp/portage/sys-fs/cryptsetup-1.6.5/work/cryptsetup-1.6.5'
  11. Thanks a lot :) it would be good to put it on official server for other interested people.
  12. Thanks for advise :) Like always life isnt simple. Metro seems to be best solution but I have to had funtoo first :) what about funtoo-current with ACCEPT_KEYWORDS="amd64"? There will be no dependence problem, new packages from current I start cover witch older from stable?
  13. But -march=core2 will be better than -march=atom for intel atom cpu? Or if I take core2_64 I cant change cflag on any other because there more differences between builds?
  14. Hi, Im gonna install Funtoo on my intel atom n450 but stable build. And I've a problem because funtoo-stable have only amd64-k8/ core2_64/ generic_64/ I was reading http://www.funtoo.org/Subarches#64-bit_Intel_Processors and I should take atom_64 but its only in funtoo-current. So what now? Download one of them and change cflag on -march=atom?
  15. Hi everyone, Im trying to start my advanture with Funtoo but Ive problem on the beginning. Just after I type: (chroot) # emerge --sync (chroot) # emerge -auDN @world there is an error in emerge. I have no idea why. Did you see anything like that? * Messages for package app-accessibility/at-spi2-core-2.12.0: * ERROR: app-accessibility/at-spi2-core-2.12.0 failed (configure phase): * econf failed * * Call stack: * ebuild.sh, line 93: Called src_configure * environment, line 2817: Called gnome2_src_configure '--disable-xevie' '--enable-introspection' '--enable-x11' * environment, line 2008: Called econf '--docdir=/usr/share/doc/at-spi2-core-2.12.0' '--disable-gtk-doc' '--disable-xevie' '--enable-introspection' '--enable-x11' * phase-helpers.sh, line 521: Called die * The specific snippet of code: * die "econf failed" * * If you need support, post the output of `emerge --info '=app-accessibility/at-spi2-core-2.12.0'`, * the complete build log and the output of `emerge -pqv '=app-accessibility/at-spi2-core-2.12.0'`. * The complete build log is located at '/var/tmp/portage/app-accessibility/at-spi2-core-2.12.0/temp/build.log'. * The ebuild environment file is located at '/var/tmp/portage/app-accessibility/at-spi2-core-2.12.0/temp/environment'. * Working directory: '/var/tmp/portage/app-accessibility/at-spi2-core-2.12.0/work/at-spi2-core-2.12.0' * S: '/var/tmp/portage/app-accessibility/at-spi2-core-2.12.0/work/at-spi2-core-2.12.0'
×
×
  • Create New...