Jump to content
funtoo forums

mlinuxgada

Members
  • Content Count

    11
  • Joined

  • Last visited

  • Days Won

    2

Everything posted by mlinuxgada

  1. mlinuxgada

    Funtoo release model

    Hi Guys, Yesterday I decided to switch to 1.3 rel. After syncing, some packages were marked for downgrade. I've red the "Upgrade to 1.3" notes, several discussions, etc ... My questions are: - whats the funtoo release model - rolling or some sort of freeze releases, with some marked as LTS - is there a way to be/stay always in current, eg to use as before, as a rolling distro Regards, M.
  2. mlinuxgada

    Funtoo release model

    @lazlo.vii You know, it will be much better if you at least try to be polite, right? @drobbins Back to the topic - if you want to get more and more involved into funtoo dev - isnt it better to have current/dev branch? If you want devs, isnt it a must to have at least dev branch,where they can work with ?! I mean, some of the major distros release based models have that : - Debian has unstable/sid -> testing ... -> stable release major/minor releases - FreeBSD has current -> release -> .. stable I still don't get it with removing current branch. Do releases, implement whatever process you think its best for you. But keep the current. Or, explain how it can be done.
  3. mlinuxgada

    Funtoo release model

    About doing smth, well, some do, me included. Small, but here and there. The question is more about the direction things are going. We all know release model is much easier than rolling distro. One of the reasons I jumped on Gentoo/long time ago/ then on Funtoo is the rolling model. Some of the others are that its source based, slots, alot of customisation/flags ... etc. My point is - today you decide to switch from rolling to release, eg no current, just freezed releases. Tomorrow nothing stops you from source based to package/bin oriented ? Maybe Debian clone /one of dozens/ ? Dont get me wrong. I use funtoo not geeky weekends, where I can spend whole day install/reinstall/fiddle with this or that. My workstation is build on Funtoo. My work depends on Funtoo. If some1 decides to flip a coin and make a decision, when I am not sure about the general direction ... I can install a Debian/Manjaro in minutes, but I dont want to. I want Funtoo as it was for years - just to have current.
  4. mlinuxgada

    Funtoo release model

    Quick note: I used current all the time. Atm there is no current, thats the problem for me. So ... funtoo imao is not a rolling distro anymore.
  5. mlinuxgada

    Funtoo release model

    Hi @pfl, So, in short there is no way atm to use current, right? Also, dunno whats the problem half of the users/or even more/ to use current. Thats one of the reasons to use rolling release distro. Maybe, if there is really no way to stay in current, I will stop using Funtoo. Feel sad, before Funtoo used Gentoo, SourceMage, Lunar ... source based distros are fun to use in fact. Thanks anyway.
  6. mlinuxgada

    MySQL 5.7.* install issues

    When I skipped the header checks, all went good, the server is up and running ok. Will keep that ebuild for me /obviously I didnt make it quite right/. Will dig into the docs, to see how its the correct way. Thanks, you can close the topic
  7. mlinuxgada

    MySQL 5.7.* install issues

    Hi, Currently I am using the layman mysql, its 5.7.12 atm. But it not upped in months. I tried to fiddle with the ebuilds - copied the latest one as mysql-5.7.15.ebuild, - ebuild mysql-5.7.15.ebuild manifest all went just fine, but at the end I receive : -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/mysql/magic -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/aclocal/mysql.m4 -- Installing: /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/share/mysql/mysql.server * Making Convenience links for mysqlcheck multi-call binary * Building default my.cnf (5.6) * Adjusting to prefix / * my.cnf.ok ... [ ok ] * Creating initial directories * Including support files and sample configurations * Header files have changed between ABIs. * --- /var/tmp/portage/dev-db/mysql-5.7.15/temp/.multilib_header_cksum 2016-10-18 19:31:00.892131266 +0300 * +++ /var/tmp/portage/dev-db/mysql-5.7.15/temp/.multilib_header_cksum.new 2016-10-18 19:31:06.632131397 +0300 * @@ -10,6 +10,7 @@ * 931919434 13470 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_command.h * 2987720505 1384 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/thread_type.h * 39760184 13897 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/plugin_audit.h.pp * +2782043840 1443 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysqlx_version.h * 4220503078 1489 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_thd_engine_lock.h * 1955776921 14902 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/sql_state.h * 1175938711 1506 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/my_list.h * @@ -43,6 +44,7 @@ * 3200460594 26101 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/plugin.h * 819488767 2682 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_thread_scheduler.h * 3234572590 2760 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/service_mysql_alloc.h * +947087210 2791 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysqlx_error.h * 4221559651 2821 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/my_xml.h * 3848574317 2837 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/mysql/psi/mysql_sp.h * 1075151809 2878 /var/tmp/portage/dev-db/mysql-5.7.15/image/usr/include/mysql/sslopt-longopts.h * ERROR: dev-db/mysql-5.7.15::x-portage failed (install phase): * Header checksum mismatch, aborting. * My USE flags atm are: [root@tangra][/usr/local/portage/dev-db/mysql]# emerge -pv mysql These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-db/mysql-5.7.15:0/20::x-portage [5.7.11:0/20::mysql] USE="openssl perl server -debug -embedded -extraengine -jemalloc -latin1 -libressl -profiling (-selinux) -static -static-libs -systemtap -tcmalloc {-test} -yassl" ABI_X86="32 (64) (-x32)" 0 KiB Total: 1 package (1 upgrade), Size of downloads: 0 KiB * IMPORTANT: 9 news items need reading for repository 'gentoo'. * Use eselect news read to view new items. [root@tangra][/usr/local/portage/dev-db/mysql emerge --info -> http://pastebin.com/d5Z0vJA8 I guess I am doing smth wrong /obviously/. How can I proceed from there? Thanks.
  8. mlinuxgada

    MySQL 5.7.* install issues

    http://pastebin.com/9813E1hd
  9. Hi, As mentioned in the title, my X stopped working after upping nvidia drivers + the kernel to the latest. Before that everything was fine Info needed: emerge --info -> http://pastebin.com/67tcuyqX emerge -pv gentoo-sources nvidia-drivers -> http://pastebin.com/DvyvtsiX cat /etc/X11/xorg.conf -> http://pastebin.com/4mZ2vWVC The .xinitrc file content : mlinuxgada@Odin ~ $ cat .xinitrc xrandr --setprovideroutputsource modesetting NVIDIA-0 xrandr --auto setxkbmap -layout 'us,bg' -variant ',phonetic' -option 'grp:alt_shift_toggle,grp_led:scroll' xset -dpms #exec ck-launch-session startxfce4 #exec ck-launch-session enlightenment_start exec ck-launch-session dbus-launch --sh-syntax --exit-with-session openbox-session #exec ck-launch-session dbus-launch --sh-syntax --exit-with-session awesome #exec ck-launch-session dbus-launch --sh-syntax --exit-with-session i3 #exec ck-launch-session dbus-launch --sh-syntax --exit-with-session xmonad The lspci | egrep 'VGA|3D' output: Odin ~ # lspci | egrep 'VGA|3D' 00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06) 07:00.0 3D controller: NVIDIA Corporation GK208M [GeForce GT 740M] (rev a1) Odin ~ # Tried to switch back to 3.16 + the old nvidia-drivers, no result. When starting X, via startx command I get smth , eg on the tty6 I see that some apps are starting/even no X is visible on the laptop display, but the laptop lcd is black. Do I need some firmware or smth ?
  10. The problem was alittle complicated - bios upgrade / on lower version kernels I had strange CPU0 offs/, firmware + got it working only on gentoo-sources-3.17.8-r1 ... On upper versions, eg 3.18+ its not fine, as on 3.16* Now all fine. Wireless stopped/using same kernel config / but its smth with the firmware I guess.
  11. Yah, I followed those docs, it was working for several months.
  12. Forgot to define the newer xorg.conf file content -> http://pastebin.com/utKTnWu7
  13. After rebuilding almost everything xorg modules/firmware/server related, I get a blank screen. Xorg is working, just the screen is black In my .xinitrc I use -> xrandr > /tmp/xrandr to be able to see what screens are seen after X is started. I get: Screen 0: minimum 8 x 8, current 8 x 8, maximum 16384 x 16384 The latest Xorg.0.log is -> http://pastebin.com/Ufc7xpUf. Do I need custom EDID ? Also, in the log there are some screens there, except Screen0: [ 777.818] (II) modesetting(G0): Output eDP-1-0 has no monitor section [ 777.819] (II) modesetting(G0): Output VGA-1-0 has no monitor section [ 777.819] (II) modesetting(G0): Output HDMI-1-0 has no monitor section [ 777.819] (II) modesetting(G0): EDID for output eDP-1-0 But xrandr in the .xinitrc file, which logs the output cannot see them. Do I need to define some options, like resolution etc, like in a normal xorg.conf file ?
  14. Yes, its compiled and loaded: Odin ~ # lsmod | grep nvidia nvidia 8314138 0 Odin ~ #
  15. Nothing from the above suggestions worked - rebuild @x11-modules-rebuid, played with xrandr .. Nvidia is listed as a xrandr provider, after starting X I get blank screen. The resolution is set to 8x8. Nvm, mark that thread as closed. Maybe the problem is somewhere in the firmware or smth like that. Thanks all for replies ;-)
  16. Sure, here is the /var/log/Xorg.0.log -> http://pastebin.com/7675dwUi
×