Jump to content
funtoo forums

leeflemingster

Members
  • Content Count

    10
  • Joined

  • Last visited

  1. I've added the following to /etc/portage/package.use but the block is still there. www-client/firefox-bin -pulseaudio # emerge -auND world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] sys-fs/exfat-utils-1.3.0 [ebuild R ] x11-libs/libdrm-2.4.94 VIDEO_CARDS="-nouveau*" [ebuild N ] sys-fs/fuse-common-3.2.6 [ebuild N ] sys-fs/fuse-2.9.8 USE="-examples -static-libs" [ebuild N ] sys-fs/fuse-exfat-1.3.0 [ebuild R ] media-libs/mesa-18.2.8 USE="-opencl* -vdpau*" [ebuild R ] x11-base/xorg-drivers-1.20 VIDEO_CARDS="-nouveau*" [ebuild U ] app-editors/vim-core-8.1.1248 [8.1.1170] [ebuild R ] gnome-base/gsettings-desktop-schemas-3.28.1 USE="introspection*" [ebuild R ] media-libs/graphene-1.8.2 USE="introspection*" [ebuild R ] net-libs/libsoup-2.64.2 USE="introspection*" [ebuild U ] app-editors/vim-8.1.1248 [8.1.1170] [ebuild R ] media-libs/libsdl2-2.0.9 USE="-pulseaudio*" [ebuild R ] dev-libs/libgudev-232 USE="introspection*" [ebuild R ] virtual/libgudev-232 USE="introspection*" [ebuild R ] net-dns/avahi-0.7-r4 USE="introspection*" [ebuild R ] media-libs/gstreamer-1.14.4 USE="introspection*" [ebuild R ] media-libs/gst-plugins-base-1.14.4-r1 USE="introspection*" [ebuild R ] media-video/ffmpeg-3.4.5 USE="-pulseaudio*" [ebuild R ] www-client/chromium-71.0.3578.30 USE="-pulseaudio*" [ebuild R ] x11-libs/gtk+-2.24.32-r1 USE="introspection*" [ebuild R ] www-client/firefox-bin-64.0 USE="-pulseaudio*" [ebuild U ] sys-libs/pam-1.3.1.20190226 [1.3.0-r3] USE="nullok%* sha512%* -minimal% -mktemp% -pam_krb5% -pam_ssh% -passwdqc% -securetty% -static-libs%" [ebuild U ] sys-auth/pambase-20190426 [20150213-r3] USE="-nullok* -sha512*" [blocks b ] <sys-auth/pambase-20190426 ("<sys-auth/pambase-20190426" is blocking sys-libs/pam-1.3.1.20190226) [ebuild R ] sys-auth/polkit-0.115-r1 USE="introspection*" [ebuild R ] sys-fs/udisks-2.7.6 USE="introspection*" [ebuild R ] sys-power/upower-0.99.9.20181025 USE="introspection*" [ebuild R ] lxqt-base/lxqt-panel-0.13.0 USE="-pulseaudio*" Would you like to merge these packages? [Yes/No]
  2. Thanks. Removing the gfxcard-nvidia mix-in has fixed the nvidia problem. As for the blocking package, I don't appear to have apulse installed and pulseaudio is already installed. # emerge -C media-sound/apulse * This action can remove important packages! In order to be safer, use * `emerge -pv --depclean <atom>` to check for reverse dependencies before * removing packages. --- Couldn't find 'media-sound/apulse' to unmerge. >>> No packages selected for removal by unmerge # emerge -a pulseaudio These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] media-sound/pulseaudio-12.2 [ebuild N ] media-plugins/alsa-plugins-1.1.7-r1 USE="ffmpeg mix pulseaudio usb_stream -arcam_av -debug -jack (-libav) -libsamplerate -oss -speex" The following USE changes are necessary to proceed: (see "package.use" in the portage(5) man page for more details) # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by pulseaudio (argument) >=media-plugins/alsa-plugins-1.1.7-r1 pulseaudio Would you like to add these changes to your config files? [Yes/No] I have removed the pulseaudio use flag and uninstalled alsa-plugins, but it is trying to reinstall alsa-plugins. # emerge -auND world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] sys-fs/exfat-utils-1.3.0 [ebuild R ] x11-libs/libdrm-2.4.94 VIDEO_CARDS="-nouveau*" [ebuild N ] sys-fs/fuse-common-3.2.6 [ebuild N ] sys-fs/fuse-2.9.8 USE="-examples -static-libs" [ebuild N ] sys-fs/fuse-exfat-1.3.0 [ebuild R ] media-libs/mesa-18.2.8 USE="-opencl* -vdpau*" [ebuild R ] x11-base/xorg-drivers-1.20 VIDEO_CARDS="-nouveau*" [ebuild U ] app-editors/vim-core-8.1.1248 [8.1.1170] [ebuild R ] gnome-base/gsettings-desktop-schemas-3.28.1 USE="introspection*" [ebuild R ] media-libs/graphene-1.8.2 USE="introspection*" [ebuild R ] net-libs/libsoup-2.64.2 USE="introspection*" [ebuild U ] app-editors/vim-8.1.1248 [8.1.1170] [ebuild R ] media-libs/libsdl2-2.0.9 USE="-pulseaudio*" [ebuild R ] dev-libs/libgudev-232 USE="introspection*" [ebuild R ] virtual/libgudev-232 USE="introspection*" [ebuild NS ] sys-kernel/debian-sources-lts-4.9.168_p1 [4.9.161_p1] USE="binary -ec2 -sign-modules" [ebuild R ] net-dns/avahi-0.7-r4 USE="introspection*" [ebuild R ] media-libs/gstreamer-1.14.4 USE="introspection*" [ebuild R ] media-libs/gst-plugins-base-1.14.4-r1 USE="introspection*" [ebuild R ] media-video/ffmpeg-3.4.5 USE="-pulseaudio*" [ebuild R ] www-client/chromium-71.0.3578.30 USE="-pulseaudio*" [ebuild R ] x11-libs/gtk+-2.24.32-r1 USE="introspection*" [ebuild N ] media-plugins/alsa-plugins-1.1.7-r1 USE="ffmpeg mix pulseaudio usb_stream -arcam_av -debug -jack (-libav) -libsamplerate -oss -speex" [ebuild U ] sys-libs/pam-1.3.1.20190226 [1.3.0-r3] USE="nullok%* sha512%* -minimal% -mktemp% -pam_krb5% -pam_ssh% -passwdqc% -securetty% -static-libs%" [ebuild U ] sys-auth/pambase-20190426 [20150213-r3] USE="-nullok* -sha512*" [blocks b ] <sys-auth/pambase-20190426 ("<sys-auth/pambase-20190426" is blocking sys-libs/pam-1.3.1.20190226) [ebuild R ] sys-auth/polkit-0.115-r1 USE="introspection*" [ebuild R ] sys-fs/udisks-2.7.6 USE="introspection*" [ebuild R ] sys-power/upower-0.99.9.20181025 USE="introspection*" [ebuild R ] lxqt-base/lxqt-panel-0.13.0 USE="-pulseaudio*" The following USE changes are necessary to proceed: (see "package.use" in the portage(5) man page for more details) # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by www-client/firefox-bin-64.0::net-kit[pulseaudio] # required by @selected # required by @world (argument) >=media-plugins/alsa-plugins-1.1.7-r1 pulseaudio Would you like to add these changes to your config files? [Yes/No]
  3. I've just found the problem. When loggin into bugs.funtoo.org the username is case sensitive and has to be all lower case. When loggin into forums.funtoo.org the username is not case sensitive.
  4. Correct. I can not log into code.funtoo.org. I even logged out of the forum and back in to make sure it wasn't something silly like using the wrong password.
  5. Tried that but it just redirects me to https://www.funtoo.org/Welcome after login in. I've also looked thorough the settings for 2FA, but can't find anything.
  6. I don't appear to be able to create an account on bugs.funtoo.org. When I go to request an account it just says. Contact Site Administrators Your Jira administrator has not yet configured this contact form.
  7. None of these solutions appear to work. My /etc/portage/package.mask is now just. >x11-drivers/nvidia-drivers-340.107 The --noreplace option gives. # emerge -av --noreplace "=x11-drivers/nvidia-drivers-340.107" These are the packages that would be merged, in order: Calculating dependencies... done! Total: 0 packages, Size of downloads: 0 KiB The exclude option gives. # emerge -avuDN world --exclude=x11-drivers/nvidia-drivers These are the packages that would be merged, in order: Calculating dependencies... done! !!! All ebuilds that could satisfy ">=x11-drivers/nvidia-drivers-347.09" have been masked. !!! One of the following masked packages is required to complete your request: - x11-drivers/nvidia-drivers-410.93::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-410.73::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-410.66::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-410.57-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-396.54::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-396.45-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-396.45::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-396.24-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-390.87::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-390.77-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-390.77::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-390.67::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-387.34::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-381.22-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-378.13-r1::core-hw-kit (masked by: package.mask) - x11-drivers/nvidia-drivers-375.82::core-hw-kit (masked by: package.mask) (dependency required by "media-video/nvidia_video_sdk-6.0.1::media-kit" [ebuild]) (dependency required by "media-video/ffmpeg-3.4.5::media-kit[encode,nvenc]" [ebuild]) (dependency required by "media-plugins/alsa-plugins-1.1.7-r1::media-kit" [installed]) (dependency required by "media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa]" [installed]) (dependency required by "lxqt-base/lxqt-panel-0.13.0::desktop-kit[volume,pulseaudio]" [installed]) (dependency required by "lxqt-base/lxqt-meta-0.13.0::desktop-kit" [installed]) (dependency required by "@selected" [set]) (dependency required by "@world" [argument]) For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. But there are clearly packages that should be emerged that don't depend on the later drivers. # emerge -uDaN world These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] sys-fs/exfat-utils-1.3.0 [ebuild R ] x11-libs/libdrm-2.4.94 VIDEO_CARDS="-nouveau*" [ebuild N ] sys-fs/fuse-common-3.2.6 [ebuild N ] sys-fs/fuse-2.9.8 USE="-examples -static-libs" [ebuild N ] sys-fs/fuse-exfat-1.3.0 [ebuild N ] virtual/opencl-0-r5 VIDEO_CARDS="nvidia -amdgpu -i965" [ebuild R ] media-libs/x264-0.0.20170701 USE="opencl*" [ebuild R ] x11-base/xorg-drivers-1.20 VIDEO_CARDS="-nouveau*" [ebuild U ] app-editors/vim-core-8.1.1248 [8.1.1170] [ebuild R ] gnome-base/gsettings-desktop-schemas-3.28.1 USE="introspection*" [ebuild R ] media-libs/graphene-1.8.2 USE="introspection*" [ebuild R ] net-libs/libsoup-2.64.2 USE="introspection*" [ebuild U ] app-editors/vim-8.1.1248 [8.1.1170] [ebuild R ] dev-libs/libgudev-232 USE="introspection*" [ebuild R ] virtual/libgudev-232 USE="introspection*" [ebuild NS ] sys-kernel/debian-sources-lts-4.9.168_p1 [4.9.161_p1] USE="binary -ec2 -sign-modules" [ebuild R ] net-dns/avahi-0.7-r4 USE="introspection*" [ebuild R ] media-libs/gstreamer-1.14.4 USE="introspection*" [ebuild R ] media-libs/gst-plugins-base-1.14.4-r1 USE="introspection*" [ebuild R ] x11-libs/gtk+-2.24.32-r1 USE="introspection*" [ebuild U #] x11-drivers/nvidia-drivers-410.93 [340.107] USE="driver%* gtk3%* kms%* uvm%* -compat% -wayland%" [ebuild N ] dev-util/nvidia-cuda-toolkit-9.2.88 USE="-debugger -doc -eclipse -profiler" [ebuild N ] media-video/nvidia_video_sdk-6.0.1 USE="-tools" [ebuild R ] dev-cpp/eigen-3.3.5-r1 USE="cuda*" [ebuild R ] media-libs/opencv-3.4.1-r4 USE="cuda* opencl*" [ebuild R ] media-video/ffmpeg-3.4.5 USE="nvenc* opencl* vdpau*" [ebuild U ] sys-libs/pam-1.3.1.20190226 [1.3.0-r3] USE="nullok%* sha512%* -minimal% -mktemp% -pam_krb5% -pam_ssh% -passwdqc% -securetty% -static-libs%" [ebuild U ] sys-auth/pambase-20190426 [20150213-r3] USE="-nullok* -sha512*" [blocks b ] <sys-auth/pambase-20190426 ("<sys-auth/pambase-20190426" is blocking sys-libs/pam-1.3.1.20190226) [ebuild R ] sys-auth/polkit-0.115-r1 USE="introspection*" [ebuild R ] sys-fs/udisks-2.7.6 USE="introspection*" [ebuild R ] sys-power/upower-0.99.9.20181025 USE="introspection*" The following mask changes are necessary to proceed: (see "package.unmask" in the portage(5) man page for more details) # required by dev-util/nvidia-cuda-toolkit-9.2.88::dev-kit # required by dev-cpp/eigen-3.3.5-r1::dev-kit[cuda] # required by media-libs/opencv-3.4.1-r4::media-kit[eigen] # required by media-plugins/frei0r-plugins-1.6.1.20190222::media-kit[facedetect] # required by media-video/ffmpeg-3.4.5::media-kit[frei0r] # required by media-plugins/alsa-plugins-1.1.7-r1::media-kit # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by lxqt-base/lxqt-panel-0.13.0::desktop-kit[volume,pulseaudio] # required by lxqt-base/lxqt-meta-0.13.0::desktop-kit # required by @selected # required by @world (argument) # /etc/portage/package.mask: =x11-drivers/nvidia-drivers-410.93 NOTE: The --autounmask-keep-masks option will prevent emerge from creating package.unmask or ** keyword changes. Would you like to add these changes to your config files? [Yes/No]
  8. I have nvidia-drivers-340.107 installed and working. An emerge -uDaN world produces the following The following mask changes are necessary to proceed: (see "package.unmask" in the portage(5) man page for more details) # required by dev-util/nvidia-cuda-toolkit-9.2.88::dev-kit # required by dev-cpp/eigen-3.3.5-r1::dev-kit[cuda] # required by media-libs/opencv-3.4.1-r4::media-kit[eigen] # required by media-plugins/frei0r-plugins-1.6.1.20190222::media-kit[facedetect] # required by media-video/ffmpeg-3.4.5::media-kit[frei0r] # required by media-plugins/alsa-plugins-1.1.7-r1::media-kit # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by lxqt-base/lxqt-panel-0.13.0::desktop-kit[volume,pulseaudio] # required by lxqt-base/lxqt-meta-0.13.0::desktop-kit # required by @selected # required by @world (argument) # /etc/portage/package.mask: =x11-drivers/nvidia-drivers-410.93 I have an nvidia quadro fx 580. According to nvidia's website the drivers for this card are 340.xx. https://www.nvidia.com/object/IO_32667.html I have the following in my /etc/portage/package.mask >=x11-drivers/nvidia-drivers-341.0.0 As these packages are trying to pull in an incompatible version of the drivers I tried just masking them. So my /etc/portage/package.mask now looks like this. >=x11-drivers/nvidia-drivers-341.0.0 >=dev-util/nvidia-cuda-toolkit-9.2.88 >=dev-cpp/eigen-3.3.5-r1 >=media-libs/opencv-3.4.1-r4 >=media-plugins/frei0r-plugins-1.6.1.20190222 >=media-video/ffmpeg-3.4.5 >=media-plugins/alsa-plugins-1.1.7-r1 >=media-sound/pulseaudio-12.2 >=lxqt-base/lxqt-panel-0.13.0 >=lxqt-base/lxqt-meta-0.13.0 Emerge is still failing. After a few rounds of repeating the above my /etc/portage/package.mask is now >=x11-drivers/nvidia-drivers-341.0.0 # The following are required to prevent the wrong nvidia-drivers being pulled in. >=dev-util/nvidia-cuda-toolkit-9.2.88 >=dev-cpp/eigen-3.3.5-r1 >=media-libs/opencv-3.4.1-r4 >=media-plugins/frei0r-plugins-1.6.1.20190222 >=media-video/ffmpeg-3.2.6 >=media-plugins/alsa-plugins-1.1.7 >=media-sound/pulseaudio-12.2 >=lxqt-base/lxqt-panel-0.13.0 >=lxqt-base/lxqt-meta-0.13.0 >=media-video/nvidia_video_sdk-6.0.1 But now I'm getting the following. Calculating dependencies... done! [ebuild N ] sys-fs/exfat-utils-1.3.0 [ebuild R ] x11-libs/libdrm-2.4.94 VIDEO_CARDS="-nouveau*" [ebuild N ] sys-fs/fuse-common-3.2.6 [ebuild N ] sys-fs/fuse-2.9.8 USE="-examples -static-libs" [ebuild N ] sys-fs/fuse-exfat-1.3.0 [ebuild N ] virtual/opencl-0-r5 VIDEO_CARDS="nvidia -amdgpu -i965" [ebuild R ] media-libs/x264-0.0.20170701 USE="opencl*" [ebuild R ] x11-base/xorg-drivers-1.20 VIDEO_CARDS="-nouveau*" [ebuild U ] app-editors/vim-core-8.1.1240 [8.1.1170] [ebuild R ] gnome-base/gsettings-desktop-schemas-3.28.1 USE="introspection*" [ebuild R ] media-libs/graphene-1.8.2 USE="introspection*" [ebuild R ] net-libs/libsoup-2.64.2 USE="introspection*" [ebuild U ] app-editors/vim-8.1.1240 [8.1.1170] [ebuild R ] dev-libs/libgudev-232 USE="introspection*" [ebuild R ] virtual/libgudev-232 USE="introspection*" [ebuild NS ] sys-kernel/debian-sources-lts-4.9.168_p1 [4.9.161_p1] USE="binary -ec2 -sign-modules" [ebuild N ] media-sound/apulse-0.1.12-r4 USE="-debug -sdk -test" [ebuild R ] net-dns/avahi-0.7-r4 USE="introspection*" [ebuild R ] media-libs/gstreamer-1.14.4 USE="introspection*" [ebuild R ] media-libs/gst-plugins-base-1.14.4-r1 USE="introspection*" [ebuild R ] x11-libs/gtk+-2.24.32-r1 USE="introspection*" [ebuild U #] x11-drivers/nvidia-drivers-410.93 [340.107] USE="driver%* gtk3%* kms%* uvm%* -compat% -wayland%" [ebuild N #] dev-util/nvidia-cuda-toolkit-9.2.88 USE="-debugger -doc -eclipse -profiler" [ebuild UD ] media-libs/opencv-3.4.1-r2 [3.4.1-r4] USE="cuda* opencl*" [ebuild UD ] media-plugins/frei0r-plugins-1.6.1 [1.6.1.20190222] [ebuild U ] sys-libs/pam-1.3.1.20190226 [1.3.0-r3] USE="nullok%* sha512%* -minimal% -mktemp% -pam_krb5% -pam_ssh% -passwdqc% -securetty% -static-libs%" [ebuild U ] sys-auth/pambase-20190426 [20150213-r3] USE="-nullok* -sha512*" [blocks b ] <sys-auth/pambase-20190426 ("<sys-auth/pambase-20190426" is blocking sys-libs/pam-1.3.1.20190226) [ebuild R ] sys-auth/polkit-0.115-r1 USE="introspection*" [ebuild R ] sys-fs/udisks-2.7.6 USE="introspection*" [ebuild R ] sys-power/upower-0.99.9.20181025 USE="introspection*" [blocks B ] media-plugins/alsa-plugins[pulseaudio] ("media-plugins/alsa-plugins[pulseaudio]" is hard blocking media-sound/apulse-0.1.12-r4) * Error: The above package list contains packages which cannot be * installed at the same time on the same system. (media-sound/apulse-0.1.12-r4:0/0::media-kit, ebuild scheduled for merge) pulled in by media-sound/apulse required by (www-client/firefox-bin-64.0:0/0::net-kit, installed) (media-plugins/alsa-plugins-1.1.7-r1:0/0::media-kit, installed) pulled in by >=media-plugins/alsa-plugins-1.0.27-r1[pulseaudio,-mgorny(-)] required by (media-sound/pulseaudio-12.2:0/0::gnome-kit, installed) For more information about Blocked Packages, please refer to the following section of the Gentoo Linux x86 Handbook (architecture is irrelevant): https://wiki.gentoo.org/wiki/Handbook:X86/Working/Portage#Blocked_packages The following mask changes are necessary to proceed: (see "package.unmask" in the portage(5) man page for more details) # required by media-libs/opencv-3.4.1-r2::media-kit[cuda] # required by media-plugins/frei0r-plugins-1.6.1::media-kit[facedetect] # required by media-video/ffmpeg-3.4.5::media-kit[frei0r] # required by media-plugins/alsa-plugins-1.1.7-r1::media-kit # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by lxqt-base/lxqt-panel-0.13.0::desktop-kit[volume,pulseaudio] # required by lxqt-base/lxqt-meta-0.13.0::desktop-kit # required by @selected # required by @world (argument) # /etc/portage/package.mask: # The following are required to prevent the wrong nvidia-drivers being pulled in. =dev-util/nvidia-cuda-toolkit-9.2.88 # required by dev-util/nvidia-cuda-toolkit-9.2.88::dev-kit # required by media-libs/opencv-3.4.1-r2::media-kit[cuda] # required by media-plugins/frei0r-plugins-1.6.1::media-kit[facedetect] # required by media-video/ffmpeg-3.4.5::media-kit[frei0r] # required by media-plugins/alsa-plugins-1.1.7-r1::media-kit # required by media-sound/pulseaudio-12.2::gnome-kit[alsa-plugin,alsa] # required by lxqt-base/lxqt-panel-0.13.0::desktop-kit[volume,pulseaudio] # required by lxqt-base/lxqt-meta-0.13.0::desktop-kit # required by @selected # required by @world (argument) # /etc/portage/package.mask: =x11-drivers/nvidia-drivers-410.93 What do I need to do to stop the wrong nvidia-drivers being pulled in?
×
×
  • Create New...