Jump to content
funtoo forums

Ryo

Members
  • Content Count

    3
  • Joined

  • Last visited

About Ryo

  • Rank
    Newbie

Personal

  • Interests
    Linux, computers & mountain biking !
  1. 👍 damn ! yes i had it set up in make.conf. Thank you , i can now get some sleep ^^
  2. Hi guys , I'm stuck with gcc-7.3.1-r5 refusing to build : checking whether fprintf_unlocked is declared... no checking whether fputc_unlocked is declared... yes checking whether fputs_unlocked is declared... yes checking whether fread_unlocked is declared... yes checking whether fwrite_unlocked is declared... yes checking whether getchar_unlocked is declared... yes checking whether getc_unlocked is declared... yes checking whether putchar_unlocked is declared... yes checking whether putc_unlocked is declared... yes checking whether getrlimit is declared... yes checking whether setrlimit is declared... yes checking whether getrusage is declared... yes checking whether ldgetname is declared... no checking whether times is declared... yes checking whether sigaltstack is declared... yes checking for struct tms... yes checking for clock_t... yes checking for F_SETLKW... yes checking if mkdir takes one argument... no Unknown CPU given in --with-arch=skylake. make[2]: *** [Makefile:4282: configure-stage1-gcc] Error 1 make[2] : on quitte le répertoire « /dev/shm/portage/sys-devel/gcc-7.3.1-r5/work/objdir » make[1]: *** [Makefile:24058: stage1-bubble] Error 2 make[1] : on quitte le répertoire « /dev/shm/portage/sys-devel/gcc-7.3.1-r5/work/objdir » make: *** [Makefile:939: all] Error 2 * ERROR: sys-devel/gcc-7.3.1-r5::core-kit failed (compile phase): * emake failed * * If you need support, post the output of `emerge --info '=sys-devel/gcc-7.3.1-r5::core-kit'`, * the complete build log and the output of `emerge -pqv '=sys-devel/gcc-7.3.1-r5::core-kit'`. * The complete build log is located at '/dev/shm/portage/sys-devel/gcc-7.3.1-r5/temp/build.log'. * The ebuild environment file is located at '/dev/shm/portage/sys-devel/gcc-7.3.1-r5/temp/environment'. * Working directory: '/dev/shm/portage/sys-devel/gcc-7.3.1-r5/work/objdir' * S: '/dev/shm/portage/sys-devel/gcc-7.3.1-r5/work/gcc-7.3.1' I found this bug report but it is supposed to be fixed. Any hints ? thank you :) ego profile list === arch: === arm-32bit, arm-64bit, pure64, x86-32bit, (x86-64bit*) === build: === (current*) === subarch: === amd64-bulldozer, amd64-excavator, amd64-jaguar, amd64-k10 amd64-k8, amd64-k8+sse3, amd64-piledriver, amd64-steamroller amd64-zen, atom_64, btver1_64, core-avx-i, core2_64, corei7 generic_64, intel64-broadwell, intel64-haswell, intel64-ivybridge intel64-nehalem, intel64-sandybridge, intel64-silvermont, intel64-skylake* intel64-skylake-avx512, intel64-westmere, native_64, nocona opteron_64, xen-pentium4+sse3_64 === flavor: === core*, desktop, hardened, minimal, server, workstation === mix-ins: === X*, amazon-ec2, audio, cinnamon, console-extras, dvd, gfxcard-intel-glamor gnome, gnome-3.16-fixups, hardened, kde, kde-plasma-5, lxde lxqt, mate, media, media-pro, mediadevice-audio-consumer, mediadevice-audio-pro mediadevice-base, mediadevice-video-consumer, mediadevice-video-pro mediaformat-audio-common, mediaformat-audio-extra, mediaformat-gfx-common mediaformat-gfx-extra, mediaformat-video-common, mediaformat-video-extra no-emul-linux-x86, no-systemd, openvz-host, print, python3-only selinux, stage1, vmware-guest, xfce ego kit /var/git/meta-repo (updated 1 hours 28 minutes ago): kit active branch default stability core-kit 1.2-prime (same) prime core-hw-kit master (same) current security-kit 1.2-prime (same) prime xorg-kit 1.19-prime (same) prime gnome-kit 3.26-prime (same) prime kde-kit 5.12-prime (same) prime media-kit 1.2-prime (same) prime perl-kit 5.24-prime (same) prime python-modules-kit master (same) current python-kit 3.6-prime (same) prime php-kit master (same) current java-kit 1.2-prime (same) prime ruby-kit 1.2-prime (same) prime haskell-kit 1.2-prime (same) prime ml-lang-kit 1.2-prime (same) prime lisp-scheme-kit 1.2-prime (same) prime lang-kit 1.2-prime (same) prime llvm-kit 1.2-prime (same) prime dev-kit 1.2-prime (same) prime xfce-kit 4.12-prime (same) prime desktop-kit 1.2-prime (same) prime editors-kit master (same) current net-kit master (same) current text-kit master (same) current science-kit master (same) current games-kit master (same) current nokit master (same) current NOTE: This information comes from /etc/ego.conf and meta-repo metadata. After making changes to ego.conf, be sure to run ego sync in so that the individual kit repositories on disk are synchronized with the kit branches shown above. gcc-config -l [1] x86_64-pc-linux-gnu-5.4.0 [2] x86_64-pc-linux-gnu-7.3.1 * Arch: X86-64 Vendor: "GenuineIntel" Model: 6.158.10 "Intel(R) Core(TM) i7-8700K CPU @ 3.70GHz" Features: fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,ht,tm,pbe,syscall,nx,pdpe1gb,rdtscp,lm,constant_tsc,art,arch_perfmon,pebs,bts,rep_good,nopl,xtopology,nonstop_tsc,cpuid,aperfmperf,tsc_known_freq,pni,pclmulqdq,dtes64,monitor,ds_cpl,vmx,smx,est,tm2,ssse3,sdbg,fma,cx16,xtpr,pdcm,pcid,sse4_1,sse4_2,x2apic,movbe,popcnt,tsc_deadline_timer,aes,xsave,avx,f16c,rdrand,lahf_lm,abm,3dnowprefetch,cpuid_fault,invpcid_single,ssbd,ibrs,ibpb,stibp,tpr_shadow,vnmi,flexpriority,ept,vpid,fsgsbase,tsc_adjust,bmi1,hle,avx2,smep,bmi2,erms,invpcid,rtm,mpx,rdseed,adx,smap,clflushopt,intel_pt,xsaveopt,xsavec,xgetbv1,xsaves,dtherm,ida,arat,pln,pts,hwp,hwp_notify,hwp_act_window,hwp_epp
  3. Hi, Thank you Dockland , i was not aware of inxi , nice tool. System: Host: RyoBox Kernel: 4.10.0-intel x86_64 (64 bit) Desktop: MATE 1.18.0 Distro: Funtoo Linux - baselayout 2.2.1 Machine: Device: desktop Mobo: Gigabyte model: Z97N-Gaming 5 v: x.x BIOS: American Megatrends v: F3 date: 06/03/2014 CPU: Quad core Intel Core i7-4790K (-MCP-) cache: 8192 KB clock speeds: max: 4400 MHz 1: 4340 MHz 2: 4400 MHz 3: 4395 MHz 4: 4400 MHz Graphics: Card-1: Intel Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller Card-2: NVIDIA GM204 [GeForce GTX 970] Display Server: X.org 1.19.1 driver: intel tty size: 100x30 Advanced Data: N/A for root Audio: Card-1 NVIDIA GM204 High Definition Audio Controller driver: vfio-pci Card-2 Intel Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller driver: snd_hda_intel Card-3 Intel 9 Series Family HD Audio Controller driver: vfio-pci Card-4 Plantronics driver: USB Audio Sound: Advanced Linux Sound Architecture v: k4.10.0-intel Network: Card-1: Qualcomm Atheros Killer E220x Gigabit Ethernet Controller driver: alx IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter> Card-2: Intel Wireless 7260 IF: N/A state: N/A mac: N/A Drives: HDD Total Size: 7315.5GB (7.4% used) ID-1: /dev/sda model: TS64GSSD320 size: 64.0GB ID-2: /dev/sdb model: Samsung_SSD_850 size: 250.1GB ID-3: /dev/sdc model: ST4000DM000 size: 4000.8GB ID-4: /dev/sdd model: ST3000DM001 size: 3000.6GB Partition: ID-1: / size: 30G used: 12G (42%) fs: ext4 dev: /dev/root Sensors: System Temperatures: cpu: 29.8C mobo: 27.8C Fan Speeds (in rpm): cpu: 1140 fan-1: 2163 fan-3: 0 fan-4: 0 fan-5: 0 Info: Processes: 198 Uptime: 5:19 Memory: 1383.7/15512.3MB Client: Shell (bash) inxi: 2.3.8 This is my main desktop since the beginning i think ( back to 2004 / 2005 ).It was gentoo at this time. I've checked the emerge.log, This system started on december 2009 :) It has survived an hardware change ( full hardware , do you now how gratefull am i ) 2 or 3 years ago. I've experimented what is explained here https://www.youtube.com/watch?v=LXOaCkbt4lI and with more details here http://vfio.blogspot.fr So no more dual boot.The result is pretty satisfaying but not perfect of course.I'm experimenting it since 1 year now , and i don't feel the need to restore a dual boot which is a good point.
  4. Ryo

    ACPI Errors

    Hi, It looks like there is no real answer to this problem. I read this topic It is certainly related to a buggy BIOS ( EFI ? ).
  5. Ryo

    Do you REALLY use multilib?

    Hi, 32bits libs are used here for games ( steam, emulators, wine ). I once tried the abi_x86_32 thing ( what a mess ! ) and the result is : i'm not ready to compile twice my system. So i think i could easily forget about gaming in funtoo 64bits. I'll try to setup a chroot for steam and wine instead. There 's no 64 bits steam planned yet.
×