Jump to content
funtoo forums

znavko

Members
  • Content Count

    123
  • Joined

  • Last visited

Everything posted by znavko

  1. thank you. openshot works fine. after last install I did not make updates. Now another gimp, another look of firefox, openshot has buttons in video preview area (had not before) and does not stop and crushes as before. I think new funtoo work faster, it does satisfy me.
  2. I do not think any package will have choice between perl and python or rust, so I added it globally. why is not recommended add USE:perl globally?
  3. I've added USE: perl in make conf, run `emerge @preserved-rebuild` again and got the message disappeared. imagemagick-6.9 installed : # compare --version Version: ImageMagick 6.9.9-18 Q16 x86_64 2017-12-24 http://www.imagemagick.org Copyright: © 1999-2017 ImageMagick Studio LLC License: http://www.imagemagick.org/script/license.php Features: Cipher DPC Modules OpenMP Delegates (built-in): bzlib cairo freetype jng jp2 jpeg ltdl png rsvg tiff webp wmf x xml zlib Now system is compiling 428 packages after run `emerge -ave openshot` as far as CFLAGS: -aes was added for PyQt5-5.8.2, openshot's dependency, that requires aes support. # cat /etc/portage/make.conf MAKEOPTS="-j5" LINGUAS="en_US ru_RU" L10N="${LINGUAS}" VIDEO_CARDS="intel" INPUT_DEVICES="evdev keyboard mouse synaptics" CPU_FLAGS_X86="mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" CFLAGS="-march=silvermont -mno-aes -O2 -pipe" CXXFLAGS="${CFLAGS}" FFLAGS="${CFLAGS}" FCFLAGS="${CFLAGS}" USE="alsa cairo dbus gui imagemagick introspection \ network opengl perl printsupport \ svg widgets \ "
  4. Hello! I have been installed shutter when I got the message about preserved libraries. I run `emerge @preserved-rebuild` as for advise. !!! existing preserved libs: >>> package: media-gfx/imagemagick-7.0.7.6 * - /usr/lib64/libMagick++-6.Q16.so.8 * - /usr/lib64/libMagick++-6.Q16.so.8.0.0 * used by /usr/lib64/libopenshot.so.0.1.8 (media-libs/libopenshot-0.1.8) * - /usr/lib64/libMagickCore-6.Q16.so.5 * - /usr/lib64/libMagickCore-6.Q16.so.5.0.0 * used by /usr/lib64/libopenshot.so.0.1.8 (media-libs/libopenshot-0.1.8) * - /usr/lib64/libMagickWand-6.Q16.so.5 * - /usr/lib64/libMagickWand-6.Q16.so.5.0.0 Use emerge @preserved-rebuild to rebuild packages using these libraries # emerge @preserved-rebuild Calculating dependencies... done! [ebuild UD ] media-gfx/imagemagick-6.9.9.18 [7.0.7.6] USE="-perl*" [ebuild R ] media-libs/libopenshot-0.1.8 Oops! Conflicts have been encountered: >>> media-libs/libopenshot-0.1.8:0/0::media-kit, ebuild scheduled for merge, wants <media-gfx/imagemagick-7:0=[cxx] >>> virtual/imagemagick-tools-0:0/0::nokit, installed, wants media-gfx/imagemagick[perl?] My candidates are: >>> media-gfx/imagemagick-6.9.9.18:0/6.9.9.18::media-kit, ebuild scheduled for merge has SLOT 0/6.9.9.18 but not IUSE perl? >>> media-gfx/imagemagick-7.0.7.6:0/7.0.7.6::media-kit, installed has SLOT 0/7.0.7.6 but not IUSE perl? We hope this informational output has been useful in identifying the problem. We are continually working to reduce conflicts. Do not hesitate to report a bug at https://bugs.funtoo.org. Thank you! :) As for my experience, please, which lines exactly to type for it?
  5. thank you. $ eix shotcut * media-video/shotcut [1] Available versions: (~)17.12 {LINGUAS="ca cs da de el en es fr gd hu it ja nb ne nl oc pl pt_BR pt_PT ru sk sl tr uk zh_CN zh_TW"} Homepage: https://www.shotcut.org/ Description: A free, open source, cross-platform video editor [1] "media-kit" /var/git/meta-repo/kits/media-kit but I cannot find it here https://github.com/search?q=org%3Afuntoo+shotcut or here https://github.com/funtoo/media-kit/tree/1.0-prime/media-video
  6. I run with cflags by Oleg Vinichenko CFLAGS="-march=silvermont -mno-aes -O2 -pipe" CXXFLAGS="${CFLAGS}" FFLAGS="${CFLAGS}" FCFLAGS="${CFLAGS}" emerge -ave @system Total: 409 packages (409 reinstalls), Size of downloads: 156,153 KiB will post after all. PS: 'linux video editors' in ixquick found this awesome post https://filmora.wondershare.com/video-editor/free-linux-video-editor.html some of them i found here https://github.com/funtoo/media-kit/tree/1.0-prime/media-video, will try to look at `eix video editor`
  7. with this make.conf as @Oleg Vinichenko said got nothing: https://pastebin.com/8kwhb1fL # gcc -c -Q -march=native --help=target > 111 # cat 111 > https://pastebin.com/BDqMEfFn I had openshot before. I'll try with flags by @palica PS: as I understand after changes in make.conf had been done needs to add options '-uDN' to emerge command...
  8. You know adding of CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" in /etc/portage/make.conf not solved. I've got the message about incompatible processor again. How can I compile openshot https://pastebin.com/265CpTr5 ? # cat /proc/cpuinfo > https://pastebin.com/aAY1XXvF # emerge --info '=dev-python/PyQt5-5.8.2::python-kit' > https://pastebin.com/mqmJbDas
  9. epro: # epro show === Enabled Profiles: === arch: x86-64bit build: current subarch: intel64-silvermont flavor: desktop mix-ins: lxde === Python kit: === branch: 3.4-prime === All inherited flavor from desktop flavor: === workstation (from desktop flavor) core (from workstation flavor) minimal (from core flavor) === All inherited mix-ins from desktop flavor: === X (from workstation flavor) audio (from workstation flavor) dvd (from workstation flavor) media (from workstation flavor) mediadevice-audio-consumer (from media mix-in) mediadevice-base (from mediadevice-audio-consumer mix-in) mediadevice-video-consumer (from media mix-in) mediadevice-base (from mediadevice-video-consumer mix-in) mediaformat-audio-common (from media mix-in) mediaformat-gfx-common (from media mix-in) mediaformat-video-common (from media mix-in) console-extras (from workstation flavor) print (from desktop flavor)
  10. system works after reinstall. I set up Xorg-x11, lxde, lightdm, networkmanager and firefox, booted and post here. but PyQt does not install with my make.conf # cat /etc/portage/make.conf LINGUAS="en_US ru_RU" L10N="${LINGUAS}" VIDEO_CARDS="intel" INPUT_DEVICES="evdev keyboard mouse synaptics" USE="cairo dbus gui introspection network opengl printsupport svg widgets " After installing gimp openshot audacity i've got this https://pastebin.com/CSRuaF6a In two words error while installing PyQT: Incompatible processor. This Qt build requires the following features: aes So now I must add cpu flags to make.conf ?
  11. now its going. but `emerge boot-update` stopped due to /boot was not empty (I did not delete it from my old system). I've run `grub-install --target=i386-pc --no-floppy /dev/sda ; boot-update ` hope it will work starting my new Funtoo installation.
  12. ok. I started it. just deleted all dirs, moving home to homeold and root to rootold, untar stage3-intel-silvermont-64, downloaded kits with ego sync, copied make.conf from my old adding input_devices var, tuned profile with epro mix-ins lxde, epro flavor desktop, started world update. compilation of 349 packages started on cpu 4cores 1.8GHz, 4Gb RAM.
  13. tyfba @jhan. Please, can I replace with a stage 3 my current system? Which directories should I delete?
  14. I have changed MAKEOPTS and DISABLED CCACHE: # cat /etc/portage/make.conf MAKEOPTS="-j1" LINGUAS="en_US ru_RU" L10N="en-US ru-RU" CFLAGS="-march=native -O2 -pipe" CXXFLAGS="${CFLAGS}" CCACHE_DISABLE="1" CPU_FLAGS_X86="mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3" VIDEO_CARDS="intel" USE="alsa bmp bzip2 dbus djvu core-kit flv gif introspection jpeg mp3 networkamagern png udev policykit rar tiff truetype X zlib -gnome -kde -minimal -wicd input_devices_evdev input_devices_keyboard input_devices_mouse input_devices_synaptics -acecad -aiptek -elographics -fpit -hyperpen -joystick -libinput -mutouch -penmount -tslib -vmmouse -void -wacom " But compiler not working due to broken binutils # emerge -uN gcc > https://pastebin.com/QDAFWKiR .... checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc checking for C compiler default output file name... configure: error: in `/var/tmp/portage/sys-devel/binutils-2.28-r4/work/build': configure: error: C compiler cannot create executables See `config.log' for more details..... # cat /var/tmp/portage/sys-devel/binutils-2.28-r4/work/build/config.log > https://pastebin.com/bLX2dj7m
  15. ok. Sorry, after attempt to unmerge old version of binutils my C compiler is not working :( I changed make.conf back typing -O2. Reading in the web the meaning of ''It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected.' I masked dev-libs/boost:0/1.62.0 that caused error '!!! Multiple package instances within a single package slot have been pulled ... boost-1.63 [ebuild] and boost-1.62 [installed]...' . After that I saw this error again and unmerged boost-1.62. I run world update with `emerge -av --update --deep --newuse --newrepo world --exclude firefox --exclude gimp ` as @jhan advised here. But it stopped with the error: Required boost headers not found installing libwpd. After other crazy stuff like attemption to unmerge binutils and other conflicting libs C compiler is not working: emerge ... world... --exclude [atoms]... ... checking whether the C compiler works... no configure: error: in `/var/tmp/portage/app-text/libwpd-0.10.2/work/libwpd-0.10.2': configure: error: C compiler cannot create executables See `config.log' for more details # gcc-config -l [1] x86_64-pc-linux-gnu-5.3.0 * # binutils-config -c x86_64-pc-linux-gnu-2.28 # binutils-config -l # Here it is other info for try repair my system: cat /etc/portage/make.conf > https://pastebin.com/z2MHHyz8 cat /etc/portage/package.use > https://pastebin.com/ryaEVQWs cat /etc/portage/package.mask > https://pastebin.com/TJ92cLAb cat /etc/portage/package.unmask > https://pastebin.com/m25Ly23W cat /etc/portage/package.license > https://pastebin.com/KFWJZC7T cat /var/lib/portage/world > https://pastebin.com/WeQf4PdM emerge --info > https://pastebin.com/Tgr5qQ7h Is it possible to mae C compiler works if I tried to update binutils ?
  16. thank you. once I had been compiling media-video/openshot and during compilation qt it stopped with error "memory limit (could not allocate memory)". I'll try to search.
  17. I booted to system-rescue-cd, chrooted to my funtoo system and see that I never seen. # emerge -avDuN xorg-x11 --verbose-conflicts These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] media-libs/libpng-1.6.31:0/16::media-kit [1.6.29:0/16::media-kit] USE="apng (-neon) -static-libs" ABI_X86="32 (64) (-x32)" CPU_FLAGS_X86="sse" 979 KiB [ebuild U ] media-libs/freetype-2.8:2::xorg-kit [2.6.5-r1:2::xorg-kit] USE="X adobe-cff bzip2 cleartype_hinting* png -bindist -debug -doc -fontforge -harfbuzz -infinality -static-libs -utils" ABI_X86="32 (64) (-x32)" 1,830 KiB [ebuild N ] dev-libs/libpcre2-10.30::dev-kit USE="bzip2 jit pcre16 readline recursion-limit unicode zlib -libedit -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" 1,547 KiB [ebuild U ] app-text/qpdf-7.0.0:0/18::text-kit [7.0_beta1:0/18::text-kit] USE="-doc -examples -perl -static-libs {-test}" 6,889 KiB [ebuild U ] x11-libs/libICE-1.0.9-r1::xorg-kit [1.0.9::xorg-kit] USE="ipv6 -doc -static-libs" ABI_X86="32 (64) (-x32)" 0 KiB [ebuild U ] dev-db/sqlite-3.19.3:3::core-kit [3.18.0:3::core-kit] USE="icu readline -debug -doc -secure-delete -static-libs -tcl {-test} -tools" ABI_X86="(64) -32 (-x32)" 2,484 KiB [ebuild U ] x11-libs/libpciaccess-0.13.5::xorg-kit [0.13.4::xorg-kit] USE="zlib -static-libs" ABI_X86="32 (64) (-x32)" 373 KiB [ebuild U ] dev-libs/libpthread-stubs-0.4::xorg-kit [0.3-r1::xorg-kit] USE="-static-libs" ABI_X86="32 (64) (-x32)" 57 KiB [ebuild U ] dev-libs/nspr-4.17::dev-kit [4.16::dev-kit] USE="-debug" ABI_X86="(64) -32 (-x32)" 1,115 KiB [ebuild U ] x11-misc/util-macros-1.19.1::xorg-kit [1.19.0::xorg-kit] 82 KiB [ebuild U ] media-fonts/encodings-1.0.4-r1::xorg-kit [1.0.4::xorg-kit] 0 KiB [ebuild U ] x11-proto/presentproto-1.1::xorg-kit [1.0::xorg-kit] ABI_X86="32 (64) (-x32)" 114 KiB [ebuild U ] x11-misc/xbitmaps-1.1.1-r1::xorg-kit [1.1.1::xorg-kit] 0 KiB [ebuild U ] x11-libs/libXfont-1.5.3::xorg-kit [1.5.2::xorg-kit] USE="bzip2 ipv6 truetype -doc -static-libs" 508 KiB [ebuild U ] dev-libs/libuv-1.14.1:0/1::core-kit [1.11.0:0/1::core-kit] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 1,131 KiB [ebuild N ] x11-libs/libXfont2-2.0.2::xorg-kit USE="bzip2 ipv6 truetype -doc -static-libs" 466 KiB [ebuild U ] x11-apps/sessreg-1.1.1::xorg-kit [1.1.0::xorg-kit] 133 KiB [ebuild U ] x11-libs/libdrm-2.4.83::xorg-kit [2.4.73::xorg-kit] USE="libkms -static-libs -valgrind" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="intel -amdgpu (-exynos) (-freedreno) -nouveau (-omap) -radeon (-tegra) (-vc4) (-vivante) -vmware" 739 KiB [ebuild U ] media-fonts/font-misc-misc-1.1.2-r1::xorg-kit [1.1.2::xorg-kit] USE="X nls" 0 KiB [ebuild U ] media-fonts/font-bh-100dpi-1.0.3-r1::xorg-kit [1.0.3::xorg-kit] USE="X nls" 0 KiB [ebuild U ] media-fonts/font-bitstream-100dpi-1.0.3-r1::xorg-kit [1.0.3::xorg-kit] USE="X nls" 0 KiB [ebuild U ] media-fonts/font-bh-75dpi-1.0.3-r1::xorg-kit [1.0.3::xorg-kit] USE="X nls" 0 KiB [ebuild U ] media-fonts/font-mutt-misc-1.0.3-r1::xorg-kit [1.0.3::xorg-kit] USE="X nls" 0 KiB [ebuild U ] x11-libs/libX11-1.6.5::xorg-kit [1.6.4::xorg-kit] USE="ipv6 -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 2,307 KiB [ebuild U ] x11-libs/libxkbcommon-0.7.2::xorg-kit [0.7.1::xorg-kit] USE="X -doc -static-libs {-test}" ABI_X86="(64) -32 (-x32)" 616 KiB [ebuild U ] x11-libs/libxkbfile-1.0.9-r1::xorg-kit [1.0.9::xorg-kit] USE="-static-libs" ABI_X86="(64%*) -32% (-x32)" 0 KiB [ebuild U ] x11-libs/libXi-1.7.9::xorg-kit [1.7.8::xorg-kit] USE="-doc -static-libs" ABI_X86="32 (64) (-x32)" 475 KiB [ebuild U ] x11-apps/xkbcomp-1.4.0::xorg-kit [1.3.1::xorg-kit] 239 KiB [ebuild U ] dev-qt/qtcore-5.9.2:5/5.9::kde-kit [5.7.1-r3:5/5.7::dev-kit] USE="icu -debug -systemd {-test}" 44,091 KiB [ebuild U ] dev-qt/qtxml-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::dev-kit] USE="-debug {-test}" 0 KiB [ebuild U ] dev-libs/libxml2-2.9.5:2::core-kit [2.9.4-r2:2::core-kit] USE="icu ipv6 python readline -debug -examples -lzma -static-libs {-test}" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" 5,339 KiB [ebuild U ] app-misc/ca-certificates-20170717.3.34.1::core-hw-kit [20161130.3.32::core-hw-kit] USE="-cacert -insecure_certs" 9,625 KiB [ebuild U ] dev-libs/libevdev-1.5.7::xorg-kit [1.5.4::xorg-kit] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 398 KiB [ebuild R ] x11-proto/xcb-proto-1.12-r2::xorg-kit ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6%" 0 KiB [ebuild U ] dev-libs/libxslt-1.1.30-r1::core-kit [1.1.29-r1::core-kit] USE="crypt python -debug -examples -static-libs" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 3,364 KiB [ebuild U #] sys-devel/binutils-2.28-r4:2.28::core-kit [2.28-r3:2.28::core-kit] USE="cxx nls -multitarget -static-libs {-test} -vanilla" 0 KiB [ebuild U ] sys-libs/e2fsprogs-libs-1.43.7::core-kit [1.43.4::core-kit] USE="nls -static-libs" ABI_X86="(64) -32 (-x32)" 582 KiB [ebuild U ] net-dns/libidn-1.33-r2::net-kit [1.33::net-kit] USE="nls -doc -emacs -java -mono -static-libs" ABI_X86="(64) -32 (-x32)" 0 KiB [ebuild U ] x11-misc/shared-mime-info-1.9::desktop-kit [1.8::desktop-kit] USE="{-test}" 594 KiB [ebuild U ] x11-misc/xkeyboard-config-2.21::xorg-kit [2.19::xorg-kit] 972 KiB [ebuild U ] net-dns/libidn2-2.0.4::core-kit [0.16-r3::core-kit] USE="-static-libs" ABI_X86="32 (64) (-x32)" 1,962 KiB [ebuild N ] sys-libs/libomp-5.0.0::nokit USE="-hwloc -ompt {-test}" ABI_X86="(64) -32 (-x32)" 2,026 KiB [ebuild N ] sys-devel/clang-runtime-3.9.1::nokit USE="openmp -libcxx" ABI_X86="(64) -32 (-x32)" 0 KiB [ebuild U ] sys-fs/e2fsprogs-1.43.7::core-kit [1.43.4::core-kit] USE="nls -fuse -static-libs" 7,318 KiB [ebuild U ] app-text/docbook-xsl-stylesheets-1.79.1-r2::core-kit [1.79.1-r1::core-kit] USE="-ruby" 0 KiB [ebuild U ] x11-libs/libXpm-3.5.12::xorg-kit [3.5.11::xorg-kit] USE="-static-libs" ABI_X86="(64) -32 (-x32)" 421 KiB [ebuild U ] x11-apps/xauth-1.0.10::xorg-kit [1.0.9-r2::xorg-kit] USE="ipv6 {-test}" 159 KiB [ebuild U ] dev-qt/qtdbus-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::dev-kit] USE="-debug {-test}" 0 KiB [ebuild U ] net-print/cups-2.2.6::net-kit [2.2.4::net-kit] USE="X acl dbus pam python ssl threads -debug -java -kerberos -lprng-compat (-selinux) -static-libs -systemd -usb -xinetd -zeroconf" ABI_X86="32 (64) (-x32)" LINGUAS="-ca -cs -de -es -fr -it -ja -ru" PYTHON_TARGETS="python2_7" 10,077 KiB [ebuild R ] sys-auth/polkit-0.113-r3::core-kit USE="gtk* introspection nls pam -elogind -examples -jit -kde (-selinux) {-test}" 0 KiB [ebuild N ] gnome-extra/polkit-gnome-0.105-r1::gnome-kit 304 KiB [ebuild R ] sys-devel/llvm-3.9.1-r1:0/3.9.1::core-kit USE="clang* libffi ncurses python sanitize static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc -gold -libedit (-lldb) -multitarget -ocaml {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" 11,911 KiB [ebuild N ] sys-devel/clang-3.9.1-r100:0/3.9.1::core-kit USE="python static-analyzer -debug -multitarget" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" 0 KiB [ebuild U ] media-libs/mesa-17.2.0::xorg-kit [13.0.1::xorg-kit] USE="classic dri3 egl gallium gbm llvm nptl xa -bindist -d3d9 -debug -gles1 -gles2 -opencl -openmax -osmesa -pax_kernel -pic (-selinux) -unwind% -vaapi -valgrind -vdpau -vulkan -wayland -xvmc (-gcrypt%) (-libressl%) (-nettle%*) (-openssl%)" ABI_X86="32 (64) (-x32)" VIDEO_CARDS="intel (-freedreno) -i915 -i965 (-imx) -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi (-vc4) -virgl% (-vivante) -vmware (-ilo%)" 10,094 KiB [ebuild U ] media-libs/libepoxy-1.4.3::xorg-kit [1.3.1::xorg-kit] USE="X%* {-test}" ABI_X86="(64) -32 (-x32)" 304 KiB [ebuild U ] media-libs/harfbuzz-1.5.1:0/0.9.18::media-kit [1.4.6-r2:0/0.9.18::media-kit] USE="cairo glib graphite icu introspection truetype -debug -fontconfig -static-libs {-test}" ABI_X86="32 (64) (-x32)" 1,578 KiB [ebuild R ] www-client/w3m-0.5.3-r9::net-kit USE="X gtk* nls ssl unicode -fbcon (-gpm) -imlib -libressl -lynxkeymap -nntp -xface" L10N="-ja" 0 KiB [ebuild R ] app-text/ghostscript-gpl-9.21::text-kit USE="X cups dbus gtk* tiff unicode -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 0 KiB [ebuild U ] sys-apps/portage-2.3.12::core-kit [2.3.8::core-kit] USE="(ipc) native-extensions xattr -build -doc -epydoc (-selinux)" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 -pypy -python3_5 -python3_6" 1,263 KiB [ebuild U ] dev-python/appi-0.1.5:0/0.1::python-kit [0.1.2:0/0.1::python-kit] PYTHON_TARGETS="python3_4 -python3_5 -python3_6" 39 KiB [ebuild U ] app-admin/ego-2.3.3-r1::core-kit [2.0.9::core-kit] USE="-zsh-completion" PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6" 116 KiB [ebuild U ] dev-qt/qtgui-5.9.2:5/5.9::kde-kit [5.7.1-r1:5/5.7::dev-kit] USE="dbus gif jpeg png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus -libinput {-test} -tslib -tuio -vnc% (-gtk%)" 0 KiB [ebuild U ] net-print/cups-filters-1.17.9::net-kit [1.17.3::net-kit] USE="dbus foomatic jpeg pdf png postscript tiff -ipp_autosetup -ldap -pclm -perl -static-libs {-test%} -zeroconf" 1,420 KiB [ebuild U ] x11-base/xorg-server-1.19.3-r1:0/1.19.3::xorg-kit [1.17.4-r1:0/1.17.4::xorg-kit] USE="ipv6 suid udev xorg -debug% -dmx -doc -glamor -kdrive -libressl -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xcsecurity% -xephyr -xnest -xvfb (-nptl%*)" 5,909 KiB [ebuild U ] x11-base/xorg-drivers-1.19::xorg-kit [1.17::xorg-kit] INPUT_DEVICES="evdev keyboard mouse synaptics (-acecad) (-aiptek) -elographics (-fpit) (-hyperpen) -joystick -libinput (-mutouch) -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="intel -amdgpu (-apm) (-ark) -ast (-chips) (-cirrus) -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint (-i128) (-i740) -i915% -i965% (-mach64) -mga (-neomagic) (-newport) -nouveau -nv -nvidia (-omap) -qxl -r128 -radeon -radeonsi (-rendition) (-s3) (-s3virge) (-savage) -siliconmotion (-sis) (-sisusb) (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) (-tdfx) (-tegra) (-tga) (-trident) (-tseng) (-vc4) -vesa -via -virtualbox -vmware (-voodoo) (-omapfb%)" 0 KiB [ebuild N ] x11-drivers/xf86-input-evdev-2.10.5::xorg-kit 397 KiB [ebuild U ] x11-drivers/xf86-input-synaptics-1.9.0::xorg-kit [1.8.3::xorg-kit] 491 KiB Total: 67 packages (55 upgrades, 7 new, 5 reinstalls), Size of downloads: 142,815 KiB !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-qt/qtgui:5 (dev-qt/qtgui-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) pulled in by (no parents that aren't satisfied by other packages in this slot) (dev-qt/qtgui-5.7.1-r1:5/5.7::dev-kit, installed) pulled in by ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtwebkit-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtgui-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtgui-5.7.1[-gles2,png,xcb] required by (dev-qt/qtwidgets-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtgui-5.7.1[-gles2] required by (dev-qt/qtmultimedia-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtgui-5.7.1[-gles2] required by (dev-qt/qtopengl-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtgui-5.7.1[-gles2] required by (dev-qt/qtprintsupport-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ dev-qt/qtcore:5 (dev-qt/qtcore-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) pulled in by ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtgui-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) ^ ^^^^^ ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtxml-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) ^ ^^^^^ ~dev-qt/qtcore-5.9.2 required by (dev-qt/qtdbus-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) ^ ^^^^^ (dev-qt/qtcore-5.7.1-r3:5/5.7::dev-kit, installed) pulled in by ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtdbus-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsql-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtopengl-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtnetwork-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1[icu] required by (dev-qt/qtwebkit-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtsvg-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtprintsupport-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtmultimedia-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ ~dev-qt/qtcore-5.7.1 required by (dev-qt/qtwidgets-5.7.1:5/5.7::dev-kit, installed) ^ ^^^^^ dev-qt/qtdbus:5 (dev-qt/qtdbus-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) pulled in by ~dev-qt/qtdbus-5.9.2 required by (dev-qt/qtgui-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge) ^ ^^^^^ (dev-qt/qtdbus-5.7.1:5/5.7::dev-kit, installed) pulled in by ~dev-qt/qtdbus-5.7.1 required by (dev-qt/qtgui-5.7.1-r1:5/5.7::dev-kit, installed) ^ ^^^^^ It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. emerge: there are no ebuilds to satisfy "x11-base/xorg-server:0/1.17.4=". (dependency required by "x11-drivers/xf86-input-mouse-1.9.2::xorg-kit" [installed]) (dependency required by "x11-base/xorg-drivers-1.19::xorg-kit[input_devices_mouse]" [ebuild]) (dependency required by "x11-base/xorg-server-1.19.3-r1::xorg-kit[xorg]" [ebuild]) (dependency required by "x11-drivers/xf86-input-synaptics-1.9.0::xorg-kit" [ebuild]) Please, how to take it all in my mind and just repair my system? Hope I will not change -O3 back to -O2.
  18. Hi! I try to recompile all my world with -O3 but I am a novice beneath a portage sky. I had been trying to emerge xorg-drivers and seen that xf86-input-evdev is masked. I deleted it with a thought that emerging xorg-x11 will get all dependencies. But it did not. So this had broken my laptop: # emerge --unmerge xf86-input-evdev # emerge xorg-x11 # reboot Now I cannot type my pass in SLIM and there is no mouse. I have usb-srick with system-rescue-cd. So how turn back my system? How to emerge xorg-x11 with all dependencies. One remark: I do not want to add to my world xorg-drivers cause wise man said: ''World contains programs that have dependencies. World is not dependencies.'
  19. Sorry, is -O3 is a method to move to trash all unnecessary stuff from my system? So the command # emerge -av --update --deep --newuse --newrepo world --exclude firefox --exclude gimp offers me to define exactly what I need and what is a garbage: [ebuild U ] x11-base/xorg-drivers-1.19::xorg-kit [1.17::xorg-kit] INPUT_DEVICES="evdev keyboard mouse synaptics (-acecad) (-aiptek) -elographics (-fpit) (-hyperpen) -joystick -libinput (-mutouch) -penmount -tslib -vmmouse -void -wacom" VIDEO_CARDS="intel -amdgpu (-apm) (-ark) -ast (-chips) (-cirrus) -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint (-i128) (-i740) -i915% -i965% (-mach64) -mga (-neomagic) (-newport) -nouveau -nv -nvidia (-omap) -qxl -r128 -radeon -radeonsi (-rendition) (-s3) (-s3virge) (-savage) -siliconmotion (-sis) (-sisusb) (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) (-tdfx) (-tegra) (-tga) (-trident) (-tseng) (-vc4) -vesa -via -virtualbox -vmware (-voodoo) (-omapfb%)" 0 KiB I think now my system compiled with CFLAGS: -O2 has all these xorg-drivers installed by default. How to check it? And if I will type these USE definitions funtoo will compile xorg-drivers with only necessary stuff. Am I right? But there are really much stuff to write. # emerge -av --update --deep --newuse --newrepo world --exclude firefox --exclude gimp > 555 # cat 555 > https://pastebin.com/B6Q01tmv Can I apply it automatically?
  20. # dmesg > https://pastebin.com/jQamF0Ac Laptop Lenovo had no problems with other linux: debian. # lspci | grep -i VGA 00:02.0 VGA compatible controller: Intel Corporation Atom Processor Z36xxx/Z37xxx Series Graphics & Display (rev 0e) # cat /proc/modules > https://pastebin.com/bLQQSrgG
  21. I added use flags in with own opinion (reading linux.org.ru ). CPU FLAGS were added with cpuidcpuflags # cpuid2cpuflags CPU_FLAGS_X86: mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3
  22. Say me, will it be better if I add USE flags in make.conf only qt5 or only gtk2, or only gtk3 or only qt4 ?? Or happens one package requires gtk and the other qt ?
  23. # equery u gimp > https://pastebin.com/ZPUyfREA # equery u firefox > https://pastebin.com/53v9WkWE # emerge -av --update --deep --newuse --newrepo world --exclude firefox --exclude gimp These are the packages that would be merged, in order: Calculating dependencies / !!! Problem resolving dependencies for media-sound/audacious from @selected ... done! !!! The ebuild selected to satisfy "media-sound/audacious" has unmet requirements. - media-sound/audacious-3.7.1-r1::media-kit USE="chardet gtk nls qt5 -gtk3" The following REQUIRED_USE flag constraints are unsatisfied: exactly-one-of ( gtk gtk3 qt5 ) (dependency required by "@selected" [set]) (dependency required by "@world" [argument]) I had such package.use : >=media-sound/audacious-3.7.1-r1 chardet gtk gtk3 nls qt5 I really had no sense. But after playing with flags I understood the meaning of 'exactly-one-of ( gtk gtk3 qt5 )'. I changed package.use line to: >=media-sound/audacious-3.7.1-r1 chardet nls qt5 -gtk -gtk3 And the emerge becomes like this: # emerge -avuDN --with-bdeps=y --newrepo @world > 222 # cat 222 > https://pastebin.com/KW5UfBd2 Humm. Can Funtoo do it itself?
×
×
  • Create New...