Jump to content


  • Content Count

  • Joined

  • Last visited

About seaofash

  • Rank

Recent Profile Visitors

1,202 profile views
  1. Good questions. I would also like to know more about this.
  2. @drobbins@eyesee Thank you so much! I followed @eyesee suggestion and it works now. Thanks again!
  3. I've seen this happen a few times. Here is what happens: 1. Trying to login at bugs.funtoo.org 2. It says "Sorry, your username and password are incorrect - please try again." 3. Changing the password on forums.funtoo.org and try again. Same results. 4. Creating a new account on forums.funtoo.org and then login at bugs.funtoo.org works 5. Using the new account for a while and it works. 6. Suddenly it stops working on bugs.funtoo.org. So, go back to step 3. This is really annoying. I have changed my account here a few times due to this issue.
  4. OK, when I query the available slots I get this: $ eix -e sys-devel/llvm [I] sys-devel/llvm Available versions: (0) ~*3.4.2-r100(0/3.4)[2] ~*3.5.2-r100(0/3.5)[2] ~*3.6.2-r100(0/3.6)[2] 3.7.1-r3(0/3.7.1)[2] 3.9.1-r1(0/3.9.1){tbz2}[2] (4) 4.0.1-r1{tbz2}[1] 4.0.1-r1{tbz2}[2] (5) 5.0.1{tbz2}[2] (6) (~)6.0.0^t{tbz2}[2] {clang debug default-compiler-rt default-libcxx doc gold libedit +libffi lldb multitarget ncurses ocaml python +sanitize +static-analyzer test xar xml ABI_MIPS="n32 n64 o32" ABI_PPC="32 64" ABI_S390="32 64" ABI_X86="32 64 x32" ELIBC=
  5. @cafaia Thank you so much good sir! Thanks to you, now I have a working debugger for C++/Unreal Engine which I can use with Qt Creator as LLDB debugger front-end to debug my game. Although it did not work out of the box, I was able to build LLVM4 using your instructions with slight modifications (it was required to fetch patches in addition to the ebuild files even patches from 9999 or 5.0.0 were required for LLVM4 to build, otherwise it failed. In addition to that, mesa had a dependency on llvm use flag and the minimum working version with llvm 4 was mesa 17.0.6 in portage so I had to un
  6. @gissf1 thank you so much for the reply. It seems that would be a good idea. I tried to mask 3.9.x version like this (I took it from meta-repo/kits/core-kit/profiles/package.mask/funtoo-cautionary-oleg): >=dev-util/lldb-3.9.0 >=sys-devel/llvm-common-3.9.0 =sys-devel/lld-3.9.0 >=sys-devel/clang-3.9.0 >=sys-devel/llvm-3.9.0 >=sys-devel/clang-runtime-3.9.0 >=app-vim/llvm-vim-3.9.0 >=sys-devel/llvmgold-3.9.0 >=dev-libs/libclc-0.2.0_pre20170118 >=sys-libs/libcxx-3.9.0 Unfortunately, portage pulls in the 5.0.x series like this and in the end I'll get the same e
  7. How to upgrade to gcc-6.3.0? It won't show up on gcc-config output: $ gcc-config -l [1] x86_64-pc-linux-gnu-5.3.0 [2] x86_64-pc-linux-gnu-5.4.0 *
  8. Hi, I'm using Funtoo for my Unreal Engine 4 development. Since lldb use flag has been masked for 3.9.x I cannot use lldb for debugging. So, I have to do my debugging on a Windows machine using Visual Studio which is a pain since I have to use my colleagues PCs. I saw these on Funtoo's system-wide profiles: # Micha? G?rny <mgorny@gentoo.org> (28 Aug 2016) # lldb fails to build in the current RC, and needs a lot of minor fixes. # It's no longer available in -9999 line, and it won't be in 3.9.0 # either unless somebody steps up to fix it. >=sys-devel/llvm-3.9.0_rc lldb # mask
  9. I would like to update my system using: $ emerge --ask --update --newuse --deep --keep-going @world I did an ego sync and now I get: These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] dev-libs/libsodium-1.0.14 USE="asm urandom -minimal -static-libs" CPU_FLAGS_X86="aes sse4_1" [ebuild N ] dev-util/boost-build-1.63.0 USE="python -examples {-test}" PYTHON_TARGETS="python2_7" [ebuild N ] dev-util/boost-build-1.62.0-r1 USE="python -examples {-test}" PYTHON_TARGETS="python2_7" [ebuild N ] dev-libs/boost-1.63.0 USE="icu nl
  10. Ah, thank you! I have to read the news more often.
  11. I updated my home Funtoo installation successfully to meta-repo using the instructions here. I did the same for my work pc but I think something went wrong. Whenever I try "emerge --ask --update --newuse --deep @world" I get the following: $ emerge --ask --update --newuse --deep @world These are the packages that would be merged, in order: Calculating dependencies / !!! Problem resolving dependencies for sys-apps/file from @system ... done! !!! The ebuild selected to satisfy "sys-apps/file" has unmet requirements. - sys-apps/file-5.30::core-kit USE="python zlib -static-libs" ABI_X86="64
  • Create New...