Jump to content
funtoo forums


  • Content Count

  • Joined

  • Last visited

  • Days Won


Everything posted by jhan

  1. I might be missing something but there is no error in the attached log file.
  2. jhan


    It seems that the version is no longer available. Current version seems to be Please file a bug at bugs.funtoo.org and if you want you can provide a pull request for the current version. Explanations how to do that can be found at drobbins youtube channel
  3. I don't know if it solves all your points but you can always try out the images at Those images are based on funtoo. The description can be found at https://area31.net.br/wiki/LiveCD_oficial It is in portugese but you probably can understand the important parts. And if you have questions about it, you can always ask here or IRC.
  4. Try the subtitles of the video. Either the autogenerated English or a translation.
  5. jhan

    Funtoo release model

    In a way I can understand both sides. The need to have a "snapshot" to have a version that is stable but also the need to have new versions available when needed. I came to gentoo and now funtoo because I always ran into problems with binary distributions when I wanted to install some package just to find out that this package did need a library or other dependency that was not available for the current release. And installing the dependencies lead to conflicts in the system. Without current or latest versions being available funtoo doesn't offer that benefit anymore. There are still ways to do it manually but it would work better integrated into the system, especially if those manually installed versions become part of a new stable system. What I don't quite understand is, why you can't have both? Yes, a stable version or release is good to have, as users can just use that and development has it easier to fix bugs. And it gives experimental users a "fallback" version, if something goes wrong with the system. But that doesn't exclude making newer versions available as early as possible. It would be easy to mark them accordingly, may that be a use flag, a special kit or something else. So the default would be a stable version and a user could choose to see all available versions or e.g. just for some packages. And handling problems with experimental versions could be done as today. Either no support at all, "best effort support" or community support. And I don't agree with @drobbins statement in the bug report: I think the opposite could be true. As the users that chosse to install experimental software are mostly the ones that have the knowledge to fix the arising problems and can help with development. Having both types of users is the key here. Users running the stable version can help fixing problems with the stable version but "experimental" users can help in both worlds. Those experimental users might have not stable systems in general but might not be completely unstable, if they e.g. just upgraded part of their system. So they could still help with problems in the stable version. And, when the former experimental versions become part of a new stable release, the knowledge for those newer verions is already there and some bugs probably fixed before they occur in a stable release. Not to mention that the more experienced users are or at least have the knowledge to run multiple versions of funtoo. So, if package versions, which are newer than the latest stable version, are clearly marked (e.g. with an experimental use flag) and users need to manually switch to the experimental version and maybe get a appropiate warning about the consequences of that switch, I see no problem in offering both worlds at the same time. A stable version and "cutting edge" technology.
  6. jhan

    Multiple NIC Configuration Help

    I am not an expert on networks but why are your nameservers for eth1 pointing to a different network? Any special reason or is that just a typo?
  7. jhan

    "dev-lang/rust:stable" has unmet requirements

    What flags did you add? The above message shows that you are still missing a value for the LLVM_TARGETS. I've just tested it on an funtoo 1.2 image and rust emerges without problem.
  8. jhan

    Cinnamon install unmet requirements

    I did see this but your image still shows PYTHON_TARGETS="python2_7 -python3_4 -python3_5". So the output of this emerge is expected. How did you set your python targets?
  9. jhan

    Cinnamon install unmet requirements

    The line any-of ( python_targets_python3_4 python_targets_python3_5) says it all. You need to activate either python 3.4 or 3.5 for this to work.
  10. jhan

    Outdated nokit repo

    If you are referring to the differences in available ebuilds, the explanation would be that you are looking at the same thing through different lenses. The ebuilds at github are all available ebuilds but as your system uses 1.3 you only see (and use) the ebuilds available in the 1.3 release. If you want you could still install other ebuilds if you want but you have to that manually. I e.g am running gentoo-sources-4.20.3 without problems here.
  11. What is the output of 'equery u net-misc/networkmanager' and 'epro' ?
  12. jhan

    Funtoo slow in my netbook :(

    On first glance I didn't see a major difference in the diff. But even such small differences as the different kernel versions can be important. There seem to be also some other version differences between the systems. If you want to identify the problem further you could use glxinfo and glxgears (package mesa-progs for funtoo) to do that. glxinfo gives you a lot of information about the opengl part and with glxgears you can see if there is a greater difference in the framerate.
  13. jhan

    Funtoo slow in my netbook :(

    Have you compared the xorg logs of both systems to see if there is a difference?
  14. Have you compared the dmesg output of both kernels? Normally you should see something like:
  15. lsmod should give you the list of modules 8169 is the kernel driver and it seems that your card is not recognized or the module not loaded. There is a driver for 8168 which you can emerge: net-misc/r8168. If the kernel driver does not work, you can try that one.
  16. This card has problems with different kernel versions. So more questions: - which kernel are you using? - which driver are you using? 8169 in the kernel or 8168?
  17. It would help if you could give more information when you have problems. What would be interesting here: - output of 'lspci -nnk' - what do you have enabled in the kernel to make it work?
  18. jhan

    From openssl to libressl + gnutls

    I am in the process of moving to libressl at the moment and the procedure described at https://bghost.xyz/post/libressl_on_funtoo/ works quite well.
  19. jhan

    I canĀ“t compile rust-1.29.2

    From which directory did you start the emerge? Please start it from a directory that is not temporary, to avoid errors like this: If the emerge fails again post the contents of '/var/tmp/portage/dev-lang/rust-1.29.2/work/rustc-1.29.2-src/config.toml'
  20. jhan

    Insert Data Into Text File

    So you are basically looking for the keyword 'Summary:' and then add the extra text before the ';;'. If I remember correctly, this should be doable with awk or gawk. Something similar to what is done on this page
  21. jhan

    Insert Data Into Text File

    To make it easier to understand what you are trying to achieve could you give a short example of a file before and after the change. So far I only understand that you want to modify a lot of files in the same way but it is not clear to me how the resulting file would look like. An example would help to clarify that.
  22. jhan

    [SOLVED] Mesa installation issues

    Could it be that you are using funtoo release 1.2? I already upgraded to release 1.3 and have mesa 18.2.4 and llvm 7.0.0-r1
  23. jhan

    Cant install funtoo from existing distro

    So you are trying to install gentoo? Or what are you trying to do and what did you do?
  24. jhan

    How Disable Kits on emerge?

    If you really don't use a graphical Environment then you should set your profile accordingly with epro (https://www.funtoo.org/Funtoo_Profiles). That should cover most of it.
  25. jhan

    Long time no update. Advise?

    Yes, that is still unresolved here as well because glibmm-2.57.1 is not compiling. It throws a long error list, mostly something about No idea what the problem is and no time to look into it further. So far my system works without that package.