Jump to content
funtoo forums

biocyberman

Members
  • Content Count

    24
  • Joined

  • Last visited

  • Days Won

    1

biocyberman last won the day on June 27 2017

biocyberman had the most liked content!

About biocyberman

  • Rank
    Member

Recent Profile Visitors

506 profile views
  1. biocyberman

    update overlays with meta-repo?

    I setup an overlay, and currently `#ego sync` does not update this overlay. I had to do manual git pull at the overlay's directory: cd /var/git/overlays/myov && git pulll origin master Is there a better way to achieve the same thing?
  2. biocyberman

    removed glibc how do I reinstall it?

    This is working: 1. Downloaded the latest stage3 file of the same characteristics as the stage3 I used to install funtoo. 2. Create a dir: /root/2018stage3 3. Cd to the dir: cd /root/2018stag3/ and save the latest stage3 there. 4. Untar: tar xpf lateststage3.tag.xz. Waring for future readers: Untar the stage3 directly to root file system cause you to lose all customized files in /etc (including passwd, group) and also list of installed packages. Be careful not to make this mistake. 5. Follow the "Chroot into Funtoo" section in this guide: https://www.funtoo.org/Install Now I have a working basic chroot environment similar to my Funtoo . I can use this to mimic the broken Funtoo and create compatible packages for it. I am now following the upgrade process following this guide: After that I will create binary package to install on the broken system. It's a long workaround but still faster than reinstalling from scratch.
  3. biocyberman

    removed glibc how do I reinstall it?

    Yeah, it went like this: I feel stomachache. What's inside, why is it causing pain? Stab, grab, pull.... Hey I pulled off my gut, what do I do? I was also reading this https://wiki.gentoo.org/wiki/Fix_My_Gentoo and I am inclined to do follow it rather than the Funtoo's guide. This is a dead end: # cd /tmp # wget https://www.python.org/ftp/python/3.6.1/Python-3.6.1.tar.xz # tar -xJf Python-3.6.1.tar.xz # cd Python-3.6.1 # ./configure --enable-shared --with-fpectl --with-system-expat --with-system-ffi # make make is complaining that it can't find crt1.o file.
  4. biocyberman

    removed glibc how do I reinstall it?

    More log: /usr/portage/distfiles # /tmp/portage-2.3.8/bin/emerge -1k glibc !!! Repository name or alias 'gentoo', defined for repository 'core-kit', overrides existing alias or repository. !!! Repository 'gentoo' is missing masters attribute in '/usr/portage/metadata/layout.conf' !!! Set 'masters = core-kit' in this file for future compatibility portage: 'portage' user or group missing. For the defaults, line 1 goes into passwd, and 2 into group. portage:x:250:250:portage:/var/tmp/portage:/bin/false portage::250:portage *** WARNING *** For security reasons, only system administrators should be *** WARNING *** allowed in the portage group. Untrusted users or processes *** WARNING *** can potentially exploit the portage group for attacks such as *** WARNING *** local privilege escalation. WARNING: One or more repositories have missing repo_name entries: /usr/portage/profiles/repo_name NOTE: Each repo_name entry should be a plain text file containing a unique name for the repository on the first line. Calculating dependencies... done! >>> Verifying ebuild manifests >>> Running pre-merge checks for sys-libs/glibc-2.26-r6 chgrp: invalid group: ‘portage’ chgrp: invalid group: ‘portage’ chgrp: invalid group: ‘portage’ chgrp: invalid group: ‘portage’ chgrp: invalid group: ‘portage’ chgrp: invalid group: ‘portage’ portage: 'portage' user or group missing. For the defaults, line 1 goes into passwd, and 2 into group. portage:x:250:250:portage:/var/tmp/portage:/bin/false portage::250:portage *** WARNING *** For security reasons, only system administrators should be *** WARNING *** allowed in the portage group. Untrusted users or processes *** WARNING *** can potentially exploit the portage group for attacks such as *** WARNING *** local privilege escalation. make -j5 -s glibc-test glibc-test.c:1:17: fatal error: pwd.h: No such file or directory #include <pwd.h> ^ compilation terminated. make: *** [<builtin>: glibc-test] Error 1 emake failed * Simple build failed ... assuming this is desired #324685 make -j5 -s glibc-test glibc-test.c:1:20: fatal error: unistd.h: No such file or directory #include <unistd.h> ^ compilation terminated. make: *** [<builtin>: glibc-test] Error 1 emake failed * Simple build failed ... assuming this is desired #324685 /var/git/meta-repo/kits/core-kit/sys-libs/glibc/glibc-2.26-r6.ebuild: line 166: tc-enables-pie: command not found * PIE hardening not applied, as your compiler doesn't default to PIE portage: 'portage' user or group missing. For the defaults, line 1 goes into passwd, and 2 into group. portage:x:250:250:portage:/var/tmp/portage:/bin/false portage::250:portage *** WARNING *** For security reasons, only system administrators should be *** WARNING *** allowed in the portage group. Untrusted users or processes *** WARNING *** can potentially exploit the portage group for attacks such as *** WARNING *** local privilege escalation. chgrp: invalid group: ‘portage’ portage: 'portage' user or group missing. For the defaults, line 1 goes into passwd, and 2 into group. portage:x:250:250:portage:/var/tmp/portage:/bin/false portage::250:portage *** WARNING *** For security reasons, only system administrators should be *** WARNING *** allowed in the portage group. Untrusted users or processes *** WARNING *** can potentially exploit the portage group for attacks such as *** WARNING *** local privilege escalation. >>> Emerging (1 of 1) sys-libs/glibc-2.26-r6::core-kit >>> Downloading 'http://distfiles.gentoo.org/distfiles/glibc-2.26.tar.xz' --2018-04-27 14:12:04-- http://distfiles.gentoo.org/distfiles/glibc-2.26.tar.xz Resolving distfiles.gentoo.org... failed: Device or resource busy. wget: unable to resolve host address ‘distfiles.gentoo.org’ >>> Downloading 'http://ftpmirror.gnu.org/glibc/glibc-2.26.tar.xz' --2018-04-27 14:12:04-- http://ftpmirror.gnu.org/glibc/glibc-2.26.tar.xz Resolving ftpmirror.gnu.org... failed: Device or resource busy. wget: unable to resolve host address ‘ftpmirror.gnu.org’ >>> Downloading 'http://ftp.gnu.org/gnu/glibc/glibc-2.26.tar.xz' --2018-04-27 14:12:04-- http://ftp.gnu.org/gnu/glibc/glibc-2.26.tar.xz Resolving ftp.gnu.org... failed: Device or resource busy. wget: unable to resolve host address ‘ftp.gnu.org’ !!! Couldn't download 'glibc-2.26.tar.xz'. Aborting. * Fetch failed for 'sys-libs/glibc-2.26-r6', Log file: * '/var/tmp/portage/sys-libs/glibc-2.26-r6/temp/build.log' >>> Failed to emerge sys-libs/glibc-2.26-r6, Log file: >>> '/var/tmp/portage/sys-libs/glibc-2.26-r6/temp/build.log' * Messages for package sys-libs/glibc-2.26-r6: * Simple build failed ... assuming this is desired #324685 * Simple build failed ... assuming this is desired #324685 * PIE hardening not applied, as your compiler doesn't default to PIE * Messages for package sys-libs/glibc-2.26-r6: * Fetch failed for 'sys-libs/glibc-2.26-r6', Log file: * '/var/tmp/portage/sys-libs/glibc-2.26-r6/temp/build.log'
  5. Found the "wrong" version of glibc installed (version 2.26-r6) which does not have xlocale.h. I was ignorant to remove glibc because I did not see any way to downgrade to version 2.25-r11. Now portage does not work, all vital system commands stop working: id uid=1000 gid=1000 groups=1000,10,27,35,100,106,993,994 sudo su sudo: unknown uid 1000: who are you? wget from root terminal fails: /tmp/portage-2.3.8 # /tmp/portage-2.3.8/bin/emerge -1k sys-apps/portage !!! Repository name or alias 'gentoo', defined for repository 'core-kit', overrides existing alias or repository. !!! Repository 'gentoo' is missing masters attribute in '/usr/portage/metadata/layout.conf' !!! Set 'masters = core-kit' in this file for future compatibility portage: 'portage' user or group missing. For the defaults, line 1 goes into passwd, and 2 into group. portage:x:250:250:portage:/var/tmp/portage:/bin/false portage::250:portage *** WARNING *** For security reasons, only system administrators should be *** WARNING *** allowed in the portage group. Untrusted users or processes *** WARNING *** can potentially exploit the portage group for attacks such as *** WARNING *** local privilege escalation. WARNING: One or more repositories have missing repo_name entries: /usr/portage/profiles/repo_name NOTE: Each repo_name entry should be a plain text file containing a unique name for the repository on the first line. Calculating dependencies... done! !!! The following installed packages are masked: - app-emulation/wine-2.3::gentoo (masked by: package.mask) /var/git/meta-repo/kits/core-kit/profiles/package.mask/00-gentoo: # Michał Górny <mgorny@gentoo.org> (28 Nov 2017) # Replaced by split packages. Please install one of: # - app-emulation/wine-vanilla (the only choice for stable) # - app-emulation/wine-staging # - app-emulation/wine-d3d9 # - app-emulation/wine-any # For more information, please read the news item: # https://www.gentoo.org/support/news-items/2017-04-10-split-and-slotted-wine.html # If you really need the old ebuilds, you can use the 'wine' repository. # Removal in 30 days. For more information, see the MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. >>> Verifying ebuild manifests >>> Emerging (1 of 3) dev-lang/python-3.4.6-r1::python-kit * Fetching files in the background. * To view fetch progress, run in another terminal: * tail -f /var/log/emerge-fetch.log >>> Downloading 'http://distfiles.gentoo.org/distfiles/Python-3.4.6.tar.xz' --2018-04-27 13:45:55-- http://distfiles.gentoo.org/distfiles/Python-3.4.6.tar.xz Resolving distfiles.gentoo.org... failed: Device or resource busy. wget: unable to resolve host address ‘distfiles.gentoo.org’ >>> Downloading 'http://www.python.org/ftp/python/3.4.6/Python-3.4.6.tar.xz' --2018-04-27 13:45:55-- http://www.python.org/ftp/python/3.4.6/Python-3.4.6.tar.xz Resolving www.python.org... failed: Device or resource busy. wget: unable to resolve host address ‘www.python.org’ !!! Couldn't download 'Python-3.4.6.tar.xz'. Aborting. * Fetch failed for 'dev-lang/python-3.4.6-r1', Log file: * '/var/tmp/portage/dev-lang/python-3.4.6-r1/temp/build.log' >>> Failed to emerge dev-lang/python-3.4.6-r1, Log file: >>> '/var/tmp/portage/dev-lang/python-3.4.6-r1/temp/build.log' * Messages for package dev-lang/python-3.4.6-r1: * Fetch failed for 'dev-lang/python-3.4.6-r1', Log file: * '/var/tmp/portage/dev-lang/python-3.4.6-r1/temp/build.log' My question is, how do I rescue this system? I posting from this broken computer because it has not been rebooted since the incident.
  6. biocyberman

    Migration to meta-repo, many blocked packages?

    There were two other problems that I luckily could solved: First problem: no ebuilds to satisfy xyz This command emerge -auDN --newrepo @system complains something like "emerge: there are no ebuilds to satisfy "=x11-libs/gtk+-3.22*:3". This is very unexpected error to me. At first I download the ebuild file manually and put it in my local overlay. Then another error appeared for another package. Somehow I remember to add `--backtrack=50` option like this: emerge -auDN --newrepo @system --backtrack=50 This prevented some packages from being upgraded. Therefore it solved the dependency problem. Second problem: can't emerge any package, "gcc not able to compile" I was tempted to run the following command when reading this thread: # paxctl-ng -R /usr/libexec/gcc/x86_64-pc-linux-gnu/4.8.0/cc1 # paxctl-ng -R /usr/libexec/gcc/x86_64-pc-linux-gnu/4.8.0/cc1plus However, I found out that there might be something to do with 'binutils' So I ran: # binutils-config -l [1] x86_64-pc-linux-gnu-2.29.1 This is different from output of: # binutils-config -c x86_64-pc-linux-gnu-2.25.1 This suggested me to switch binutils profile: # binutils-config 1 After this, emerge runs normally :)
  7. biocyberman

    Migration to meta-repo, many blocked packages?

    Well after x11-proto problem, I have many other problems with package conflicts. I took the opportunity to setup Funtoo 1.2 following Robbin's guide here: This did not solve the conflicts directly, but it gives an idea of working from the gcc up. I then have to manually unmerge or update some conflicts packages with `emerge -uv1 <packagenames>` For example, I have to upgrade many dev-qt packages and their downstream packages. I see this pattern: Package A is scheduled for merge with version A2. Package B which is installed wants package A version A1 (older than A2). Then this command helps to solve the confict: emerge -vua1 A B This command is very useful when: emerge -auDN @system #or this emerge -auDN @world Both fail because of conflicts.
  8. biocyberman

    Migration to meta-repo, many blocked packages?

    I found out that `app-editors/emacs-26.1_rc1:26/26::editors-kit` is asking to install `x11-base/xorg-proto-2018.4:0/0::xorg-kit`. I mask the two packages in `/etc/portage/package.mask`: =app-editors/emacs-26.1 >=x11-base/xorg-proto-2018.4 And then running emerge with `--autounmask-keep-masks` emerge -auDN @world --with-bdeps=y --autounmask-keep-masks This helped me to solve the problem and the emerge process could continue.
  9. After following instructions to migrate to meta-repo here: https://github.com/funtoo/meta-repo I did this command: emerge -auDN @world --with-bdeps=y --verbose-conflicts --backtrack=50 This brought up many conflicts and blocked package problems. I solved the conflicts packages by removing, manually upgrading. I am still stuck with the blocked packages as following. What do I do to get my system up to date? I have tried unmerge all blocking packages (i.e. x11-proto/*) and emerge x11-base/xorg-proto-2018.4. After that I re-ran the command above. I still get the same errors. These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] sys-libs/glibc-2.23-r8 [2.23-r3] [ebuild U ] app-arch/bzip2-1.0.6-r9 [1.0.6-r7] [ebuild U ] net-dns/openresolv-3.9.0 [3.8.1] [ebuild U ] app-text/poppler-data-0.4.8 [0.4.7] [ebuild U ] sys-apps/debianutils-4.8.1.1 [4.8.1] [ebuild U ] dev-util/pkgconf-1.2.2 [0.9.11] [ebuild N ] sys-apps/opentmpfiles-0.1.3 USE="(-selinux)" [ebuild N ] net-libs/libnsl-1.1.0-r1 [ebuild N ] net-libs/rpcsvc-proto-1.2-r1 [ebuild U ] dev-qt/qtchooser-0_p20170803 [0_p20151008] [ebuild U ] dev-lang/go-1.9.4 [1.8.3] [ebuild U ] sys-devel/autoconf-archive-2017.03.21 [2016.09.16] [ebuild U ] net-libs/http-parser-2.8.1 [2.6.2] [ebuild U ] media-libs/opus-1.2.1 [1.1.4] [ebuild N ] app-i18n/unicode-emoji-5.0 [ebuild U ] net-wireless/wireless-regdb-20171223-r1 [20170307] [ebuild U ] app-text/libexttextcat-3.4.5 [3.4.4] [ebuild U ] sys-apps/miscfiles-1.5-r3 [1.5-r1] [ebuild U ] app-shells/gentoo-bashcomp-20180302 [20140911] [ebuild U ] app-doc/linux-kernel-in-a-nutshell-1-r1 [1] [ebuild U ] app-text/tree-1.7.0-r1 [1.7.0] [ebuild U ] sys-kernel/linux-firmware-20180416 [20170519] [ebuild U ] sys-devel/binutils-config-5-r3 [5-r2] [ebuild N ] virtual/tmpfiles-1 [ebuild U ] app-emulation/docker-proxy-0.8.0_p20180314 [0.8.0_p20161111] [ebuild U ] app-i18n/unicode-data-10.0.0 [9.0.0] [ebuild N ] app-i18n/unicode-cldr-31.0.1 [ebuild N ] app-arch/zstd-1.3.4 USE="-static-libs" [ebuild U ] sys-libs/gdbm-1.13 [1.12] [ebuild UD ] dev-libs/npth-1.3 [1.5] [ebuild U ] x11-themes/hicolor-icon-theme-0.17 [0.15] [ebuild R ] net-wireless/wireless-tools-30_pre9 [30_pre9] LINGUAS="(-cs%) (-fr%)" [ebuild U ] net-misc/rsync-3.1.2-r2 [3.1.2] USE="-examples%" [ebuild UD ] virtual/ttf-fonts-1 [1-r1] [ebuild U ] media-libs/libjpeg-turbo-1.5.2 [1.5.1] [ebuild U ] sys-apps/baselayout-2.2.2 [2.2.1] [ebuild U ] app-emacs/emacs-common-gentoo-1.6-r1 [1.6] [ebuild R ] x11-base/xorg-drivers-1.19 [1.19] VIDEO_CARDS="-i915% (-vc4) (-omapfb%)" [ebuild N ] app-emulation/runc-1.0.0_rc5-r1 USE="ambient hardened seccomp -apparmor" [uninstall ] app-emulation/docker-runc-1.0.0_rc3_p20170607 [blocks b ] app-emulation/docker-runc ("app-emulation/docker-runc" is blocking app-emulation/runc-1.0.0_rc5-r1) [blocks b ] app-emulation/runc ("app-emulation/runc" is blocking app-emulation/docker-runc-1.0.0_rc3_p20170607) [ebuild N ] sys-devel/llvm-common-6.0.0 [ebuild U ] app-editors/vim-core-8.0.1735 [8.0.0606] [ebuild U ] dev-libs/libgpg-error-1.27-r1 [1.24] [ebuild U ] sys-libs/e2fsprogs-libs-1.43.8 [1.43.4] [ebuild U ] net-dns/libidn-1.34 [1.33] [ebuild U ] app-crypt/rhash-1.3.6-r1 [1.3.4] [ebuild U ] dev-db/m17n-db-1.7.0 [1.6.4] [uninstall ] dev-db/m17n-contrib-1.1.14 [blocks b ] dev-db/m17n-contrib ("dev-db/m17n-contrib" is blocking dev-db/m17n-db-1.7.0) [ebuild U ] app-shells/bash-4.4_p18 [4.3_p48] [ebuild U ] sys-devel/bc-1.07.1 [1.06.95-r2] [ebuild U ] app-shells/bash-completion-2.7-r3 [2.5] USE="{-test%}" [ebuild U ] dev-libs/libburn-1.4.8 [1.4.6] [ebuild N ] dev-libs/libinput-1.7.0 USE="{-test}" INPUT_DEVICES="-wacom" [ebuild U ] app-admin/eselect-1.4.9 [1.4.8] [ebuild U ] app-eselect/eselect-ruby-20171225 [20161226] [ebuild U ] sys-apps/sysvinit-2.88-r11 [2.88-r9] [ebuild U ] media-libs/libv4l-1.12.5 [1.10.1] [ebuild U ] virtual/freedesktop-icon-theme-0-r2 [0-r1] [ebuild U ] net-misc/dhcpcd-7.0.0 [6.11.5] [ebuild U ] sys-auth/pambase-20150213-r3 [20150213-r2] USE="-elogind%" [ebuild U ] sys-apps/sandbox-2.10-r4 [2.10-r3] [ebuild N ] virtual/libelf-1 ABI_X86="(64) -32 (-x32)" [ebuild U ] sys-apps/openrc-0.35.0_beta1-r1 [0.23.2] [ebuild U ] virtual/service-manager-1 [0] [ebuild U ] virtual/man-0-r1 [0] [ebuild U ] sys-apps/man-pages-4.10 [4.09] [ebuild U ] xfce-base/libxfce4util-4.13.1 [4.13.0] [ebuild U ] xfce-base/xfconf-4.13.4 [4.12.1] USE="{-test%}" [ebuild U ] app-text/docbook-xsl-stylesheets-1.79.1-r2 [1.79.1-r1] [ebuild U ] media-libs/gst-plugins-ugly-1.12.3 [1.10.3] [ebuild U ] media-plugins/gst-plugins-cdparanoia-1.12.3 [1.10.4] [ebuild U ] media-plugins/gst-plugins-mad-1.10.5 [1.10.3] [ebuild U ] media-plugins/gst-plugins-dvdread-1.12.3 [1.10.3] [ebuild U ] media-plugins/gst-plugins-a52dec-1.12.3 [1.10.3] [ebuild U ] media-plugins/gst-plugins-dts-1.12.3 [1.10.3] [ebuild U ] media-plugins/gst-plugins-resindvd-1.12.3 [1.10.3] [ebuild r U ] dev-haskell/http-client-0.5.7.0 [0.5.5] [ebuild rR ] dev-haskell/http-client-tls-0.3.3 [0.3.3] [ebuild UD ] virtual/notification-daemon-0 [1] [ebuild U ] media-plugins/gst-plugins-lame-1.12.3 [1.10.3] [ebuild N ] dev-libs/double-conversion-2.0.1 USE="-static-libs" [ebuild U ] media-plugins/gst-plugins-mpeg2dec-1.12.3 [1.10.3] [ebuild U ] app-shells/zsh-completions-0.27.0 [0.25.0] [ebuild U ] dev-texlive/texlive-basic-2017-r1 [2017] [ebuild U ] app-office/libreoffice-l10n-5.4.5.1 [5.2.4.2] [ebuild U ] virtual/ffmpeg-9-r2 [9-r1] USE="(-libav)" [ebuild U ] x11-themes/murrine-themes-0.98.0-r1 [0.98.0] [ebuild U ] app-emulation/virtualbox-modules-5.2.10 [5.1.22] USE="pax_kernel*" [ebuild U ] sys-devel/libtool-2.4.6-r4 [2.4.6-r3] [ebuild U ] dev-libs/confuse-3.2 [3.1] [ebuild U ] sys-devel/automake-1.15.1-r2 [1.15-r2] USE="{-test%}" [ebuild U ] sys-libs/zlib-1.2.11-r2 [1.2.11] [ebuild N ] x11-proto/xproto-7.0.31 USE="-doc" ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/xextproto-7.3.0 USE="-doc" ABI_X86="32 (64) (-x32)" [ebuild U ] dev-libs/icu-58.2-r1 [58.2] [ebuild N ] x11-proto/inputproto-2.3.2 ABI_X86="32 (64) (-x32)" [ebuild U ] dev-libs/libgcrypt-1.8.2 [1.7.3] [ebuild U ] dev-libs/nspr-4.17 [4.15] [ebuild N ] x11-proto/kbproto-1.0.7 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/renderproto-0.11.1-r1 ABI_X86="32 (64) (-x32)" [ebuild U ] sys-libs/gpm-1.20.7-r4 [1.20.7-r3] [ebuild N ] x11-proto/xineramaproto-1.2.1-r1 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/randrproto-1.5.0 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/xf86vidmodeproto-2.3.1-r1 ABI_X86="32 (64) (-x32)" [ebuild U ] x11-libs/libdrm-2.4.83 [2.4.75] [ebuild N ] x11-proto/damageproto-1.2.1-r1 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/compositeproto-0.4.2-r1 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/recordproto-1.14.2-r1 USE="-doc" ABI_X86="(64) -32 (-x32)" [ebuild N ] x11-proto/xf86bigfontproto-1.2.0-r1 ABI_X86="32 (64) (-x32)" [ebuild U ] media-fonts/encodings-1.0.4-r1 [1.0.4] [ebuild U ] app-text/hunspell-1.6.2 [1.6.1-r1] L10N="-kk%" [ebuild N ] x11-proto/videoproto-2.3.3 ABI_X86="(64) -32 (-x32)" [ebuild N ] x11-proto/fontsproto-2.1.3 USE="-doc" [ebuild N ] x11-proto/dri2proto-2.8-r1 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/glproto-1.4.17-r1 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/xf86driproto-2.1.1-r1 ABI_X86="32 (64) (-x32)" [ebuild U ] dev-libs/libuv-1.14.1 [1.11.0] [ebuild N ] x11-proto/scrnsaverproto-1.2.2-r1 USE="-doc" ABI_X86="(64) -32 (-x32)" [ebuild N ] x11-proto/dri3proto-1.0 ABI_X86="32 (64) (-x32)" [ebuild N ] x11-proto/presentproto-1.1 ABI_X86="32 (64) (-x32)" [ebuild U ] x11-misc/xkeyboard-config-2.21 [2.20] [ebuild U ] media-libs/faad2-2.8.5 [2.7-r3] [ebuild N ] x11-proto/resourceproto-1.2.0 [ebuild U ] dev-libs/libebml-1.3.5 [1.3.4] [ebuild U ] dev-libs/apr-util-1.6.1 [1.6.0] [ebuild R ] app-text/aspell-0.60.7_rc1 [0.60.7_rc1] LINGUAS="(-af%) (-be%) (-bg%) (-br%) (-ca%) (-cs%) (-cy%) (-da%) (-de%) (-de@1901%) (-el%) (-en%) (-eo%) (-es%) (-et%) (-fi%) (-fo%) (-fr%) (-ga%) (-gl%) (-he%) (-hr%) (-hu%) (-hy%) (-is%) (-it%) (-la%) (-lt%) (-nl%) (-no%) (-pl%) (-pt%) (-pt_BR%) (-ro%) (-ru%) (-sk%) (-sl%) (-sr%) (-sv%) (-uk%) (-vi%)" [ebuild U ] app-misc/tmux-2.6 [2.5-r1] [ebuild U ] dev-util/google-perftools-2.6.1 [2.5] [ebuild U ] net-libs/libsrtp-1.6.0 [1.5.4] ABI_X86="(64%*) -32% (-x32)" [ebuild N ] x11-proto/xf86miscproto-0.9.3 [ebuild N ] x11-proto/xf86dgaproto-2.1-r2 ABI_X86="(64) -32 (-x32)" [ebuild N ] x11-proto/trapproto-3.4.3 [ebuild N ] x11-proto/bigreqsproto-1.1.2 USE="-doc" [ebuild N ] x11-proto/xf86rushproto-1.1.2-r1 [ebuild N ] x11-proto/xcmiscproto-1.2.2 USE="-doc" [ebuild N ] dev-libs/jemalloc-5.0.1 USE="hardened hugepages -debug -lazy-lock -static-libs -stats -xmalloc" ABI_X86="(64) -32 (-x32)" [ebuild N ] media-libs/speexdsp-1.2_rc3 USE="-static-libs" ABI_X86="(64) -32 (-x32)" CPU_FLAGS_X86="sse sse2" [ebuild U ] app-portage/eix-0.32.9-r1 [0.32.9] [ebuild U ] dev-lang/perl-5.24.0-r3 [5.24.0-r2] [ebuild U ] x11-libs/libX11-1.6.5 [1.6.4] [ebuild U ] media-libs/libpng-1.6.34 [1.6.28] CPU_FLAGS_X86="sse%*" [ebuild U ] media-libs/tiff-4.0.8 [4.0.7] [ebuild U ] dev-libs/libpcre-8.41-r1 [8.40-r1] [ebuild U ] dev-db/sqlite-3.19.3 [3.17.0] [ebuild NS ] sys-devel/binutils-2.29.1-r1 [2.25-r2] USE="cxx nls -multitarget -static-libs {-test} -vanilla" [ebuild U ] x11-libs/libxkbcommon-0.7.2 [0.7.1] [ebuild N ] x11-proto/fixesproto-5.0-r1 ABI_X86="32 (64) (-x32)" [ebuild UD ] sys-libs/binutils-libs-2.28 [2.28-r1] [ebuild U ] app-text/qpdf-8.0.2 [6.0.0-r2] [ebuild U ] media-libs/gst-plugins-good-1.12.3 [1.10.4] [ebuild U ] media-libs/libmtp-1.1.14 [1.1.12] [ebuild N ] dev-libs/re2-0.2017.03.01 USE="icu" ABI_X86="(64) -32 (-x32)" [ebuild U ] dev-libs/protobuf-3.4.1 [3.3.0] [ebuild N ] dev-libs/libpcre2-10.30 USE="bzip2 pcre16 readline recursion-limit unicode zlib -jit -libedit -pcre32 -static-libs" ABI_X86="(64) -32 (-x32)" [ebuild U ] media-fonts/font-misc-misc-1.1.2-r1 [1.1.2] [ebuild U ] media-plugins/gst-plugins-faad-1.12.3 [1.10.3] [ebuild U ] media-libs/libmatroska-1.4.8 [1.4.5] [ebuild U ] media-fonts/unifont-10.0.06 [9.0.06] [ebuild U ] media-fonts/source-pro-20170111 [20160608] [ebuild U ] app-admin/sudo-1.8.21_p2 [1.8.20_p2] USE="-sasl%" [ebuild U ] media-fonts/symbola-9.17 [8.00] [ebuild U ] media-fonts/terminus-font-4.46 [4.40] [ebuild U ] media-fonts/font-bitstream-100dpi-1.0.3-r1 [1.0.3] [ebuild U ] media-fonts/noto-20170403 [20160531] [ebuild U ] dev-libs/libisofs-1.4.8 [1.4.6] [ebuild U ] app-text/enchant-1.6.1 [1.6.0] USE="{-test%}" [ebuild U ] media-fonts/font-mutt-misc-1.0.3-r1 [1.0.3] [ebuild U ] media-fonts/font-bh-75dpi-1.0.3-r1 [1.0.3] [ebuild U ] x11-apps/sessreg-1.1.1 [1.1.0] [ebuild U ] media-fonts/font-bh-100dpi-1.0.3-r1 [1.0.3] [ebuild U ] media-libs/freetype-2.8 [2.6.5-r1] USE="cleartype_hinting*" [ebuild R ] sys-kernel/linux-headers-4.9 [4.9] USE="-headers-only%" [ebuild U ] media-libs/lcms-2.8-r2 [2.8-r1] [ebuild NS ] sys-devel/gcc-5.4.0-r1 [4.9.3-r3] USE="cxx hardened (multilib) nls openmp -ada (-altivec) -doc -fortran -graphite (-libssp) -objc -objc++ (-sanitize) -vanilla" [ebuild U ] sys-apps/hwids-20170328 [20161103] [ebuild U ] dev-libs/libtasn1-4.12-r1 [4.12] [ebuild U ] media-libs/jbig2dec-0.14 [0.13-r1] [ebuild U ] net-dns/libidn2-2.0.4 [2.0.2] [ebuild U ] sys-devel/automake-1.13.4-r2 [1.13.4-r1] USE="{-test%}" [ebuild U ] sys-apps/less-491 [487] [ebuild U ] dev-libs/nss-3.34.1 [3.31] [ebuild U ] dev-libs/m17n-lib-1.7.0 [1.6.4] [ebuild N ] dev-lang/nasm-2.13.01 USE="-doc" [ebuild U ] media-plugins/gst-plugins-vpx-1.12.3 [1.10.4] [ebuild U ] media-plugins/gst-plugins-wavpack-1.12.3 [1.10.4] [ebuild U ] media-plugins/gst-plugins-flac-1.12.3 [1.10.4] [ebuild U ] media-gfx/qrencode-4.0.0 [3.4.4-r1] USE="{-test%}" [ebuild U ] x11-libs/libXcursor-1.1.14-r1 [1.1.14] [ebuild UD ] dev-libs/libbsd-0.8.3 [0.8.3-r2] [ebuild U ] sys-apps/iproute2-4.14.1-r3 [4.3.0] [ebuild U ] sys-apps/busybox-1.27.2 [1.26.2] [ebuild U ] media-libs/x264-0.0.20170701 [0.0.20160712] USE="(-altivec)" [ebuild U ] x11-libs/libpciaccess-0.13.5 [0.13.4] [ebuild U ] x11-apps/xkbcomp-1.4.0 [1.3.1] [ebuild U ] x11-libs/libXfont2-2.0.3 [2.0.1] [ebuild UD ] sys-apps/keyutils-1.5.9-r4 [1.5.10] [ebuild U ] x11-libs/libXfont-1.5.4 [1.5.2] [ebuild U ] media-libs/imlib2-1.4.10 [1.4.9] [ebuild U ] media-plugins/gst-plugins-x264-1.12.3 [1.10.3] [ebuild U ] dev-libs/openssl-1.0.2o [1.0.2k] [ebuild U ] net-misc/curl-7.54.0 [7.53.0] [ebuild U ] net-misc/wget-1.19.2-r1 [1.19.1] [ebuild U ] net-misc/openssh-7.5_p1-r4 [7.4_p1] USE="hpn*" [ebuild U ] net-vpn/openvpn-2.4.5 [2.4.2-r1] [ebuild U ] dev-qt/qtcore-4.8.7-r4 [4.8.7-r2] USE="(-icu*)" [ebuild U ] net-libs/serf-1.3.9 [1.3.8-r1] [ebuild U ] net-libs/libssh2-1.8.0-r1 [1.8.0] [ebuild U ] mail-mta/postfix-3.2.4 [3.1.4] [ebuild U ] www-client/w3m-0.5.3_p20180125 [0.5.3-r9] USE="-gdk-pixbuf%" L10N="-de%" [ebuild U ] app-crypt/gnupg-2.1.20 [2.1.18] [ebuild UD ] dev-util/cmake-3.8.0 [3.8.2] [ebuild U ] dev-qt/qtcore-5.9.4-r2 [5.7.1-r1] [ebuild U ] net-misc/keychain-2.8.5 [2.8.3] [ebuild U ] media-libs/openjpeg-2.3.0 [2.1.2] [ebuild U ] dev-qt/qtnetwork-5.9.4 [5.7.1] USE="-libressl%" [ebuild U ] dev-qt/qtxml-5.9.4 [5.7.1] [ebuild U ] dev-qt/qtdbus-5.9.4 [5.7.1] [ebuild U ] net-libs/libssh-0.7.5-r2 [0.7.5] [ebuild U ] media-libs/x265-2.5 [2.3] USE="(-power8)" [ebuild U ] dev-libs/libical-2.0.0-r2 [2.0.0-r1] [ebuild U ] dev-qt/qtsql-5.9.4-r1 [5.7.1] [ebuild U ] app-arch/snappy-1.1.7 [1.1.3-r1] USE="{-test%}" [ebuild U ] media-libs/taglib-1.11.1-r1 [1.11.1] [ebuild N ] app-text/cmark-0.28.3 USE="{-test}" [ebuild U ] dev-qt/qtpositioning-5.9.4 [5.7.1] [ebuild U ] dev-qt/qttest-5.9.4 [5.7.1] [ebuild U ] sys-process/tini-0.17.0 [0.14.0] [ebuild U ] media-libs/glm-0.9.8.5 [0.9.8.4] [ebuild U ] sys-libs/libomp-6.0.0 [4.0.0] USE="-cuda% -offload%" [ebuild U ] dev-qt/qtconcurrent-5.9.4 [5.7.1] [ebuild U ] dev-qt/linguist-tools-5.9.4 [5.7.1] [ebuild r U ] dev-haskell/cmark-0.5.6 [0.5.5] USE="system-cmark%*" [ebuild U ] dev-libs/leveldb-1.18-r2 [1.18-r1] [ebuild U ] dev-qt/qtxmlpatterns-5.9.4 [5.7.1] [ebuild U ] media-plugins/gst-plugins-taglib-1.12.3 [1.10.4] [ebuild U ] dev-libs/qtkeychain-0.8.0 [0.7.0] USE="-gnome-keyring% -qt4*" [ebuild rR ] app-text/pandoc-1.19.2.1-r1 [1.19.2.1-r1] [ebuild U ] dev-lang/python-2.7.13-r1 [2.7.13] [ebuild NS ] sys-devel/llvm-5.0.1 [3.9.1-r1] USE="libffi ncurses -debug -doc -gold -libedit {-test}" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" [ebuild U ] sys-apps/usbutils-008-r1 [007] [ebuild U ] media-libs/alsa-lib-1.1.4.1 [1.1.3] [ebuild U ] dev-util/boost-build-1.63.0 [1.62.0-r1] [ebuild U ] app-crypt/mit-krb5-1.15.2-r1 [1.15.1] [ebuild U ] app-portage/pfl-2.4-r5 [2.4-r4] [ebuild U ] app-misc/byobu-5.125 [5.119] [ebuild U ] media-libs/mesa-17.2.8 [17.0.0] USE="-unwind%" VIDEO_CARDS="-virgl%" [ebuild U ] media-libs/libsndfile-1.0.28-r1 [1.0.27-r1] [ebuild U ] media-sound/alsa-utils-1.1.4-r1 [1.1.3] [ebuild UD ] x11-libs/cairo-1.14.8 [1.14.10] [ebuild UD ] media-libs/harfbuzz-1.7.5 [9999] USE="-debug%" [ebuild U ] app-text/poppler-0.52.0-r2 [0.51.0] [ebuild U ] media-libs/libass-0.13.7 [0.13.6] [ebuild U ] media-plugins/gst-plugins-assrender-1.12.3 [1.10.3] [ebuild U ] dev-lang/python-3.4.6-r1 [3.4.6] [ebuild U ] dev-libs/libxml2-2.9.7-r1 [2.9.4-r1] PYTHON_TARGETS="-python3_6%" [ebuild U ] sys-apps/util-linux-2.29.2-r2 [2.29.2] [ebuild U ] app-misc/ca-certificates-20180409.3.36.1-r1 [20161130.3.29.1] [ebuild U ] sys-apps/kmod-25 [23] PYTHON_TARGETS="-python3_6%" [ebuild U ] media-libs/libepoxy-1.4.3 [1.4.0] USE="X%*" [ebuild R ] sys-libs/libcap-ng-0.7.8 [0.7.8] PYTHON_TARGETS="(-python3_6%)" [ebuild U ] dev-python/pyelftools-0.24 [0.23-r1] [ebuild U ] app-portage/gentoolkit-0.4.1 [0.3.3] PYTHON_TARGETS="-python3_6%" [ebuild r U ] dev-libs/boost-1.63.0 [1.62.0-r1] PYTHON_TARGETS="-python3_6%" [ebuild U ] app-text/iso-codes-3.76 [3.74] [ebuild U ] app-crypt/gpgme-1.10.0 [1.8.0-r3] [ebuild UD ] dev-libs/libnl-3.3.0_rc1 [3.3.0] [ebuild U ] dev-python/pycairo-1.15.1 [1.13.1-r1] [ebuild N ] dev-libs/libbytesize-1.2 USE="-doc {-test}" PYTHON_SINGLE_TARGET="python3_4 -python2_7 -python3_5 -python3_6" PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" [ebuild R ] dev-python/typing-3.5.3.0 [3.5.3.0] PYTHON_TARGETS="(-python3_6%)" [ebuild U ] sys-boot/boot-update-1.8.2 [1.7.7] PYTHON_SINGLE_TARGET="python3_4%* -python3_5% -python3_6%" PYTHON_TARGETS="python3_4%* -python3_5% -python3_6%" [ebuild UD ] dev-python/pyparsing-2.1.10 [2.2.0] [ebuild U ] x11-misc/shared-mime-info-1.9 [1.8] [ebuild U ] sys-fs/e2fsprogs-1.43.8 [1.43.4] [ebuild U ] sys-apps/pciutils-3.5.4 [3.5.3] [ebuild U ] sys-fs/eudev-3.2.2-r1 [3.1.5] [ebuild U ] sys-apps/gptfdisk-1.0.3 [1.0.0] [ebuild UD ] app-crypt/p11-kit-0.23.2 [0.23.7] [ebuild U ] sys-fs/xfsprogs-4.14.0 [4.5.0] [ebuild U ] dev-libs/libxslt-1.1.30-r1 [1.1.29-r1] [ebuild U ] dev-libs/librevenge-0.0.4-r1 [0.0.4] [ebuild NS ] sys-devel/llvm-6.0.0 [3.9.1-r1] USE="libffi ncurses xml -debug -doc -gold -libedit {-test} -xar" ABI_X86="32 (64) (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" [ebuild rR ] dev-util/mdds-1.2.3 [1.2.3] [ebuild U ] media-libs/libbluray-1.0.2 [0.9.3] [ebuild U ] app-text/scrollkeeper-dtd-1.0-r1 [1.0] [ebuild U ] sys-fs/cryptsetup-1.7.5 [1.7.2] PYTHON_TARGETS="-python3_6%" [ebuild R ] x11-proto/xcb-proto-1.12-r2 [1.12-r2] PYTHON_TARGETS="-python3_6%" [ebuild rR ] dev-cpp/libcmis-0.5.2_pre20160820-r1 [0.5.2_pre20160820-r1] [ebuild U ] net-wireless/wpa_supplicant-2.6-r4 [2.6-r1] USE="-eapol_test% -privsep%" [ebuild N ] net-libs/nghttp2-1.31.1 USE="cxx threads xml -debug -hpack-tools -jemalloc -libressl -static-libs {-test} -utils" ABI_X86="(64) -32 (-x32)" [ebuild U ] dev-vcs/mercurial-4.3.3 [4.2.1] [ebuild rR ] games-strategy/wesnoth-1.12.6 [1.12.6] [ebuild UD ] x11-misc/xdg-utils-1.1.1-r1 [1.1.2] [ebuild U ] app-text/mupdf-1.12.0 [1.11-r1] USE="-lcms%" [ebuild U ] dev-libs/libcroco-0.6.11-r1 [0.6.11] [ebuild UD ] app-text/rarian-0.8.1-r2 [0.8.1-r3] [ebuild R ] dev-python/pygobject-3.20.1 [3.20.1] PYTHON_TARGETS="-python3_6%" [ebuild U ] app-text/asciidoc-8.6.10 [8.6.9-r5] [ebuild U ] app-text/libwpd-0.10.2 [0.10.1] [ebuild U ] media-libs/raptor-2.0.15 [2.0.14] [ebuild U ] kde-frameworks/extra-cmake-modules-5.43.0 [5.31.0] [ebuild N ] dev-libs/volume_key-0.3.9 USE="{-test}" PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6" [ebuild U ] sys-power/cpupower-4.13.0 [4.5.0-r1] [ebuild U ] sys-apps/accountsservice-0.6.45 [0.6.43-r1] [ebuild U ] sys-kernel/genkernel-3.4.40.20 [3.4.40.13] [ebuild U ] media-libs/libcdr-0.1.4 [0.1.3] [ebuild N ] app-text/libstaroffice-0.0.5 USE="zlib -debug -doc -tools" [ebuild N ] media-libs/libzmf-0.0.2 USE="-debug -doc {-test} -tools" [ebuild U ] media-libs/libfreehand-0.1.2 [0.1.1] USE="{-test%}" [ebuild U ] app-text/libebook-0.1.3 [0.1.2-r1] [ebuild U ] media-libs/libvisio-0.1.5-r1 [0.1.5] [ebuild U ] app-text/libetonyek-0.1.7 [0.1.6] [ebuild U ] app-text/libabw-0.1.2 [0.1.1] [ebuild U ] app-text/libmspub-0.1.4 [0.1.2] [ebuild U ] app-text/libwps-0.4.8 [0.4.4-r1] [ebuild U ] app-text/libmwaw-0.3.13 [0.3.9] [ebuild N ] dev-libs/xmlsec-1.2.24-r1 USE="nss openssl -doc -gcrypt -gnutls -libressl -static-libs" [ebuild U ] dev-libs/libixion-0.12.2 [0.11.1] USE="threads%* -debug%" PYTHON_SINGLE_TARGET="-python3_6%" PYTHON_TARGETS="-python3_6%" [ebuild U ] sys-libs/talloc-2.1.11 [2.1.9] [ebuild U ] app-text/po4a-0.47-r2 [0.47-r1] [ebuild U ] dev-libs/libgudev-232 [231] [ebuild U ] net-libs/nodejs-8.9.3 [8.1.2] USE="-inspector%" [ebuild U ] sys-apps/man-db-2.7.6.1-r2 [2.7.6.1-r1] [ebuild U ] virtual/libgudev-232 [230] [ebuild U ] app-editors/vim-8.0.1735 [8.0.0606] [ebuild NS ] sys-kernel/debian-sources-4.14.12 [4.8.15] USE="binary" [ebuild U ] x11-misc/lightdm-1.24.0 [1.22.0] [ebuild U ] dev-util/colm-0.13.0.5 [0.13.0.4] [ebuild N ] sys-libs/libblockdev-2.15-r1 USE="cryptsetup -bcache -dmraid -doc -kbd -lvm {-test}" PYTHON_SINGLE_TARGET="python3_4 -python3_5 -python3_6" PYTHON_TARGETS="python3_4 -python3_5 -python3_6" [ebuild N ] sys-fs/btrfs-progs-4.14.1 USE="convert zstd -reiserfs -static -static-libs" [ebuild U ] dev-libs/liborcus-0.12.1 [0.11.2] PYTHON_SINGLE_TARGET="-python3_6%" PYTHON_TARGETS="-python3_6%" [ebuild U ] app-text/libwpg-0.3.2 [0.3.1] [ebuild U ] net-fs/cifs-utils-6.8 [6.7] [ebuild U ] media-gfx/feh-2.21 [2.19] [ebuild U ] media-libs/jasper-2.0.12 [2.0.10] [ebuild U ] dev-util/ragel-7.0.0.10 [7.0.0.9] [ebuild U ] sys-fs/udisks-2.7.5 [2.6.5] [ebuild U ] media-plugins/gst-plugins-v4l2-1.12.3 [1.10.4] [ebuild U ] app-emulation/containerd-1.0.3 [0.2.8_p20170504] USE="btrfs%*" [ebuild U ] net-misc/nx-3.5.99.16 [3.5.0.32] [ebuild U ] app-editors/emacs-25.3-r4 [25.2] [ebuild NS ] app-editors/emacs-26.1_rc1 [25.2] USE="X acl alsa dbus gif gpm gtk3 imagemagick inotify jpeg png ssl svg threads tiff xft xpm zlib -Xaw3d (-aqua) -athena (-cairo) -dynamic-loading -games -gconf -gfile -gsettings -gtk -gzip-el -kerberos -libxml2 -livecd -m17n-lib -mailutils -motif (-selinux) -sound -source -systemd -toolkit-scroll-bars -wide-int -xwidgets" [ebuild U ] app-emulation/virtualbox-bin-5.2.10.122088 [5.1.22.115126] [ebuild U ] dev-libs/libwacom-0.26 [0.25] [ebuild U ] x11-libs/gdk-pixbuf-2.36.9 [2.36.6] [ebuild U ] gnome-base/gvfs-1.28.3-r2 [1.28.3-r1] [ebuild U ] net-misc/networkmanager-1.10.2 [1.8.0] USE="-ovs%" [ebuild U ] app-emulation/docker-18.04.0 [17.06.0] [ebuild FU ] net-misc/icaclient-13.9.1.6 [13.5.0.10185126] L10N="-de% -es% -fr% -ja% -zh_CN%" [ebuild U ] dev-python/setuptools-36.4.0 [36.0.1] [ebuild R ] sys-apps/file-5.30 [5.30] PYTHON_TARGETS="-python3_6%" [ebuild U ] dev-python/certifi-2017.7.27.1 [2017.4.17] [ebuild U ] dev-python/idna-2.6 [2.5] [ebuild U ] dev-python/chardet-3.0.4 [3.0.3] [ebuild R ] dev-python/pyxattr-0.6.0 [0.6.0] PYTHON_TARGETS="(-python3_6%)" [ebuild N ] dev-python/appi-0.1.7 PYTHON_TARGETS="python3_4 -python3_5 -python3_6" [ebuild N ] dev-python/mwparserfromhell-0.5 PYTHON_TARGETS="python2_7 python3_4 -python3_5 -python3_6" [ebuild R ] dev-python/pypax-0.9.2 [0.9.2] PYTHON_TARGETS="(-python3_6%)" [ebuild U ] dev-util/meson-0.43.0 [0.41.0] [ebuild UD ] dev-python/m2crypto-0.25.1-r2 [0.26.0] [ebuild U ] media-libs/mutagen-1.38 [1.36.2] PYTHON_TARGETS="-python3_6%" [ebuild U ] dev-python/lxml-3.8.0 [3.7.3] [ebuild UD ] dev-python/cryptography-1.7.2 [1.9] [ebuild U ] dev-vcs/subversion-1.9.7 [1.9.5] [ebuild UD ] dev-python/pyopenssl-16.2.0 [17.0.0] [ebuild U ] dev-python/urllib3-1.22 [1.21.1] [ebuild UD ] dev-python/ndg-httpsclient-0.4.2 [0.4.2-r1] [ebuild U ] dev-python/requests-2.18.4 [2.11.1] USE="ssl%* -socks5%" [ebuild R ] dev-python/ssl-fetch-0.4 [0.4] PYTHON_TARGETS="(-python3_6%)" [ebuild U ] app-portage/layman-2.4.2-r1 [2.4.2] [ebuild U ] net-print/cups-2.2.7 [2.2.3] [ebuild U ] x11-libs/gtk+-3.20.10 [3.20.9] [ebuild U ] net-print/cups-filters-1.20.3 [1.14.0] USE="-pclm% {-test%}" [ebuild UD ] net-wireless/bluez-5.44-r1 [5.45] [ebuild U ] app-office/libreoffice-bin-5.4.2.2 [5.2.4.2] [ebuild U ] net-im/skypeforlinux-8.18.0.6 [5.3.0.1] ABI_X86="-32% (-x32)" [ebuild U ] dev-java/oracle-jdk-bin-1.8.0.162 [1.8.0.131] [ebuild U ] app-i18n/ibus-1.5.16 [1.5.14] USE="emoji%* libnotify%* -kde%" PYTHON_TARGETS="python3_4%* -python3_5% -python3_6%" [ebuild R ] dev-libs/libpeas-1.18.0 [1.18.0] PYTHON_TARGETS="-python3_6%" [ebuild U ] gnome-extra/gucharmap-10.0.0 [9.0.0] [ebuild UD ] x11-misc/xdg-user-dirs-gtk-0.10 [0.10-r1] [ebuild U ] gnome-extra/nm-applet-1.8.6 [1.8.2] [ebuild U ] xfce-base/libxfce4ui-4.13.3 [4.13.1] USE="introspection%*" [ebuild U ] www-client/google-chrome-66.0.3359.117 [59.0.3071.104] [ebuild U ] app-text/evince-3.20.1-r1 [3.20.1] [ebuild U ] app-text/atril-1.18.3 [1.18.0] [ebuild U ] app-arch/engrampa-1.18.3 [1.18.1] [ebuild U ] gnome-extra/evolution-data-server-3.20.6 [3.20.5] [ebuild U ] x11-libs/libcryptui-3.12.2-r1 [3.12.2] [ebuild U ] xfce-base/exo-0.11.5 [0.11.3] [ebuild U ] app-i18n/ibus-unikey-0.6.1-r2 [0.6.1-r1] USE="nls%* -gtk% -gtk2%" [ebuild U ] net-misc/networkmanager-openvpn-1.8.2 [1.2.10] [ebuild R ] app-i18n/ibus-m17n-1.3.4 [1.3.4] USE="-gtk2%" [ebuild U ] mate-base/mate-session-manager-1.18.0-r1 [1.18.0] USE="xtrans*" [ebuild U ] app-editors/pluma-1.18.3 [1.18.2] [ebuild U ] mate-base/mate-applets-1.18.1-r1 [1.18.1] [ebuild U ] x11-misc/lightdm-gtk-greeter-2.0.3 [2.0.2] [ebuild U ] dev-lang/ruby-2.4.3 [2.4.1-r2] [ebuild U ] media-sound/pulseaudio-11.1 [10.0] [ebuild U ] media-video/ffmpeg-3.3.4 [3.2.4] USE="-chromium% -sofalizer% -zeromq%" [ebuild U ] media-libs/libmatemixer-1.18.0 [1.16.0] [ebuild U ] media-plugins/gst-plugins-pulse-1.12.3 [1.10.4] [ebuild U ] media-sound/mpg123-1.25.7 [1.23.8] [ebuild U ] media-libs/openal-1.18.2 [1.17.2] [ebuild U ] media-plugins/alsa-plugins-1.1.4-r1 [1.1.1] [ebuild U ] media-plugins/gst-plugins-libav-1.12.3 [1.10.4] [ebuild U ] net-misc/freerdp-2.0.0_rc1-r1 [2.0.0_pre20161219] USE="-openh264%" CPU_FLAGS_X86="ssse3%*" [ebuild U ] net-misc/remmina-1.2.0_rc29-r1 [1.2.0_rc18] USE="-libressl% -vnc%" [ebuild U ] media-plugins/gst-plugins-meta-1.10.5 [1.10.3] [ebuild U ] dev-lang/ruby-2.3.6 [2.3.4-r2] [ebuild U ] dev-lang/ruby-2.2.9 [2.2.7-r2] [ebuild U ] dev-ruby/rubygems-2.6.14 [2.6.12] [ebuild R ] virtual/rubygems-13 [13] RUBY_TARGETS="(-ruby21%*)" [ebuild U ] dev-ruby/rake-12.1.0 [12.0.0] [ebuild U ] dev-ruby/power_assert-1.1.0 [1.0.2] [ebuild U ] dev-ruby/minitest-5.10.3 [5.10.2] [ebuild R ] dev-ruby/net-telnet-0.1.1-r1 [0.1.1-r1] RUBY_TARGETS="(-ruby21%*)" [ebuild R ] dev-ruby/kpeg-1.1.0 [1.1.0] RUBY_TARGETS="(-ruby21%*)" [ebuild U ] net-libs/webkit-gtk-2.18.6 [2.16.3] [ebuild R ] dev-ruby/json-2.1.0 [2.1.0] RUBY_TARGETS="(-ruby21%*)" [ebuild U ] dev-ruby/test-unit-3.2.6 [3.2.4] [ebuild R ] dev-ruby/racc-1.4.14 [1.4.14] RUBY_TARGETS="(-ruby21%*)" [ebuild R ] dev-ruby/rdoc-5.1.0 [5.1.0] RUBY_TARGETS="(-ruby21%*)" [ebuild U ] x11-misc/i3lock-2.9.1 [2.9] [ebuild U ] x11-misc/rofi-1.4.2 [1.3.1] USE="{-test%}" [ebuild U ] dev-qt/qtgui-5.9.4-r3 [5.7.1] USE="libinput* -vnc%" [ebuild U ] dev-qt/qtwidgets-5.9.4-r1 [5.7.1] USE="-gtk%" [ebuild U ] dev-qt/qtx11extras-5.9.4 [5.7.1] [ebuild U ] x11-wm/i3-4.14.1 [4.13-r1] USE="-debug% {-test%}" [ebuild U ] dev-qt/qtmultimedia-5.9.4-r1 [5.7.1] [ebuild U ] dev-qt/qtdeclarative-5.9.4 [5.7.1] [ebuild U ] dev-qt/qtprintsupport-5.9.4 [5.7.1] [ebuild U ] dev-qt/qtsvg-5.9.4-r1 [5.7.1] [ebuild U ] dev-qt/qtopengl-5.9.4 [5.7.1] [ebuild U ] net-misc/nextcloud-client-2.3.3 [2.3.1-r2] [ebuild U ] media-video/vlc-2.2.6-r2 [2.2.4-r1] USE="qt5* -qt4*" [ebuild U ] dev-qt/qtwebkit-5.9.1 [5.7.1] USE="-gles2%" [ebuild U ] dev-qt/qtwebchannel-5.9.4 [5.7.1] [ebuild U ] net-misc/x2goclient-4.1.1.1 [4.1.0.0-r1] [ebuild U ] dev-qt/qtwebengine-5.9.4 [5.7.1-r1] USE="(-system-icu*)" [ebuild FU ] sci-misc/mendeleydesktop-1.18 [1.17.10] [ebuild U ] dev-lang/rust-1.23.0-r1 [1.16.0] USE="jemalloc%* -extended%" [ebuild N ] virtual/rust-1.23.0 [ebuild U ] dev-util/cargo-0.24.0 [0.17.0] [ebuild NS ] sys-devel/clang-6.0.0 [3.9.1-r100] USE="static-analyzer xml -debug -default-compiler-rt -default-libcxx -doc {-test} (-z3)" ABI_X86="(64) -32 (-x32)" LLVM_TARGETS="AMDGPU BPF NVPTX (X86) -AArch64 -ARM -Hexagon -Lanai -MSP430 -Mips -PowerPC -Sparc -SystemZ -XCore" PYTHON_TARGETS="python2_7" [uninstall ] sys-devel/llvm-3.9.1-r1 [blocks b ] sys-devel/llvm:0 ("sys-devel/llvm:0" is blocking sys-devel/llvm-5.0.1, sys-devel/llvm-common-6.0.0, sys-devel/llvm-6.0.0) [blocks b ] <sys-devel/llvm-4.0.0_rc:0 ("<sys-devel/llvm-4.0.0_rc:0" is blocking sys-devel/clang-6.0.0) [uninstall ] sys-devel/llvm-3.9.1-r1 [blocks b ] sys-devel/llvm:0 ("sys-devel/llvm:0" is blocking sys-devel/llvm-5.0.1, sys-devel/llvm-common-6.0.0, sys-devel/llvm-6.0.0) [blocks b ] <sys-devel/llvm-4.0.0_rc:0 ("<sys-devel/llvm-4.0.0_rc:0" is blocking sys-devel/clang-6.0.0) [uninstall ] sys-devel/clang-3.9.1-r100 [blocks b ] sys-devel/clang:0 ("sys-devel/clang:0" is blocking sys-devel/clang-6.0.0) [ebuild N ] sys-libs/compiler-rt-sanitizers-6.0.0 USE="clang {-test}" [ebuild N ] sys-libs/compiler-rt-6.0.0 USE="clang {-test}" [ebuild NS ] sys-devel/clang-runtime-6.0.0 [3.9.1] USE="compiler-rt openmp sanitize -libcxx" ABI_X86="(64) -32 (-x32)" [ebuild U ] www-client/firefox-58.0.1 [54.0] USE="screenshot%* -eme-free%" [blocks B ] <x11-proto/fontsproto-2.1.3-r1 ("<x11-proto/fontsproto-2.1.3-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/fixesproto-5.0-r2 ("<x11-proto/fixesproto-5.0-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xf86miscproto-0.9.3-r1 ("<x11-proto/xf86miscproto-0.9.3-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/resourceproto-1.2.0-r1 ("<x11-proto/resourceproto-1.2.0-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/inputproto-2.3.2-r1 ("<x11-proto/inputproto-2.3.2-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xf86dgaproto-2.1-r3 ("<x11-proto/xf86dgaproto-2.1-r3" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/kbproto-1.0.7-r1 ("<x11-proto/kbproto-1.0.7-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xf86driproto-2.1.1-r2 ("<x11-proto/xf86driproto-2.1.1-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/presentproto-1.1-r1 ("<x11-proto/presentproto-1.1-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xf86bigfontproto-1.2.0-r2 ("<x11-proto/xf86bigfontproto-1.2.0-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/scrnsaverproto-1.2.2-r2 ("<x11-proto/scrnsaverproto-1.2.2-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xineramaproto-1.2.1-r2 ("<x11-proto/xineramaproto-1.2.1-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/glproto-1.4.17-r2 ("<x11-proto/glproto-1.4.17-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] x11-proto/xf86rushproto ("x11-proto/xf86rushproto" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/videoproto-2.3.3-r1 ("<x11-proto/videoproto-2.3.3-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/trapproto-3.4.3-r1 ("<x11-proto/trapproto-3.4.3-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/randrproto-1.5.0-r1 ("<x11-proto/randrproto-1.5.0-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/compositeproto-0.4.2-r2 ("<x11-proto/compositeproto-0.4.2-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/bigreqsproto-1.1.2-r1 ("<x11-proto/bigreqsproto-1.1.2-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/dri3proto-1.0-r1 ("<x11-proto/dri3proto-1.0-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/dri2proto-2.8-r2 ("<x11-proto/dri2proto-2.8-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xproto-7.0.31-r1 ("<x11-proto/xproto-7.0.31-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xf86vidmodeproto-2.3.1-r2 ("<x11-proto/xf86vidmodeproto-2.3.1-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/renderproto-0.11.1-r2 ("<x11-proto/renderproto-0.11.1-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xextproto-7.3.0-r1 ("<x11-proto/xextproto-7.3.0-r1" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/recordproto-1.14.2-r2 ("<x11-proto/recordproto-1.14.2-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/damageproto-1.2.1-r2 ("<x11-proto/damageproto-1.2.1-r2" is blocking x11-base/xorg-proto-2018.4) [blocks B ] <x11-proto/xcmiscproto-1.2.2-r1 ("<x11-proto/xcmiscproto-1.2.2-r1" is blocking x11-base/xorg-proto-2018.4) Fetch instructions for sci-misc/mendeleydesktop-1.18: * Please download mendeleydesktop-1.18-linux-x86_64.tar.bz2 from: * http://www.mendeley.com/download-mendeley-desktop/ * and move it to /var/tmp/tmpvLKdzF/portage/sci-misc/mendeleydesktop-1.18/distdir Fetch instructions for net-misc/icaclient-13.9.1.6: * Download the client file linuxx64-13.9.1.6.tar.gz from * https://www.citrix.com/downloads/citrix-receiver.html * and place it in /var/tmp/tmpdQvxOW/portage/net-misc/icaclient-13.9.1.6/distdir. * Error: The above package list contains packages which cannot be * installed at the same time on the same system.
  10. biocyberman

    ERROR: USE flag <flag> does not exist

    I am baffled. This happens after I switch to "meta-repo" from "ports-2012". I tried several packages, euse can't see packages flag. For example, the following is for xorg-server: # euse -p "x11-base/xorg-server" -E "xephyr" ERROR: USE flag "xephyr" does not exist # equery u xorg-server [ Legend : U - final flag setting for installation] [ : I - package is installed with flag ] [ Colors : set, unset ] * Found these USE flags for x11-base/xorg-server-1.17.4-r2: U I - - dmx : Build the Distributed Multiheaded X server - - doc : Add extra documentation (API, Javadoc, etc). It is recommended to enable per package instead of globally - - glamor : Enable Glamor OpenGL 2D acceleration + + ipv6 : Add support for IP version 6 - - kdrive : Build the kdrive X servers - - libressl : Use dev-libs/libressl as SSL provider (might need ssl USE flag), packages should not depend on this USE flag - - minimal : Install a very minimal build (disables, for example, plugins, fonts, most drivers, non-critical features) + + nptl : Enable support for Native POSIX Threads Library, the new threading module (requires linux-2.6 or better usually) - - static-libs : Build static versions of dynamic libraries as well + + suid : Enable setuid root program, with potential security risks - - systemd : Enable use of systemd-specific libraries and features like socket activation or session tracking - - tslib : Build with tslib support for touchscreen devices + + udev : Enable virtual/udev integration (device discovery, power and storage device support, etc) - - unwind : Enable libunwind usage for backtraces - - wayland : Enable dev-libs/wayland backend - - xephyr : Build the Xephyr server - - xnest : Build the Xnest server + + xorg : Build the Xorg X server (HIGHLY RECOMMENDED) + + xvfb : Build the Xvfb server
  11. Found it! The trick is "# emerge -auDN --newrepo @world". The '--newrepo' option is crucial. Update 19 Oct 2017: The command above works for more than 1000 packages I have installed, except the qt* packages. For these stubborn qt* packages I had to do the following: emerge -Cav "dev-qt/qt*" * This action can remove important packages! In order to be safer, use * `emerge -pv --depclean <atom>` to check for reverse dependencies before * removing packages. >>> These are the packages that would be unmerged: dev-qt/qtsql selected: 5.9.2 protected: none omitted: none dev-qt/qtx11extras selected: 5.7.1 protected: none omitted: none ... truncated for clarity ... dev-qt/qtprintsupport selected: 5.7.1 protected: none omitted: none All selected packages: =dev-qt/qtwidgets-5.7.1 =dev-qt/qtgui-4.8.7 =dev-qt/qtcore-5.9.2 =dev-qt/qtwebchannel-5.7.1 =dev-qt/qtpositioning-5.9.2 =dev-qt/qtopengl-4.8.7 =dev-qt/qtcore-4.8.7-r2 =dev-qt/qtwebengine-5.7.1-r2 =dev-qt/qtgui-5.7.1 =dev-qt/qtsql-5.9.2 =dev-qt/qtprintsupport-5.7.1 =dev-qt/qtdeclarative-5.7.1 = dev-qt/qtxmlpatterns-5.9.2 =dev-qt/qtdbus-5.9.2 =dev-qt/qtsvg-4.8.7 =dev-qt/qtopengl-5.7.1 =dev-qt/qtxml-5.9.2 =dev-qt/qttranslations-4.8.7 =dev-qt/qtdbus-4.8.7 =dev-qt/qtchooser-0_p20170803 =dev-qt/qtwebkit-5.7.1 =dev-qt/qttest-5.9.2 =dev-qt/qtnetwork-5.9.2 =dev-qt/qtsvg-5.7.1 =dev-qt/qtscript-4.8.7 =dev-qt/qtconcu rrent-5.9.2 =dev-qt/qtx11extras-5.7.1 >>> 'Selected' packages are slated for removal. >>> 'Protected' and 'omitted' packages will not be removed. Would you like to unmerge these packages? [Yes/No] Yes Next, run this command: # Here I have renamed the /usr/portage directory for backup emerge -av @preserved-rebuild
  12. I asked about a problem with upgrade to meta repo here: I got most of the things to work now, but the following issue of ebuild source conflicts keeps bugging me: # emerge -av "=dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit" "=dev-qt/qtgui-5.9.2:5/5.9::kde-kit" "=dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit" !3940 Password: !!! Repository 'x-portage' is missing masters attribute in '/usr/local/portage/metadata/layout.conf' !!! Set 'masters = core-kit' in this file for future compatibility * IMPORTANT: config file '/etc/portage/package.use' needs updating. * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS * sections of the emerge man page to learn how to update config files. These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-qt/qtgui-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::gentoo] USE="dbus gif jpeg libinput* png udev xcb -accessibility -debug -egl -eglfs -evdev -gles2 -ibus {-test} -tslib -tuio -vnc% (-gtk%)" 0 KiB [ebuild U ] dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::gentoo] USE="png xcb -debug -gles2 -gtk% {-test}" 0 KiB [ebuild U ] dev-qt/qtdeclarative-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::gentoo] USE="widgets xml -debug -gles2 -jit -localstorage {-test}" 0 KiB [ebuild U ] dev-qt/qtwebchannel-5.9.2:5/5.9::kde-kit [5.7.1:5/5.7::gentoo] USE="qml -debug {-test}" 0 KiB [ebuild U ] dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit [5.7.1-r2:5/5.7::kde-kit] USE="alsa pax_kernel pulseaudio system-ffmpeg system-icu widgets -bindist -debug -geolocation {-test}" 0 KiB Total: 5 packages (5 upgrades), Size of downloads: 0 KiB Oops! Conflicts have been encountered: >>> =dev-qt/qtgui-5.9.2:5/5.9::kde-kit, wants =dev-qt/qtgui-5.9.2:5/5.9::kde-kit >>> dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge, wants ~dev-qt/qtgui-5.9.2[gles2=,png=,xcb?] >>> dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge, wants ~dev-qt/qtgui-5.9.2 >>> dev-qt/qtdeclarative-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge, wants ~dev-qt/qtgui-5.9.2[gles2=] >>> dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtgui-5.7.1 >>> dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtgui-5.7.1 >>> dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtgui-5.7.1[-gles2] >>> dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtgui-5.7.1[-gles2,png,xcb] >>> dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtgui-5.7.1[-gles2] My candidates are: >>> dev-qt/qtgui-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge has SLOT 5/5.9 >>> dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed has SLOT 5/5.7 >>> dev-qt/qtdeclarative-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge, wants ~dev-qt/qtwidgets-5.9.2[gles2=] >>> =dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit, wants =dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit >>> dev-qt/qtwebengine-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge, wants ~dev-qt/qtwidgets-5.9.2 >>> dev-qt/qtsvg-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtwidgets-5.7.1 >>> dev-qt/qtprintsupport-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtwidgets-5.7.1[-gles2] >>> dev-qt/qtopengl-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtwidgets-5.7.1[-gles2] >>> dev-qt/qtwebkit-5.7.1:5/5.7::gentoo, installed, wants ~dev-qt/qtwidgets-5.7.1 My candidates are: >>> dev-qt/qtwidgets-5.9.2:5/5.9::kde-kit, ebuild scheduled for merge has SLOT 5/5.9 >>> dev-qt/qtwidgets-5.7.1:5/5.7::gentoo, installed has SLOT 5/5.7 We hope this informational output has been useful in identifying the problem. We are continually working to reduce conflicts. Do not hesitate to report a bug at https://bugs.funtoo.org. Thank you! :) How do I force reinstallation of all packages that were installed from the old repo?
  13. biocyberman

    can't sync with emerge

    Holy cow, I have a local version of dev-libs/glib-2.50.3-r1. Moved that out of place and the update could start. Wonder why I created the most challenging upgrade for myself. Lesson learned: When there is a conflict, check , really check where it comes from. I was assuming that both gdbus-codegen and dev-libs/glib come from the same repo, but later found out that dev-libs/glib comes from another repo.
  14. biocyberman

    can't sync with emerge

    @Oleg: Thanks for the pointer. It solved the problem with pythong_tagrgets. However, I came to another problem: version conflict between dev-util/gdbus-codegen-2.50.3 and dev-libs/glib-2.50.3-r1: # emerge -av "dev-libs/glib" These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild U ] dev-libs/glib-2.50.3-r1:2::x-portage [2.48.2:2::gentoo] USE="dbus* mime xattr -debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7" 9,298 KiB [blocks B ] <dev-util/gdbus-codegen-2.50.3 ("<dev-util/gdbus-codegen-2.50.3" is blocking dev-libs/glib-2.50.3-r1) Total: 1 package (1 upgrade), Size of downloads: 9,298 KiB Conflict: 1 block (1 unsatisfied) * Error: The above package list contains packages which cannot be * installed at the same time on the same system. dev-util/gdbus-codegen-2.48.2:0/0::gentoo, installed pulled in by >=dev-util/gdbus-codegen-2.32 required by sys-fs/udisks-2.6.5:2/2::gentoo, installed dev-util/gdbus-codegen required by net-print/cups-filters-1.14.1:0/0::gentoo, installed dev-util/gdbus-codegen required by app-crypt/gcr-3.20.0:0/1::gentoo, installed dev-util/gdbus-codegen required by net-libs/webkit-gtk-2.4.11-r1:3/25::gentoo, installed dev-util/gdbus-codegen required by net-misc/modemmanager-1.6.4:0/1::gentoo, installed >=dev-util/gdbus-codegen-2.38.2 required by x11-libs/gtk+-3.20.9:3/3::gentoo, installed dev-util/gdbus-codegen required by gnome-base/gnome-desktop-3.20.2:3/12::gentoo, installed dev-util/gdbus-codegen required by gnome-base/gvfs-1.28.3-r1:0/0::gentoo, installed dev-util/gdbus-codegen required by gnome-extra/evolution-data-server-3.20.5:0/57::gentoo, installed dev-util/gdbus-codegen required by app-misc/geoclue-2.4.4:2.0/2.0::gentoo, installed >=dev-util/gdbus-codegen-2.30.0 required by net-libs/gnome-online-accounts-3.20.4:0/1::gentoo, installed dev-util/gdbus-codegen required by net-libs/webkit-gtk-2.16.3:4/37::gentoo, installed dev-util/gdbus-codegen required by gnome-base/dconf-0.26.0:0/0::gentoo, installed dev-util/gdbus-codegen required by app-crypt/libsecret-0.18.5:0/0::gentoo, installed dev-libs/glib-2.50.3-r1:2/2::x-portage, ebuild scheduled for merge pulled in by >=dev-libs/glib-2.34:2 required by sci-geosciences/geocode-glib-3.20.1:0/0::gentoo, installed >=dev-libs/glib-2.40:2 required by gnome-extra/evolution-ews-3.20.5:0/0::gentoo, installed >=dev-libs/glib-2.40:2=[dbus] required by sys-auth/consolekit-1.0.1:0/0::gentoo, installed >=dev-libs/glib-2.40:2 required by gnome-extra/evolution-data-server-3.20.5:0/57::gentoo, installed >=dev-libs/glib-2.46.2:2 required by gnome-base/gvfs-1.28.3-r1:0/0::gentoo, installed dev-libs/glib:2 required by net-misc/remmina-1.2.0_rc18:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by net-libs/libsoup-2.54.1-r1:2.4/2.4::gentoo, installed >=dev-libs/glib-2.45.8:2[abi_x86_64(-)] required by x11-libs/gtk+-3.20.9:3/3::gentoo, installed >=dev-libs/glib-2.37.6:2[abi_x86_64(-)] required by dev-libs/json-glib-1.2.2:0/0::gentoo, installed dev-libs/glib:2 required by dev-qt/qtgui-5.7.1:5/5.7::gentoo, installed >=dev-libs/glib-2.32:2[abi_x86_64(-)] required by app-accessibility/at-spi2-atk-2.20.1:2/2::gentoo, installed >=dev-libs/glib-2.34:2 required by app-misc/geoclue-2.4.4:2.0/2.0::gentoo, installed >=dev-libs/glib-2.32:2 required by dev-lang/vala-0.32.1:0.32/0.32::gentoo, installed >=dev-libs/glib-2.28:2[abi_x86_64(-)] required by net-wireless/bluez-5.45:0/3::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by x11-libs/pango-1.40.3:0/0::gentoo, installed >=dev-libs/glib-2.35.1:2 required by dev-libs/libgweather-3.20.3:2/3-6::gentoo, installed >=dev-libs/glib-2.48.0:2[abi_x86_64(-)] required by dev-cpp/glibmm-2.48.1:2/2::gentoo, installed dev-libs/glib required by app-emulation/virtualbox-bin-5.1.22.115126:0/0::gentoo, installed >=dev-libs/glib-2.4.0:2[abi_x86_64(-)] required by media-sound/pulseaudio-10.0:0/0::gentoo, installed >=dev-libs/glib-2.45.8:2 required by dev-util/gtk-update-icon-cache-3.20.9:0/0::gentoo, installed >=dev-libs/glib-2.40:2 required by x11-libs/vte-0.44.2:2.91/2.91::gentoo, installed dev-libs/glib:2 required by net-misc/icaclient-13.5.0.10185126:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by dev-libs/fribidi-0.19.7:0/0::gentoo, installed >=dev-libs/glib-2.36:2 required by mate-base/mate-desktop-1.18.0:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by dev-libs/libcroco-0.6.11:0.6/0.6::gentoo, installed dev-libs/glib:2 required by app-text/poppler-0.51.0:0/66::gentoo, installed >=dev-libs/glib-2.16.0:2[abi_x86_64(-)] required by gnome-base/libgnome-keyring-3.12.0-r1:0/0::gentoo, installed dev-libs/glib:2 required by net-print/cups-filters-1.14.1:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by media-libs/gstreamer-0.10.36-r2:0.10/0.10::gentoo, installed >=dev-libs/glib-2.48:2 required by dev-libs/gobject-introspection-1.48.0:0/0::gentoo, installed >=dev-libs/glib-2.6:2 required by dev-util/gtk-doc-1.25-r1:0/0::gentoo, installed >=dev-libs/glib-2.32 required by net-libs/libqmi-1.18.0:0/5.1::gentoo, installed >=dev-libs/glib-2.24:2[abi_x86_64(-)] required by net-libs/rest-0.8.0:0.7/0.7::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by dev-libs/atk-2.20.0:0/0::gentoo, installed >=dev-libs/glib-2:2 required by app-admin/system-config-printer-1.4.8:0/0::gentoo, installed >=dev-libs/glib-2.44.0:2[dbus] required by gnome-base/gnome-desktop-3.20.2:3/12::gentoo, installed dev-libs/glib:2 required by net-im/slack-bin-2.5.2:0/0::gentoo, installed >=dev-libs/glib-2.36:2 required by net-libs/webkit-gtk-2.4.11-r1:3/25::gentoo, installed >=dev-libs/glib-2.32:2 required by net-libs/libmbim-1.14.0:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by media-libs/harfbuzz-9999:0/0.9.18::gentoo, installed >=dev-libs/glib-2.40.0:2[abi_x86_64(-)] required by media-libs/gst-plugins-bad-1.10.3:1.0/1.0::gentoo, installed >=dev-libs/glib-2.40.0:2[abi_x86_64(-)] required by media-libs/gst-plugins-base-1.10.4:1.0/1.0::gentoo, installed >=dev-libs/glib-2.30.0:2[abi_x86_64(-)] required by dev-libs/libgudev-231:0/0::gentoo, installed >=dev-libs/glib-2.38:2 required by gnome-base/gnome-keyring-3.20.0:0/0::gentoo, installed dev-libs/glib:2 required by x11-misc/rofi-1.3.1:0/0::gentoo, installed dev-libs/glib:2[abi_x86_64(-)] required by dev-qt/qtcore-4.8.7-r2:4/4::gentoo, installed >=dev-libs/glib-2.46:2 required by net-im/telepathy-mission-control-5.16.4:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_64(-)] required by dev-libs/dbus-glib-0.108:0/0::gentoo, installed >=dev-libs/glib-2.34.3:2[abi_x86_32(-),abi_x86_64(-)] required by gnome-base/librsvg-2.40.16:2/2::gentoo, installed
  15. biocyberman

    can't sync with emerge

    Ok found this one and reading: http://forums.funtoo.org/topic/1176-how-to-migrate-from-ports-2012-to-meta-repo/ Still can't find the answer to "what should I do with stage3 files?" Running this: emerge -auDN @world --with-bdeps=y --verbose-conflicts --backtrack=30 gives error messages for one package after another: These are the packages that would be merged, in order: Calculating dependencies / !!! Problem resolving dependencies for sys-apps/file from @system ... done! !!! The ebuild selected to satisfy "sys-apps/file" has unmet requirements. - sys-apps/file-5.30::core-kit USE="python zlib -static-libs" ABI_X86="64 -32 -x32" PYTHON_TARGETS="-pypy -python2_7 -python3_4 -python3_5 -python3_6" The following REQUIRED_USE flag constraints are unsatisfied: python? ( any-of ( python_targets_pypy python_targets_python2_7 python_targets_python3_4 python_targets_python3_5 python_targets_python3_6 ) ) I editted the package.use and added: >=sys-apps/file-5.30 python_targets_python2_7 And similar error appeared for another package, and another package, ... There must be something not right here. Should I download stage3 file and overwrite before proceed further? I installed Funtoo with this stage3 file: stage3-intel64-sandybridge-funtoo-current-hardened-2017-06-09.tar.xz
×