Jump to content


Popular Content

Showing content with the highest reputation since 02/27/2019 in all areas

  1. 8 points

    1.4 is (almost!) ready to go!

    Hey everyone, 1.4 is almost ready to be released. Thanks so much to everyone who has contributed pull requests for 1.4 and tested 1.4. There's still a bunch of work to do, but there always will be and I believe 1.4 will be our most well-tested release so far. After 1.4 is released, we will start development on 2.0, to be released some time in the Fall (Sept/Oct timeframe). I've been thinking about the release schedule a lot and I think that aiming for a .0 release every Fall seems to be a good idea. This means the work is completed well before the winter holidays, and fall in the US is a good season of change and looking forward to new things. What I have left to do for 1.4 is to update the ARM builds to 1.4 and then also to update our documentation, release notes, upgrade steps and related docs. I want to incorporate the new video cards mix-ins into the official installation steps and not leave it to just be a "First Steps" item after install. This way, people can use the install docs to get their desktop environment of choice up and running, too. I hope to get all this completed in the next few days.
  2. 7 points

    1.4-release efforts starting

    Everyone, I have just started getting kit-fixups ready for 1.4-release development. Some key changes that are coming in 1.4-release: move away from eselect opengl and to libglvnd. official support of container-based solution for steam, etc. updates to pam and pambase 1.4-release will be tracking "current" gentoo for a while and will freeze sometime this summer, likely in June 2019. If you want to get involved, chat on #funtoo and look at the latest commits to kit-fixups on code.funtoo.org. I'll also be doing some introductory videos on how to get involved with the new release of Funtoo. -Daniel
  3. 6 points

    Funtoo release model

    We are not doing rolling release for the following reasons: Too much time is spent on fixing various breakages coming in from Gentoo, which takes time away from other things... other things are more important such as new technology like fchroot and the upcoming containerization solution... If users are interested in certain packages being updated, I am encouraging them to submit a pull request and maintain these ebuilds themselves, so I am going to focus on helping YOU maintain ebuilds rather than have a few people (this has generally been Oleg) maintaining them for everyone. This model doesn't scale -- we all need to do a little bit rather than a few people doing a lot. See the YouTube channel here: https://www.youtube.com/channel/UCKmOY6p3c9hxv3vJMAF8vVw for tutorials Short-term, this means development slows down. But in reality, it will speed up development greatly. For those hanging out on IRC, you know that Oleg who has helped to maintain Funtoo for years has moved on to a new chapter in his life, so he is no longer active on Funtoo. But even though I am not slaving away over here, thanks to incoming pull requests Funtoo is continuing to move forward and be responsive to user needs. So think of it as a course correction as we become more agile and community-oriented, and be part of the solution. If you are reading this, it means you are part of the Funtoo community and just as able to contribute to Funtoo as anyone else (maybe with some tutorials/videos to help). When I work on technologies, I am trying more to work on key tools that help the community be more productive (like fchroot) rather than focusing on specific ebuilds, which I am leaving to the community to manage using pull requests. Best, Daniel
  4. 5 points
    Hey Everyone, I want to officially announce 'fchroot', Funtoo's new QEMU-based chroot tool which allows you to chroot into ARM stage3's and live systems using your 64-bit PC. It is pretty neat stuff. Check out this video for a demo: Enjoy ? -Daniel
  5. 3 points
    GNOME 3.34.1 is ready for use and will become the default version of GNOME in 1.4-release in a few days. If you would like to use it now, you can add the following to /etc/ego.conf: [kits] gnome-kit = 3.34-prime Then ego sync, emerge -auDN @world, emerge @preserved-rebuild, and restart xdm and you should be in business. If you would like to avoid upgrading to GNOME 3.34, now is the time to insert the following code into /etc/ego.conf: [kits] gnome-kit = 3.32-prime Then, in a few days when 3.34-prime becomes active, you will stick with 3.32-prime and not get the updates until you want them.
  6. 3 points

    1.4 -- Even More New Stuff

    There has been a lot of updates to Funtoo Linux 1.4 since its release -- most of these not officially announced. So it would be a good idea to make an official announcement of many of them: SELinux Updates Firefox and Firefox-bin 69, updated thunderbird. New gfxcard-nvidia-legacy mix-in for older drivers. Updated NVIDIA drivers to latest releases. Conky updated. kde-plasma merge fixes. mesa merge fixes and version bump. ffpmeg updated to latest release, with fixes for arm-64bit. Latest Spotify release added. Openrc net-online major improvements. New Language added: crystal (check it out) debian-sources/debian-sources-lts updates and now compile using your -march settings (since custom-cflags is now enabled by default.) Prior to this they compiled using generic 64-bit optimizations on x86-64bit. New encrypted-root mix-in to be used to enable LUKS in genkernel/debian-sources(-lts). To use, enable this mix-in and re-build your debian-sources(-lts) kernel. Rust-kit is now at 1.37-prime New dev-lua/lua and fixes for lua-using packages. Ebuilds using lua-5.2+ should use the new dev-lua/lua ebuild (not the legacy dev-lua/lua.) fwupd bumped to 1.3.1 nginx, nginx-unit, dovecot, php, mariadb vivaldi updated dovecot updated Anything I forgot? Follow up in this discussion thread. MANY OF THESE FIXES WERE SUBMITTED BY OUR USERS! Thanks to bcowan, perfinion, jhan, tux, tczaude, KlipKyle, scottfurry and anyone I forgot to mention for making Funtoo better for everyone ๐Ÿ™‚ ๐Ÿ™‚ ๐Ÿ™‚
  7. 3 points

    Funtoo Linux 1.4 Released!

    Hey everyone -- Funtoo Linux 1.4 is now to be considered officially released! Some changes in the last several weeks include: Updating to gcc-9.2.0 to address an upstream compilation bug (thanks: calrama) Additional testing/fixing of dependencies (thanks: sandro and others) New debian-sources and debian-sources-lts kernels (thanks: bcowan) Debian-sources-lts will now default to using "custom-cflags" USE by default, which will give you a more optimized kernel. -march settings from your subarch mix-in will be applied to your kernel compilation as well. This appears to result in a noticeable performance improvement. Many thanks to jhan, digifuzzy, klipkyle, librin.so.1, niranjan, sandro and everyone else (sorry if I forgot to mention you) for making this the most tested and most community-focused release of Funtoo ever! I will continue to update documentation on the wiki relating to 1.4, and of course, 1.4 development continues with pull requests and issues reported to bugs.funtoo.org. I hope to start 2.0 development in about a month. Also note -- we now have a "Announcement Discussion" forum visible from the main forums page which allows posts and is open to discussing any announcements. Best, Daniel
  8. 3 points

    Funtoo Linux 1.4 Released!

    Please see the following for more info: Release Notes: https://www.funtoo.org/Release_Notes/1.4-release Upgrading from 1.3: https://www.funtoo.org/Upgrade_Instructions/1.4-release Download and Install: https://www.funtoo.org/Install/Introduction
  9. 3 points

    Is Funtoo dying?

    Funtoo isn't dying. Funtoo is changing just like it always has. You know far better than we do what you want from your Linux distro so ask yourself if you have liked all of the past changes to Funtoo. Then stick with it and have some faith in the wisdom of our BDFL. If you don't like what you see in a year or two you can go to another distro and have not lost anything. I originally switched to Funtoo because too many things in Gentoo and Debian stayed the same. Having bleeding edge packages wasn't why I used Gentoo. It was because it gave me a greater degree of control than any other OS. The reason I love Debian is because the stable release is always stable but unfortunately I have to give a lot of control to use it. Funtoo can give me the control that I want and at the same time give me the stability that I need so I am keeping an open mind. If you have the skills to contribute to the code base and improve things for all of us I encourage you to get involved. If you are like me and couldn't write a program if your life depended on it then I encourage you donate a bit of money to Funtoo every month.
  10. 2 points
    A full set of Funtoo Linux 1.4 maintenance release 2 stages has been uploaded to build.funtoo.org. These stages include: GNOME 3.34.2 Updates to debian-sources-lts (4.19.87_p1) Updated Linux firmware Updated firefox Various other fixes If you are already using 1.4, you can get all these updates via a regular ego sync and world update. But if you are planning to install 1.4 from scratch, these builds are up-to-date.
  11. 2 points
    Hi folks O/ few years ago I wonder about a friendly version of Gentoo and Funtoo, the gentoo community don't liked, but I keep did some tests but I didn't continue, well, few week ago I start again, but this time only a Funtoo Friendly version, and now I have something really beginning. the project will resume in few flavors and one version with a overlay with update packages and few extra. the funtoo flavors are X+openbox, gnome and Plasma, they are just the Funtoo Stage3 Generic with few packages and some configuration. and has one version with plasma, but with an overlay with few update packages and other stuffs, a stage more out of the box, I want make something to people learn about gentoo/funtoo or for who use the system without spent hours to build the system. the webiste will be done in the next weeks, and the stages will be available in the next days "sorry, I'm with one pc now, and the net is a turtle". website -> https://bentoo.info/ binhost -> http://binhost.bentoo.info github repos : overlay -> https://github.com/lucascouts/bentoo configurations -> https://github.com/lucascouts/bentoo-cfg I don't know if the funtoo community will like but anyway I'll forward with this project, but will be great if few users could help with feedback or criticisms. thank you anyway ?
  12. 2 points

    Funtoo is now on Discord

    Hey Everyone, We're now supporting Discord as an official Funtoo online community. Join via this link: https://discord.gg/BNUSpUU Forums discussion thread for this announcement here: Best, Daniel
  13. 2 points
    You and I are on the cusp of a political discussion here ๐Ÿ™‚ but I would argue that even "reputable" sites these days are spewing propaganda, so there is no substitute for critical thinking. We do not live in an ethical age. Whether intentional or the result of our modern echo chamber, there is misleading information EVERYWHERE online and I couldn't really tell you ANY trustworthy source of information that I would tell you that you could trust implicitly. Even Associated Press and Reuters seem horribly compromised and full of spin! Every journalist seems to want to write an atomic bomb of a news story and go though such extreme lengths to try to inject bias while remaining 'factual' -- it would be comical if it weren't so sad. Assuming a posture of skepticism and "it's probably not as bad as it sounds" is highly recommended when looking at sources of information online. Politics is the art of getting a ton of people pissed off and then leveraging that energy -- and doing this online is known to be extremely effective. So you just have to be wary. Don't be a pawn. Now, as for the other issues you raised, I guess I can read and think about those now that I've vented ๐Ÿ™‚
  14. 2 points

    SOLVED: Container Host Out of Space

    @tux yes LXD has its limitations compared to OpenVZ -- I still miss OpenVZ a lot. But LXD is gradually improving. I have plans to offer a lot more to users with hosting and I am hoping to actually realize these plans in a month or so -- let's see if things go as planned ๐Ÿ™‚ (Note: it should help with this issue.)
  15. 2 points
    Hey All, I've gone ahead and updated Funtoo Linux 1.4 to contain the latest implementation of SELinux from Gentoo. SELinux is working well under Funtoo now. To use it, see the SELinux page on the Funtoo wiki. Also reference the https://wiki.gentoo.org/wiki/SELinux/Installation and https://wiki.gentoo.org/wiki/SELinux pages for documentation reference. These Gentoo wiki pages were originally put together by SwiFT and are excellent, and the SELinux team has kept them up-to-date (I must give credit where credit is due ๐Ÿ™‚. We need to work on our modest SELinux wiki page here to improve it: https://www.funtoo.org/SELinux If you are new to SELinux, here are the basic steps. Enable the SELinux mix-in, emerge the SELinux tools as well as policies, rebuild world and etc-update, apply security labels to files, enable in kernel in "permissive mode" -- where it just logs things but doesn't "block" anything, and then start to play. In your /etc/boot.conf, you'll want to add "security=selinux enforcing=0" to your "params +=" line and re-run "ego boot update" to get the kernel booting properly. This is assuming you are using debian-sources or debian-sources-lts. Funtoo is also helping perfinion (find him in #gentoo-base on freenode) in Gentoo test the SELinux-next security policies. Here is how you can test them: 1. Add the following to package.keywords: sec-policy/selinux-* ** 2. Then emerge @selinux-rebuild to reinstall all the 9999 policies (to be used with 2.9 userspace) 3. Do a full relabel. 4. Reboot. Then, you can run and start auditd which will generate logs of what SELinux activity is going on. After your initial reboot into the new SELinux, start auditd with empty logs, and keep it running as you go about your business. After a few days of using Funtoo as you normally would, these logs can be useful to the SELinux team to determine if the new policies are working as expected. Of particular interest is the use of elogind under SELinux. Once using the new SELinux-next policies, 'ps auxfZ | grep logind' should be in the systemd_logind_t domain. Thanks to perfinion and the SELinux team for moving SELinux forward! Let's help them ๐Ÿ™‚
  16. 2 points
    Hey Everyone, I recently upgraded to a newer Thinkpad Laptop (P1) and decided this was a good time to upgrade Funtoo's graphics stack to sort of finish the work that TemptorSent had started. You'll recall that if you tested 1.4, media-libs/mesa could be quite picky with USE vars/VIDEO_CARDS settings. This should now be fixed. One thing that bugged me when I installed Funtoo on my P1 was that video acceleration wasn't working well. So I've tried very hard to address this so that "out of the box" with minimal/no configuration, you will have good video acceleration support in Funtoo. New documentation on this system that is now in 1.4 can be found here: https://www.funtoo.org/Make.conf/VIDEO_CARDS In particular, see here: https://www.funtoo.org/Make.conf/VIDEO_CARDS/Mix-ins (This table is also included in the main page linked above.) You'll also see extensive documentation on the new VIDEO_CARDS settings that are available and all map directly to a particular graphics driver now (eliminating confusion between gallium and DRI drivers that existed.) The workstation and desktop flavors will now auto-enable Open Source Intel integrated graphics (DRI) and Radeon Gallium graphics (Gallium) -- enabling Vulkan for both. I did not enable nvidia or nouveau by default as I leave this choice of proprietary vs. open source to the user (for Intel and Radeon, the best choices are obvious so safe to enable these.) This should be a big step towards getting everyone optimal video performance in Funtoo without significant work! Be sure to give https://www.funtoo.org/Make.conf/VIDEO_CARDS/Mix-ins and the parent page a good read. And if you use firefox, play around with the h264ify plugin to optimize YouTube video playback and see if it helps reduce your CPU usage. Enjoy!
  17. 2 points

    agetty log spam

    need to edit /etc/inittab and make sure the lines # TERMINALS #x1:12345:respawn:/sbin/agetty 38400 console linux #c1:12345:respawn:/sbin/agetty 38400 tty1 linux #c2:2345:respawn:/sbin/agetty 38400 tty2 linux #c3:2345:respawn:/sbin/agetty 38400 tty3 linux #c4:2345:respawn:/sbin/agetty 38400 tty4 linux #c5:2345:respawn:/sbin/agetty 38400 tty5 linux #c6:2345:respawn:/sbin/agetty 38400 tty6 linux are commented/REM'd like the above
  18. 2 points

    How to run Steam in Funtoo/LXD

    Hey everyone, I have added documentation on how to essentially get Steam running in Funtoo using LXD. First, you will want to follow these instructions to get LXD running: https://www.funtoo.org/LXD Then, follow these instructions, which will get you to the point of setting up a multilib Gentoo container that can run glxgears. At that point, getting Steam running should be pretty straightforward: https://www.funtoo.org/LXD/GPU_Acceleration Please test it out and let me know how it works.
  19. 2 points

    GNOME 3.32 is working well

    Hey everyone, Just wanted to let you know that as of last night, I am happily running GNOME 3.32 with no issues (I did need to fix librsvg to get SVG's to display properly, but after that, it's working great.) I successfully upgraded my dev workstation from 1.3 to 1.4. If you want to upgrade from 1.3, or install a fresh 1.4 using one of our 1.4 stages (now available for Intel only), things should work well. One thing to note, on both the beta 1.4 stages and a 1.3 upgrade, you will need to manually run "eselect python set --python3 python3.7" to set python3.7 to be the default python interpreter instead of 3.6. Our stages will be fixed to have this set already but this is not done yet. I will also include a copy of my post from another place on the forums about upgrading from 1.3: So, upgrade is pretty easy this time around.I will have instructions soon. But you can basically use "standard" upgrade steps. I recommend emerge -1 glibc gcc first, then emerge -auDN @world should generally work. Report any bugs related to upgrade like failed builds because often this can be fixed by tweaking dependencies. Overall the upgrade is MUCH easier than 1.2 -> 1.3. One trick is to remember to "eselect python set --python3 python3.7" after python-3.7 is emerged to make it default. Also, mesa right now is very picky about USE flags related to video card. For example, if you don't have a card that supports vulkan, you cannot have vulkan in USE. Same with xa and other things that were more "permissible" before. As of yesterday, I am now happily running gnome 3.32 and it is working perfectly. I would still call things "in beta" but the remaining issues (there is a "reboot doesn't work" issue currently active, due to a missing /run/initctl -> /dev/initctl symlink) should be worked out with minor package updates.
  20. 2 points

    1.4 stages

    So, upgrade is pretty easy this time around.I will have instructions soon. But you can basically use "standard" upgrade steps. I recommend emerge -1 glibc gcc first, then emerge -auDN @world should generally work. Report any bugs related to upgrade like failed builds because often this can be fixed by tweaking dependencies. Overall the upgrade is MUCH easier than 1.2 -> 1.3. One trick is to remember to "eselect python set --python3 python3.7" after python-3.7 is emerged to make it default. Also, mesa right now is very picky about USE flags related to video card. For example, if you don't have a card that supports vulkan, you cannot have vulkan in USE. Same with xa and other things that were more "permissible" before. As of yesterday, I am now happily running gnome 3.32 and it is working perfectly. I would still call things "in beta" but the remaining issues (there is a "reboot doesn't work" issue currently active, due to a missing /run/initctl -> /dev/initctl symlink) should be worked out with minor package updates.
  21. 2 points

    Mininal and Optimized Stage3

    Some few days ago I knew about CloverOS that's basically Gentoo with more packages installed by default, with custom config files and also highly optimized with a bunch of flags to compile programs by the most optimized way. This caught my attention so I checked their packages and I saw that the CloverOS guys disable some flags that may break some specific packages, which is nice! Also some few days ago I knew about GentooLTO, that's an overlay for optimizing the compilation of packages. I like to try new things, so I tried GentooLTO with Funtoo on virtualbox but I got a bad news that GentooLTO doesn't work properly on Funtoo. With those discoveries about the Gentoo world, I got myself thinking about if Funtoo had a stage3 with the suckless philosophy, minimal (this is, no custom config files and without a lot of packages installed by default, unlike CloverOS do, unfortunately; only the core as Funtoo's stage3 do), without "bloat" or "bad" (or maybe unnecessary) packages (as CloverOS do by not using systemd, pulseaudio, dbus, avahi and nls), with LibreSSL instead OpenSSL (and also with musl instead glibc if possible), and configured to compile programs to be the most optimized as possible. Well, I'm a young man, I started using Linux about 5 months ago (and I started using Funtoo about 4 months ago) so I have no much experience to do all things I want on my Funtoo system. So I would like (and I think that many other people also would do) if someone that also liked theses ideas make a stage3 with theses "features". This is only an idea to try to make Funtoo more "cozy" to different kinds of people, I hope you guys liked it.
  22. 2 points
    Hey all, I've been really busy this month -- in Funtoo-land as well as on other projects (currently in Washington, DC area doing some work.) I've just moved 1.4-release to ALPHA status (it was "in development" status) and will be working on getting some alpha builds available. I've updated the snapshot that 1.4 is based upon and frozen 1.4 so 1.4 will be based on a June 21, 2019 snapshot of Gentoo. I will also be looking to start a non-frozen variant of Funtoo again... New Firefox and firebox-bin are now in the tree to address security issues. I've also added the latest version of dev-lang/dart to the tree. This is a very interesting language that comes from Google and recently received a major revamp to make it really nice. Here's an interesting article about it: https://hackernoon.com/why-i-moved-from-java-to-dart-8f3802b1d652 . I am using Dart to do multi-platform development using Google's flutter (which uses Dart) -- and I've enjoyed my experience so far. More updates to come... Best, Daniel
  23. 2 points

    1.3 Maintenance Release 1 Now Live

    Folks, The Funtoo Linux 1.3 Maintenance Release 1 is now live, and contains the following updates in order to modernize the distro as well as to allow for a smoother transition to 1.4-release, currently in development: OpenSSL updated to 1.1.1b Ruby stack updated to current 2.6.3 release and moved to independently-maintained status rather than auto-generated. node.js updated to 12.3.0. webkit-gtk updated to 2.24.2. wpa_supplicant update to 2.8 to resolve some connectivity issues. updates to dev-libs/icu, libuv, http-parser, nghttp2, genkernel, eudev System updates should be pretty pain-free with no conflicts or other issues. To upgrade, simply ego sync and then emerge -auDN @world. For security reasons, all packages that use openssl will be automatically rebuilt by emerge. If you encounter complications, a bug report to bugs.funtoo.org would be appreciated. Upgrading from openssl 1.0 to 1.1.1 did require several packages to be updated and there could be a few that were missed and still need patches. Enjoy! -Daniel
  24. 2 points

    xfce terminal input/output error

    Thank you so much this solves the problem without any hicupps ?
  25. 2 points

    xfce terminal input/output error

    Your processor doesn't support aes which is in your CPU_FLAGS_86 and CFLAGS="- march=westmere" Building nettle with aes cpu flag set on gcc when your processor doesn't support aes could be the cause of the error. Reference: https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html โ€˜westmereโ€™ Intel Westmere CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, POPCNT, AES and PCLMUL instruction set support. Set to native and add the proper flags to match your processor. Install cpuid2cpuflags Follow my directions here starting at Remove any gcc override settings you've made previously. After you've finished configuring gcc to match your processor rebuild nettle.
  26. 2 points

    Funtoo release model

    And to expand on this some more -- While it's true that we don't have a dedicated security team and rely on users to report CVE's, this doesn't mean that we trail behind Gentoo in all areas. For example, we have a fix in gettext for CVE-2018-18751 that gentoo does not appear to have. We also had important fixes for avahi remote exploits before Gentoo. In general this means that our ability to be up-to-date with CVEs depends upon our users' ability to report these. In areas where we have had good reports, we have sometimes had things fixed sooner.
  27. 2 points

    forums, member map updated

    Hi All, Forums have been updated to the latest version and I have re-enabled a new version of member map. Let me know if you encounter any issues. -Daniel
  28. 2 points
    Note to all -- this kernel has been unmasked and is ready for general use.
  29. 2 points

    New drobbins YouTube vlog

    Hi All, I've created a new YouTube vlog entry for your enjoyment. This one is about the latest shocking news of being let go from a job. View it here -- I appreciate it if you help me get the word out about my channel, send me some upwardly-pointing thumbs and possibly even subscribe! ? Thanks! Best, Daniel
  30. 1 point
    Recent Funtoo News: GNOME 3.34.3 is now available in Funtoo (as part of gnome-kit 3.34-prime, the default kit) A Gentoo dev found that it is theoretically possible for arbitrary users on the system to locallly 'exploit' a package while it is being built. Portage-2.3.78-r1 addresses this by removing 'other' permissions from /var/tmp/portage. ego-2.8.0 is released with updated sync code.
  31. 1 point
    Hi Everyone, I"ve posted a new YouTube video which I hope you find useful. Troubleshooting is an important topic and something worth reflecting on.
  32. 1 point

    New steam-nvidia-launcher

    Steam now has an official launcher script to make it easier to use, called "steam-nvidia-launcher". I've updated the Steam documentation at https://www.funtoo.org/Steam to now direct users to use the launcher script instead. It's easier to use and more robust, as you just have one script that does everything from download the docker image, to create the container, to start the container if it already exists and needs to be started locally. steam-nvidia-launcher also fixes a bug where the Steam container wouldn't start consistently after a reboot. Launcher is available here. Remember to consult the wiki (link above) for usage info: https://code.funtoo.org/bitbucket/users/drobbins/repos/docker-steam/browse/steam-nvidia-launcher
  33. 1 point

    Funtoo is now on Discord

    For those who may not understand the embracing of next-gen communication clients... it's really not about the technology here. We have people who use Discord and Telegram already, and do not like IRC. I, personally, am really enjoying the newer communities over freenode. I feel like there's too much rumors/OSS politics on freenode these days. I spend my time on freenode dealing with this crap rather than having fun and moving Funtoo forward. I see too much weird community dynamics -- too much drama, and we're sitting right next to the Gentoo channels and there is often unpleasant "overspray" I need to deal with -- things like "hey drobbins, did you see that person X is saying thing Y about Funtoo and/or you in channel Z?" Then I feel obligated to personally deal with it. If you are someone who loves freenode and the freenode community, you should be there. I have been using freenode since before it was called freenode. I remember when lilo (now deceased, and relentlessly attacked by his detractors) ran the show. Freenode, despite its reputation for being the place on the Internet for OSS-related chat, has always been a rough place socially to some degree. The truth is that there are a lot of options for Funtoo users to find a community that works for them, and I'm really happy to be not just on Discord but on Telegram too: https://t.me/funtoolinux The important thing is to find a community that is a positive environment for you, that gives you energy rather than takes it away, so for these reasons I am very glad for Discord and now Telegram and think everyone should be too ๐Ÿ™‚ The newer technology is also nice -- like being able to edit posts, post actual screenshots into the channel for support purposes, funny gifs, voice support, *amazing mobile clients*, etc etc etc. -Daniel
  34. 1 point

    cannot grab -march

    It is fine to use generic arch, if that is what you *really* want shrug. If you do want generic then you need to add -custom-cflags to USE or package.use for debian-sources-lts
  35. 1 point
    also by default nomodeset is in /etc/boot.conf, please try removing that and re-running ego boot update, reboot and see if that helps.
  36. 1 point

    How to run Steam in Funtoo/LXD

    In my testing, the --exclude method did not work and I manually modified the PDEPEND in nvidia-drivers in /var/git/meta-repo/kits for now as a local work-around. Just a note -- you will likely need to do this too. Other option is to also --exclude nvidia-drivers and then do an emerge -1 nvidia-drivers --exclude nvidia-kernel-modules after the big emerge.
  37. 1 point

    How to run Steam in Funtoo/LXD

    Also note that for now, if you are using nvidia drivers, add an --exclude nvidia-kernel-modules to your emerge line when emerging everything. The nvidia-kernel-modules won't build in containers and you don't need them anyway. I will look into a fix for this.
  38. 1 point

    1.4 now in BETA

    I found a last-minute bug related to xorg-server building with some new tweaks to mesa and libglvnd. I have applied some fixes and as of right now the tree is being regenerated. When you have the fixes, 'glvnd' global USE will be enabled with workstation or desktop profile. And you may need to re-emerge mesa-19.1 if xorg-server doesn't build. Since it's a beta, I won't always make things perfectly smooth -- that is the goal for the release ๐Ÿ˜‰
  39. 1 point
    This user override only exists if booted into a debian patched kernel: /proc/sys/kernel/unprivileged_userns_clone
  40. 1 point

    dependency conflict libxml2, itstool

    Add to package.use dev-util/itstool PYTHON_TARGETS: -* python3_6 PYTHON_SINGLE_TARGET: -* python3_6 dev-libs/libxml2 PYTHON_TARGETS: -* python3_6 I don't specify >=< and package version when overriding default USE flags in package.use Reference: https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS https://wiki.gentoo.org/wiki/Handbook:Parts/Working/USE
  41. 1 point

    alternative to fchroot

    Not a criticism or to belittle Drobbins hard work, but I have been doing this for years with a simple bash script. If you haven't seen his video on fchroot on the forum here and don't know what it does search for fchroot. I simply keep 2 bash scripts in ROOT directory of any device I want to use it with, navigate to that directory (mounted via NFS) from the BIG BOY computer and run 1st one script to enter the QEMU chroot, the other to cleanup when exiting. Here's an example from my odroid C1+, armv7a: #MOUNTDIRS - script name mount -t proc none proc mount --rbind /sys sys mount --rbind /dev dev mount --bind /dev/pts dev/pts mount tmpfs -t tmpfs -o rw,nosuid,nodev,noexec dev/shm mount --bind /tmp tmp cp /etc/resolv.conf etc echo "" echo "don't use pump" echo 'env -i HOME=/root TERM=$TERM DISTCC_HOSTS="star,cpp,lzo joshua,cpp.lzo mrpink,cpp,lzo micah,cpp,lzo localhost" MAKEOPTS="-j8" chroot . /bin/bash -l' # UMOUNTDIRS - script name umount proc umount -l sys umount -l dev/pts umount -l tmp umount dev/shm umount -l dev umount tmp That's it! The 1st script echoes some reminders to me and the exact line to chroot in, I just copy & paste it (the script can't run that line directly). This is a particularly good example because I also set some environment variables on the way in, shows that. Of course you must set up your makefile as drobbins states, in my case: QEMU_SOFTMMU_TARGETS="i386 arm" QEMU_USER_TARGETS="i386 arm" And install qemu. Finally, you must run /etc/init.d/binfmt either in rc-update (bootup) or add starting/stopping it to the scripts. I find it mainly handy for things that overwhelm the whopping 1G ram on the odroid, it'll work but it's s...l...o...w. If at all possible it's much faster to use the cross-compile SYSROOT method, search on the web for "gentoo cross-compile", you'll find it. Unfortunately it doesn't work with many packages, particularly the intensive ones you'd like to use it on. One notable exception is LLVM. The odroid can't build it anymore as of a couple of years ago, but I found a trick to build it natively on the powerful machine and output a 32 bit arm package in minutes. Last time I used the qemu chroot method it was > 10 hours on a core2. Here are my notes: ****WARNING!!! DO NOT DO THIS, THERE IS A PROBLEM, READ BELOW**** # LLVM trick notes: # 1. you must have same version already installed on the compile machine # 2. in $SYSROOT/etc/portage/profile/use.mask, put a file that has this in it: abi_x86_64 llvm_targets_X86 # 3. you must have libffi installed: armv7a-hardfloat-linux-gnueabi-emerge libffi type: ABI_X86="" LLVM_TARGETS="BPF ARM" armv7a-hardfloat-linux-gnueabi-emerge -BO llvm:<version> probably just this now: LLVM_TARGETS="BPF ARM" armv7a-hardfloat-linux-gnueabi-emerge -BO llvm:<version> #5. Check out the package.env stuff for llvm, see llvm.conf ENJOY! # ${SYSROOT}/etc/portage/package.env sys-devel/llvm notmpfs.conf nodistccccache.conf llvm.conf # ${SYSROOT}/etc/portage/env/llvm.conf ABI_X86="" CMAKE_EXTRA_CACHE_FILE=/usr/armv7a-hardfloat-linux-gnueabi/etc/portage/env/cmake_cache_files/llvm.cmake # ${SYSROOT}/etc/portage/env/cmake_cache_files/llvm.cmake SET (CMAKE_INSTALL_LIBDIR "lib" CACHE STRING "" FORCE) SET (LIB_SUFFIX="" CACHE STRING "" FORCE) SET (LLVM_TARGETS_TO_BUILD "ARM;BPF" CACHE STRING "" FORCE) SET (LLVM_LIBDIR_SUFFIX "" CACHE STRING "" FORCE) SET (FFI_LIBRARY_DIR "/usr/armv7a-hardfloat-linux-gnueabi/usr/lib" CACHE STRING "" FORCE) SET (FFI_INCLUDE_DIR "/usr/armv7a-hardfloat-linux-gnueabi/usr/lib/libffi-3.2.1/include" CACHE STRING "" FORCE) THE PROBLEM: This indeed makes the package in arm-32 bit format, but later I found it is linked to lib64, non-existent on the arm. In my case, the odroid does just fine with it for my uses and I'm sure that can be remedied with CMAKE_OPTIONS, but since I have no problem I haven't worked on it. I skipped Funtoo 1.3 on the odroid, when 1.4 is released I'll update to that and get to the bottom of a solution on it. It makes a package which you can then install natively on the arm with emerge -K. Hmm, it's been so long, maybe I did fix that lib problem, maybe that's why it JUST WORKSยฎ. I dunno...try it at your risk... I used to build my arm kernels with the SYSROOT method, but nowadays I find that pump distcc on the native device is just as fast and easier. Here's the basic script for doing such a thing, minus the dracut and mkimage operations: export SYSROOT=/usr/armv7a-hardfloat-linux-gnueabi armv7a-hardfloat-linux-gnueabi-emerge odroidc1-sources #custom amlogic kernel # cd usr/src/linux # ${SYSROOT}/usr/bin/xkmake menuconfig # cd ${SYSROOT} KERNEL_VERSION=-$(readlink ${SYSROOT}/usr/src/linux|cut -d'-' --complement -s -f1) cd ${SYSROOT}/usr/src/linux ${SYSROOT}/usr/bin/xkmake -j3 ${SYSROOT}/usr/bin/xkmake -j3 modules ${SYSROOT}/usr/bin/xkmake -j3 INSTALL_MOD_PATH="/mnt/nfs/odroid" modules install ${SYSROOT}/usr/bin/xkmake -j3 uImage cp ${SYSROOT}/usr/src/linux/arch/arm/boot/uImage /mnt/nfs/odroid/mnt/sdcard/storage/uImage.funtoo cp ${SYSROOT}/usr/src/linux/arch/arm/boot/dts/meson8b_odroidc.dtb /mnt/nfs/odroid/mnt/sdcard/storage/meson8b_odroidc.funtoo.dtb Just a rough guide there to show what can be done. The gentoo cross-compile info tells you to use xkmake rather than make when using the cross-compile ${SYSROOT} method. Here's my ${SYSROOT}/usr/bin xkmake file for the odroid: #!/bin/bash make ARCH="armv7a" CROSS_COMPILE="armv7a-hardfloat-linux-gnueabi-" INSTALL_MOD_PATH="${SYSROOT}" $* My 2 cents worth...
  42. 1 point

    Funtoo release model

    Hey I just want to jump in and say it's OK, I understand if there are some people that are disappointed about us not having pure rolling releases anymore. It's fine to express your opinions here. I think that's totally understandable, frankly. Now yes, these changes were totally needed and like I said earlier, there is a strategy that is being very successful so far even though it's in its early stages. The strategy is that I support our users (with things like YouTube videos, code.funtoo.org, fchroot) to be contributors to Funtoo. So yes, right now I think it's fair to say we are playing a bit of catch-up with Oleg moving on to other things -- BUT, considering we just started this effort, I also think it's fair to say that in time we will likely catch up and even go beyond what we were capable of before. And that means that we can push ahead more with many more updates and possibly even a more up-to-date release (betas?) or a true rolling release again. In the mean time, I ask @lazlo.vii and others to be supportive of those expressing disappointment since I want people to have a place to vent their disappointment -- I don't see it being overboard or in poor taste at all -- and in my experience, the worst thing for a community is if any disappointment is bottled up and never expressed (and then we need to guess why people are unhappy) so I would much rather have people share how they feel. As long as they understand the reason for the decision, it's fine to share feedback and vent a bit.
  43. 1 point

    Funtoo release model

    About doing smth, well, some do, me included. Small, but here and there. The question is more about the direction things are going. We all know release model is much easier than rolling distro. One of the reasons I jumped on Gentoo/long time ago/ then on Funtoo is the rolling model. Some of the others are that its source based, slots, alot of customisation/flags ... etc. My point is - today you decide to switch from rolling to release, eg no current, just freezed releases. Tomorrow nothing stops you from source based to package/bin oriented ? Maybe Debian clone /one of dozens/ ? Dont get me wrong. I use funtoo not geeky weekends, where I can spend whole day install/reinstall/fiddle with this or that. My workstation is build on Funtoo. My work depends on Funtoo. If some1 decides to flip a coin and make a decision, when I am not sure about the general direction ... I can install a Debian/Manjaro in minutes, but I dont want to. I want Funtoo as it was for years - just to have current.
  44. 1 point

    Is Funtoo dying?

    I believe that Funtoo has switched to a more stable release cycle (Not exactly, more like a break less stuff cycle). @drobbins has also released some great videos on his youtube channel for submitting put requests to have the community start helping with the updates.
  45. 1 point

    feedback (for devs)

    So I had to update my desktop system from version 1.2 to 1.3 and I've chosen to do the fresh install from the stage3 (stage3-core2_64-1.3-release-std-2019-02-05). But.. During the process I've noticed some (at least for me) ugly things that I would like to inform developers about: TL;DR: metalog is NOT added to any runlevel by default. I think it should be added to default/boot runlevel by default sshd IS added to the default runlevel by default. I think it's bad - this should be disabled by default ... if you want to read further please be advised that I'll be grumpy from now on: I've noticed that version 1.3 is out because there were no updates for a while yep it was announced but I'm not checking neither funtoo.org nor forums.funtoo.org on a regular basis - what happened with good old eselect news? I can not find any information when the support for 1.2 version ends - LTS schedule could help with planning the upgrade ... (please consider sth like this: https://nodejs.org/en/about/releases/ ) and yeah performing a fresh install is time consuming, at least for a desktop machine - so it would be cool to be aware early that end of support for 1.2 is coming and that it's recommended to do a fresh install I think that funtoo.org web page should be rearranged. Here is what I mean: there are a lot of useful articles there but often they are hidden and I can find them only via google there should be a section where you can see all of the articles examples: https://www.funtoo.org/Security https://www.funtoo.org/Installing_a_Logger forums.funtoo.org I was not able to write this post using vanilla firefox-bin-65.0 (w/o any addons) I had to do it by using google-chrome ... wow you've came that far now I'll be sentimental: Gentoo was my first distro back in early 2000s When Daniel started Funtoo, for me it was something cool, something fresh I have a feeling that now the Funtoo Project is going in some weird direction (from end user perspective) that is different to what I was used to back in the days. People on the #funtoo IRC channel used to be more responsive I wrote this post in a good faith. I like funtoo but I'm close to the point where I will switch to other distro ... TBH it strongly depends how long and how smooth will be the process of building rest of desktop environment. Ofc everyone has his own point of view but I really wanted to give you some feedback. If I somehow missed something and somebody disagrees - I look forward to know your point of view.
  46. 1 point

    feedback (for devs)

    Thanks. I hadn't realized that "PasswordAuthentication" doesn't affect PAM authentication. I've always secured my machines by only allowing ssh access to accounts that I specifically configure. It's @drobbins call but I still think it's a bad idea to configure ssh by default on machines where novice users may believe that their physical console is the only vector for someone to attack their trivial password. There definitely should be some documentation in the install procedure for locking that down.
  47. 1 point

    feedback (for devs)

    Sorry for the questions? sshd running by default - did you file a bug report? Have you all checked out the youtube videos on contributing? Lets fix these things. We are Funtoo, @drobbins, @Oleg Vinichenko and other regulars are the directors. If it is broken fix it.
  48. 1 point

    feedback (for devs)

    I have that feeling that maybe Funtoo needs more devs.
  49. 1 point
    Hi, about your qestion why Daniel developed Funtoo you may find this Video useful
  50. 1 point

    funtoo logo ideas

    Yeah, skulls don't really say "Funtoo" to me. Not even screaming satanic ones.
  • Create New...