Jump to content
funtoo forums

Leaderboard


Popular Content

Showing content with the highest reputation since 11/12/2018 in Posts

  1. 4 points
    Hi All, Within 12 hours, I plan to move 1.3-release to BETA status. Along with this comes the very important change on 64-bit platforms -- I am removing multilib and making "pure64" compatibility the default. This means that 1.3-release builds with the x86-64bit arch will be 64-bit only. This is done for a variety of reasons, most important of which is that the world has had a 64-bit PC instruction set for approximately 15 years. It is time to drop 32-bit support. For those who still need 32-bit support, it will be available via a Funtoo 32-bit chroot setup. The story behind multilib is rather complex and interesting, and might be the focus of a future blog post, but for now, you will just have to trust me -- multilib support in Gentoo is a pain in the butt. It takes a lot of effort to work with and slows us down. Our efforts are best spent in other places, and chroot should work for the vast majority of users who truly are running a critical 32-bit application (other options are 32-bit containers, etc.) EDIT: Upgrade Instructions Here: https://www.funtoo.org/Upgrade_Instructions/1.3-release Best, Daniel
  2. 4 points
    drobbins

    We have a new FAQ!

    Hey Everyone, We have a new FAQ developed that allows you to more easily browse answers. See: https://www.funtoo.org/FAQ You can also submit your own FAQ questions which I will answer! πŸ™‚ Hope you enjoy it. Best, Daniel
  3. 4 points
    drobbins

    Official Funtoo AWS Images

    Hi Everyone, I'm very happy to announce that we are now offering official Funtoo AWS images in the AWS Marketplace: https://aws.amazon.com/marketplace/pp/B07KT3VN7Q/ Please test them out. They are optimized for specific instance types to offer the best performance possible in AWS. Please leave us a positive review (or file a bug πŸ™‚ ) and take advantage of these free images to Funtoo-ize AWS and advance the benefits of building software from source, optimized for the underlying CPU architecture -- Funtoo style! Best, Daniel
  4. 3 points
    drobbins

    Wiki Improvements

    Hello Everyone -- I want to highlight some improvements that have been made to the wiki besides our new FAQ (https://www.funtoo.org/FAQ) We now have a new Subarches page that is a lot easier to navigate: https://www.funtoo.org/Subarches And the look of various things like notes, tips, warnings, etc. have been improved for a cleaner, more consistent look. This is a good sample page to browse the new look. Note that you may need to "hard reload" the page to get the new CSS: https://www.funtoo.org/Upgrade_Instructions Enjoy! -Daniel
  5. 3 points
    drobbins

    Funtoo Linux 1.3 Alpha Builds Starting

    Hey Everyone, We are starting to build Funtoo Linux 1.3 ALPHA builds. We will let you know when these are uploaded and ready for testing. UPDATE: Ryzen 1.3 Alpha builds now available for download and testing: https://build.funtoo.org/1.3-release-std/x86-64bit/amd64-zen/ -Daniel
  6. 2 points
    Hi, everyone! mysql-community-8.0.12 added in 1.3-release. This is Oracle's MySQL-8 major release. Please, notice, that this package cannot be installed with mysql (replacing). It also has certain incompatibilities with older versions of mysql and databases, created. https://dev.mysql.com/doc/relnotes/mysql/8.0/en/news-8-0-12.html
  7. 1 point
    drobbins

    Long time no update. Advise?

    One of the things I am pushing for is for Portage to grab any installed conflicting packages and add them to the package set automatically, before backtracking at all. This is likely going to resolve the majority of conflicts automatically. The upstream gentoo bug for this feature is https://bugs.gentoo.org/559354 <-- and I am thinking of something like an --expand option that will auto-add installed packages that conflict to the set of packages to be rebuilt, so users don't have to. If you think this would be a good idea, you may want to comment on the upstream bug and this may result in it being prioritized.
  8. 1 point
    You are very kind, thank you for the support.
  9. 1 point
    Hi folks O/ few years ago I wonder about a friendly version of Gentoo and Funtoo, the gentoo community don't liked, but I keep did some tests but I didn't continue, well, few week ago I start again, but this time only a Funtoo Friendly version, and now I have something really beginning. the project will resume in few flavors and one version with a overlay with update packages and few extra. the funtoo flavors are X+openbox, gnome and Plasma, they are just the Funtoo Stage3 Generic with few packages and some configuration. and has one version with plasma, but with an overlay with few update packages and other stuffs, a stage more out of the box, I want make something to people learn about gentoo/funtoo or for who use the system without spent hours to build the system. the webiste will be done in the next weeks, and the stages will be available in the next days "sorry, I'm with one pc now, and the net is a turtle". website -> https://bentoo.info/ binhost -> http://binhost.bentoo.info github repos : overlay -> https://github.com/lucascouts/bentoo configurations -> https://github.com/lucascouts/bentoo-portagedir I don't know if the funtoo community will like but anyway I'll forward with this project, but will be great if few users could help with feedback or criticisms. thank you anyway πŸ™‚
  10. 1 point
    so you looked at github and explored git locally - no sign of ego kit list here. You wonder if there is a way to do it with ego or any funtoo specific command -> ego kit list 1.3-release will show once you switch to 1.3-release in ego.conf [global] release = 1.3 the stability tag: current - tracking gentoo prime - somehow seen as good for production anything else - alpha, beta, dev => not good for production if you are not a developer
  11. 1 point
    If emerge -avuND @world then add EMERGE_DEFAULT_OPTS="--with-bdeps=y" to /etc/portage/make.conf If not then always update with this command: emerge -avuND --with-bdeps=y @world
  12. 1 point
    drobbins

    We have a new FAQ!

    @nrc question answered -- https://www.funtoo.org/FAQ:What_Are_Funtoo_Kits
  13. 1 point
    eyesee

    Virtualbox issues fresh Funtoo install

    Hej! Good it worked for you so far! πŸ˜€ I can imagine VirtualBox source ebuild or the installed guest additions have some issues. As said, I remember having problems with the source package on my Intel system too. But I have not investigated any further yet due to lack of time. I just switched to the binary package and that worked for me. So unfortunately I can not tell if this is a Threadripper related problem. I hope someone else can help you better than me. Perhaps you should consider writing a bug report on the Funtoo bug tracker. By the end of year I will also retry installing from sources. Cheers
  14. 1 point
    Amazing project my friend, If you need any kinda help let me know and yes i speak brazilian portuguese πŸ˜›
  15. 1 point
    Ryo

    Unknown CPU given in --with-arch=skylake

    πŸ‘ damn ! yes i had it set up in make.conf. Thank you , i can now get some sleep ^^
  16. 1 point
    Hey, so I think no one is really telling you the obvious -- you found a small bug, and I'm going to fix it with a commit to the profiles so that pclmul is added to CPU_FLAGS_X86 for skylake and skylake-avx512. πŸ™‚
  17. 1 point
    Recently I fell into the trap having march=skylake in my CFLAGS which is not really supported by GCC 7. Now I have fixed this by setting CFLAGS march option to broadwell which makes sense and works so far. Thanks to all the people involved doing the hard work on that beast! To squeeze out the last bit of my CPU I wonder if it makes sense to adjust the CPU_FLAGS_X86 setting to the output I am getting from the cpuid2cpuflags tool. The output I am getting does differ from the recommendation on the subarches wiki page for skylake and the given x86-64bit make.defaults for Intel Skylake. Could the output be different because I have a Xeon E3 instead of an iCore 3/5/7? My ego profile shows the following: arch: x86-64bit build: current subarch: intel64-skylake The basic CPU_FLAGS_X86 option for Intel Skylake is according to the Subarches page: aes avx avx2 fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 make.defaults for x86-64-bit Intel skylake contains the following (difference underlined): aes avx avx2 f16c fma3 mmx mmxext popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 cpuid2cpuflags for my Xeon E3 v5 states there is another option available (difference underlined): aes avx avx2 f16c fma3 mmx mmxext pclmul popcnt sse sse2 sse3 sse4_1 sse4_2 ssse3 It seems like f16c and pclmul are not used in many packages explicitly. But I am also compiling non-ebuild stuff and some stuff from my own overlay. In general I have not that much insight how CPU flags are used and I do not know if the compilation of GCC with those additional flags would automagically improve compilation results in general. So my question is: would it be of any benefit to modify the CPU_FLAGS_X86 flag to reflect what cpuid2cpuflags spits out? Thanks! eyesee
  18. 1 point
    lazlo.vii

    Why Funtoo is not migrating on GitLab ?

    I think that Microsoft knows the kind of problems that would be caused if they abused their ownership of GitHub and I think they know beyond a shadow of a doubt what it would cost them: https://www.theregister.co.uk/2018/06/08/nat_friedman_github_ceo_elect_ama_session/ Let's face it, when it comes to freedom, privacy, an open market, and just about every other category of economic threat you can imagine Google/Alphabet/Android/Chrom* is bigger than Microsoft ever was. If Microsoft wants to stop their market share slide (much less regain market dominance) then they need software developers to like them and to work with them.
  19. 1 point
    Thank you Cardinal. https://bugs.funtoo.org/browse/FL-5837
  20. 1 point
    Also note that I will be helping with this new distribution because I think it is very much needed and wanted by the user community.
  21. 1 point
    drobbins

    Containers migrated to BTRFS + SSD

    Hi All, As we move to our third-generation infrastructure, I am currently migrating containers to BTRFS+SSD (from ZFS and HDD+Optane) which may result in up to an hour of downtime, especially if you have a lot of data stored in your containers. But the result will be much, much, much faster IO. So if you have seen your uptime on your container change recently, this is why. Best, Daniel
  22. 1 point
    The 1.0 release of Funtoo Linux is not going to be maintained after September 30, 2018. So please be sure to upgrade your systems to Funtoo Linux 1.2 using https://www.funtoo.org/Upgrade_Instructions so that you will continue to get updates! We will also be starting development on Funtoo Linux 1.3 in a few days, on August 31. We are moving to a new agile (scrum) process, where we will be doing 1-week sprints (time-constrained sets of work). Our work will include some portion of fixes for 1.2 and some new work on 1.3. When we as a team decide that 1.3 is ready for various milestones (alpha, beta, release candidate) we will mark it as such. Thus, we have no hard deadline for 1.3 as I do not want to try to hit arbitrary dates that are not based on the actual work. But we will get there, sooner rather than later!
  23. 0 points
    I'm not losing my time anymore with you. As said, you didn't read or understood the genuine post. Also you just copied and pasted the command I proposed on the first post which obviously doesn't answer any of the questions set out. By moving to any kit git repo locally one can git ls-remote (or fetch all branches and check them out) and see what branches exists. But What I would like to know if there's any command to see how many or which branches exists for a given kit repo. Also I would like to query a description/definition for the stability associated to those branches. Unfortunately none of these can be achieved by ego, AFAIK. ego kit -v list|status doesn't show all the existing branches for a given kit repository. Neither describes it's stability. As example, you should be able to comprehend kde-kit has 3 git branches which are not shown by ego kit, nor a description for its stability: ego kit -v list /var/git/meta-repo (updated 5 hours 42 minutes ago): kit is active? branch stability kde-kit active 5.12-prime prime So my questions persists. Is there any way to get this kind of information through system utilities or one should dig into with git commands and then decide which branch suits best reading untrusted sources? Kind regards,
  24. 0 points
    Hello to everybody & sorry for my poor english. I really wish to ask the comunity of Funtoo: Why you are staying on GitHub,scince it was acquired by the Sionistic/Massonic microsoft? Are you not affraid,that someone can manipulate your sources to realese some kind of backdoor in your images ? Thanks .
  25. -1 points
    Otakku

    Why Funtoo is not migrating on GitLab ?

    And why Microsoft will create or add some backdoor ? is just business, grow up.
×