Jump to content
funtoo forums

All Activity

This stream auto-updates     

  1. Today
  2. Thanks, but that shows the version of the kernel, which I think is not related to the Funtoo release version.
  3. Jhan I have installed bumblebee but performances are worst than intel card
  4. Ok thanks. I see mostly 1.2-release when I run this command so I guess it means I'm running version 1.2. Would that explain why I don't get new updates?
  5. Thanks guys - I've put all three way to override python in my package.use!! # package.use # # three ways to select python version >=app-text/asciidoc-8.6.10 python_single_target_python2_7 python_targets_python2_7 dev-util/itstool PYTHON_TARGETS: -* python3_6 PYTHON_SINGLE_TARGET: -* python3_6 dev-libs/libxml2 python_targets_python*
  6. Yesterday
  7. I was trying to install steam but I obtain some errors. Using layman and anyc's Steam repository I obtain this is the error: !!! All ebuilds that could satisfy ">=sys-devel/gcc-4.6.0[multilib]" have been masked. !!! One of the following masked packages is required to complete your request: - sys-devel/gcc-8.2.1-r5::core-kit (masked by: missing keyword) (dependency required by "games-util/steam-launcher-1.0.0.59-r3::steam-overlay[amd64]" [ebuild]) (dependency required by "games-util/steam-launcher" [argument]) I also tried to download steam from repo.steampowered.com extract files and run ./steam and got this error: Couldn't find dpkg, please update steamdeps for your distribution. Running Steam on funtoo intel64-ivybridge-2019-05-08 64-bit STEAM_RUNTIME is enabled automatically Pins up-to-date! /home/carmelo/.local/share/Steam/steam.sh: line 828: /home/carmelo/.local/share/Steam/ubuntu12_32/steam-runtime/run.sh: No such file or directory Error: You are missing the following 32-bit libraries, and Steam may not run: libc.so.6 /home/carmelo/.local/share/Steam/steam.sh: line 888: /home/carmelo/.local/share/Steam/ubuntu12_32/steam: No such file or directory I followed this wiki https://wiki.gentoo.org/wiki/Steam. Since package.use is a file I added the lines in the wiki in this file instead of create /etc/portage/package.use/steam
  8. Last week
  9. I can't install php-5.6.38 due to the icu problem , it should be removed from core-server-kit It's not possible on my system to install 2 versions of icu at the same time to satisfy this older version of php. If you have an older version of php installed that's trying to upgrade/downgrade to php-5.6.38 then you will have to remove it. Portage would install dev-lang/php-7.2.12 on my updated 1.3-release php free system without any conflicts: rj@funtoo ~ $ sudo emerge -pv php These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild N ] dev-libs/oniguruma-6.9.0:0/5::dev-kit USE="-crnl-as-line-terminator -static-libs" 0 KiB [ebuild N ] dev-libs/libsodium-1.0.16-r2:0/23::dev-kit USE="asm urandom -minimal -static-libs" CPU_FLAGS_X86="-aes -sse4_1" 0 KiB [ebuild N ] dev-libs/libzip-1.3.0:0/5::dev-kit USE="bzip2 -static-libs" 0 KiB [ebuild N ] app-text/tidy-html5-5.6.0::text-kit 0 KiB [ebuild N ] app-eselect/eselect-php-0.9.5::core-kit USE="fpm -apache2" 0 KiB [ebuild N ] app-text/aspell-0.60.7_rc1::text-kit USE="nls unicode" L10N="en -af -be -bg -br -ca -cs -cy -da -de -de-1901 -el -eo -es -et -fi -fo -fr -ga -gl -he -hr -hu -hy -is -it -la -lt -nl -no -pl -pt -pt-BR -ro -ru -sk -sl -sr -sv -uk -vi" 0 KiB [ebuild N ] app-dicts/aspell-en-2017.01.22.0::text-kit 0 KiB [ebuild N ] dev-lang/php-7.2.12:7.2::core-server-kit USE="acl argon2 berkdb bzip2 cgi cli ctype curl exif fileinfo filter fpm gd gdbm hash iconv intl ipv6 json mysql mysqli nls opcache pcntl pdo phar posix readline session simplexml sockets sodium spell sqlite ssl tidy tokenizer truetype unicode webp xml xmlreader xmlrpc xmlwriter xslt zip zip-encryption zlib -apache2 -bcmath -calendar -cdb -cjk -coverage -debug -embed -enchant -firebird -flatfile -ftp -gmp -imap -inifile -iodbc -kerberos -ldap -ldap-sasl -libedit -libressl -lmdb -mhash -mssql -oci8-instant-client -odbc -phpdbg -postgres -qdbm -recode (-selinux) -session-mm -sharedmem -snmp -soap -systemd -sysvipc -test -threads -tokyocabinet -wddx -xpm" 5,010 KiB Total: 8 packages (8 new), Size of downloads: 5,010 KiB
  10. Each kit is a git repo that is set to the active branch that has it's release name. # ego kit funtoo /home/rj # ego kit /var/git/meta-repo (updated 17 hours 23 minutes ago): kit active branch default stability core-kit 1.3-release (same) prime core-hw-kit 1.3-release (same) prime core-ui-kit 1.3-release (same) prime core-server-kit 1.3-release (same) prime core-gl-kit 1.3-release (same) prime security-kit 1.3-release (same) prime xorg-kit 1.20-release (same) prime gnome-kit 3.30-prime (same) prime rust-kit 1.32-prime (same) prime xfce-kit 4.13-release (same) prime kde-kit 1.3-release (same) prime desktop-kit 1.3-release (same) prime media-kit 1.3-release (same) prime editors-kit 1.3-release (same) prime net-kit 1.3-release (same) prime text-kit 1.3-release (same) prime science-kit 1.3-release (same) prime games-kit 1.3-release (same) prime perl-kit 5.28-release (same) prime java-kit 1.3-release (same) prime ruby-kit 1.3-release (same) prime haskell-kit 1.3-release (same) prime ml-lang-kit 1.3-release (same) prime lisp-scheme-kit 1.3-release (same) prime python-kit 3.7-release (same) prime lang-kit 1.3-release (same) prime llvm-kit 1.3-release (same) prime dev-kit 1.3-release (same) prime python-modules-kit 1.3-release (same) prime nokit 1.3-release (same) prime NOTE: This information comes from /etc/ego.conf and meta-repo metadata. After making changes to ego.conf, be sure to run ego sync in so that the individual kit repositories on disk are synchronized with the kit branches shown above. Additional Information comes from /var/git/meta-repo/metadata/kit-info.json Specific revision number for each kits git repo: /var/git/meta-repo/metadata/kit-sha1.json
  11. Here it is: denis@euclide(~)$ cat /etc/ego.conf # This is the ego.conf file [kits] # You can set your default kits here. Unset kits will use the Funtoo default prime/master # branch by default. # python-kit = 3.6-prime
  12. I haven't updated my Funtoo systems in a while and now when I run ego sync there's no new packages. I see that there are new releases of Funtoo (1.2, 1.3). Can someone please tell me how to see which release I'm running. Thanks.
  13. Hi, I can't emerge php5.6.40, portage says it does not exists but i can see the ebuild at /var/git/meta-repo/kits/php-kit/dev-lang/php/php-5.6.40.ebuild ls /var/git/meta-repo/kits/php-kit/dev-lang/php/php-5.6.40.ebuild /var/git/meta-repo/kits/php-kit/dev-lang/php/php-5.6.40.ebuild eix dev-lang/php [I] dev-lang/php [1] Available versions: (5.6) 5.6.38 (7.0) 7.0.32 (7.1) 7.1.22 (~)7.1.23 (~)7.1.24 (7.2) 7.2.10 (~)7.2.11 (~)7.2.12 (7.3) [M](~)7.3.0_rc2 [M](~)7.3.0_rc3 {M}(~)7.3.0_rc5 {acl apache2 argon2 bcmath berkdb bzip2 calendar cdb cgi cjk +cli coverage crypt +ctype curl debug embed enchant exif +fileinfo +filter firebird flatfile fpm ftp gd gdbm gmp +hash +iconv imap inifile intl iodbc ipv6 +json kerberos ldap ldap-sasl libedit libmysqlclient libressl lmdb mhash mssql mysql mysqli nls oci8-instant-client odbc +opcache pcntl pdo +phar phpdbg +posix postgres qdbm readline recode selinux +session session-mm sharedmem +simplexml snmp soap sockets sodium spell sqlite ssl sybase-ct systemd sysvipc test threads tidy +tokenizer tokyocabinet truetype unicode vpx wddx webp +xml xmlreader xmlrpc xmlwriter xpm xslt zip zip-encryption zlib} Installed versions: 5.6.38(5.6)(12:39:34 PM 05/19/2019)(apache2 bzip2 cgi cli crypt ctype curl exif fileinfo filter fpm gd hash iconv intl json mysql mysqli nls opcache pcntl pdo phar posix readline session simplexml sockets spell sqlite ssl threads tidy tokenizer truetype unicode vpx xml xmlreader xmlrpc xmlwriter xslt zip zlib -acl -bcmath -berkdb -calendar -cdb -cjk -coverage -debug -embed -enchant -firebird -flatfile -ftp -gdbm -gmp -imap -inifile -iodbc -ipv6 -kerberos -ldap -ldap-sasl -libedit -libmysqlclient -libressl -mhash -mssql -oci8-instant-client -odbc -postgres -qdbm -recode -selinux -sharedmem -snmp -soap -sybase-ct -systemd -sysvipc -wddx -xpm) 7.3.0_rc5(7.3)(02:51:57 AM 05/20/2019)(apache2 argon2 bzip2 cgi cli ctype curl exif fileinfo filter fpm gd hash iconv intl json mysql mysqli nls opcache pcntl pdo phar posix readline session simplexml sockets sodium spell sqlite ssl threads tidy tokenizer truetype unicode webp xml xmlreader xmlrpc xmlwriter xslt zip zip-encryption zlib -acl -bcmath -berkdb -calendar -cdb -cjk -coverage -debug -embed -enchant -firebird -flatfile -ftp -gdbm -gmp -imap -inifile -iodbc -ipv6 -kerberos -ldap -ldap-sasl -libedit -libressl -lmdb -mhash -mssql -oci8-instant-client -odbc -phpdbg -postgres -qdbm -recode -selinux -session-mm -sharedmem -snmp -soap -systemd -sysvipc -test -tokyocabinet -wddx -xpm) Homepage: https://secure.php.net/ Description: The PHP language runtime engine [1] "core-server-kit" /var/git/meta-repo/kits/core-server-kit emerge -va1 =dev-lang/php-5.6.40 * emerging -va1 =dev-lang/php-5.6.40 * IMPORTANT: 2 config files in '/etc/portage' need updating. * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS * sections of the emerge man page to learn how to update config files. These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy "=dev-lang/php-5.6.40". I'm cool with php-5.6.38 but it needs icu:60 while other packages want icu:63 and this is causing too many conflicts. Any tip? thx.
  14. Someone on #funtoo told me perl 5.28 should be masked so after removing it from unmask I'm trying to update the system.
  15. mrl5

    funtoo and yubikey

    one more note. If someone plans to play with yubikey-personalization-gui - adding /etc/udev/rules.d/69-yubikey.rules is also needed: https://github.com/Yubico/yubikey-personalization/blob/master/69-yubikey.rules ACTION!="add|change", GOTO="yubico_end" # Udev rules for letting the console user access the Yubikey USB # device node, needed for challenge/response to work correctly. # Yubico Yubikey II ATTRS{idVendor}=="1050", ATTRS{idProduct}=="0010|0110|0111|0114|0116|0401|0403|0405|0407|0410", \ ENV{ID_SECURITY_TOKEN}="1" LABEL="yubico_end"
  16. Hi guys, i'm just posting because I'm having a nightmare trying to upgrade Funtoo after a few months out. By now, i'm working around the following issue by running a script which updates every single package which needs an update by ussing --oneshot parameter. The following are the "errors" I get when running emerge -auDNU @system --ignore-world --verbose-conflicts emerge -auDNU @system --ignore-world --verbose-conflicts * IMPORTANT: config file '/etc/portage/package.use' needs updating. * See the CONFIGURATION FILES and CONFIGURATION FILES UPDATE TOOLS * sections of the emerge man page to learn how to update config files. These are the packages that would be merged, in order: Calculating dependencies | ... done! [ebuild UD ] sys-libs/timezone-data-2018g::core-hw-kit [2018i::core-hw-kit] USE="nls -leaps_timezone" 594 KiB [ebuild UD ] sys-apps/kmod-25::core-kit [26-r1::libressl] USE="lzma* tools zlib -debug -doc -python -static-libs (-libressl%*) (-ssl%)" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5 -python3_7" 533 KiB [ebuild U ] sys-libs/libcap-2.25-r1::core-kit [2.25::core-kit] USE="pam -static-libs" 63 KiB [ebuild UD ] app-text/qpdf-8.2.1:0/21::text-kit [8.3.0:0/21::text-kit] USE="-doc -examples -perl -static-libs -test" 8,063 KiB [ebuild r U ] dev-libs/icu-63.1-r1:0/63.1::core-kit [60.2:0/60.2::core-kit] USE="-debug -doc -examples -static-libs" 23,191 KiB [ebuild UD ] dev-libs/nettle-3.4:0/6.2::security-kit [3.4.1:0/6.2::security-kit] USE="gmp -doc (-neon) -static-libs -test" CPU_FLAGS_X86="-aes" 1,890 KiB [ebuild rR ] dev-db/sqlite-3.28.0:3::core-kit USE="icu readline -debug -doc -secure-delete -static-libs -tcl -test -tools" 0 KiB [ebuild rR ] mail-mta/postfix-3.2.4::core-kit USE="eai pam -berkdb -cdb -doc -dovecot-sasl -hardened -ldap -ldap-bind -libressl -lmdb -mbox -memcached -mysql -nis -postgres -sasl (-selinux) -sqlite -ssl" 4,288 KiB [ebuild rR ] www-client/w3m-0.5.3_p20180125::net-kit USE="X nls unicode -fbcon -gdk-pixbuf (-gpm) -imlib -libressl -lynxkeymap -nntp -ssl -xface" L10N="-de -ja" 2,131 KiB [ebuild UD ] dev-lang/perl-5.26.2-r1:0/5.26::perl-kit [5.28.0:0/5.28::perl-kit] USE="ithreads -berkdb -debug -doc -gdbm" 11,770 KiB [ebuild rR ] dev-lang/spidermonkey-52.9.1_pre1:52::net-kit USE="system-icu -custom-cflags -custom-optimization -debug -minimal -test" 29,477 KiB [ebuild UD ] dev-python/setuptools-40.0.0::python-modules-kit [40.7.1::python-modules-kit] USE="-test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 830 KiB [ebuild UD ] dev-python/certifi-2018.8.24::python-modules-kit [2018.11.29::python-modules-kit] PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 144 KiB [ebuild UD ] dev-python/idna-2.7::python-modules-kit [2.8::python-modules-kit] PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 169 KiB [ebuild UD ] dev-python/six-1.11.0::python-modules-kit [1.12.0::python-modules-kit] USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 30 KiB [ebuild UD ] dev-python/pyopenssl-17.5.0::python-modules-kit [18.0.0::python-modules-kit] USE="-doc -examples -test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 167 KiB [ebuild UD ] dev-python/urllib3-1.23::python-modules-kit [1.24.1::python-modules-kit] USE="-doc -test" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 223 KiB [ebuild UD ] dev-python/requests-2.19.1-r1::python-modules-kit [2.21.0-r1::python-modules-kit] USE="-socks5 -ssl" PYTHON_TARGETS="python2_7 python3_6 -pypy -pypy3 -python3_4 -python3_5 -python3_7" 128 KiB [ebuild rR ] dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit USE="icu -debug -systemd -test" 0 KiB [ebuild UD ] net-misc/dhcpcd-7.0.8::core-hw-kit [7.1.0::core-hw-kit] USE="embedded udev -ipv6" 206 KiB [ebuild rR ] dev-libs/libxml2-2.9.9-r1:2::core-kit USE="icu python readline -debug -examples -ipv6 -lzma -static-libs -test" PYTHON_TARGETS="python2_7 python3_6 -python3_5 -python3_7" 5,365 KiB [ebuild UD ] sys-cluster/openmpi-3.1.2::nokit [3.1.3::nokit] USE="cxx -cma -cuda -fortran -heterogeneous -ipv6 -java -numa -romio" OPENMPI_FABRICS="-knem -ofed -psm" OPENMPI_OFED_FEATURES="-control-hdr-padding -dynamic-sl -rdmacm -udcm" OPENMPI_RM="-pbs -slurm" 9,241 KiB [ebuild rR ] sys-fs/xfsprogs-4.19.0::core-kit USE="icu nls readline -libedit -static-libs" 1,185 KiB [ebuild UD ] app-crypt/rhash-1.3.6-r1::nokit [1.3.7::nokit] USE="nls -debug -libressl* -ssl -static-libs" 321 KiB [ebuild rR ] dev-libs/boost-1.65.0:0/1.65.0::core-kit USE="icu mpi nls threads -context -debug -doc -python -static-libs -tools" PYTHON_TARGETS="python2_7 python3_6 -python3_4 -python3_5" 80,662 KiB [ebuild rR ] media-libs/harfbuzz-2.4.0:0/0.9.18::media-kit USE="cairo glib graphite icu introspection truetype -debug -static-libs -test" 0 KiB [ebuild UD ] app-text/ghostscript-gpl-9.25-r1::text-kit [9.26::text-kit] USE="X cups dbus gtk tiff unicode -static-libs" L10N="-de -ja -ko -zh-CN -zh-TW" 32,258 KiB Total: 27 packages (2 upgrades, 16 downgrades, 9 reinstalls), Size of downloads: 212,919 KiB !!! Multiple package instances within a single package slot have been pulled !!! into the dependency graph, resulting in a slot conflict: dev-lang/perl:0 (dev-lang/perl-5.28.0:0/5.28::perl-kit, installed) pulled in by dev-lang/perl:0/5.28= required by (virtual/perl-podlators-4.90.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/libwww-perl-6.270.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/HTTP-Message-6.130.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (app-text/po4a-0.47-r2:0/0::core-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/HTML-Parser-3.720.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-CPAN-Meta-2.150.10-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (perl-core/ExtUtils-MakeMaker-7.240.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/XML-Parser-2.440.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Net-HTTP-6.170.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Digest-MD5-2.550.0:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-parent-0.236.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (perl-core/File-Temp-0.230.400-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/IO-Socket-SSL-2.52.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/WWW-RobotRules-6.20.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-ExtUtils-MakeMaker-7.240.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Net-SSLeay-1.820.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/File-BaseDir-0.70.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-parent-0.236.0-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/HTTP-Date-6.20.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Text-Unidecode-1.300.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/Tie-IxHash-1.230.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/XML-Twig-3.520.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Getopt-Long-2.490.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Time-Local-1.250.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Carp-1.420.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-XSLoader-0.270.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-File-Spec-3.670.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Time-Local-1.250.0-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/File-Listing-6.40.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Sub-Name-0.210.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/libintl-perl-1.280.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Socket6-0.280.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/URI-1.730.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/IO-HTML-1.1.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Module-Metadata-1.0.33-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Encode-2.880.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/HTTP-Negotiate-6.10.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Module-Metadata-1.0.33-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/HTTP-Daemon-6.10.0-r2:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Text-Iconv-1.700.0-r2:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/Text-CharWidth-0.40.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Storable-2.620.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/X11-Protocol-0.560.0-r2:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/TermReadKey-2.370.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Parse-CPAN-Meta-2.150.10-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Digest-MD5-2.550.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/IO-Socket-INET6-2.720.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Test-Harness-3.380.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-File-Temp-0.230.400-r5:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/Unicode-EastAsianWidth-1.330.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/XML-XPath-1.420.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-IO-Compress-2.74.0-r1:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-CPAN-Meta-YAML-0.18.0-r3:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-IO-Compress-2.74.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/LWP-MediaTypes-6.20.0-r1:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-MIME-Base64-3.150.0-r4:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (sys-apps/texinfo-6.5:0/0::core-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Perl-OSType-1.10.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Encode-Locale-1.50.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-MIME-Base64-3.150.0-r4:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Time-HiRes-1.974.100-r2:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Text-ParseWords-3.300.0-r4:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-Perl-OSType-1.10.0-r1:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/SGMLSpm-1.1-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-IO-Socket-IP-0.380.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Compress-Raw-Bzip2-2.74.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-libnet-3.100.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/File-DesktopEntry-0.220.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-version-0.991.700:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Module-Build-0.422.400:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/IPC-System-Simple-1.250.0:0/0::perl-kit, installed) ^^^^^^^^ =dev-lang/perl-5.28* required by (virtual/perl-ExtUtils-Manifest-1.700.0-r5:0/0::perl-kit, installed) ^ ^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Locale-gettext-1.70.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/File-MimeInfo-0.280.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Exporter-5.720.0-r3:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Try-Tiny-0.300.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-File-Path-2.130.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/Text-WrapI18N-0.60.0-r1:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/HTTP-Cookies-6.40.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-Data-Dumper-2.167.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (perl-core/File-Path-2.130.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (dev-perl/Net-DBus-1.1.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28= required by (virtual/perl-IO-1.380.0:0/0::perl-kit, installed) ^^^^^^^^ dev-lang/perl:0/5.28=[-build(-)] required by (dev-perl/HTML-Tagset-3.200.0-r1:0/0::perl-kit, installed) ^^^^^^^^ (dev-lang/perl-5.26.2-r1:0/5.26::perl-kit, ebuild scheduled for merge) pulled in by =dev-lang/perl-5.26* required by (virtual/perl-JSON-PP-2.274.0.200_rc:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Exporter-5.720.0-r3:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-ParseXS-3.340.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Compress-Raw-Zlib-2.74.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Test-Harness-3.380.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-XSLoader-0.270.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Carp-1.420.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-version-0.991.700:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-podlators-4.90.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-Install-2.40.0-r3:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Storable-2.620.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-ExtUtils-CBuilder-0.280.225-r2:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Getopt-Long-2.490.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-IO-1.380.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Time-HiRes-1.974.100-r2:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-IO-Socket-IP-0.380.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-libnet-3.100.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Scalar-List-Utils-1.460.200_rc:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-File-Spec-3.670.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Data-Dumper-2.167.0:0/0::perl-kit, installed) ^ ^^^^^ =dev-lang/perl-5.26* required by (virtual/perl-Encode-2.880.0:0/0::perl-kit, installed) ^ ^^^^^ It may be possible to solve this problem by using package.mask to prevent one of those packages from being selected. However, it is also possible that conflicting dependencies exist such that they are impossible to satisfy simultaneously. If such a conflict exists in the dependencies of two different packages, then those packages can not be installed simultaneously. You may want to try a larger value of the --backtrack option, such as --backtrack=30, in order to see if that will solve this conflict automatically. For more information, see MASKED PACKAGES section in the emerge man page or refer to the Gentoo Handbook. The following packages are causing rebuilds: (dev-libs/icu-63.1-r1:0/63.1::core-kit, ebuild scheduled for merge) causes rebuilds for: (dev-libs/libxml2-2.9.9-r1:2/2::core-kit, ebuild scheduled for merge) (dev-lang/spidermonkey-52.9.1_pre1:52/52::net-kit, ebuild scheduled for merge) (mail-mta/postfix-3.2.4:0/0::core-kit, ebuild scheduled for merge) (media-libs/harfbuzz-2.4.0:0/0.9.18::media-kit, ebuild scheduled for merge) (dev-db/sqlite-3.28.0:3/3::core-kit, ebuild scheduled for merge) (sys-fs/xfsprogs-4.19.0:0/0::core-kit, ebuild scheduled for merge) (dev-qt/qtcore-5.11.2-r1:5/5.11::core-ui-kit, ebuild scheduled for merge) (dev-libs/boost-1.65.0:0/1.65.0::core-kit, ebuild scheduled for merge) Does anyone knows how could I workaround this issue? Thanks
  17. If you have rust-bin installed then it includes cargo. /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 You have to manually run this command to symlink the cargo-bin-1.32.0 executable to /usr/bin/cargo : # eselect rust set 1 Verify cargo: # which cargo /usr/bin/cargo # file `which cargo` /usr/bin/cargo: symbolic link to /usr/bin/cargo-bin-1.32.0 # file `which cargo-bin-1.32.0` /usr/bin/cargo-bin-1.32.0: symbolic link to ../../opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 # file /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0 /opt/rust-bin-1.32.0/bin/cargo-bin-1.32.0: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.9, stripped Reference: https://bugs.funtoo.org/browse/FL-5843 dev-util:cbindgen-0.8.2:20190519-154310.log
  18. I was updating world but the operation stops when portage tries to install cbindgen. here are the last lines of log file >>> Source unpacked in /var/tmp/portage/dev-util/cbindgen-0.8.2/work >>> Preparing source in /var/tmp/portage/dev-util/cbindgen-0.8.2/work/cbindgen-0.8.2 ... >>> Source prepared. >>> Configuring source in /var/tmp/portage/dev-util/cbindgen-0.8.2/work/cbindgen-0.8.2 ... >>> Source configured. >>> Compiling source in /var/tmp/portage/dev-util/cbindgen-0.8.2/work/cbindgen-0.8.2 ... /var/tmp/portage/dev-util/cbindgen-0.8.2/temp/environment: line 451: cargo: command not found [31;01m*[0m ERROR: dev-util/cbindgen-0.8.2::dev-kit failed (compile phase): [31;01m*[0m cargo build failed [31;01m*[0m [31;01m*[0m Call stack: [31;01m*[0m ebuild.sh, line 92: Called src_compile [31;01m*[0m environment, line 690: Called cargo_src_compile [31;01m*[0m environment, line 451: Called die [31;01m*[0m The specific snippet of code: [31;01m*[0m cargo build -j $(makeopts_jobs) $(usex debug "" --release) || die "cargo build failed" [31;01m*[0m [31;01m*[0m If you need support, post the output of `emerge --info '=dev-util/cbindgen-0.8.2::dev-kit'`, [31;01m*[0m the complete build log and the output of `emerge -pqv '=dev-util/cbindgen-0.8.2::dev-kit'`. [31;01m*[0m The complete build log is located at '/var/tmp/portage/dev-util/cbindgen-0.8.2/temp/build.log'. [31;01m*[0m The ebuild environment file is located at '/var/tmp/portage/dev-util/cbindgen-0.8.2/temp/environment'. [31;01m*[0m Working directory: '/var/tmp/portage/dev-util/cbindgen-0.8.2/work/cbindgen-0.8.2' [31;01m*[0m S: '/var/tmp/portage/dev-util/cbindgen-0.8.2/work/cbindgen-0.8.2'
  19. Hi folks. now we have a livecd iso and an installer with calamares, both need some improvement but already work, I would like fix and improve better, but I need some help with the feedback. so, who could test, even in a vm, please give the feedback, about something to add, remove or change. here the site => http://bentoo.info ISO => https://sourceforge.net/projects/bentoo/ binaries and ISO => https://binhost.bentoo.info/ and the Telegram group => https://t.me/joinchat/DG0l5Rez0MRt4p2GHnNohQ
  20. Well, you are mistaken. The IP 192.99.210.63 is a valid IP located in Canada. It was accessible but has been down for some time now. The internal IP range you are talking about is only 192.168.0.0 to 192.168.255.255. And, although the page is not in English, I think it is quite understandable what you are looking at and what the download is about. The words "funtoo-livecd" and the instructions near the bottom should be enough to understand it. And if that is not enough, you are free to use google or any other service that translates webpages to get a better understanding of the text on the page: https://translate.google.com/translate?sl=auto&tl=en&u=https%3A%2F%2Farea31.net.br%2Fwiki%2FLiveCD_oficial
  21. Sorry to report, but you have a major problem there: the link you supply refers to a local file (see the 192.xxx.yyy.zzz IP address range) so it's not available to anyone except yourself. Not very useful for sharing 😔 You're also advised to translate the download page in English, so people know what it is they're looking at before committing a download. HTH!
  22. So, I'm onto my fifth emerge @preserved-rebuild in less than 2 days. It seems to keep repeating and, at the end, recommending I run the same command. I'm sure I should find something to adjust this, but I have no idea what. Help?
  23. Thank you so much this solves the problem without any hicupps 👍
  24. Your processor doesn't support aes which is in your CPU_FLAGS_86 and CFLAGS="- march=westmere" Building nettle with aes cpu flag set on gcc when your processor doesn't support aes could be the cause of the error. Reference: https://gcc.gnu.org/onlinedocs/gcc/x86-Options.html ‘westmere’ Intel Westmere CPU with 64-bit extensions, MMX, SSE, SSE2, SSE3, SSSE3, SSE4.1, SSE4.2, POPCNT, AES and PCLMUL instruction set support. Set to native and add the proper flags to match your processor. Install cpuid2cpuflags Follow my directions here starting at Remove any gcc override settings you've made previously. After you've finished configuring gcc to match your processor rebuild nettle.
  1. Load more activity
×
×
  • Create New...