Jump to content

All Activity

This stream auto-updates

  1. Yesterday
  2. https://bugs.funtoo.org/browse/FL-8123 FL-8123: Remove patches merged upstream in sys-devel/distcc. The source prepare patch failure that was stopping the emerge for distcc-3.3.5 was fixed by removing the eapply patch commands for the failing patches from the ebuild.
  3. im not a veteran but ive seen the horrors of war from being from a military family. support our troops, bring them home. im going to take a break for a while and move to an apartment because i cant live with my family anymore.
  4. i have found a fix, apperantly distcc dosen't like the default -march=native so i have found this guide ( https://blogs.gentoo.org/mgorny/2014/06/23/inlining-marchnative-for-distcc/ ) and used this command gcc -### -march=native -x c - which gives all of the cpu information and i have put it into the make.conf files under CFLAGS="{insert here}" and distcc has installed with no problems
  5. The patches need to be updated for distcc-3.3.5.ebuild My workaround for failed updates is git revert the commit to the prior version distcc-3.3.3.ebuild After successfully emerging distcc-3.3.3 mask it until the patches are fixed and distcc-3.3.5 will build. funtoo /var/git/meta-repo/kits/core-kit # git log --all --full-history -- "*distcc*.*" Checkout the 2nd commit in the result to restore distcc-3.3.3.ebuild funtoo /var/git/meta-repo/kits/core-kit # git checkout 8d890 funtoo /var/git/meta-repo/kits/core-kit # emerge -av distcc Mask distcc-3.3.5 from update until it's fixed. f
  6. Last week
  7. i am using linux mint debbi 4 ( live usb ) to install funtoo ( using generic_64 since using westmere gives me illegal instruction when i try to do ego update ) onto my p6100 intel cpu laptop and i want to use distcc to use my other more powerful windows 10 ltsc 2019 laptop ( with ubuntu 20.04 LTS from microsoft store (better performance than regular virtual machine??) ) to speed up building programs for my p6100 laptop since last time i tried installing gentoo and it was taking forever, i was still on the handbook at the time and installing the network dependencies were around half way finishe
  8. howudodat

    openjdk 11

    I'm looking for any instructions on getting openjdk 11 installed. I only see up to version 8, which is 7 years old already.
  9. Is there a similar write up as: https://www.funtoo.org/Funtoo_VMware_Guest_Support but for proxmox? Particularly to get the qxl video driver working?
  10. In general, I have three options, all bad: 1. install libreoffice with the entire gnome library 2. try to look for a solution to problems with wps-office installation 3. wade in openoffice a local overlay, layman, etc. ☹️
  11. Libreoffice{-bin} needs qt5 Openoffice-bin no qt5. Openoffice-bin on funtoo requires configuring a local overlay,adding sys-libs/ncurses-compat-6.2 from gentoo, installing layman, enabling guru overlay for openoffice-bin-4.1.9 Bug report: Emerge for Openoffice-bin-4.1.6 depends on removed ncurses:5
  12. I wanted but I'm using QT5. emerge -pv libreoffice-bin ....... Total: 167 packages (161 new, 6 in new slots), Size of downloads: 1 574 662 KiB
  13. Just a note -- I forgot to re-enable gdm for GNOME, so SDDM is still the default for GNOME. Some notes here -- By default, SDDM will try to start a "GNOME on Wayland" session which will fail. Just toggle it to "GNOME on Xorg" in the top-left drop-down. And if you want to switch to GDM, just edit /etc/conf.d/xdm as root and change "sddm" to "gdm" and reboot. Then you'll be using GDM.
  14. Hi Today I tried to install openoffice-bin and found the error, an earlier version ncurses is needed: emerge -av openoffice-bin These are the packages that would be merged, in order: Calculating dependencies... done! emerge: there are no ebuilds to satisfy "sys-libs/ncurses:5/5". (dependency required by "app-office/openoffice-bin-4.1.6::desktop-kit" [ebuild]) (dependency required by "openoffice-bin" [argument]) emerge -pv sys-libs/ncurses These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] sys-libs/ncurses-6.2:0/6::core-
  15. Earlier
  16. New stage releases are ready for download which includes the 5.10.13_p1 kernel. Also, there has been much work to get modern Intel laptop support with these stages with updated Intel open sound firmware, updated NVidia drivers, a multitude of bug fixes, as well as gnome-base/gdm back as default with added support for French keyboard layouts via gnome-base/adrien-gdm-keyboard. Please note: Non-Ryzen AMD will not be included in these updates but will be uploaded sometime at a later date. Thank you for your patience. If you have questions, issues, or just want to drop in and
  17. >>> Emerging (1 of 4) media-libs/mesa-20.2.4::core-gl-kit * Fetching files in the background. * To view fetch progress, run in another terminal: * tail -f /var/log/emerge-fetch.log ^CTraceback (most recent call last): File "/usr/lib/portage/python2.7/lock-helper.py", line 29, in <module> Exiting on signal 2 rval = main(sys.argv[1:]) File "/usr/lib/portage/python2.7/lock-helper.py", line 21, in main lock_obj = portage.locks.lockfile(args[0], wantnewlockfile=True) File "/usr/lib64/python2.7/site-packages/portage/locks.py", line 113, in lockfile unlinkfile=u
  18. When installing world: # emerge -auDN @world --keep-going .... >>> Emerging (4 of 21) net-fs/samba-4.11.16::core-server-kit * samba-4.11.16.tar.gz SHA512 size ;-) ... [ ok ] * Using python3.7 to build >>> Unpacking source... >>> Unpacking samba-4.11.16.tar.gz to /var/tmp/portage/net-fs/samba-4.11.16/work >>> Source unpacked in /var/tmp/portage/net-fs/samba-4.11.16/work >>> Preparing source in /var/tmp/portage/net-fs/samba-4.11.16/work/samba-4.11.16 ... * Applying samba-4.4.0-pam.
  19. Exclude doesn't allow = or - in package name. category/ is optional emerge -avuDN @world --exclude qtcore emerge -avuDN @world --exclude dev-qt/qtcore emerge -avuDN @world --exclude qtcore:5.15.2 emerge -avuDN @world --exclude dev-qt/qtcore:5.15.2 emerge -avuDN @world --exclude qtcore:* emerge -avuDN @world --exclude dev-qt/qtcore:*
  20. The same error as trying to exclude dev-qt # emerge -auDN @world --exclude '=dev-qt/qtcore-5.15.2' ... emerge: error: Invalid Atom(s) in --exclude parameter: '=dev-qt/qtcore-5.15.2'
  21. How can we replace DE to be XFCE instead, (on cinnamon tarball because of xfce one not available option in the subarch)? this # emerge xfce_meta has been completed, then what should we do after or previous reboot first time to smoothly get into xfce DE instead?
  22. You've expelled me out of a-week HELL... Nearly a week felt as if in truly hell without answer whatsoever Should have been as the default, then if one need the utmost security do s.t. e.g: FEATURES="-sandbox -realsandbox"
  23. Portage builds the packages in a sandbox to prevent the process from writing or modifying files on your running system. Emerge tried to open_write to /usr/lib/python3.7/lib2to3/Grammar3.7.7.final.0.pickle a file owned by dev-lang/python. A workaround is to disable the sandbox and build the package: funtoo /home/rj # FEATURES="-sandbox -usersandbox" emerge -1av dev-python/setuptools
  24. If you designate a version number after the package name you have to start with = =category/package-version funtoo /home/rj # emerge -pv =dev-python/setuptools-53.0.0 These are the packages that would be merged, in order: Calculating dependencies... done! [ebuild R ] dev-python/setuptools-53.0.0::python-modules-kit USE="-test" PYTHON_TARGETS="python2_7 python3_7 -pypy3 -python3_8 -python3_9" 0 KiB Total: 1 package (1 reinstall), Size of downloads: 0 KiB If you don't designate the version number and there are multiple versions the greatest unmasked version is built. c
  25. The emerge cannot find name of package in --exclude usage In attempt to prevent the installation of emerge failed # emerge -auDN @world --exclude 'dev-python/setuptools-53.0.0' ... emerge: error: Invalid Atom(s) in --exclude parameter: 'dev-python/setuptools-53.0.0' (only package names and slot atoms (with wildcards) allowed) Nor on: # emerge -auDN @world --exclude 'dev-qt/qtcore-5.15.2::qt-kit' ... emerge: error: Invalid Atom(s) in --exclude parameter: 'dev-qt/qtcore-5.15.2::qt-kit' (only package names and slot atoms (with wildcards) allowed) Where is the mistake, please
  26. The solution to the X problem was to remove nomodest from /etc/boot.conf, then ego boot update.
  1. Load more activity
×
×
  • Create New...