You are not logged in.

#26 2013-10-24 10:07:07

Anakin Skywalker
Member
From: Germany
Registered: 2013-03-23
Posts: 18

Re: Portage acting strange (takes a long time and emerges nothing)

eix python-exec
[i] dev-python/python-exec
     Available versions:  
     (0)    0.3.1 **0.9999
     (2)    (~)2.0-r1 **2.9999
       {PYTHON_TARGETS="jython2_5 jython2_7 pypy2_0 python2_6 python2_7 python3_2 python3_3"}
     Installed versions:  0.3.1(11:59:42 24.10.2013)(PYTHON_TARGETS="jython2_5 jython2_7 python2_6 python2_7 python3_2 python3_3 -pypy2_0") 2.0-r1(2)(09:43:40 24.10.2013)(PYTHON_TARGETS="jython2_5 jython2_7 python2_6 python2_7 python3_2 python3_3 -pypy2_0")
     Homepage:            https://bitbucket.org/mgorny/python-exec/
     Description:         Python script wrapper

Now it is installed but still It is not working right now.

Last edited by Anakin Skywalker (2013-10-24 10:20:42)

Offline

#27 2013-10-24 20:39:57

Anakin Skywalker
Member
From: Germany
Registered: 2013-03-23
Posts: 18

Re: Portage acting strange (takes a long time and emerges nothing)

I can not afford not being able to update my system any more, please can anybody help?

Offline

#28 2013-10-25 10:57:03

alexpj
Member
From: England
Registered: 2012-08-18
Posts: 49

Re: Portage acting strange (takes a long time and emerges nothing)

Does anything 'emerge' work?
I found that "sudo emerge -DNuva @world" would work but "sudo  emerge --ask --update --newuse --deep --with-bdeps=y @world" didn't (ignore the - vs --).
There's nothing in my queue so I can't test it again at the moment.

Have you been on IRC to ask there? Good idea.

Offline

#29 2013-10-26 15:04:05

Anakin Skywalker
Member
From: Germany
Registered: 2013-03-23
Posts: 18

Re: Portage acting strange (takes a long time and emerges nothing)

emerge -auDN @world --dynamic-deps=n --ignore-built-slot-operator-deps=y

  helped me updating my system.

EDIT: Thanks to angry_vincent

Last edited by Anakin Skywalker (2013-11-24 14:38:36)

Offline

#30 2013-10-26 15:14:13

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: Portage acting strange (takes a long time and emerges nothing)

--dynamic-deps=n smile

Offline

Board footer

Powered by FluxBB