You are not logged in.

#1 2013-10-06 08:48:41

pascal50
Member
From: France (Sarthe)
Registered: 2013-07-15
Posts: 31

gnome 3.6 install

Hello,

Is there a clean way to install (and run wink ) gnome 3.6 ?

I'm stuck there :

# emerge -av gnome-base/gnome

 * IMPORTANT: 1 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U #] x11-libs/gtk+-3.8.4:3 [3.6.3-r2:3] USE="X colord cups introspection (-aqua) -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama (-egl%)" 0 kB
[ebuild  N     ] app-editors/gedit-3.8.3  USE="introspection python -spell {-test} -zeitgeist" PYTHON_TARGETS="python3_3 -python3_2" 0 kB
[ebuild  N     ] gnome-base/gnome-core-apps-3.6.2:3.0  USE="bluetooth cdr cups networkmanager" 0 kB
[ebuild  N     ] gnome-base/gnome-3.6.2:2.0  USE="bluetooth cdr cups extras fallback -accessibility" 0 kB

Total: 4 packages (1 upgrade, 3 new), Size of downloads: 0 kB

The following mask changes are necessary to proceed:
 (see "package.unmask" in the portage(5) man page for more details)
# required by gnome-base/gnome-applets-3.6.0-r2[gnome]
# required by gnome-base/gnome-3.6.2[fallback]
# required by gnome-base/gnome (argument)
# /etc/portage/package.mask:
=x11-libs/gtk+-3.8.4

NOTE: The --autounmask-keep-masks option will prevent emerge
      from creating package.unmask or ** keyword changes.

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- dev-python/python-exec-2.0::gentoo (masked by: package.mask)
/usr/portage/profiles/package.mask/funtoo-cautionary:
#  Oleg Vinichenko (2 Oct 2013)
#  FL-791, mask python-exec-2.0, revealed portage slot bug

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I can't get over the 'emerge -av gnome-base/gnome' : I did 'emerge -av1' to compile the last 50 ebuids, but now, I can't go further

Herre is my package.mask :

>=gnome-base/gnome-core-libs-3.8.0
>=gnome-base/gnome-desktop-3.8.4
>=gnome-base/gnome-fallback-3.8.0
>=x11-libs/gtk+-3.8.4
>=gnome-base/gnome-panel-3.8.0

And my profile :

# eselect profile list
Currently available arch profiles:
  [1]   funtoo/1.0/linux-gnu/arch/x86-64bit * 
  [2]   funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
  [3]   funtoo/1.0/linux-gnu/build/stable
  [4]   funtoo/1.0/linux-gnu/build/current * 
  [5]   funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
  [6]   funtoo/1.0/linux-gnu/flavor/minimal
  [7]   funtoo/1.0/linux-gnu/flavor/core
  [8]   funtoo/1.0/linux-gnu/flavor/desktop * 
  [9]   funtoo/1.0/linux-gnu/flavor/workstation
  [10]  funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
  [11]  funtoo/1.0/linux-gnu/mix-ins/audio (auto) 
  [12]  funtoo/1.0/linux-gnu/mix-ins/console-extras (auto) 
  [13]  funtoo/1.0/linux-gnu/mix-ins/dvd (auto) 
  [14]  funtoo/1.0/linux-gnu/mix-ins/gnome * 
  [15]  funtoo/1.0/linux-gnu/mix-ins/kde
  [16]  funtoo/1.0/linux-gnu/mix-ins/mate
  [17]  funtoo/1.0/linux-gnu/mix-ins/media (auto) 
  [18]  funtoo/1.0/linux-gnu/mix-ins/print (auto) 
  [19]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [20]  funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
  [21]  funtoo/1.0/linux-gnu/mix-ins/server-db
  [22]  funtoo/1.0/linux-gnu/mix-ins/server-mail
  [23]  funtoo/1.0/linux-gnu/mix-ins/server-web
  [24]  funtoo/1.0/linux-gnu/mix-ins/X (auto) 
  [25]  funtoo/1.0/linux-gnu/mix-ins/xfce
  [26]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest
  [27]  funtoo/1.0/linux-gnu/mix-ins/hardened

Last edited by pascal50 (2013-10-06 08:51:59)

Offline

#2 2013-10-06 15:36:59

mlmoses
Member
From: Michigan, USA
Registered: 2012-04-14
Posts: 55

Re: gnome 3.6 install

app-editors/gedit-3.8.3 requires >=x11-libs/gtk+-3.7.10. You'll have to unmask GTK+ 3.8 in order to install GEdit.

Offline

#3 2013-10-06 16:36:17

pascal50
Member
From: France (Sarthe)
Registered: 2013-07-15
Posts: 31

Re: gnome 3.6 install

Hello mlmoses,
Yes, but gtkmm-3.6.0 fails to compile emake failed.
dev-cpp/gtkmm-3.8.1 is masked, and gtkmm-3.6.0 don't compile against  x11-libs/gtk+-3.8.4 ....

# eix -e gtkmm
[i] dev-cpp/gtkmm
     Available versions:  
     (2.4)  2.24.2 (~)2.24.4
     (3.0)  3.4.2 (~)3.6.0 [M](~)3.8.1
       {+X aqua doc examples test wayland}
     Installed versions:  3.6.0(3.0)(06:30:55 10/06/13)(X -aqua -doc -examples -test -wayland)
     Homepage:            http://www.gtkmm.org
     Description:         C++ interface for GTK+

Last edited by pascal50 (2013-10-06 16:39:13)

Offline

#4 2013-10-06 17:07:46

mlmoses
Member
From: Michigan, USA
Registered: 2012-04-14
Posts: 55

Re: gnome 3.6 install

You should be able to unmask gtkmm-3.8.0 without any problems, then you can unmask gtk+3.8 and get through your GNOME install. I think your only other option is to use the gnome-light ebuild and forego the installation of gedit.

Offline

#5 2013-10-06 21:24:06

pascal50
Member
From: France (Sarthe)
Registered: 2013-07-15
Posts: 31

Re: gnome 3.6 install

I had to unleash dev-cpp/glibmm-2.36.2 to pass the 'emerge -NDauv world'
Here are my files :
package.mask

>=gnome-base/gnome-core-libs-3.8.0
>=gnome-base/gnome-desktop-3.8.4
>=gnome-base/gnome-fallback-3.8.0
>=gnome-base/gnome-panel-3.8.0

package.unmask

=dev-cpp/gtkmm-3.8.1
=dev-cpp/glibmm-2.36.2

Thanks a lot.

Offline

Board footer

Powered by FluxBB