You are not logged in.

#1 2013-09-27 23:59:45

Duncan.Britton
Member
Registered: 2013-09-27
Posts: 10

[solved] Ati-drivers Problem

After completing a fresh install of Funtoo with LUKS and ZFS, I went ahead and tried installing ati-drivers and xorg-server. Everything compiles nicely until I get to the compilation of the ati-drivers. (I posted this earlier in the wrong section of the forums - sorry for the double post)

This is the error I get:

 * ERROR: x11-drivers/ati-drivers-13.6_beta failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3406:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";

Here is the output of emerge -pqv '=x11-drivers/ati-drivers-13.6_beta':

[ebuild  N    ] x11-drivers/ati-drivers-13.6_beta  USE="modules (multilib) qt4 vaapi -debug -disable-watermark -static-libs"
[ebuild  N    ] x11-libs/xvba-video-0.8.0-r3  USE="opengl -debug"

Here is the build log:

 * Package:    x11-drivers/ati-drivers-13.6_beta
 * Repository: gentoo
 * USE:        amd64 elibc_glibc kernel_linux modules multilib qt4 userland_GNU vaapi
 * FEATURES:   preserve-libs sandbox
 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found kernel object directory:
 *     /lib/modules/3.11.1-gentoo/build
 * Found sources for kernel version:
 *     3.11.1-gentoo
 * Checking for suitable kernel configuration options...                                                    [ ok ]
 *
 * Please note that this driver only supports graphic cards based on
 * Evergreen chipset and newer.
 * This includes the AMD Radeon HD 5400+ series at this moment.
 *
 * If your card is older then use x11-drivers/xf86-video-ati
 * For migration information, please refer to:
 * http://www.gentoo.org/proj/en/desktop/x/x11/ati-migration-guide.xml
 *
>>> Unpacking source...
>>> Unpacking amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip to /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work
>>> Unpacking xvba-sdk-0.74-404001.tar.gz to /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work
Warning: target directory exists /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work
Verifying archive integrity... All good.
Uncompressing AMD Catalyst(TM) Proprietary Driver-13.101..................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................
>>> Source unpacked in /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work
>>> Preparing source in /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work ...
 * Applying ati-powermode-opt-path-3.patch ...                                                              [ ok ]
 * Applying ati-drivers-x32_something_something.patch ...                                                   [ ok ]
 * Applying ati-drivers-12.9-KCL_AGP_FindCapsRegisters-stub.patch ...                                       [ ok ]
 * Applying typesafe-kuid.diff ...                                                                          [ ok ]
 * Applying ati-drivers-13.6-linux-3.10-proc.diff ...                                                       [ ok ]
 * Converting 2.6.x/Makefile to use M= instead of SUBDIRS= ...                                              [ ok ]
>>> Unpacking ./../common/usr/src/ati/fglrx_sample_source.tgz to /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/extra
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work ...
 * Preparing fglrx module
make -j9 HOSTCC=x86_64-pc-linux-gnu-gcc CROSS_COMPILE=x86_64-pc-linux-gnu- LDFLAGS= GCC_VER_MAJ=4 KVER=3.11.1-gentoo KDIR=/usr/src/linux 'CFLAGS_MODULE+=-DMODULE -DATI -DFGL' CFLAGS_MODULE+=-DCOMPAT_ALLOC_USER_SPACE=arch_compat_alloc_user_space kmod_build
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-3.11.1-gentoo'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_acpi.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_agp.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_debug.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_ioctl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_io.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_pci.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_str.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_iommu.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl.o
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/kcl_wait.o
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST 1 modules
  CC      /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-3.11.1-gentoo'
 * Building fgl_glxgears ...
In file included from fgl_glxgears.c:81:0:
/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/usr/include/GL/glATI.h:5370:0: warning: "GL_PROXY_TEXTURE_2D_MULTISAMPLE" redefined [enabled by default]
/usr/include/GL/glext.h:1445:0: note: this is the location of the previous definition
/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/common/usr/include/GL/glATI.h:6009:25: error: conflicting types for ‘GLDEBUGPROCARB’
/usr/include/GL/glext.h:2603:26: note: previous declaration of ‘GLDEBUGPROCARB’ was here
 * ERROR: x11-drivers/ati-drivers-13.6_beta failed (compile phase):
 *   fgl_glxgears build failed
 *
 * Call stack:
 *     ebuild.sh, line  93:  Called src_compile
 *   environment, line 3405:  Called die
 * The specific snippet of code:
 *       "$(tc-getCC)" -o fgl_glxgears ${CFLAGS} ${LDFLAGS} -DUSE_GLU -I"${S}"/${FOLDER_PREFIX}usr/include fgl_glxgears.c -lGL -lGLU -lX11 -lm || die "fgl_glxgears build failed";
 *
 * If you need support, post the output of `emerge --info '=x11-drivers/ati-drivers-13.6_beta'`,
 * the complete build log and the output of `emerge -pqv '=x11-drivers/ati-drivers-13.6_beta'`.
 * The complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work/extra/fgl_glxgears'
 * S: '/var/tmp/portage/x11-drivers/ati-drivers-13.6_beta/work'

Here is the output of emerge --info '=x11-drivers/ati-drivers-13.6_beta':

!!! CONFIG_PROTECT is empty
Portage 2.3.6-r5 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.6.4, glibc-2.15-r4, 3.11.1-gentoo x86_64)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.11.1-gentoo-x86_64-AMD_FX-tm-8150_Eight-Core_Processor-with-gentoo-2.2.0
KiB Mem:    32850704 total,  30863760 free
KiB Swap:          0 total,         0 free
Timestamp of tree: Fri, 27 Sep 2013 11:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-lang/python:          2.7.5-r1000, 3.3.2-r1000
dev-util/cmake:           2.8.11.2
sys-apps/baselayout:      2.2.0-r4
sys-apps/openrc:          0.10.3-r1
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.69
sys-devel/automake:       1.13.4
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.4-r2
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r4
Repositories: gentoo
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -mtune=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT=""
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=native -mtune=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
MAKEOPTS="-j9"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X acl alsa amd64 apng berkdb bzip2 cdr cracklib crypt cups cxx dbus dri dvd dvdr dvdread flac gdbm gif gpm iconv icu ipv6 jpeg lame libzfs luks mad mmx modules mp3 mpeg mudflap multilib ncurses nls nptl ogg opengl openmp pam pcre png pppd python qt4 readline resolvconf sse sse2 ssl tcpd tiff truetype udev unicode vorbis wavpack win32codecs xml zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel ice1724 intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev synaptics keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="fglrx" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LINGUAS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

Any help would be greatly appreciated.

Last edited by Duncan.Britton (2013-09-29 16:34:00)

Offline

#2 2013-09-29 16:33:42

Duncan.Britton
Member
Registered: 2013-09-27
Posts: 10

Re: [solved] Ati-drivers Problem

The issue has been fixed with the addition of ati-drivers-13.9 to the portage tree.

Offline

Board footer

Powered by FluxBB