You are not logged in.

#1 2013-07-11 03:35:11

donjames
Member
Registered: 2010-10-09
Posts: 99

[solved] Missing bridge configuration in kernel

Where is the bridge configuration in the kernel?

It doesn't seem to be under networking.

Please give me a hint as to where to look.

Thanks,

Don James

Last edited by donjames (2013-07-31 23:49:44)

Offline

#2 2013-07-12 16:23:41

drumfire
New member
Registered: 2013-06-12
Posts: 9

Re: [solved] Missing bridge configuration in kernel

I could just give you the answer, but here's a method that's handy if you're searching for a kernel option - look at the following link: http://cateee.net/lkddb/web-lkddb/BRIDGE.html
Hint: Behind 'prompt' you see the text you should look for in menuconfig/nconfig.
The answer's right there, so I hope this helps you. smile

Last edited by drumfire (2013-07-12 16:25:31)

Offline

#3 2013-07-12 20:42:42

Judge
Staff
From: Germany, NRW, Heiligenhaus
Registered: 2011-07-03
Posts: 283

Re: [solved] Missing bridge configuration in kernel

Hi you two,

very good answer from drumfire! But let me try to clarify this a little:

@donjames: You know of the possibility to "search" in menuconfig and derevates? Just hit "/" , followed by the pattern you are searching for. In this case, entering "bridging" should have lead to first results already. Mix this with a Google - Query to get a first idea of the best buzzwords and you should be able to help yourself in the majority of cases.

Does this solve your issue? If so, please consider to add "[solved]" to the threads topic.

Offline

#4 2013-07-31 23:49:03

donjames
Member
Registered: 2010-10-09
Posts: 99

Re: [solved] Missing bridge configuration in kernel

Hi folks,

I finally figured it out.

/usr/src/Linux
make menuconfig

Select on  Networking support  --->
Then select  Networking options  --->
Then select <M> 802.1d Ethernet Bridging
Then select  [\*] Network packet filtering framework (Netfilter)  --->
Now you will see:
[\*]   Advanced netfilter configuration
[\*]     Bridged IP/ARP packets filtering
################
Problem solved.
Thanks for all of the help.

Sincerely,
Don James

Offline

Board footer

Powered by FluxBB