You are not logged in.

#1 2012-03-26 10:17:48

vo1ty
New member
From: Saint-Petersburg, Russia
Registered: 2012-03-26
Posts: 4

Kernel Panic in VirtualBox.

Good day everyone!
I have to say sorry for my bad English.

I'm using VirtualBox. When I try to boot up I see the Kernel Panic.
So, how the problem looks like:
_http://cs10686.userapi.com/u40882963/111260773/y_e3ee2a13.jpg

What I've done:

# lspci | grep IDE

And got something like this:

pcilib: Cannot open /proc/bus/pci
00:01.1 IDE interface: Intel Corporation 82371AB/EB/MB PIIX4 ID (rev 01)

I've tried to find anything about Intel PIIX4 in configuration.
Device Drivers ---> Serial ATA and Parallel ATA Drivers
_http://cs10686.userapi.com/u40882963/111260773/y_aeb6a1a1.jpg
But it was <*> before me.

And
Device Drivers --> I2C support --> I2C Hardware Bus support
_http://cs10686.userapi.com/u40882963/111260773/y_71197de3.jpg
But this time I marked the option as <*>.
It didn't solve the problem.

I have to show you this screen of File Systems:
_http://cs10686.userapi.com/u40882963/111260773/y_cf9ae521.jpg
And this, I suppose:
_http://cs10686.userapi.com/u40882963/111260773/y_7ff3bf3c.jpg
(Device Drivers --> SCSI Drivers support)
Because I've made some changes there.

How can I solve the problem?
Thanks.

Offline

#2 2012-03-26 15:59:56

PaddyMac
Member
From: Alabama, USA
Registered: 2011-08-20
Posts: 124

Re: Kernel Panic in VirtualBox.

I think the kernel driver you want is under Device Drivers -> Serial ATA and Parallel ATA drivers -> ATA SFF support -> ATA BMDMA support -> Intel ESB, ICH, PIIX3, PIIX4 PATA/SATA support. And also make sure you have the Virtualbox kernel modules loaded: vboxdrv vboxnetadp vboxnetflt. Make sure you add them to /etc/conf.d/modules. As for the filesystem driver, depending on which filesystem you want to use, you can enable support for Ext2 or Ext3, or you can just use the Ext4 driver and ensure you enable support for Ext2 and Ext3 in which case the Ext4 driver can handle all three types of filesystems.

Last edited by PaddyMac (2012-03-26 16:04:33)

Offline

#3 2012-03-31 07:03:08

vo1ty
New member
From: Saint-Petersburg, Russia
Registered: 2012-03-26
Posts: 4

Re: Kernel Panic in VirtualBox.

Thank you for the reply. I solved my problem editing /boot/grub/grub.cfg actually. There was no problem in kernel configuration.

Offline

#4 2013-07-23 17:58:35

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Kernel Panic in VirtualBox.

PaddyMac wrote:

...also make sure you have the Virtualbox kernel modules loaded: vboxdrv vboxnetadp vboxnetflt. Make sure you add them to /etc/conf.d/modules.

Hi!  I do have the three above mentioned modules listed, one line each, in

grep vbox /etc/conf.d/modules 
vboxdrv
vboxnetadp
vboxnetflt

Still, I can't run any VB machine unless I manually load the modules.  Why aren't they loaded at boot time?  How can I trace back the "problem"?

Thanks, Nikos

Offline

#5 2013-07-23 22:57:31

Azerthoth
Moderator
Registered: 2010-10-25
Posts: 33

Re: Kernel Panic in VirtualBox.

You have to put them in /etc/conf.d/modules to have them load when you boot. As shown:

modules="vboxdrv vboxnetadp vboxnetflt"

Offline

#6 2013-07-24 02:38:34

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Kernel Panic in VirtualBox.

Azerthoth wrote:

You have to put them in /etc/conf.d/modules to have them load when you boot. As shown:

modules="vboxdrv vboxnetadp vboxnetflt"

Oh man, too tired. Need to rest...  The whole file is full with modules="... " examples! big_smile
Thanks for heads-up.

Last edited by Nikos Alexandris (2013-07-24 02:40:48)

Offline

Board footer

Powered by FluxBB