You are not logged in.

#1 2013-07-06 09:35:08

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

Hi!

After a new installation following the Funtoo Linux Installation guide, I can't

startx

I am writing from another machine so (handcrafting what I see in the terminal) the response to

Xorg -configure

  is

Number of created screens does not match number of detected devices. Configuration failed.

  In the log, the lines of interest say:

(II) LoadModule: "nvidia"
...
(II) LoadModule "nouveau"

although I have blacklisted "nouveau" in /etc/modprobe.d/blacklist.conf.  Next, in the log, there are no (EE) messages, but a few (WW)s. Specifically,

* one for Hotplugging is on, devices using drivers... will be disabled
* some Disabling... mouse, keyboard
* one that reads Unresolved symbol: fbGetGCPPrivateKey


The /root/xorg.conf.new used by Xorg -configure is not that good. I copied over to /etc/X11/, edited and kept only the basics for one Monitor, Device, Screen. The "glx" module is also instructed to be loaded.

If I try to

X -config /etc/X11/xorg.conf

, the system just goes to a black screen!  I have re-installed the nvidia-drivers (currently the version 325.08 is getting installed).

How can I troubleshoot this further?

Thanks, Nikos

Last edited by Nikos Alexandris (2013-07-22 13:38:05)

Offline

#2 2013-07-06 09:52:48

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

I guess it was as simple as adding the "xorg" USE flag.  Yet, I strictly followed the Installation guide where there is no exact/detailed section on setting up USE flags. I thought this would be covered by selecting the appropriate profiles, which I did.

?

Offline

#3 2013-07-09 22:50:07

funfool
Member
Registered: 2012-11-21
Posts: 23

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

No, not everything is covered. If you look at the gentoo handbook, is really huge and although it is very good, takes a week just to read it to get installed.
funtoo  users  just need to read the install guide and it works.
This gives you a basic install that you can boot.
Now that you have a booting system look here

http://www.funtoo.org/wiki/Funtoo_Linux_First_Steps

will always be changes, I am really surprised for how small the funtoo comunity is, how active it is.
If something does not work the way it should, please post here about it or on funtoo-jira for a bug or visit us on freenode @ #funtoo.
I have several funtoo kde systems running, I may not be able to fix a particular issue, but we can discuss it.

I was going to add

I guess it was as simple as adding the "xorg" USE flag

No, that is not correct, is still a issue with your profile and I would like to see your profile. But you can add use flags as needed, xorg would never be one of them with kde set.
Before profile 1.0, we all did this manually as you are now ... does not hurt your system, just the tools are not being used.

Last edited by funfool (2013-07-09 22:55:50)

Offline

#4 2013-07-10 15:38:15

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

funfool wrote:

I was going to add

I guess it was as simple as adding the "xorg" USE flag

No, that is not correct, is still a issue with your profile and I would like to see your profile. But you can add use flags as needed, xorg would never be one of them with kde set.
Before profile 1.0, we all did this manually as you are now ... does not hurt your system, just the tools are not being used.

Just a quick reply:  once I have more free-time, I would be glad to provide and info/feed-back.  Funtoo Rocks :-).  For now, I have a running system, I can work with.  I am sure I have mixed-up some stuff, and I would like to understand them, clean them, optimize the system for highest performance as it will be a workhorse.

Best regards, Nikos

Offline

#5 2013-07-10 22:14:10

ryo
Member
From: Fréjus, France
Registered: 2010-11-17
Posts: 42

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

Hi,

if you are going to use nvidia drivers then give a try to

nvidia-xconfig

.

* some Disabling... mouse, keyboard

Doesn't smells good smile

Try to redirect X output to a text file and post it .

Offline

#6 2013-07-10 22:24:31

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

ryo wrote:

Hi,

if you are going to use nvidia drivers then give a try to

nvidia-xconfig

.

* some Disabling... mouse, keyboard

Doesn't smells good smile

Try to redirect X output to a text file and post it .

All is working fine now.  I have installed the nvidia driver (x11-drivers/nvidia-drivers, 325.08) and the media-video/nvidia-settings (319.32).  Removed the nouveau driver (although I'd love to see a system running exclusuively on FOSS).  I "know" that actually xorg.conf is not required (anymore?).  Currently, I use the following:

Section "ServerLayout"
        Identifier     "X.org Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
EndSection

Section "Files"
        ModulePath   "/usr/lib64/xorg/modules"
        FontPath     "/usr/share/fonts/misc/"
        FontPath     "/usr/share/fonts/TTF/"
        FontPath     "/usr/share/fonts/OTF/"
        FontPath     "/usr/share/fonts/Type1/"
        FontPath     "/usr/share/fonts/100dpi/"
        FontPath     "/usr/share/fonts/75dpi/"
EndSection

Section "Module"
        Load  "glx"
EndSection

Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
EndSection

Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option      "Protocol" "auto"
        Option      "Device" "/dev/input/mice"
        Option      "ZAxisMapping" "4 5 6 7"
EndSection

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "EIZO"
        ModelName    "S2031W"
EndSection

Section "Device"
        Identifier  "Card0"
        Driver      "nvidia"
        BusID       "PCI:4:0:0"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
                Viewport   0 0
                Depth     1
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     4
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     8
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     15
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     16
        EndSubSection
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection

Best, N

Offline

#7 2013-07-11 01:58:20

rh1
_Member
From: Eastern Shore, VA
Registered: 2010-10-08
Posts: 388

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

For nvidia-drivers you need an xorg.conf but all you need in it is the "Device" section, everything else can usually be deleted.

Offline

#8 2013-07-15 16:12:27

dougchug
Member
Registered: 2012-01-11
Posts: 72

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

I don't know if it matters, but I am using the "X" USE flag. Per the listing of the file /usr/portage/profiles/use.desc (file identified in manpage for portage), I have an "X" USE flag but no "xorg" USE flag. The file use.local.desc does not seem to be relevant to a listing of USE flags, based on the contents in my system. The "X" USE flag was working fine for me on a Sony laptop and I am here to figure out why the initial resolution GUI resolution is so small (making items really big and grainy), so I'm just passing through on this thread. I had a devil of a time configuring X before. It was so much easier ten years ago.

Offline

#9 2013-07-22 13:37:36

Nikos Alexandris
Member
From: Trikala, Greece
Registered: 2013-07-06
Posts: 26

Re: Can't configure Xorg and `startx` for NVIDIA Quadro K2000D [Resolved]

funfool wrote:

...
No, that is not correct, is still a issue with your profile and I would like to see your profile. But you can add use flags as needed, xorg would never be one of them with kde set.
Before profile 1.0, we all did this manually as you are now ... does not hurt your system, just the tools are not being used.

Just for the records, my current profile (didn't change the profile after I "magically" resolved the issue):

Currently available arch profiles:
  [1]   funtoo/1.0/linux-gnu/arch/x86-64bit * 
  [2]   funtoo/1.0/linux-gnu/arch/pure64
Currently available build profiles:
  [3]   funtoo/1.0/linux-gnu/build/stable
  [4]   funtoo/1.0/linux-gnu/build/current * 
  [5]   funtoo/1.0/linux-gnu/build/experimental
Currently available flavor profiles:
  [6]   funtoo/1.0/linux-gnu/flavor/minimal
  [7]   funtoo/1.0/linux-gnu/flavor/core
  [8]   funtoo/1.0/linux-gnu/flavor/desktop * 
  [9]   funtoo/1.0/linux-gnu/flavor/workstation
  [10]  funtoo/1.0/linux-gnu/flavor/hardened
Currently available mix-ins profiles:
  [11]  funtoo/1.0/linux-gnu/mix-ins/audio (auto) 
  [12]  funtoo/1.0/linux-gnu/mix-ins/console-extras (auto) 
  [13]  funtoo/1.0/linux-gnu/mix-ins/dvd (auto) 
  [14]  funtoo/1.0/linux-gnu/mix-ins/gnome
  [15]  funtoo/1.0/linux-gnu/mix-ins/kde * 
  [16]  funtoo/1.0/linux-gnu/mix-ins/mate
  [17]  funtoo/1.0/linux-gnu/mix-ins/media (auto) 
  [18]  funtoo/1.0/linux-gnu/mix-ins/print (auto) 
  [19]  funtoo/1.0/linux-gnu/mix-ins/python3-only
  [20]  funtoo/1.0/linux-gnu/mix-ins/rhel5-compat
  [21]  funtoo/1.0/linux-gnu/mix-ins/server-db
  [22]  funtoo/1.0/linux-gnu/mix-ins/server-mail
  [23]  funtoo/1.0/linux-gnu/mix-ins/server-web
  [24]  funtoo/1.0/linux-gnu/mix-ins/X (auto) 
  [25]  funtoo/1.0/linux-gnu/mix-ins/xfce
  [26]  funtoo/1.0/linux-gnu/mix-ins/vmware-guest

Offline

Board footer

Powered by FluxBB