You are not logged in.

#1 2013-07-02 10:08:04

T86g
New member
Registered: 2013-02-10
Posts: 7

[solved] Emerge dev-python/pyinotify-0.9.4-r1000 gets stuck

Hi!

When updating my system portage stops when reaching pyinotify.
It starts and seems to successfully build for python-2.7. When reaching the build script for python-3.3 it stops. Here is the output of portage:

>>> Emerging (1 of 1) dev-python/pyinotify-0.9.4-r1000
 * pyinotify-0.9.4.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...                           [ ok ]
>>> Unpacking source...
>>> Unpacking pyinotify-0.9.4.tar.gz to /var/tmp/portage/dev-python/pyinotify-0.9.4-r1000/work
>>> Source unpacked in /var/tmp/portage/dev-python/pyinotify-0.9.4-r1000/work
>>> Preparing source in /var/tmp/portage/dev-python/pyinotify-0.9.4-r1000/work/pyinotify-0.9.4 ...
>>> Source prepared.
>>> Configuring source in /var/tmp/portage/dev-python/pyinotify-0.9.4-r1000/work/pyinotify-0.9.4 ...
>>> Source configured.
>>> Compiling source in /var/tmp/portage/dev-python/pyinotify-0.9.4-r1000/work/pyinotify-0.9.4 ...
 * Building of dev-python/pyinotify-0.9.4-r1000 with CPython 2.7...
python2.7 setup.py build -b build-2.7
running build
running build_py
creating build-2.7
creating build-2.7/lib
copying python2/pyinotify.py -> build-2.7/lib
warning: build_py: byte-compiling is disabled, skipping.

 * Building of dev-python/pyinotify-0.9.4-r1000 with CPython 3.3...
python3.3 setup.py build -b build-3.3

This last process remains visible in top as if it would do something, but does not use CPU or IO. There is no change even after hours.

If I go into the work directory and enter the command manually everything seems to work fine

# python3.3 setup.py build -b build-3.3
running build
running build_py
creating build-3.3
creating build-3.3/lib
copying python3/pyinotify.py -> build-3.3/lib

And here is my emerge --info

Portage 2.3.6-r1 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.6.3, glibc-2.15-r4, 3.9.8-gentoo x86_64)
=================================================================
System uname: Linux-3.9.8-gentoo-x86_64-Intel-R-_Core-TM-2_Duo_CPU_T5450_@_1.66GHz-with-gentoo-2.2.0
KiB Mem:     2050060 total,    275632 free
KiB Swap:    4192960 total,   4176696 free
Timestamp of tree: Mon, 01 Jul 2013 17:15:01 +0000
ld GNU ld (GNU Binutils) 2.22
ccache version 3.1.9 [disabled]
app-shells/bash:          4.2_p37
dev-java/java-config:     2.2.0-r1000
dev-lang/python:          2.7.5-r1000, 3.2.5-r1000, 3.3.2-r1000
dev-util/ccache:          3.1.9-r1::science
dev-util/cmake:           2.8.10.2-r2
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2.0-r4
sys-apps/openrc:          0.10.2-r9
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r4
Repositories: gentoo science perl-experimental spiderlay local-overlay
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=core2 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt /usr/share/polkit-1/actions"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=core2 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch parallel-install preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="de_DE.UTF-8"
LC_ALL="de_DE.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/science /var/lib/layman/perl-experimental /var/lib/layman/spiderlay /usr/local/portage"
SYNC="git://github.com/funtoo/ports-2012.git"
SYNC_USER="root"
USE="X aac acl acpi alsa amd64 apng bash-completion berkdb boost bzip2 cdda cdr consolekit cracklib crypt cuda cups cxx dbus dri dvd dvdr dvdread faac ffmpeg fftw flac gcj gdbm gif gnuplot gpm hdf5 iconv icu inotify ipp ipv6 jabber java jpeg kde kerberos lame lastfm latex libnotify mad midi mmx modules mp3 mp4 mpeg mudflap multilib musicbrainz ncurses nls nptl nsplugin ogg opencl opengl openmp openssl pam pcre plotutils png policykit pppd profiler pulseaudio python qt4 readline replaygain resolvconf rtmp scanner semantic-desktop sse sse2 ssh ssl tcpd theora threads tiff timidity tk truetype udev unicode vim-syntax vorbis wavpack wifi win32codecs x264 xinerama xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" GRUB_PLATFORMS="coreboot multiboot pc" INPUT_DEVICES="evdev synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="de en" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_ABIS="2.7 3.3" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

I already tried running python-updater and revdep-rebuild.

Do you hvae any ideas what could be causing the problem? Which additional information do you need?

Thank you very much!

Last edited by T86g (2013-07-02 22:00:24)

Offline

#2 2013-07-02 21:12:48

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: [solved] Emerge dev-python/pyinotify-0.9.4-r1000 gets stuck

please, update to newer sys-apps/sandbox-2.6-r1 and try.

Offline

#3 2013-07-02 21:59:59

T86g
New member
Registered: 2013-02-10
Posts: 7

Re: [solved] Emerge dev-python/pyinotify-0.9.4-r1000 gets stuck

This solved the problem. Thank you very much!

Offline

Board footer

Powered by FluxBB