You are not logged in.

#1 2013-06-29 10:08:41

zizo
New member
Registered: 2012-09-12
Posts: 2

[SOLVED] failed to install ibus

hi all guys

I intalled ibus, but it failed with the following information

!!! Problem resolving dependencies for app-i18n/ibus
... done!

!!! The ebuild selected to satisfy "ibus" has unmet requirements.
- app-i18n/ibus-1.5.1::gentoo USE="X gconf gtk3 (multilib) nls python -dconf -deprecated -gtk -introspection -test -vala"

  The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

  The above constraints are a subset of the following complete expression:
    any-of ( gtk gtk3 X ) deprecated? ( python ) python? ( any-of ( deprecated ( gtk3 introspection ) ) )

and my make.conf is

ACCEPT_KEYWORDS="amd64"
SYNC="git://github.com/funtoo/ports-2012.git"
CHOST="x86_64-pc-linux-gnu"
CFLAGS="-mtune=generic -O2 -pipe"
CXXFLAGS="-mtune=generic -O2 -pipe"
MAKEOPTS="-j3"
USE="nls userlocales unicode X alsa qt3support jpeg"
GENTOO_MIRRORS="http://mirrors.163.com/gentoo/ http://distfiles.gentoo.org"
INPUT_DEVICES="evdev synaptics"
VIDEO_CARDS="intel nvidia"

so I changed the USE line to

USE="nls userlocales unicode alsa qt3support jpeg"

which I deleted the X keyword, but it doesn't work.
I also followed the ibus installation, but it is not successed.

Thank you in advance for your help.

Last edited by zizo (2013-07-01 10:35:23)

Offline

#2 2013-06-30 14:51:53

funfool
Member
Registered: 2012-11-21
Posts: 23

Re: [SOLVED] failed to install ibus

The following REQUIRED_USE flag constraints are unsatisfied:
    python? ( any-of ( deprecated ( gtk3 introspection ) ) )

I think this is telling you that ibus wants one of the 3 flags. I have introspection and gtk3 flags set for other packages, looks ibus will emerge fine here.
Here is my emerge -pv ibus to show the flags

[ebuild  N     ] app-i18n/ibus-1.5.1  USE="X gconf gtk gtk3 introspection nls python -dconf -deprecated {-test} -vala"

Another thing you can do, use equery to help you decide which flags you want to set.  "equery u ibus"  will show you the available flags for a package and the descriptopn of them.

Offline

#3 2013-07-01 10:20:29

zizo
New member
Registered: 2012-09-12
Posts: 2

Re: [SOLVED] failed to install ibus

Thank you very much, funfool. I changed my USE flags as you said and it's ok now.

[ebuild  N     ] app-i18n/ibus-1.5.1  USE="X gconf gtk gtk3 introspection nls python -dconf -deprecated {-test} -vala" 1,845 kB

Last edited by zizo (2013-07-01 10:34:34)

Offline

Board footer

Powered by FluxBB