You are not logged in.

#1 2013-06-01 00:44:06

Mason
New member
Registered: 2013-05-29
Posts: 2

Kernel Panic Vanilla-Sources Linux 3.9.4

Error message: VFS Cannot open root device "null" or unknown block (1,0) error -6
.config file: http://bpaste.net/show/102922/
lspci: http://bpaste.net/show/102924/
lsblk -o NAME,FSTYPE,LABEL,SIZE,MOUNTPOINT: http://bpaste.net/show/102925/
cat /proc/cpuinfo: http://bpaste.net/show/102926/
cat /etc/fstab: http://bpaste.net/show/102928/
Thank you,
-Mason

Offline

#2 2013-06-28 19:56:57

Xrazik
New member
From: U.S.A.
Registered: 2013-06-28
Posts: 1

Re: Kernel Panic Vanilla-Sources Linux 3.9.4

In your kernel .config, try setting:

CONFIG_CMDLINE="root=/dev/sda4"

also, if you rely on an initramfs, it would be worthwhile to checkout this:

Funtoo guide to a better-initramfs


I had a similar kernel problem last week, and just specifying my root partition in the kernel's .config file fixed the issue.

Best wishes,
-Xrazik.

Offline

#3 2013-06-29 00:17:04

BillWho
New member
Registered: 2013-06-08
Posts: 4

Re: Kernel Panic Vanilla-Sources Linux 3.9.4

Mason,

Try setting CONFIG_DEVTMPFS_MOUNT="y"

Have you tried placing the output of lspci -n here http://kmuto.jp/debian/hcl/   to check your drivers ?

What does your menu.list or grub.cfg look like ?

Offline

Board footer

Powered by FluxBB