You are not logged in.

#1 2013-06-10 17:26:02

8MilesHi
Member
From: Allentown, PA
Registered: 2012-10-27
Posts: 11

[Solved] boot-update-1.6.11

Hello - Anyone having issues with boot-update today? I synced this morning. There was a new boot update (1.6.11) but, seemed to emerge just fine (no errors noted during install). Went ahead and built new vanilla-sources-3.9.5, moved everything /boot as normal and went to do normal 'boot-update'. Result:

updike ~ # boot-update --help
Traceback (most recent call last):
  File "/sbin/boot-update", line 15, in <module>
    import funtoo.boot.config
ImportError: No module named funtoo.boot.config
updike ~ #

(same error when run without help as well)

Last edited by 8MilesHi (2013-06-12 12:08:43)

Offline

#2 2013-06-11 04:58:28

angry_vincent
Staff
From: Ukraine
Registered: 2010-10-07
Posts: 687

Re: [Solved] boot-update-1.6.11

you need to run emerge -auDN @world, and then run python-updater, packages supposed to rebuild against python-3.3.2, this should fix.

Offline

#3 2013-06-11 12:46:53

8MilesHi
Member
From: Allentown, PA
Registered: 2012-10-27
Posts: 11

Re: [Solved] boot-update-1.6.11

Hi, thanks for reply. Yah, turned out to be an easy one (palm-2-4head!). I still had 'python' eselect(ed) to 3.2. I had noticed my PYTHON_ABIS was set for '2.7 3.3' during the updater run. Made the quick 'set' to 3.3 in eselect and all seems well. Boot-update worked fine, new kernel installed, things looking up.

Solution summary: 'eselect python set 3'  <- or whatever number matched '3.3' (in my case, ymmv)

This changed me from 3.2 to 3.3, and things started to clear up (gentoolkit was misbehaving too, I had just discovered).
Thanks a_v! OK to mark (Re)[Solved].

Offline

Board footer

Powered by FluxBB