You are not logged in.

#1 2013-04-26 11:02:52

Epcylon
New member
Registered: 2013-04-26
Posts: 2

Slot conflict on xorg-server when trying to emerge world

I've not used this machine for a while, so I haven't run emerge world for probably a month or so. When I try now, I get the following slot conflicts:

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

x11-base/xorg-server:0

  (x11-base/xorg-server-1.13.3::gentoo, installed) pulled in by
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-video-fbdev-0.4.3-r1::gentoo, installed)
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-input-joystick-1.6.2::gentoo, installed)
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-input-vmmouse-13.0.0::gentoo, installed)
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-video-dummy-0.3.6-r1::gentoo, installed)
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-input-evdev-2.8.0::gentoo, installed)
    x11-base/xorg-server:0/1.13.3= required by (x11-drivers/xf86-video-vesa-2.3.2-r1::gentoo, installed)

  (x11-base/xorg-server-1.13.4::gentoo, ebuild scheduled for merge) pulled in by
    (no parents that aren't satisfied by other packages in this slot)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously.  If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously.

The weird thing is that as far as I can tell, the packages listed as requiring xorg-server-1.13.3 does not actually require a specific slot of xorg-server, and should be perfectly happy working with xorg-server-1.13.4. I guess they might be compiled against 1.13.3, and require a re-compile if I upgrade?

To make matters worse, if I try masking 1.13.4, emerge wants to downgrade to 1.12.4-r1, because 1.13.3 has been removed from the tree, and that creates another slot conflict.

My problem is I don't understand what I can do to fix this? Even if 1.13.3 still was in my tree, masking every new version of xorg-server doesn't seem to be a sensible solution, but it's the only one that presents itself from the error message.


One notable detail about my system that might be relevant, is that it started life as a sabayon installation, that was slowly converted to funtoo using various guides I found online. As far as I can tell, most traces of sabayon is gone, except for a mess of a packages.use that I haven't dared trying to touch yet. If that might be the cause of this problem, I'd be happy for pointers on what to look for.

fimojoha-w530 ~ # emerge --info
Portage 2.3.5-r7 (funtoo/1.0/linux-gnu/arch/x86-64bit, gcc-4.6.3, glibc-2.15-r3, 3.8.5-gentoo x86_64)
=================================================================
System uname: Linux-3.8.5-gentoo-x86_64-Intel-R-_Core-TM-_i7-3820QM_CPU_@_2.70GHz-with-gentoo-2.2.0
KiB Mem:    16063984 total,  12043312 free
KiB Swap:   18087932 total,  18087932 free
Timestamp of tree: Fri, 26 Apr 2013 05:45:01 +0000
ld GNU ld (GNU Binutils) 2.22
app-shells/bash:          4.2_p37
dev-java/java-config:     2.2.0::java-overlay
dev-lang/python:          2.7.3-r1000, 3.2.3-r1000
dev-util/cmake:           2.8.10.2-r1
dev-util/pkgconfig:       0.28
sys-apps/baselayout:      2.2.0-r4
sys-apps/openrc:          0.10.2-r7
sys-apps/sandbox:         2.6
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.12.6
sys-devel/binutils:       2.22-r1
sys-devel/gcc:            4.6.3
sys-devel/gcc-config:     1.5-r1
sys-devel/libtool:        2.4.2
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.4-r2 (virtual/os-headers)
sys-libs/glibc:           2.15-r3
Repositories: gentoo betagarden steam-overlay java-overlay epcylon
Installed sets: @system
ACCEPT_KEYWORDS="amd64 ~amd64"
ACCEPT_LICENSE="* -@EULA Broadcom Oracle-BCLA-JavaSE AdobeFlash-11.x skype-4.0.0.7-copyright"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O2 -march=x86-64 -pipe -ggdb"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /etc/conf.d /etc/init.d /usr/share/config/kdm /usr/share/gnupg/qualified.txt /usr/share/maven-bin-3.0/conf"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/skel /etc/splash /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-O2 -march=x86-64 -pipe -ggdb"
DISTDIR="/usr/portage/distfiles"
FEATURES="assume-digests binpkg-logs ccache config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms splitdebug strict unknown-features-warn unmerge-logs unmerge-orphans userfetch"
FFLAGS=""
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="en_US.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LINGUAS="en en_US nb nb_NO nn_NO"
MAKEOPTS="-j6 -s"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/betagarden /var/lib/layman/steam /var/lib/layman/java-overlay /var/lib/layman/epcylon"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
SYNC_USER="root"
USE="X aac acl alsa amd64 apng berkdb bluray bzip2 cdr consolekit cracklib crypt cups cxx dbus dri dvd dvdr dvdread flac gdbm gif gles2 gpm gtk iconv icu introspection ipv6 java jpeg lame ldap libnotify lock mad mmx modules mp3 mpeg mudflap multilib ncurses networkmanager nls nptl ogg opengl openmp opus pam pcre png policykit ppp pppd pulseaudio python readline resolvconf sdl session spell sse sse2 ssl startup-notification svg tcpd theora thunar tiff truetype udev unicode vorbis wavpack x264 xml xvid zlib" ABI_X86="64" ALSA_CARDS="emu10k1x darla20 darla24 emu10k1 gina20 gina24 hdsp hdspm ice1712 indigo indigoio layla20 layla24 mia mixart mona pcxhr rme32 rme96 sb16 sbawe sscape usbusx2y vx222 usb-usx2y" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias authn_core authz_core socache_shmcb unixd" APACHE2_MPMS="prefork" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump" CAMERAS="agfa_cl20 casio_qv dimagev dimera3500 kodak_dc120 kodak_dc210 kodak_dc240 kodak_dc3200 kodak_ez200 konica_qm150 panasonic_coolshot panasonic_dc1000 panasonic_dc1580 panasonic_l859 polaroid_pdc320 polaroid_pdc640 polaroid_pdc700 ricoh_g3 sipix_blink sipix_blink2 sipix_web2 sony_dscf1 sony_dscf55 toshiba_pdrm11 adc65 aox barbie canon clicksmart310 digigr8 digita directory enigma13 fuji gsmart300 hp215 iclick jamcam jd11 konica largan lg_gsm mars mustek pccam300 pccam600 ptp2 ricoh samsung sierra smal sonix soundvision spca50x sq905 stv0674 stv0680 sx330z template" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ubx" INPUT_DEVICES="evdev void" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer pdfimport wiki-publisher" LINGUAS="en en_US nb nb_NO nn_NO" LIRC_DEVICES="audio audio_alsa serial pctv" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-3" PYTHON_ABIS="2.7 3.2" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2" QEMU_SOFTMMU_TARGETS="x86_64 arm cris i386 m68k microblaze mips mips64 mips64el mipsel ppc ppc64 ppcemb sh4 sh4eb sparc sparc64" QEMU_USER_TARGETS="alpha arm armeb cris i386 m68k microblaze mips mipsel ppc ppc64 ppc64abi32 sh4 sh4eb sparc sparc32plus sparc64 x86_64" RUBY_TARGETS="ruby18 ruby19" USERLAND="GNU" VIDEO_CARDS="fbdev vesa nvidia" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, SYNC_UMASK

Offline

#2 2013-04-26 14:05:57

Cloud
Member
Registered: 2011-09-20
Posts: 10

Re: Slot conflict on xorg-server when trying to emerge world

Try

emerge --oneshot xorg-server

Offline

#3 2013-04-26 14:13:37

Epcylon
New member
Registered: 2013-04-26
Posts: 2

Re: Slot conflict on xorg-server when trying to emerge world

A while after posting, I decided to upgrade some specific packages, and used -uDN when doing so. As a result of one of those emerges, xorg-server was emerged, and that solved the problem.

That leads me to belive your fix would also have worked, I just can't understand why this has to be the way this is done. I think more or less the same happened the last time xorg-server was upgraded.
I've also had similar problems with other packages, where emerge complains about a slot conflict, when there's no reason (that I can find) it should insist on installing two different versions into that slot.

It seems like the correct way to upgrade my system is:

emerge @world
emerge --oneshot all packages that have slot conflicts
<repeat until emerge @world actually emerges world>

... that seems awfully cumbersome? hmm

Offline

#4 2013-04-26 15:01:26

Cloud
Member
Registered: 2011-09-20
Posts: 10

Re: Slot conflict on xorg-server when trying to emerge world

emerge @world

Will rebuild your entire system... Update with -auD instead. And you shouldn't be getting many slot conflicts. In this case x11-drivers need to be rebuilt after every xorg-server update hence probably the conflict.

Offline

#5 2013-04-26 16:54:48

funfool
Member
Registered: 2012-11-21
Posts: 23

Re: Slot conflict on xorg-server when trying to emerge world

Not sure what your error was, I also seen the slot conflict message. But emerge just ignored it and continued on with a -uavND world.
There is more info here, http://bugs.funtoo.org/browse/FL-522
The way I understand it, 1.13.3 ebuild was removed, so portage wanted to revert back to the next available xorg-server, then 1.13.4 was unmasked and is what you see now.
There was a little bouncing around with xorg-server this week, also look at http://bugs.funtoo.org/browse/FL-520 and will see a little more discussion on it.

Just curious why on two systems here, I saw the slot conflict message and portage ignored it and installed anyways.

I do want to say, Welcome to funtoo. I have some experience with sabayon.
I would say that a conversion from gentoo to funtoo is not supported. Sabayon to funtoo, just wow is all I can think of to say.  smile

One noticeable difference between gentoo and funtoo, is funtoo core system tools are kept at a sane and stable level.
Would be interesting to hear how you managed to convert to a older glibc. The sabayon make.conf would make grown men cry, it is so totally bloated to a one size fits all, which is needed for a binary system, package.use, .mask and unmask, accept_keywords would all need attention. And in the end, would still be part of sabayon tool chain in it, I just do not see how you could get it all out, would be much faster to just build a new funtoo from scratch and have a clean install.

But it sounds like you had a fun project.

Offline

Board footer

Powered by FluxBB